Teledyne LeCroy XenaManager — программное обеспечение для генерации и
XenaManager
Программное обеспечение для генерации и анализа Ethernet-трафика
XenaManager — бесплатное приложение для Windows, используемое для конфигурирования и генерации потоков Ethernet-трафика между тестовым оборудованием Xena и тестируемыми устройствами (DUT) на всех скоростях до 800 Гбит/с, а также для анализа результатов.
Удобный пользовательский интерфейс делает XenaManager эффективным инструментом для выполнения широкого спектра основных тестовых сценариев для производителей полупроводниковых компонентов и сетевого оборудования (NEM), поставщиков сетевых услуг и гиперскейлеров.
Ключевые особенности: Teledyne LeCroy XenaManager — программное обеспечение для генерации и анализа Ethernet-трафика
Основные функции
Табличные представления конфигурации портов и потоков позволяют инженерам по тестированию быстро просматривать и одновременно работать с большим количеством портов и потоков. Потоки трафика могут формироваться в соответствии с конкретными реальными сценариями с использованием широкого набора переменных.
Функция редактора пакетов поддерживает как протокольное определение пакетов (IP, VLAN, UDP и т. д.), так и определение на уровне отдельных байтов. Функция захвата пакетов также может автоматически декодировать содержимое пакетов на уровне протоколов.
XenaManager позволяет быстро просматривать и анализировать статистику трафика, ошибки полезной нагрузки, задержку и джиттер, настраивать определённые фильтры для входящего трафика и выполнять захват пакетов в реальном времени.
XenaManager предоставляет различные средства оптимизации тестирования. Среди них — быстрое копирование и вставка определений потоков между портами, а также настройка пользовательского интерфейса в соответствии с задачами инженера по тестированию, например возможность скрыть неиспользуемые элементы управления и сосредоточиться на выполняемой задаче.
После конфигурирования тестовых стендов и тестовых сценариев их можно сохранить и передать другим пользователям.
XenaManager может использоваться несколькими пользователями в различных местах для одновременного управления несколькими шасси Xena.
Рисунок 1. Представление свойств потока и редактор заголовка пакета
Возможности пользовательского интерфейса
XenaManager оптимизирует рабочий процесс тестирования:
Рисунок 2. Интерфейс конфигурирования портов и потоков XenaManager
Области применения: Teledyne LeCroy XenaManager — программное обеспечение для генерации и анализа Ethernet-трафика
Программное обеспечение в комплекте
Более сложные тестовые сценарии могут выполняться с помощью других бесплатных приложений, поставляемых вместе с XenaManager. К ним относятся Xena2544, Xena3918, Xena2889 и Xena1564 для выполнения тестов RFC2544, RFC3918, RFC2889 и Y.1564.
Также доступен ChassisUpgrader, упрощающий обновление программного обеспечения и микропрограммы тестовых шасси Xena без прямого физического подключения.
Скрипты и автоматизация тестирования
Xena OpenAutomation (XOA)
В состав XenaManager входит Xena OpenAutomation (XOA) — фреймворк автоматизации тестирования с открытым исходным кодом для использования со всеми решениями Xena.
XOA отличается высокой скоростью работы, простотой использования и гибкостью и предоставляет Python API, работающий в любой операционной системе.
Xena CLI
Тестовые решения Xena поставляются с мощным и удобным API командной строки (CLI). Доступны примеры скриптов, в том числе на Perl и Python.
XOA REST API
Также доступен REST API, который может использоваться вместо CLI. Кроме того, предоставляется полнофункциональный объектно-ориентированный REST-клиент Python, позволяющий разработчикам Python установить его через pip и сразу приступить к созданию сценариев автоматизации без затрат времени на разработку уровня генератора трафика.
XenaManager Scheduler
XenaManager поддерживает планирование последовательности операций, запускаемой одним щелчком мыши. XenaManager Scheduler может использоваться для запуска и остановки трафика, изменения скорости передачи пакетов, изменения порядка операций, добавления циклических секций и т. д.
Системные требования
XenaManager требует Windows 10 или более новой версии и может работать на любом стандартном ПК, способном работать под управлением Windows 10.
Базовый рабочий процесс
Рисунок 3. Анализ статистики, фильтров и результатов в XenaManager
Документация и поддержка
Подробная документация по всем функциям доступна онлайн. Xena также предоставляет клиентам веб-обучение в рамках бесплатной технической поддержки.
Информация для заказа
| Продукт | Описание | Код продукта |
|---|---|---|
| XenaManager | Ethernet Traffic Generation & Analysis Software. | XenaManager |
Характеристики Teledyne LeCroy XenaManager — программное обеспечение для генерации и анализа Ethernet-трафика
Возможность автоматизации с помощью собственного ПО: интеграция, автоматизация измерений, собственные база данных и VISA-мост.
СПОАИ — специальное программное обеспечение для автоматизации измерений, разработанное на мощностях "Акметрон" — отечественного разработчика программного обеспечения, производителя и крупнейшего поставщика оборудования с 2012 года.
Это клиент-серверное приложение с многопользовательской распределённой архитектурой, которое решает задачи повышения производительности труда на производстве, сокращения длительности измерений и снижения требований к квалификации персонала. ПО внесено в реестр Минцифры: №28145
Ключевые преимущества:
- Полный цикл «под ключ»: от разработки до сопровождения
- Клиент-серверная архитектура с самостоятельной переналадкой
- Централизованный сбор и хранение результатов в БД с возможностью миграции в вашу БД
- Генератор отчетов на основе ваших шаблонов (docx. и xlsx.)
- Управление приборами с любым типом интерфейса
- ПО работает на системах Windows, Linux, MacOS, доступна веб-версия
Результаты внедрений:
- Непрерывная работа в автоматическом режиме до 48 часов
- До 4 500 измерений за этап
- Одновременное управление 15+ приборами
- Автоматизация техтренировки и полной программы испытаний выпускаемых изделий — более 10 контролируемых приборов на одном рабочем месте, до 4 500 автоматизированных измерений в каждом этапе, непрерывная работа в автоматическом режиме 24–48 часов
- Измерение радиотехнических характеристик приемопередающих модулей
- Автоматизация тестирования фотонных интегральных схем
- Контроль и испытания СВЧ-усилителей для космических аппаратов
Для каждого продукта мы предоставляем полный комплект документации: инструкция по установке с пошаговой настройкой, руководство по эксплуатации с описанием требований и рабочих процессов, презентация с обзором возможностей и кейсов внедрения.
Предоставим систему с учётом требований промышленных стандартов и рассчитанную на многолетнюю эксплуатацию. Также мы обеспечиваем соответствие отраслевым требованиям, надёжность архитектуры для критических систем и масштабируемость без потери стабильности.
Наши специалисты помогут вам решить самые сложные задачи по автоматизации, измерениям и интеграции