VIAVI (Spirent) TestCenter Virtual — виртуальная платформа
VIAVI TestCenter Virtual
Конвергентное виртуальное решение для тестирования сетей L2–L7
VIAVI TestCenter Virtual — конвергентное виртуальное решение для тестирования L2–L7, предназначенное для оптимизации и обеспечения производительности сетевых сервисов, развёрнутых в публичных, частных или гибридных облаках. TestCenter Virtual создаёт расширенные тестовые топологии с эмуляцией масштабируемых плоскостей управления и данных для нагрузочного тестирования как физических, так и виртуализированных сетевых функций. Благодаря этому поставщики услуг могут контролировать соответствие сетевых сервисов SLA, предприятия — проверять, обеспечивает ли перенос сервисов в облако оптимальную производительность для пользователей, а операторы центров обработки данных — достигать масштабируемости и отказоустойчивости, необходимых для предоставления приложений и сервисов следующего поколения.
TestCenter Virtual обеспечивает удобство использования, переносимость, масштабируемость и экономическую эффективность с поддержкой как традиционных, так и новейших протоколов. Независимо от того, внедряются ли виртуализация или контейнеры, решения VIAVI упрощают для поставщиков услуг, операторов центров обработки данных и облачных провайдеров развёртывание NFV и облачной инфраструктуры.
Фреймворк TestCenter Virtual
Миграция с физической инфраструктуры на виртуальную
По мере преобразования физических сетевых функций и их переноса в программную форму требования к функциональности, производительности и предсказуемости остаются чрезвычайно высокими. Инвестиции, сделанные за годы тестирования сетевых функций операторского класса — маршрутизаторов, коммутаторов, межсетевых экранов и другого оборудования, — должны быть перенесены в виртуальную среду.
TestCenter Virtual предоставляет унифицированную архитектуру тестирования, обеспечивающую полную совместимость с любым интерфейсом TestCenter для точной генерации высокопроизводительного сетевого трафика аппаратными FPGA. Это позволяет переносить ранее созданные тестовые сценарии из физической среды в виртуальную. Также можно создавать виртуальную тестовую лабораторию для ускорения разработки, снижения совокупной стоимости владения (TCO) тестовыми ресурсами и оптимизации использования инфраструктуры за счёт тестирования программного обеспечения во множестве реальных сценариев ещё до появления аппаратной платформы.
Функции
Преимущества
Производительность и синхронизация
TestCenter Virtual поддерживает скорости центров обработки данных 1G, 2.5G, 5G, 10G, 25G, 40G, 100G и 200G.
Рисунок 2. Производительность VIAVI TestCenter Virtual
Поддержка ведущих платформ виртуализации и облачных платформ
Использование контейнеров в DevOps постоянно растёт, поскольку они упрощают непрерывную доставку, обеспечивая переносимость кода между средами разработки, тестирования и эксплуатации. TestCenter Virtual предлагается в контейнерном формате для ускорения работы разработчиков. Это контейнеризированное решение для сетевого тестирования доступно в форматах Docker и LXC с пропускной способностью до 1G на контейнер.
TestCenter Virtual поддерживает широкий набор гипервизоров, включая KVM, ESXi, Hyper-V и Oracle VM, а также облачные платформы OpenStack, Amazon Web Services, Microsoft Azure, Google Cloud Platform и другие.
Рисунок 3. Поддержка платформ TestCenter Virtual
Непрерывные облачные развёртывания
DevOps и непрерывная интеграция сокращают время вывода решений на рынок и улучшают SLA для организаций, использующих механизмы Continuous Integration и Delivery. В условиях растущей глобальной конкуренции компании должны своевременно и экономически эффективно выводить на рынок продукты и сервисы высокого качества. Организациям требуются автоматизированные и масштабируемые решения для улучшения процессов сборки, тестирования и развёртывания программного обеспечения.
TestCenter Virtual интегрируется с системами управления облачной инфраструктурой, включая VMware и OpenStack. Расширенная поддержка API позволяет программировать виртуальную машину, конфигурировать её и управлять ею из стороннего фреймворка оркестрации. Через API доступны все возможности, присутствующие в графическом интерфейсе TestCenter.
Валидация NFV
Network Functions Virtualization (NFV) — отраслевой термин, обозначающий возможность предоставления сетевых функций через виртуализированную вычислительную инфраструктуру. Несмотря на множество преимуществ NFV для операторов сетей и центров обработки данных, остаётся значительная неопределённость при выборе технологий, настройке инфраструктуры, оптимизации производительности и усилении безопасности.
Необходимо тестировать не только Virtual Network Functions, но и виртуальную инфраструктуру, на которой размещаются виртуальные машины. Функциональность и производительность Virtual Network Function в значительной степени зависят от предсказуемости NFV-инфраструктуры.
TestCenter Virtual обеспечивает высокоскоростное функциональное тестирование и тестирование производительности Layer 2–7 виртуальных и физических сетевых ресурсов посредством одновременной генерации LAN unicast-, multicast- и VLAN-трафика совместно с SAN IO, а также stateful-протоколов прикладного уровня, включая HTTP и FTP.
Рисунок 4. Валидация NFV
Квалифицированные и совместимые среды
| Категория | Квалифицированные параметры |
|---|---|
| Характеристики VM |
CPU — от 2 до 4 виртуальных CPU в зависимости от требований к производительности. Память — от 2 до 4 GB в зависимости от требований к производительности. Сетевые интерфейсы — 1 интерфейс управления и до 9 тестовых портов. Скорости портов — 100M, 1G, 2.5G, 5G, 10G, 25G, 40G, 50G, 100G, 200G. |
| Упаковка | ПО доступно в форматах OVA, qcow2 и vhd. |
| Гипервизоры и Host OS |
VMWare ESXi 6.7, 7.0, 8.0. QEMU/KVM на Ubuntu 18.04, 20.04, 22.04, 24.04 и Fedora 40, Fedora 41. Hyper-V. |
| Публичное облако | OpenStack. Amazon Web Services. Google Cloud Platform. Microsoft Azure. |
| Контейнерная платформа | LSX, Docker. |
| Поддерживаемые сетевые адаптеры и драйверы |
Intel I350 Gigabit Network Card. Intel X520-DA2, X550T 10-Gigabit SFP+ Network Card. Intel Ethernet Controller XXV710 25G. Intel Ethernet Controller XL710 40Gb QSPF+. Mellanox MT27520 Family [ConnectX-3 Pro] 40Gb QSFP+. Mellanox ConnectX-5 Family of smart NICs QSFP+. Драйверы: igb, ixgbe, i40e, mlx4_en. И другие. |
| Автоматизация | TCL, Python, REST. |
Сетевые протоколы
TestCenter Virtual может эмулировать широкий набор протоколов. Каждый виртуальный порт способен эмулировать тысячи маршрутизаторов или коммутаторов с миллионами сетей и хостов. Пользователи могут масштабировать топологии добавлением виртуальных тестовых портов.
| Технология | VIAVI |
|---|---|
| Автоматизация | TCL, Python, REST. |
| Поддерживаемые версии IP | IPv4, IPv6. |
| Протоколы маршрутизации и MPLS |
Основные IPv4- и IPv6-протоколы unicast- и multicast-маршрутизации: IGMPv1/v2/v3. ISISv4/v6. BGP. OSPFv4/v6. RIP/RIPng. EIGRP/EIGRPv6. Carrier Ethernet и Bridging — LACP, STP, RSTP, MSTP, 802.1ag, CFM, Y.1731, PBB, PBB-TE, Link OAM. Mobile Backhaul — MPLS-TP, 1588v2, SyncE. |
| MPLS | MPLS-TP. RSVP-TE, LDP, VPLS-LDP, VPLS-BGP, BGP/MPLS-VPN, Fast Re-route, mVPN, P2MP-TE, BFD, PWe3 (RFC4447). |
| SDN-протоколы | PCEP, Segment Routing, OSPF, ISIS, BGP, BGP LS, BGP Flow Spec, эмуляция коммутатора OpenFlow, эмуляция контроллера OpenFlow. |
| Поддержка протоколов предприятий и центров обработки данных |
Основные IPv4- и IPv6-протоколы unicast- и multicast-маршрутизации: IGMPv1/v2/v3, MLDv1/v2, LACP, STP, RSTP и MSTP. Data Center — DCBX, FCoE, FIP, 802.1Qbb, VXLAN-EVPN, EVPN-MPLS, EVPN-PBB, EVPN-IRB, EVPN-VPWS, OTV, TRILL, LISP, SPB, LISP, VEPA. Stateful L4–7 — HTTP, SIP, FTP. |
| Протоколы доступа | 802.1, ANCP, DHCPv4/v6, L2TP, IGMPv1/v2/v3, MLDv1/v2, PPPoEv4 и PPPoEv6, 6RD, Dual-Stack Lite. |
| Carrier Ethernet и Bridging | LACP, STP, RSTP и MSTP, 802.1ag CFM, Y.1731, PBB, PBB-TE, Link OAM. |
| Расширенные протоколы L4–L7 | FTP, HTTP 1.0/1.1, HTTPS 1.0/1.1, HTTP Live Stream (Video), CIFS-SMB, IMAP4, POP3, TCP, SMTP, Telnet. |
| Поддерживаемые приложения L4–L7 | Amazon, Facebook, Instagram, Netflix, YouTube, импорт и воспроизведение Application PCAP. |
| RFC | 2544, 2889, 3918. |
| Протоколы аутентификации | 802.1x. Network Access Control (NAC). Radius. |
Информация для заказа
| Описание | P/N |
|---|---|
| AION Virtual Bandwidth Low | AON-SWO-V-BANDWIDTH-L |
| AION Virtual Bandwidth Medium | AON-SWO-V-BANDWIDTH-M |
| AION Virtual Bandwidth High | AON-SWO-V-BANDWIDTH-H |
| VIAVI TestCenter Virtual port — скорости 100M, 1G, 2.5G, 5G, 10G, 25G, 40G, 100G, 200G | P/N зависит от скорости. |
| Virtual Routing bundle | V-SPK-9001/2 |
| Virtual Switching bundle | V-SPK-9003 |
| Virtual MBH bundle | V-SPK-9005 |
| Virtual Access bundle | V-SPK-9006/7 |
| Virtual Multiplay bundle | V-SPK-9008 |
| Virtual RFC-2544 with VLAN network device benchmark test package | V-TPK-1000 |
| Virtual RFC-2889 with VLAN switching benchmark test package | V-TPK-1001 |
| Virtual RFC-3918 Multicast benchmark test package | V-TPK-1042 |
| Virtual Unicast Routing Convergence test package | V-TPK-1050 |
| Virtual Enhanced L4-7, 1 Port | V-BPK-2001-001 |
Характеристики VIAVI (Spirent) TestCenter Virtual — виртуальная платформа тестирования сетей L2–L7
Документация VIAVI (Spirent) TestCenter Virtual — виртуальная платформа тестирования сетей L2–L7
Возможность автоматизации с помощью собственного ПО: интеграция, автоматизация измерений, собственные база данных и VISA-мост.
СПОАИ — специальное программное обеспечение для автоматизации измерений, разработанное на мощностях "Акметрон" — отечественного разработчика программного обеспечения, производителя и крупнейшего поставщика оборудования с 2012 года.
Это клиент-серверное приложение с многопользовательской распределённой архитектурой, которое решает задачи повышения производительности труда на производстве, сокращения длительности измерений и снижения требований к квалификации персонала. ПО внесено в реестр Минцифры: №28145
Ключевые преимущества:
- Полный цикл «под ключ»: от разработки до сопровождения
- Клиент-серверная архитектура с самостоятельной переналадкой
- Централизованный сбор и хранение результатов в БД с возможностью миграции в вашу БД
- Генератор отчетов на основе ваших шаблонов (docx. и xlsx.)
- Управление приборами с любым типом интерфейса
- ПО работает на системах Windows, Linux, MacOS, доступна веб-версия
Результаты внедрений:
- Непрерывная работа в автоматическом режиме до 48 часов
- До 4 500 измерений за этап
- Одновременное управление 15+ приборами
- Автоматизация техтренировки и полной программы испытаний выпускаемых изделий — более 10 контролируемых приборов на одном рабочем месте, до 4 500 автоматизированных измерений в каждом этапе, непрерывная работа в автоматическом режиме 24–48 часов
- Измерение радиотехнических характеристик приемопередающих модулей
- Автоматизация тестирования фотонных интегральных схем
- Контроль и испытания СВЧ-усилителей для космических аппаратов
Для каждого продукта мы предоставляем полный комплект документации: инструкция по установке с пошаговой настройкой, руководство по эксплуатации с описанием требований и рабочих процессов, презентация с обзором возможностей и кейсов внедрения.
Предоставим систему с учётом требований промышленных стандартов и рассчитанную на многолетнюю эксплуатацию. Также мы обеспечиваем соответствие отраслевым требованиям, надёжность архитектуры для критических систем и масштабируемость без потери стабильности.
Наши специалисты помогут вам решить самые сложные задачи по автоматизации, измерениям и интеграции