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Guaranty and Declaration 
 

Copyright 
©  2020 RIGOL TECHNOLOGIES CO., LTD. All Rights Reserved. 

 

Trademark Information 
RIGOL®  is the trademark of RIGOL TECHNOLOGIES CO., LTD. 

 

Publication Number 
UGA27101-1110 
 

Software Version 

00.01.01.00.00 
Software upgrade might change or add product features. Please acquire the latest 
version of the manual from RIGOL website or contact RIGOL to upgrade the 

software. 

 

Notices 
⚫ RIGOL products are covered by P.R.C. and foreign patents, issued and pending. 

⚫ RIGOL reserves the right to modify or change parts of or all the specifications 

and pricing policies at the company’s sole decision. 
⚫ Information in this publication replaces all previously released materials. 
⚫ Information in this publication is subject to change without notice. 
⚫ RIGOL shall not be liable for either incidental or consequential losses in 

connection with the furnishing, use, or performance of this manual, as well as 
any information contained. 

⚫ Any part of this document is forbidden to be copied, photocopied, or rearranged 
without prior written approval of RIGOL. 

 

Product Certification 
RIGOL guarantees that this product conforms to the national and industrial 

standards in China as well as the ISO9001:2015 standard and the ISO14001:2015 
standard. Other international standard conformance certifications are in progress. 
 

Contact Us 

If you have any problem or requirement when using our products or this manual, 
please contact RIGOL. 

E-mail: service@rigol.com 
Website: www.rigol.com 
 
 
 
 

http://www.rigol.com/
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Safety Requirement 
 

General Safety Summary 
 

Please review the following safety precautions carefully before putting the 
instrument into operation so as to avoid any personal injury or damage to the 
instrument and any product connected to it. To prevent potential hazards, please 
follow the instructions specified in this manual to use the instrument properly. 
 
Use Proper Power Cord. 
Only the exclusive power cord designed for the instrument and authorized for use 
within the local country could be used. 
 
Ground the Instrument. 
The instrument is grounded through the Protective Earth lead of the power cord. To 
avoid electric shock, connect the earth terminal of the power cord to the Protective 
Earth terminal before connecting any input or output terminals. 
 
Connect the Probe Correctly. 
If a probe is used, the probe ground lead must be connected to earth ground. Do not 
connect the ground lead to high voltage. Improper way of connection could result in 
dangerous voltages being present on the connectors, controls or other surfaces of 
the oscilloscope and probes, which will cause potential hazards for operators. 
 
Observe All Terminal Ratings. 
To avoid fire or shock hazard, observe all ratings and markers on the instrument and 
check your manual for more information about ratings before connecting the 
instrument. 
 
Use Proper Overvoltage Protection. 
Ensure that no overvoltage (such as that caused by a bolt of lightning) can reach the 
product. Otherwise, the operator might be exposed to the danger of an electric 
shock. 
 
Do Not Operate Without Covers. 
Do not operate the instrument with covers or panels removed. 
 
Do Not Insert Objects into the Air Outlet. 
Do not insert anything into the holes of the fan to avoid damaging the instrument. 
 
Use Proper Fuse. 
Please use the specified fuses. 
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Avoid Circuit or Wire Exposure. 
Do not touch exposed junctions and components when the unit is powered on. 
 

Do Not Operate with Suspected Failures. 
If you suspect that any damage may occur to the instrument, have it inspected by 
RIGOL authorized personnel before further operations. Any maintenance, 

adjustment or replacement especially to circuits or accessories must be performed 
by RIGOL authorized personnel. 
 

Provide Adequate Ventilation. 
Inadequate ventilation may cause an increase of temperature in the instrument, 
which would cause damage to the instrument. So please keep the instrument well 
ventilated and inspect the air outlet and the fan regularly. 
 
Do Not Operate in Wet Conditions. 
To avoid short circuit inside the instrument or electric shock, never operate the 
instrument in a humid environment. 
 
Do Not Operate in an Explosive Atmosphere. 
To avoid personal injuries or damage to the instrument, never operate the 
instrument in an explosive atmosphere. 
 
Keep Product Surfaces Clean and Dry. 
To avoid dust or moisture from affecting the performance of the instrument, keep the 
surfaces of the instrument clean and dry. 
 
Prevent Electrostatic Impact. 
Operate the instrument in an electrostatic discharge protective environment to avoid 
damage induced by static discharges. Always ground both the internal and external 
conductors of cables to release static before making connections. 
 
Use the Battery Properly. 
Do not expose the battery (if available) to high temperature or fire. Keep it out of the 
reach of children. Improper change of a battery (lithium battery) may cause an 
explosion. Use the RIGOL specified battery only. 

 
Handle with Caution. 
Please handle with care during transportation to avoid damage to keys, interfaces, 
and other parts on the panels. 
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Safety Notices and Symbols 
 
Safety Notices in this Manual: 
 

 

WARNING    
Indicates a potentially hazardous situation or practice which, if not 
avoided, will result in serious injury or death. 

 

 

CAUTION    
Indicates a potentially hazardous situation or practice which, if not 
avoided, could result in damage to the product or loss of important data. 

 
Safety Terms on the Product: 
 
DANGER It calls attention to an operation, if not correctly performed, could 

result in injury or hazard immediately. 
WARNING It calls attention to an operation, if not correctly performed, could 

result in potential injury or hazard. 
CAUTION It calls attention to an operation, if not correctly performed, could 

result in damage to the product or other devices connected to the 
product. 

 
Safety Symbols on the Product: 
 

     

Hazardous 
Voltage 

Safety Warning Protective Earth 
Terminal 

Chassis Ground Test Ground 
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Measurement Category 
 
Measurement Category 
DS8000-R series digital oscilloscopes can make measurements in Measurement 
Category I. 
 

 

WARNING 
This oscilloscope can only be used for measurements within its specified 
measurement categories. 

 

Measurement Category Definitions 
Measurement category I is for measurements performed on circuits not directly 
connected to MAINS. Examples are measurements on circuits not derived from 
MAINS, and specially protected (internal) MAINS derived circuits. In the latter case, 
transient stresses are variable. Thus, you must know the transient withstand 
capability of the equipment. 
 
Measurement category II is for measurements performed on circuits directly 
connected to low voltage installation. Examples are measurements on household 
appliances, portable tools and similar equipment. 
 
Measurement category III is for measurements performed in the building installation. 
Examples are measurements on distribution boards, circuit-breakers, wiring 
(including cables, bus-bars, junction boxes, switches and socket-outlets) in the fixed 
installation, and equipment for industrial use and some other equipment. For 
example, stationary motors with permanent connection to a fixed installation. 
 
Measurement category IV is for measurements performed at the source of a 
low-voltage installation. Examples are electricity meters and measurements on 
primary overcurrent protection devices and ripple control units. 
 

Ventilation Requirement 
 
This oscilloscope uses a fan to force cooling. Please make sure that the air intake and 
exhaust areas are free from obstructions and have free air. When using the 
oscilloscope in a bench-top, allow at least 30 cm clearance from both sides of the 
instruments; when using it in rack setting, keep at least 1 m clearance from the 
surroundings of the cabinet. When running in the cabinet, keep it run in the room 

temperature below 30°C. 

 

WARNING    
Inadequate ventilation may cause an increase of temperature in the 
instrument, which would cause damage to the instrument. So please 
keep the instrument well ventilated and inspect the air outlet and the fan 
regularly. 
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Working Environment 
 
Temperature 

Operating: -40℃ to +50℃ (for a single instrument)   

-40℃ to +30℃ (for instruments in the cabinet) 

Non-operating: -50℃ to +70℃ 

 

Humidity 
Operating: 

Below +30℃: ≤90%RH (without condensation) 

+30℃ to +40℃: ≤75%RH (without condensation) 

+40℃ to +50℃: ≤45%RH (without condensation) 

 
Non-operating: 

Below 65℃: ≤90% RH (without condensation) 

 
 

 

WARNING    
To avoid short circuit inside the instrument or electric shock, never 
operate the instrument in a humid environment. 

 
Altitude 
Operating: below 3 km 
Non-operating: below 15 km 
 
Installation (Overvoltage) Category 
This product is powered by mains conforming to installation (overvoltage) category 
II. 
 

 

WARNING    
Ensure that no overvoltage (such as that caused by a bolt of lightning) 
can reach the product. Otherwise, the operator might be exposed to the 
danger of an electric shock. 

 
Installation (Overvoltage) Category Definitions 
Installation (overvoltage) category I refers to signal level which is applicable to 
equipment measurement terminals connected to the source circuit. Among these 
terminals, precautions are done to limit the transient voltage to a low level. 
Installation (overvoltage) category II refers to the local power distribution level 
which is applicable to equipment connected to the AC line (AC power). 
 
Pollution Degree 
Pollution Degree 2 
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Pollution Degree Definition 
Pollution Degree 1: No pollution or only dry, nonconductive pollution occurs. The 
pollution has no effect. For example, a clean room or air-conditioned office 
environment. 
Pollution Degree 2: Normally only nonconductive pollution occurs. Temporary 
conductivity caused by condensation is to be expected. For example, indoor 
environment. 
Pollution Degree 3: Conductive pollution or dry nonconductive pollution that 
becomes conductive due to condensation occurs. To be found in industrial 
environment or construction sites (harsh environments). For example, sheltered 
outdoor environment. 
Pollution Degree 4: The pollution generates persistent conductivity caused by 
conductive dust, rain, or snow. 
For example, outdoor areas. 
 
Safety Class 
Class 1 – Grounded Product 
 
 

Care and Cleaning 
 
Care 
Do not store or leave the instrument where it may be exposed to direct sunlight for 
long periods of time. 
 
Cleaning 
Clean the instrument regularly according to its operating conditions.  
1. Disconnect the instrument from all power sources. 
2. Clean the external surfaces of the instrument with a soft cloth dampened with 

mild detergent or water. Avoid having any water or other objects into the chassis 
via the heat dissipation hole. When cleaning the LCD, take care to avoid 
scarifying it. 
 
 

 

CAUTION    
To avoid damage to the instrument, do not expose it to caustic liquids. 

 
 

 

WARNING    
To avoid short-circuit resulting from moisture or personal injuries, ensure 
that the instrument is completely dry before connecting it to the power 
supply. 
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Environmental Considerations 
 
The following symbol indicates that this product complies with the WEEE Directive 
2002/96/EC. 
 

 
 
Product End-of-Life Handling 
The equipment may contain substances that could be harmful to the environment or 
human health. To avoid the release of such substances into the environment and 
avoid harm to human health, we recommend you to recycle this product 
appropriately to ensure that most materials are reused or recycled properly. Please 
contact your local authorities for disposal or recycling information. 
 
You can click on the following link https://int.rigol.com/services/declaration.html to 
download the latest version of the RoHS&WEEE certification file. 
 

https://int.rigol.com/services/declaration.html


  RIGOL 

DS8000-R User Guide IX 

DS8000-R Series Overview 
 
DS8000-R series is a medium and high-end digital oscilloscope with a compact size 
designed on the basis of the ASIC chip (RIGOL self-owns its intellectual property 

right) and UltraVision II technical platform developed by RIGOL. It is compact and 

thin in design. It supports system integration of multiple devices, rack mount 
installation, and remote system operation to meet the system requirements for 
industrial automation test system. DS8000-R series oscilloscope has an analog 
bandwidth of up to 2 GHz, supporting multi-device synchronous triggering, available 
to be extended to 512 channels. It provides an excellent solution for users to meet 
their middle and high-speed requirement for the system integration test and 
synchronization requirement for multi-channel data acquisition. 
 

Main Features: 
⚫ Analog channel bandwidth: 350 MHz, 1 GHz, and 2 GHz 
⚫ Up to 10 GSa/s real-time sample rate (for DS8104-R/DS8204-R), 5 GSa/s (for 

DS8034-R) 
⚫ 4 analog channels, 1 EXT input channel 
⚫ Standard memory depth up to 500 Mpts 
⚫ High waveform capture rate (over 600,000 wfm/s) 
⚫ Low jitter, multiple-device synchronization (<200 psRMS, typical) 
⚫ High-speed data communication interface (10 GE SFP+), ensuring the reliable 

transmission of massive data 
⚫ Integrates 6 independent instruments into 1, including digital oscilloscope, 

spectrum analyzer, AWG (option), digital voltmeter, 6-digit counter and totalizer, 
and protocol analyzer (option) 

⚫ Available to be extended to 512 channels, supporting synchronous acquisition 
(with the multi-channel synchronization module) 

⚫ Real-time eye diagram and jitter analysis software (option for 
DS8104-R/DS8204-R, but unavailable for DS8034-R) 

⚫ Built-in advanced power analysis software (option) 

⚫ Operating temperature low below -40℃, available to be used for signal 

monitoring in some special conditions 
⚫ Multiple interfaces available: USB HOST&DEVICE, LAN(LXI), 10 GE SFP+, HDMI, 

TRIG OUT, 10 MHz In, and 10 MHz Out 
⚫ Web Control remote command 
⚫ Compact and thin design, save rack space, 1U rack mount kit (standard) 
⚫ Software development kit available for users to meet their customized 

development according to their specific scenarios 
⚫ Easy-to-use on-site multi-channel synchronization calibration kit, enabling you 

to view multiple channels synchronously 
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Document Overview 
 

Main Topics of this Manual: 
 
Chapter 1 Quick Start 
Introduces the preparations before using the oscilloscope and provides a basic 
introduction of the instrument. 
 
Chapter 2 To Set the Vertical System 
Introduces the vertical system functions of the oscilloscope. 
 
Chapter 3 To Set the Horizontal System 
Introduces the horizontal system functions of the oscilloscope. 
 
Chapter 4 To Set the Sample System 
Introduces the sample system functions of the oscilloscope. 
 
Chapter 5 To Trigger the Oscilloscope 
Introduces the trigger mode, trigger coupling, trigger holdoff, external trigger, and 
various trigger types of the oscilloscope. 
 
Chapter 6 Operations and Measurements 
Introduces how to make math operation, auto measurement, and cursor 
measurement. 
 
Chapter 7 Digital Voltmeter (DVM) and Frequency Counter 
Introduces how to use the digital voltmeter and the frequency counter.  
 
Chapter 8 Power Analysis (Option) 
Introduces the power analysis function, analyzes the power quality and output ripple 
noise of the input power. 
 
Chapter 9 Histogram Analysis 
Introduces the histogram analysis function. 
 
Chapter 10 Real-time Eye Diagram and Jitter Analysis (Option) 
Introduces the real-time eye diagram and jitter analysis function. 
 
Chapter 11 Protocol Decoding 
Introduces how to decode the input signal by using those common protocols. 
 
Chapter 12 Reference Waveform 
Introduces how to compare the input waveform with the reference waveform. 
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Chapter 13 Pass/Fail Test 
Introduces how to monitor the input signal by using the Pass/Fail test. 
 
Chapter 14 Waveform Recording & Playing 
Introduces the waveform recording & playing function. 
 
Chapter 15 Search and Navigation Function 
Introduces the navigation function and how to quickly search the relevant events. 
 
Chapter 16 Display Control 
Introduces how to control the display of the oscilloscope. 
 
Chapter 17 Function/Arbitrary Waveform Generator (Option)  
Introduces how to use the built-in Function/Arbitrary Waveform Generator option. 
 
Chapter 18 Store and Load 
Introduces how to store and load; how to carry out disk management. 
 
Chapter 19 System Utility Function Setting 
Introduces how to set the remote interfaces and system-related functions. 
 
Chapter 20 Remote Control 
Introduces how to control the oscilloscope remotely. 
 
Chapter 21 Troubleshooting 
Introduces how to deal with the common failures of the oscilloscope. 
 
Chapter 22 Appendix 
Provides the basic information for the options and accessories. 
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Format Conventions in this Manual: 
1. Key 

The key on the front panel is denoted by the format of "Key Name (Bold) + Text 

Box" in the manual. For example, RUN/STOP denotes the "RUN/STOP" key. 

 
2. Menu 

The menu items are denoted by the format of "Menu Word (Bold) + Character 
Shading". For example, System denotes the "System" menu item under 
"Utility" function.  

 
3. Operation Procedures 

→ denotes the next step of operation. For example, Utility → System denotes 
clicking on the navigation function icon to enter the "Utility" menu first, and then 
clicking the System menu item. 
 

4. Connector 
The connectors on the front or rear panel are usually denoted by the format of 
"Connector Name (Bold) + Square Brackets (Bold)". For example, [TRIG OUT]. 

 
 

Content Conventions in this Manual: 
 
DS8000-R series includes the following models. Unless otherwise specified, this 
manual takes DS8204-R as an example to illustrate the functions and operation 
methods of DS8000-R series digital oscilloscope. 
 

Model 
Analog 
Bandwidth 

No. of 
Analog 
Channels 

No. of Function/Arbitrary 
Waveform Generator 
Channels 

DS8104-R 1 GHz 4 1, Opt 

DS8204-R 2 GHz 4 1, Opt 

DS8034-R 350 MHz 4 1, Opt 

 
 
Manuals of this Product: 
Quick Guide, User Guide, Programming Guide, Data sheet, etc. For the latest version 
of this manual, download it from the official website of RIGOL (www.rigol.com). 

http://www.rigol.com/
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Chapter 1 Quick Start 
 
This chapter introduces the precautions when using the oscilloscope for the first time, 
the user interface, and how to use the built-in help system. 
 
Contents in this chapter: 
◼ General Inspection 
◼ Appearance and Dimensions 
◼ To Prepare for Use 
◼ Front Panel Overview 
◼ Rear Panel Overview 
◼ User Interface 
◼ Common Operation 
◼ To Use the Built-in Help System 
◼ To View the Option Information and the Option Installation 
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General Inspection 
 
1． Inspect the packaging 

If the packaging has been damaged, do not dispose the damaged packaging or 
cushioning materials until the shipment has been checked for completeness and 
has passed both electrical and mechanical tests. 
 
The consigner or carrier shall be liable for the damage to the instrument 
resulting from shipment. RIGOL would not be responsible for free 

maintenance/rework or replacement of the instrument. 
 
2． Inspect the instrument 

In case of any mechanical damage, missing parts, or failure in passing the 
electrical and mechanical tests, contact your RIGOL sales representative. 

 
3． Check the accessories 

Please check the accessories according to the packing lists. If the accessories 
are damaged or incomplete, please contact your RIGOL sales representative. 
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Appearance and Dimensions 
 

 
                     Figure 1-1 Front View              Unit: mm 

 
                                             

 
 
 

 
 
                            Figure 1-2 Side View           Unit: mm 
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To Prepare for Use 
 

To Connect to AC Power 
 
The input AC power requirements of the oscilloscope are 100~240 V, 45~440 Hz. 
Please use the power cord provided in the accessories to connect the oscilloscope to 
the AC power source via the power cord connector, as shown in Figure 1-3.  
 

 
 
 

Figure 1-3 To Connect to AC Power 
 

 

CAUTION    
To avoid electric shock, ensure that the instrument is correctly grounded. 

 
 

To Connect to the Display and the Control Device 
 
DS8000-R series does not have an LCD display or monitor. To set the parameters and 
view the measurement results, you need to connect it to an external control and 
display device. You can use the externally connected monitor, mouse, or keyboard to 
control the DS8000-R series oscilloscope. Also, you can use the Web Control remote 
control method to control the oscilloscope. 
 
⚫ To control with the externally connected display device, mouse, and 

keypad board 
You can configure the parameters for the function menu, observe acquired 
waveforms, measurement results, and other information on the user interface 
through the display device (e.g. LCD, TV, projector, etc.) externally connected 
via the rear-panel HDMI interface. The keyboard and mouse can be connected 
to the oscilloscope via the USB interface. In this way, you can input values or 
strings with the externally connected keypad and mouse; scroll with the mouse 
to select the desired parameter and adjust the parameter value; drag the mouse 
cursor to make dragging operation on the screen.  
Note: 
The operations for controlling the DS8000-R series oscilloscope in this manual 
are, by default, described based on the externally connected mouse and keypad 
board operation. The screen mentioned in this manual refers to the externally 

Power Cord Connector 
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connected display device that is connected via the HDMI interface. 
 

⚫ Web Control remote operation 
Connect the oscilloscope to the network, then input the IP address of the 
oscilloscope into the address bar of the browser of your PC or any mobile 
devices. The RIGOL web control interface is displayed. Click Web Control at 

the left section to enter the web control page. Then you can view the display of 
the real-time interface of oscilloscope. Through the Web Control method, you 
can migrant the device control and waveform analysis to the control terminals 
(e.g. PC, Mobile, iPad, and other smart terminals) to realize remote control of 
instruments. For methods on how to realize Web Control for the instrument, 
refer to "Remote Control". 
When you first log in to the Web Control page, the user name is "admin" and the 
password is "rigol". 

 
 

Turn-on Checkout 
 
When the oscilloscope is connected to power, press the Power key at the lower-left 
corner of the front panel to start the oscilloscope. During the start-up process, the 
oscilloscope performs a series of self-tests. If the oscilloscope has been connected to 
an external display device, after the self-test, the splash screen is displayed.  
 

 

Tip 
Restart and Shutdown: 
1. Operate the oscilloscope with the externally connected mouse. Click on the 

function navigation icon  at the lower-left corner of the screen to enable 
the function navigation.  

2. Click on the "Restart" icon , and then the "Restart" selection menu is 
displayed, as shown in the figure below: 

  

3. If you click on the "Restart" icon , the oscilloscope will be powered off 
and then automatically restart again. If you click on the "Shutdown" icon 

, the oscilloscope is powered off (you can also press the Power key at the 
lower-left corner of the front panel to turn off the oscilloscope).  
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To Replace the Fuse 
 
If you need to replace the fuse, use only the specified fuse (AC 250 V, T3.15 A; 5.2 
mm× 20 mm) and perform the following operations (as shown in Figure 1-4):  
1． Turn off the instrument, cut off the power and remove the power cord. 

2． Insert a slotted screwdriver into the slot of the fuse holder to pry it out. 
3． Take out the fuse. 
4． Replace the old fuse with a specified fuse. 

5． Install the fuse holder. 

 
Figure 1-4 To Replace the Fuse 

 

 

WARNING   
To avoid electric shock, please ensure that the instrument has been turned 
off, the power source has been cut off, and the fuse to be used conforms 
to the fuse rating. 

 
 

To Connect the Probe 
 
RIGOL provides the passive probe and the active probe (required to be purchased 

by yourself if necessary) for DS8000-R series. For specific probe models, please refer 
to DS8000-R Series Datasheet. For detailed technical information of the probes, 
please refer to the specified Probe User Guide. 
 
Connect the passive probe: 
1. Connect the BNC terminal of the probe to an analog channel input terminal of 

the oscilloscope on the front panel, as shown in Figure 1-5. 
2. Connect the ground alligator clip or spring of the probe to the circuit ground 

terminal, and then connect the probe tip to the circuit point to be tested. 
 

Fuse Holder 

Fuse 
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Figure 1-5 To Connect the Passive Probe 

 
After you connect the passive probe, check the probe function and probe 
compensation adjustment before making measurements. For detailed procedures, 
refer to "Function Inspection" and "Probe Compensation". 
 
Connect the active probe: 
Take RP7150 (active differential probe head) as an example. 
1. Connect the probe head to the preamp of the active probe, as shown in Figure 

1-6. 

 
Figure 1-6 To Connect the Probe Head to the Preamp of the Active Probe 

 
2. Connect the other end of the preamp to an analog channel input terminal of the 

oscilloscope on the front panel, as shown in Figure 1-7. Note that you should 
push the probe to the end to ensure that it is tightly connected. 
 

 

 
Figure 1-7 To Connect the Active Probe 

 
3. Use the probe auxiliary equipment to connect the probe head to the circuit 

under test. For details about the probes, refer to RP7000 Series Active Probe 
User Guide. 

 
After connecting the active probe, you can perform probe calibration and offset 
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voltage adjustment if necessary. For detailed procedures, refer to the "Active 
Probe" section. 
 
 

Function Inspection 
 
This section takes RP3500A passive high-impedance probe as an example to 
illustrate the steps of function inspection for the oscilloscope. 

1. Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Then click on the "Storage" icon  to enter 
the storage and loading setting menu. Click More → Default, then a prompt 
message "Restore default settings?" is displayed. Click OK to restore the 
instrument to its factory default settings. 

2. Connect the ground alligator clip of the probe to the "Ground Terminal" as 
shown in Figure 1-8 below. 

3. Use the probe to connect the input terminal of CH1 of the oscilloscope and the 
"Compensation Signal Output Terminal" of the probe, as shown in Figure 1-8. 
 

  
Figure 1-8 To Use the Compensation Signal 

 
4. Set the probe attenuation to 10X, and then click the Auto key in the Web 

Control page. 
5. Observe the waveform on the display. In normal condition, the square waveform 

as shown in Figure 1-9 should be displayed. 

 
Figure 1-9 Square Waveform Signal 

Compensation Signal Output Terminal 

Ground Terminal 
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6. Use the same method to test the other channels. If the square waveforms 
actually shown do not match that in the figure above, please perform "Probe 
Compensation" introduced in the next section. 

 

 

WARNING 
To avoid electric shock when using the probe, please make sure that the 
insulated wire of the probe is in good condition. Do not touch the 
metallic part of the probe when the probe is connected to high voltage 
source. 

 
 

 
 

Probe Compensation 
 
When the probes are used for the first time, you should compensate the probes to 
make them match the input channels of the oscilloscope. Non-compensated or 
poorly compensated probes may cause measurement inaccuracy or errors. The 
probe compensation procedures are as follows: 
 
1. Perform Step 1, 2, 3 and 4 specified in "Function Inspection". 
2. Check the displayed waveforms and compare them with Figure 1-10. 

 
 
 

Figure 1-10 Probe Compensation 
 

3. Use a nonmetallic screwdriver to adjust the low-frequency compensation 
adjustment hole on the probe until the waveform is displayed as "Perfectly 
compensated" in the figure above. 

 

Tip 
The signal output from the probe compensation connector can only be used for 
making compensation adjustment for the 10X high-impedance probe and cannot 
be used for calibration. 

Over compensated        Perfectly compensated     Under compensated 
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Front Panel Overview 
 
 
 
 

 
 

 
Figure 1-11 Front Panel 

 
 
Table 1-1 Front Panel Description 

No. Description No. Description 

1 RUN/STOP Key 2 LAN Interface Indicator 

3 Acq Indicator 4  50 Ω Indicator 

5 USB HOST Interface 6 
Probe Compensation Signal Output 

Terminal/Ground Terminal 

7 1 MΩ Indicator 8 Analog Channel Input Terminals 

9 Power Key 10 
Force Key (used to initiate a trigger 

forcibly) 
 
 

Rear Panel Overview 
 
 
 

 
 
 

 
Figure 1-12 Rear Panel 
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1. LAN Interface 
Connect the instrument to network via this interface. The instrument is in 
compliance with the standards specified in LXI Device Specification 2011. It can 
be used to set up a test system. 
When you access to the Internet, you can use the Web Control, PC software 
Ultra Scope, or use the user-defined programming to control the instrument. 
When update is available, you can perform online upgrading for the system 
software of the instrument via the LAN interface. After it is connected to the 
network, you can print the waveform displayed on the screen through the 
network printer. 

 

 
2. USB HOST Interface 

You can connect the storage device that is compatible with the USB to the 
instrument via the USB HOST interface. 
Connecting the storage device can save or recall the waveform files and setup 
files; as well as save the data and screen image. When update is available, you 
can perform local upgrading for the system software of the instrument via the 
USB HOST interface.  

 

Tip 
After the oscilloscope is connected to network (if you do not have the access 
to the Internet, please ask the administrator to open the specified network 
authority), you can perform online upgrading for the system software: 

1) Click on the function navigation icon  at the lower-left corner of the 
externally connected screen to enable the function navigation.  

2) Click on the "Help" icon , and then the "Help" menu is displayed on 
the screen. 

3) Click Online upgrade, then a "System Update Information" window is 
displayed, requesting you whether to accept or cancel "RIGOL 
PRODUCT ONLINE UPGRADE SERVICE TERMS". Click "Accept" to start 
online upgrade. Click "Cancel" to cancel the online upgrade.  

Tip 
Perform local upgrading for the system software: 
1) Insert the USB storage device (stored with upgrading files under its root 

directory) into the USB HOST interface. 

2) Click on the function navigation icon  at the lower-left corner of the 
externally connected screen to enable the function navigation. Then 

click on the "Help" icon , and then the "Help" menu is displayed on 
the screen. Click Local upgrade, then a dialog box "Upgrade system 
firmware?" is displayed.  

3) Click OK to start local upgrade for the oscilloscope. If you click 
"Cancel", the local upgrade will be cancelled. 
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3. SFP+ Interface 
SFP (Small Form-factor Pluggable) module electrical interface. It is an 
optical transceiver and supports hot plugging. Through this interface, the 
oscilloscope can support 10 Gbit/s data transmission rate. 

 
4. HDMI Video Output 

Through this interface, you can connect the instrument to an external 
display (e.g. monitor or projector) equipped with the HDMI interface to 
better observe the waveform display clearly.  
 

5. USB DEVICE Interface 
You can connect the instrument to the PC via this interface. Then you can 
use the PC software Ultra Scope to send the SCPI commands, or use the 
user-defined programming to control the instrument. 
 

6. 10 M In/Out 
Indicates the reference clock. It can provide accurate sample clock signal 
for the oscilloscope, and can be used to synchronize the clock of two or 
multiple oscilloscopes. 
 

7. EXT 
Inputs the external signal via the external input terminal. 

 
8. GEN 

Outputs the built-in signal output from the function/arbitrary waveform 
generator via this GEN connector. This function is only available for the 
model installed with the DS8000-R-AWG option. 

  
9. Trigger Out and Pass/Fail 

⚫ TRIG OUT 
The oscilloscope can output a signal that can reflect the current 
capture rate of the oscilloscope at each trigger via this interface. 
Connect the signal to a waveform display device and measure the 
frequency of the signal. The measurement result is the same as the 
current capture rate. 

⚫ Pass/Fail 
The instrument can output a pulse from the [TRIG OUT] connector 
when a pass/failed event is detected during the pass/fail test. 

 
10. Fuse 

If you need to replace the fuse, use only the specified fuse. For details, refer 
to descriptions in "To Replace the Fuse". 

 
11. AC Power Cord Connector 

Indicates the input terminal where AC power source is connected. The 
power supply requirements of the instrument are: 100 V~240 V; 45 
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Hz~440 Hz. Please use the power cord provided in the accessories to 
connect the oscilloscope to the AC power source. 
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User Interface 
 
DS8000-R series does not have an LCD display. You can operate the oscilloscope and 
configure parameters with the externally connected mouse via the USB interface on 
the oscilloscope; observe acquired waveforms, the setting information, and the 
measurement results on the user interface through the monitor externally connected 
via the HDMI interface. 
 
Note: The screen mentioned in this manual refers to the externally connected 
display device that is connected via the HDMI interface. 
 
 
 
 

  
 
 

 
 

Figure 1-13 User Interface 
 
1. Analog Channel Label/Waveform 

Different channels are marked with different colors. The color of the channel 
label is the same as that of the waveform. 

 
2. Operating Status 

Available states include RUN, STOP, T’D (triggered), WAIT, and AUTO. 
 
 

1      2       3        4       5  6  7     8        9             10 11 12  

21        20         19        18       17  16              15          14   13  
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3. Horizontal Time Base 
Represents the time length per grid in the horizontal axis of the screen. 

 
4. Sample Rate/Memory Depth 

⚫ Displays the current sample rate and memory depth of the analog channel. 
⚫ The sample rate and the memory depth will change along with the 

horizontal time base. 
 
5. Auto Measurement Label 

Click the label, and up to 41 waveform parameters are available for auto 
measurement. It also offers full-memory hardware measurement function. 
 

6. Waveform Memory 
Provides a diagram of the position of the screen waveform in the memory. 
 
 
 
 

 
 
7. Trigger Position 

Displays the trigger position of the screen waveform and that of the waveform in 
the memory. 
 

8. Run/Stop Label 
In the run state, the label is displayed in green; while in the stop state, it is 
displayed in red. You can click the label "STOP/RUN" to control its operating 
status. 
 

9. Horizontal Position 
Displays the horizontal position. Click this label, and you can adjust the 
horizontal position. 
 

10. Trigger Type 
Displays the currently selected trigger type and trigger condition setting. When 
you select different trigger types, different labels are displayed. For example,  
represents triggering on the rising edge in "Edge" trigger. 
 

11. Trigger Source 
Displays the currently selected trigger source (CH1-CH4, AC Line, or EXT). When 
you select different trigger sources, different labels are displayed. For example, 

 denotes that CH1 is selected as the trigger source. 
 

12. Trigger Level 
⚫ When CH1-CH4 or EXT is selected as the trigger source, you need to set a 

proper trigger level. 

screen waveform 

waveform in the memory 
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⚫ The trigger level label  is displayed at the left section of the screen, and 
the trigger level value is displayed at the upper-right corner of the screen. 

⚫ When you modify the trigger level, the trigger level value will change with 
the up and down of . 

Note: In Slope Trigger, Runt Trigger, and Window trigger, you need to set the 
upper and lower limits of the trigger level, and two trigger level labels (  and 

) are displayed. 
 

13. Operation Menu 

Click the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation. Click any icon in the 
navigation menu to open the corresponding menu.  
 

14. Notification Area 
Displays the beeper icon, the USB storage device icon, time, and the LAN 
connection icon. 
⚫ Beeper icon: open the function navigation men, click Utility → Beeper to 

turn on or off the beeper. When the beeper is turned on,  will be 

displayed; when off,  will be displayed. 

⚫ USB storage device icon: When a USB storage device is detected,  will be 
displayed. 

⚫ Time: displays the system time. For the system time setting, refer to 
descriptions in "System Time". 

⚫ LAN connection icon: When the LAN interface is successfully connected, 

 will be displayed. 
 
15. AWG 

⚫ Displays the on/off status of AWG. 
⚫ Displays the waveform type set for the current AWG. 
⚫ It is only available for the model installed with the DS8000-R-AWG option. 
 

16. CH4 Status Label 
⚫ Displays the status of CH4.  
⚫ Displays the vertical scale of CH4. That is, the voltage value per grid of CH4 

in the vertical axis.  
⚫ Displays the offset of CH4, i.g. the vertical offset of CH4 waveform.  
⚫ Different labels will be displayed according to the current channel setting. 

For example, if you select "DC" for channel coupling,  is displayed; if you 
enable the bandwidth limit,  is displayed; if you select "50 Ω" for 
impedance,  is displayed. 

 
17. Message Box 

Displays the prompt messages. 
 

18. CH3 Status Label 
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⚫ Displays the status of CH3.  
⚫ Displays the vertical scale of CH3. That is, the voltage value per grid of CH3 

in the vertical axis.  
⚫ Displays the offset of CH3, i.g. the vertical offset of CH3 waveform.  
⚫ Different labels will be displayed according to the current channel setting. 

For example, if you select "DC" for channel coupling,  is displayed; if you 
enable the bandwidth limit,  is displayed; if you select "50 Ω" for 
impedance,  is displayed. 
 

19. CH2 Status Label 
⚫ Displays the status of CH2.  
⚫ Displays the vertical scale of CH2. That is, the voltage value per grid of CH2 

in the vertical axis.  
⚫ Displays the offset of CH2, i.g. the vertical offset of CH2 waveform.  
⚫ Different labels will be displayed according to the current channel setting. 

For example, if you select "DC" for channel coupling,  is displayed; if you 
enable the bandwidth limit,  is displayed; if you select "50 Ω" for 
impedance,  is displayed. 

 
20. CH1 Status Label 

⚫ Displays the status of CH1.  
⚫ Displays the vertical scale of CH1. That is, the voltage value per grid of CH1 

in the vertical axis.  
⚫ Displays the offset of CH1, i.g. the vertical offset of CH1 waveform.  
⚫ Different labels will be displayed according to the current channel setting. 

For example, if you select "DC" for channel coupling,  is displayed; if you 
enable the bandwidth limit,  is displayed; if you select "50 Ω" for 
impedance,  is displayed. 
 

21. Function Navigation 

Click the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation. 
 
 

Common Operation 
 

Click Operation 
⚫ Click the menu displayed on the externally connected screen to operate on the 

menu. 

⚫ Click the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation. 

⚫ Click the displayed numeric keypad to set the parameters. 
⚫ Click the virtual keypad to set the label name, the filename, and other character 

strings. 
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⚫ Click the close button  at the upper-right corner of the message box to close 
the prompt window. 

⚫ Click other windows on the externally connected screen and operate on the 
windows. 

⚫ Double-click the left mouse button to stop the recording/playing of the 
waveforms or stop the self-calibration. 

 
 

Drag Operation 
Click to select the menu and then drag the mouse to change the position of the 
waveforms or the cursor on the screen.  
 
 

Scroll Operation 
For the menu with the icon  on it, click to select the parameter item, then scroll 
up and down with the mouse to adjust the parameter value. You can also set it with 

the pop-up numeric keypad. For the menu with the icon , click the menu and 
scroll up and down with the mouse to adjust the parameter.  

 
For example, to adjust the waveform brightness, first click on the function navigation 

icon  to open the function navigation. Then click on the "Display" icon  to 
enter the "Display" setting menu. Click Intensity to adjust the intensity. The 
adjustable range of the intensity is from 1% to 100%. Scroll up with the mouse to 
increase the brightness, and scroll down with the mouse to decrease the brightness. 
 
 

Rectangle Drawing 
Click on the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation. Then click on the "Draw rect" icon 

 to switch to the rectangle drawing mode. Drag the mouse cursor from upper left 
to lower right across the screen to draw a rectangle on the screen, and then a menu 
is displayed on the screen. At this time, you can click to select "Trigger zone A", 
"Trigger zone B", "Histogram", "Horizontal zoom in", "Vertical zoom in", or 
"Waveform zoom in". Drag the mouse cursor from lower right to upper left across the 
screen to draw a rectangle on the screen. Move your cursor away from the screen, 
and then a menu is displayed on the screen. At this time, you can click to select 
"Trigger zone A", "Trigger zone B", "Histogram", "Horizontal zoom out", "Vertical 
zoom out", or "Waveform zoom out". 
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⚫ Select "Trigger zone A": 
➢ Draw the region for Trigger zone A; 
➢ Open Trigger zone A; 
➢ Open the "Zone Trigger" menu. 

⚫ Select "Trigger zone B": 
➢ Draw the region for Trigger zone B; 
➢ Open Trigger zone B; 
➢ Open the "Zone Trigger" menu. 

⚫ Select "Histogram": 
➢ Draw the region for the histogram; 
➢ Open the "Histogram" menu. 

⚫ Select "Horizontal zoom in": expands the waveforms in the horizontal direction. 
Select "Horizontal zoom out": compresses the waveforms in the horizontal 
direction. 

⚫ Select "Vertical zoom in": expands the waveforms in the vertical direction. Select 
"Vertical zoom out": compresses the waveforms in the vertical direction. 

⚫ Select "Waveform zoom in": expands the waveforms both in the horizontal and 
vertical direction. Select "Waveform zoom out": compresses the waveforms both 
in the horizontal and vertical direction. 
 

 
Note: The menu displayed on the externally connected screen or the icon available 
to be enabled on the screen can all be operated by Web Control. However, Web 
Control does not support the following operations: 
⚫ Double-click the mouse left button to stop recording/playing of the waveforms; 

or stop the self-calibration. 

Tip 
Click on the "Draw rect" icon to switch between the rectangle drawing and 
waveform operation modes. 

Click on the "Draw rect" icon, if  is displayed, it indicates that the rectangle 

drawing mode is enabled. Click on the "Draw rect" icon, if  is displayed, it 
indicates that the waveform operation mode is enabled. By default, the waveform 
operation mode is enabled.  
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⚫ All the mouse dragging operation. 
⚫ All the mouse scrolling operation. 
⚫ Rectangle drawing operation. 
 
In this manual, descriptions on menu operation through externally connected screen 
are illustrated in details. For details about menu operation through Web Control, we 
will illustrate it in relevant chapters if necessary. 
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Parameter Setting Method 
 
You can set the parameters of DS8000-R series through the Web Control or the 
externally connected display device/mouse/keyboard. The common parameter 
setting method is shown as follows:  

 

 
    Figure 1-14 Numeric Keypad 

 
In the numeric keypad, click to select the value or the unit in the numeric keypad. 
You can also use the externally connected keyboard to input the parameter value. 
After you input all the values and select the desired units, the numeric keypad is 
turned off automatically. This indicates that you have completed parameter setting. 
Besides, after you have input the values, you can also click OK directly to close the 
numeric keypad. At this time, the unit of the parameter is the default unit. In the 
numeric keypad, you can also perform the following operations: 
⚫ Delete the parameter value that has been input. 
⚫ Set the parameter to a maximum or minimum value (sometimes, the maximum 

or minimum value are the specified one for the current state). 
⚫ Set the parameter to a default value. 
⚫ Clear the parameter input field. 
 

Tip 
The above method is commonly used for the parameter settings of the 
oscilloscope. For other methods of parameter settings, refer to details in relevant 
chapters. 

Parameter 
Input Field 
Delete key 
 
Max. value 
 
Min. value 

Default 

Clear key 
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To Use the Built-in Help System 
 
The help system of this oscilloscope provides instructions for all the function keys 
and their corresponding menu keys. The steps for viewing the help information are 
as follows: 

1. Click the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Click the "Help" icon  to enter the "Help" 
menu. 

2. Click Content, and then the help information is displayed on the screen, as 
shown in Figure 1-15. The help interface mainly consists of two sections. The 
left section lists "Help Options", and the right section is the "Help Display Area". 

 
 
 

 

 
Figure 1-15 Help Information 

 
After opening the help interface, you can click the desired help option to get its help 
information in the "Help Display Area". 

     Help Options           Help Display Area 
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To View the Option Information and the Option 
Installation 
 
DS8000-R series oscilloscope provides multiple options to fulfill your measurement 
requirements. If you need any of these options, order them according to the Order 
No. available in "Appendix A: Accessories and Options", and then install the 
options according to this section. Besides, you can also view the options currently 
installed on the oscilloscope or activate the newly purchased option. 
 
1. View the installed option 

The instrument is installed with the trial versions of the options before leaving 
factory. When you power on the instrument for the first time, the trial time is 
about 2,160 minutes. If your instrument has currently installed the option, 
perform the following operations to view the name of the installed option and 
other detailed information about the option from the option list. 

(1) Click the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click the "Help" icon  to enter the 
"Help" menu. 

(2) Click the Option list menu item, and then a list of the options installed is 
displayed on the screen for users to view. 
 

2. Install the option 
The option license is a string of fixed characters. Each instrument has one 
unique license. The license file should be in specific format, with the filename 
extension ".lic". After you purchase an option, you will obtain a key (used for 
obtaining the license). Then, you can install the option according to the 

following steps. 
1) Obtain an option license 

(1) Log in to the RIGOL official website (www.rigol.com), click License 

Activation to enter the "Registered product license code" interface. 
(2) In the software license registration interface, input the correct key, 

serial number (Click the function navigation icon  at the lower-left 
corner of the screen to open the function navigation. Click the "Help" 

icon  to enter the "Help" menu. Click About to obtain the serial 
number), and the verification code. Click Generate to obtain the 
download link of the option license file. If you need to use the option 
license file, please click the link to download the file to the root 
directory of the USB storage device. 
 

2) Install the option 
(1) Confirm that the option license file is located in the root directory of the 

USB storage device, and connect the USB storage device to the 
oscilloscope properly.  

http://www.rigol.com/
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(2) The Option install key is activated, and click this menu item to start 
installing the option.  

(3) After installation, a prompt message "Option activated successfully" is 
displayed. 
Note: After the option has been installed, you are recommended to 
restart the instrument. 
 

Tip 
⚫ Only 1 option license file of one instrument is allowed to be stored in the 

same USB storage device, but the USB storage device can store the option 
license file of several different instruments. You are not allowed to modify 
the licensed filename. 

⚫ During the installation process, you are not allowed to power off the 
instrument or pull out the USB storage device. 

⚫ Sending the SCPI commands (:SYSTem:OPTion:INSTall <license>) to install 
options is supported. Installing options by inputting the license code 
manually is not supported. 
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Chapter 2 To Set the Vertical System 
 
DS8000-R series provides four analog input channels (CH1-CH4), and each channel 
is equipped with an independent vertical control system. The setting methods for the 
vertical systems of the four channels are the same. This chapter takes CH1 as an 
example to introduce the setting method for the vertical system. For this oscilloscope, 
only CH1 is enabled by default. 
 
Contents in this chapter: 
◼ To Enable or Disable the Analog Channel 
◼ To Adjust the Vertical Scale 
◼ Vertical Expansion 
◼ To Adjust the Vertical Offset 
◼ Channel Coupling 
◼ Bandwidth Limit 
◼ Probe Ratio 
◼ Input Impedance 
◼ Waveform Invert 
◼ To Set the Probe 
◼ Amplitude Unit 
◼ Channel Delay 
◼ Offset Cal 
◼ Channel Label 
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To Enable or Disable the Analog Channel 
 
Enable the analog channel: 
Connect a signal to the channel connector of CH1, and then click the CH1 label at the 
bottom part of the screen to enable CH1. Then, CH1 label is illuminated in yellow. At 
this point, the channel setting menu is displayed at the right section of the screen 
and the channel is activated. The channel status label at the bottom of the screen is 
shown in the figure below.  

  
 
The information displayed in the channel status label is related to the current channel 
setting but irrelevant with the on/off status of the channel. After the channel is 
turned on, modify the parameters such as the vertical scale, horizontal time base, 
trigger mode, and trigger level according to the input signal for easy observation and 
measurement of the waveform. 
 
If CH1 is enabled but not activated, the channel status label is shown in the following 
figure. To activate the channel, click the channel number in the channel status label 
or the channel label at the left side of the screen. 

 
 
Disable the analog channel: 
If the setting menu of the channel that needs to be disabled (the current channel is 
activated) is displayed at the right section of the screen, click the channel status label 
to disable the channel. If the setting menu of the channel that needs to be disabled is 
not displayed at the right section of the screen, first open the setting menu of the 
channel to be disabled (activate the channel), then click the channel status label to 
disable the channel. For example, if CH1 and CH2 are enabled, and CH2 channel 
setting menu is displayed on the screen, then if you need to disable CH1, first 
activate CH1, and then click the CH1 channel status label displayed on the externally 
connected screen to disable CH1. If CH1 is disabled, the channel status label is 
shown in the following figure. 

 
 
 

To Adjust the Vertical Scale 
 
Vertical scale indicates the voltage value per grid in the vertical axis of the screen. It 
is often expressed in V/div. While you adjust the vertical scale, the display amplitude 
of the waveform would enlarge or reduce. The scale information of the channel 
status label (e.g. as shown in the following figure) at the lower section of the screen 
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would change accordingly. 

 
 
The adjustable range of the vertical scale is related to the currently set probe ratio 
and input impedance. By default, the probe ratio is 1X and the input impedance is 1 
MΩ. In this case, the adjustable range of the vertical scale is from 1 mV/div to 10 
V/div. 
 
When CH1 is turned on, you can adjust the vertical scale with the following method: 
Click the channel status label at the bottom of the screen. The following window is 

displayed. Click on the  icon at the right side of the Scale input field to 
decrease or increase (i.g. compress or enlarge the waveforms). You can also click the 
Scale input field to input a specific value with the displayed numeric keypad. 

 
 

 
 
 

Vertical Expansion 
 
Click the channel status label at the bottom of the screen. In the channel menu, click 
More, then click Expand continuously to select "Center" or "GND". 
⚫ Center: when the vertical scale is changed, the waveform will be expanded or 

compressed around the screen center. 
⚫ GND: when the vertical scale is changed, the waveform will be expanded or 

compressed around the signal ground level position. 
 
 

To Adjust the Vertical Offset 
 
Vertical offset indicates the offset of the signal ground level position of the waveform 
from the screen center in the vertical direction. Its unit is consistent with the 
currently selected amplitude unit (refer to "Amplitude Unit"). When adjusting the 
vertical offset, the waveforms of the corresponding channel moves up and down. 
The vertical offset information (as shown in the following figure) in the channel 
status label at the bottom of the screen will change accordingly. 

 
Vertical Offset 

Vertical Scale 

Value Input Field Decrease Increase 
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The adjustable range of the vertical offset is related to the current input impedance, 
probe ratio, and vertical scale.  
 
When CH1 is turned on, you can adjust the vertical offset with the following method: 
Click the channel status label at the bottom of the screen. The following window is 

displayed. Click on the  icon at the right side of the Offset input field to 
decrease or increase the offset. You can also click the Offset input field to input a 
specific value with the displayed numeric keypad. 
 

 
 

 
 
 

Channel Coupling 
 
The undesired signals can be filtered out by setting the coupling mode. For example, 
the signal under test is a square waveform with DC offset. 
⚫ When the coupling mode is "DC": the DC and AC components of the signal under 

test can both pass the channel. 
⚫ When the coupling mode is "AC": the DC components of the signal under test 

are blocked. 
⚫ When the coupling mode is "GND", the DC and AC components of the signal 

under test are both blocked. 
 
Click Coupling in the channel setting menu to select the coupling mode. The 
available coupling modes include DC, AC, and GND. The current coupling mode is 
displayed in the channel status label at the bottom of the screen, as shown in the 
figure below.  
 

                  
               DC                       AC                    GND     
 

Note:  
⚫ When the input impedance is set to "50 Ω", the channel coupling is set to DC 

coupling by force, and the Coupling menu is grayed out and cannot be 
modified. 

⚫ When the coupling mode is "AC", the input impedance is set to 1 MΩ by force, 

Value Input Field  Decrease Increase 
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and the Impedance menu is grayed out and cannot be modified. 
 
 

Bandwidth Limit 
 
DS8000-R series supports the bandwidth limit function. Setting the bandwidth limit 
can reduce the noises in the displayed waveforms. For example, the signal under test 
is a pulse with high frequency oscillation. 
⚫ When the bandwidth limit is disabled, the high frequency components of the 

signal under test can pass the channel. 
⚫ When you enable the bandwidth limit and limit it to 20 MHz, 250 MHz, or 500 

MHz, the high frequency components found in the signal under test that are 
greater than 20 MHz, 250 MHz, or 500 MHz are attenuated. 

Note: The bandwidth limit is different for different models.  
 
Click the channel status label and select the desired bandwidth limit in the CH1 
setting menu. When the bandwidth limit is enabled, the character "B" will be 
displayed in the channel status label at the bottom of the screen, as shown in the 
figure below.  

 
 
The bandwidth limit that you select is based on the input impedance of your 
oscilloscope model, as shown in Table 2-1. 
 
Table 2-1 Bandwidth Limit 

Input Impedance of 
the Oscilloscope 

Available Bandwidth Limit 

50 Ω 
DS8104-R/DS8204-R: 20 M 
DS8034-R: 20 MHz, 250 MHz 

1 MΩ 
DS8104-R/DS8204-R: 20 MHz, 250 MHz, 500 MHz;  
DS8034-R: 20 MHz, 250 MHz 

Note: Bandwidth limit can not only reduce the noise, but also can attenuate or 
eliminate the high frequency components of the signal. 

 
 

Probe Ratio 
 
DS8000-R series allows you to set the probe attenuation manually. To obtain the 
correct measurement results, you must set the probe ratio properly. By default, the 
probe ratio is 1X. 
 
Click the CH1 channel status label to open the setting menu of CH1. Then, click 
Attenuation to select the desired probe ratio. The probe ratio values available are 
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as shown in Table 2-2. 
 
Table 2-2 Probe Ratio 

Menu 
Attenuation Ratio 
(display amplitude of the signal: actual amplitude 
of the signal) 

0.0001X 
0.0002X 
0.0005X 
0.001X 
0.002X 
0.005X 
0.01X 
0.02X 
0.05X 
0.1X 
0.2X 
0.5X 
1X (default) 
2X 
5X 
10X  
20X 
50X 
100X 
200X 
500X 
1000X 
2000X 
5000X 
10000X 
20000X 
50000X 

0.0001:1 
0.0002:1 
0.0005:1 
0.001:1 
0.002:1 
0.005:1 
0.01:1 
0.02:1 
0.05:1 
0.1:1 
0.2:1 
0.5:1 
1:1 
2:1 
5:1 
10:1 
20:1 
50:1 
100:1 
200:1 
500:1 
1000:1 
2000:1 
5000:1 
10000:1 
20000:1 
50000:1 

Note: After the oscilloscope auto-recognized certain probes with a fixed attenuation 
ratio, the probe ratio will also be auto recognized. You do not have to set it 
manually. 

 
 

Input Impedance 
 
To reduce the circuit load between the oscilloscope and the circuit under test, this 
oscilloscope provides two input impedance modes: 1 MΩ (default) and 50 Ω. 
⚫ 1 MΩ: The input impedance of the oscilloscope is very high, and the current 

flowed from the circuit under test can be ignored. 
⚫ 50 Ω: makes the oscilloscope match the device whose input impedance is 50 Ω. 
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Click the CH1 channel status label to open the setting menu of CH1. Then, click 
Impedance continuously to select the input impedance of the oscilloscope. If you 
select "50 Ω", the channel status label at the bottom of the screen will display the 
icon . 
 
Note: 
⚫ After the oscilloscope recognizes the probe automatically, the input impedance 

will also be auto recognized. You do not have to set it manually. 
⚫ The setting of the input impedance will affect the ranges of channel vertical 

scale and offset.  
 
 

Waveform Invert 
 
Click the CH1 channel status label to open the setting menu of CH1. Then, click 
Invert continuously to enable or disable the waveform invert. When enabled, the 
channel label is displayed, as shown in the following figure. 

 
 
When disabled, the waveform is displayed normally; when enabled, the voltage 
values of the displayed waveform are inverted (as shown in Figure 2-1). Enabling the 
waveform invert will also change the result of math function and waveform 
measurement. 

 
(a) "Invert" Off 

 
(b) "Invert" On 

Figure 2-1 Waveform Invert 
 

Note: When the waveform invert is enabled, the trigger edge or the trigger polarity 
will change (e.g. Edge trigger, Pulse trigger, or Slope trigger). 
 
 

To Set the Probe 
 
The analog channel of this oscilloscope not only supports the common passive probe, 
but also the active probe. It can automatically recognize the currently connected 
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probe type and its probe ratio. For detailed technical information of the probes, 
please refer to the corresponding Probe User Guide. 
 
Click the CH1 channel status label to open the setting menu of CH1. Then, click 
Probe to open the probe menu. If different probes are connected to the oscilloscope, 
different information about the probe will be displayed, and you can perform the 
different operations on the menu. 
 
 

Passive Probe 
 
If a passive probe is connected, for example, when RIGOL's RP3500A probe model 

is connected to the oscilloscope, click Probe to open the probe menu. Its sub-menus 
are grayed out and disabled. 
  

 
 

Active Probe 
 
If an active probe is connected, for example, when RIGOL's RP7150 probe model is 

connected to the oscilloscope, click Probe to open the probe menu, and you can 
operate on the menu item. 
  

 
⚫ Probe Delay 

To avoid measurement result errors arising from the transmission delay of the 
probe cable, the oscilloscope provides the probe delay adjustment function for 
the active probe. Click Skew, and use the pop-up numeric keypad or scroll with 
the mouse to set the probe delay time. 
 

⚫ Bias Voltage 
The oscilloscope provides the bias voltage adjustment function for active probes. 
This function is used to adjust the signal under test that exceeds the input 
dynamic range of the probe amplifier to an appropriate range to ensure the 

Tip  
For some of the ordinary passive probes, the oscilloscope can recognize their 
probe ratio automatically. If not recognized, please refer to "Probe Ratio" to set 
the probe ratio.  

Tip  
⚫ When a 50 Ω active probe is connected, the input impedance (refer to "Input 

Impedance") of the channel will be automatically set to "50 Ω". 
⚫ For the active probe, the oscilloscope can recognize the probe ratio 

automatically. If the currently connected probe supports a variety of probe 
ratios, please refer to "Probe Ratio" to set the probe ratio. 
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integrity of the signal under test. Click Bias, and use the pop-up numeric keypad 
or scroll with the mouse to set the DC bias voltage.  
 

⚫ Probe Information 
Click About to view information about the probe currently connected, such as 
the manufacturer, model, serial number, and the last calibration date. 
 

⚫ Probe Calibration 
Click Calibration to start zero calibration automatically for the probe.  
 

⚫ Demagnetization 
Click Demagnetize to perform demagnetization automatically for the probe. 
 
Note: This function is only available when the specified probe is connected. For 
details about the probe demagnetization operation, refer to 
PCA1030/PCA2030/PCA1150 User Guide. 

 
 

Amplitude Unit 
 
Select the amplitude display unit for the current channel. The available units are W, A, 
V, and U. When the unit is changed, the unit related to the relevant functions of the 
channel will change accordingly. 
 
Click the CH1 channel status label to open the CH1 setting menu. Click More → Unit 
to select a unit. The default unit for the value is V. 
 
 

Channel Delay 
 
When using an oscilloscope for actual measurement, the transmission delay of the 
probe cable may bring relatively greater errors (zero offset). DS8000-R allows you to 
set a delay time for calibrating the zero offset of the corresponding channel. Zero 
offset is defined as the offset of the crossing point of the waveform and trigger level 
line relative to the trigger position, as shown in Figure 2-2. 
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Figure 2-2 Zero Offset 

 
Click the CH1 channel status label to open the CH1 setting menu. Click More → 
Ch-Ch Skew, then use the pop-up numeric keypad or scroll with the mouse to set 
the desired delay calibration time. The available range of the delay calibration time is 
from -100 ns to 100 ns.  
 
Note: This parameter is related to the instrument model and the current horizontal 

time base setting. The larger the horizontal time base is, the larger the setting 
step will be.  

 
 

Offset Cal 
 
When you use an oscilloscope to make actual measurements, a small offset that 
arises from the temperature drift of the component or external environment 
disturbance may occur on the zero-cross voltage of the channel, which will affect the 
measurement results of the vertical parameters. DS8000-R allows you to set an 
offset calibration voltage for calibrating the zero point of the corresponding channel, 
so as to improve the accuracy of the measurement results. 
 
Note: If the zero-cross voltage of the channel has a larger amplitude offset that 

exceeds the adjustable offset calibration range, please perform self-calibration 
for the instrument manually to ensure the measurement accuracy. For details, 
refer to descriptions in "Self-calibration". 

 
Click the CH1 channel status label to enter the CH1 setting menu. Click More → 
Offset Cal, then use the pop-up numeric keypad or scroll with the mouse to set the 
offset calibration value.  
 
 
 



Chapter 2 To Set the Vertical System  RIGOL 

DS8000-R User Guide 2-11 

Channel Label 
 
The instrument uses the channel number to mark the corresponding channel by 
default. For ease of use, you can also set a label for each channel. For example, 

" ". 
 
Click the CH1 channel status label to enter the CH1 setting menu. Click More → 
Label to enter the label setting menu. You can use the built-in label or manually 
input a label. Three input methods are available for you to input a label name, 
including Chinese, English, and Traditional Chinese. 
 
The label setting menu includes the following menu items. 
⚫ Click Display to turn on or off the display of the channel label. If it is enabled, 

the label will be displayed at the left side of the waveform. When on, CH1 is, by 
default, displayed to be the channel label. 

⚫ Click Library to select the preset labels such as CH1, ACK, ADDR, BIT, CLK, CS, 
DATA, IN, MISO, MOSI, OUT, RX and TX. 

⚫ Click Label and the label editing interface is automatically displayed, as shown in 
Figure 2-3. You can input the label manually. For the label input method, refer to 
"To Create a Folder". 
 
 
 
 

 
 

Figure 2-3 Label Editing Interface 
 

For example, set the label to " ". In the virtual keypad, click "Caps" (only available 
to be selected for English input method) to switch the uppercase or lowercase mode. 
Select "C" and click it to complete inputting C. Use the same method to input "hn1". 
After finishing the input, click OK to finish the editing. If Display is enabled, the 

label  will be displayed at the left of CH1 waveform. 
 
To delete or modify the input characters, move the cursor to the right side of the 
character required to be deleted or modified, and then click the delete key to delete 
the character. To modify the characters, input the desired character again. 

 Label Input Area  Input Selection Area  Virtual Keypad   Delete Key 
 

Upper/Lower 
Case Switch 
 



RIGOL Chapter 2 To Set the Vertical System 

2-12 DS8000-R User Guide 

The "Input Selection Area" is only available when you select the Chinese input 
method. 
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Chapter 3 To Set the Horizontal System 
 
Contents in this chapter: 
◼ To Adjust the Horizontal Time Base 
◼ To Adjust the Horizontal Position 
◼ Delayed Sweep 
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To Adjust the Horizontal Time Base 
 
Horizontal time base, also called the horizontal scale, refers to the time of each grid 
in the horizontal direction of the screen. It is usually expressed in s/div. The 
adjustable range of the horizontal time base is from 200 ps/div to 1 ks/div.  
 
While you change the horizontal time base, the displayed waveforms of all channels 
are expanded or compressed horizontally relative to the current selected horizontal 
reference baseline (refer to "Horizontal Expansion"). The horizontal time base at 
the upper-left corner of the screen will be changed accordingly, as shown in the 
figure below. 

 
 
You can adjust the horizontal time base with the following methods: 

Click the horizontal time base label  at the top of the screen. The following 

window is displayed. Click on the  icon at the right side of the Scale input 
field to decrease or increase the scale (i.g. enlarge or compress the waveforms). You 
can also click the Scale input field to input a specific value with the displayed 
numeric keypad. 

 
 
 

 
 
You can click on the function navigation icon to open the function navigation. Then 
click Acquisition → Fine to enable or disable the fine adjustment of the horizontal 
time base. 
⚫ Coarse adjustment: adjusts the horizontal time base of the waveforms of all 

channels at 1-2-5 step within the adjustable range.  
⚫ Fine adjustment: adjusts the horizontal time base of the waveforms of all 

channels with a minor step value within the adjustable range.  
 
 

To Adjust the Horizontal Position 
 
Horizontal position, also called trigger position, refers to the trigger point position of 
the waveforms of all channels in the horizontal direction relative to the screen center. 
When the waveform trigger point is at the left (right) side of the screen center, the 

Decrease the Scale Increase the Scale 
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horizontal position is a positive (negative) value. 
While you change the horizontal position, the waveform trigger points and the 
displayed waveforms of all channels are moved left and right. The horizontal position 
at the right-upper corner of the screen changes accordingly, as shown in the figure 
below. 

 
 
You can adjust the horizontal position with the following method: 

Click the horizontal position label  at the top of the screen. The following 

window is displayed. Click the  icon at the right side of the Pos input field 
to decrease or increase the horizontal position. You can also click the Pos input field 
to input a specific value with the displayed numeric keypad. 
 

 
 
 
 
 
 

Delayed Sweep 
 
Delayed sweep can be used to enlarge a length of waveform horizontally to view 
waveform details. 
 

Click the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation menu. Click the acquisition icon 

 to open the acquisition setting menu. Click More → Zoom to enable or disable 
the delayed sweep function. 
 
Note: To enable the delayed sweep, you must ensure that the current time base 

mode is "YT". 
 
In delayed sweep mode, the screen is divided into two display areas, as shown in 
Figure 3-1. 
 
 
 
 Horizontal Position of the 

Delayed Sweep 

Decrease the Position Increase the Position 
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Figure 3-1 Delayed Sweep Mode 
 
Waveform before enlargement: 
The waveform in the area that is not covered by subtransparent blue in the upper 
part of the screen is the waveform before enlargement. Its horizontal time base (also 
called main time base) is displayed at the upper-left corner of the screen.  
 
Waveform after enlargement: 
The waveform in the lower part of the screen is the horizontally expanded delayed 
sweep waveform. Its horizontal time base (also called the time base of the delayed 
sweep) is displayed on the screen. Compared with the main time base, the time 
based of the delayed sweep has increased the waveform resolution. 
 
Note: The time base of the delayed sweep should be smaller than or equal to the 

main time base. 

Waveform Before Enlargement 

 
Main 
Time 
Base 

 
 

Time 
Base of 

the 
Delayed 
Sweep 

 
 
 
 

Waveform After Enlargement 
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Chapter 4 To Set the Sample System 
 
Contents in this chapter: 
◼ Timebase Mode 
◼ Acquisition Mode 
◼ Sampling Mode 
◼ Sample Rate 
◼ Memory Depth 
◼ Anti-Aliasing 
◼ Horizontal Expansion 
 



RIGOL Chapter 4 To Set the Sample System  

4-2 DS8000-R User Guide 

Timebase Mode 
 
DS8000-R series supports three available time base modes: YT mode, XY mode, and 
ROLL mode. By default, the time base mode is YT. 
 

Click the function navigation icon  at the lower-left corner of the externally 
connected screen to open the function navigation menu. Click the acquisition icon 

 to open the acquisition setting menu. Click Timebase Mode to select the 
desired time base mode. 
 
 

YT Mode 
 
In this mode, the Y axis represents voltage, and the X axis represents time. 
 
Note: Only when this mode is enabled, can delayed sweep be turned on. In this 

mode, when the horizontal time base is equal to or greater than 200 ms/div, 
the instrument enters slow sweep mode. For details, refer to descriptions for 
slow sweep in "ROLL Mode". 

 
 

XY Mode 
 
In this mode, both the X axis and the Y axis represent the voltage. The mode 
changes the display from voltage-time display mode to voltage-voltage display. You 
can use the Lissajous method to measure the phase deviation of the two input 
signals whose frequencies are the same. The following figure shows the 
measurement schematic diagram of phase deviation. 
 

 

Figure 4-1 Measurement Schematic Diagram of Phase Deviation 

According to sin=A/B or C/D,  is the phase deviation angle between the two 
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channels. The definitions of A, B, C, and D are shown in the above figure. The phase 
deviation angle is obtained, that is: 

=arcsin(A/B) or arcsin(C/D) 

If the principal axis of the ellipse is within Quadrant I and III, the phase deviation 
angle obtained should be within Quadrant I and IV, namely within (0 to π/2) or (3π/2 
to 2π). If the principal axis of the ellipse is within Quadrant II and IV, the phase 
deviation angle obtained should be within Quadrant II and III, namely within (π/2 to 

π) or (π to 3π/2). 
 
The XY function can be used to measure the phase deviation occurred when the 
signal under test passes through a circuit network. Connect the oscilloscope to the 
circuit to monitor the input and output signals of the circuit. 
 
Application example: measures the phase deviation between the input signals of 
two channels. 
 
Use Lissajous method 
1. Connect one sine signal to CH1, and then connect another sine signal (with the 

same frequency and amplitude as the previous one but a 90° phase deviation 
from the previous one) to CH2. 

2. In the Web Control page, click Auto at the right side of the operation interface. 

After you select "XY" mode, click the label  at the top of the 
screen to adjust the horizontal timebase for obtaining a proper sample rate to 
get a better view of Lissajous graph for observation and measurement. 

3. Click the channel label of CH1 and CH2 at the bottom of the screen respectively 
to adjust their vertical scale and offset to make the signals easy to observe. 
Then, a circle, as shown in the figure below, should be displayed. 
 

 
 

4. Observe the measurement result shown in the figure above. According to the 
measurement schematic diagram of the phase deviation (as shown in Figure 
4-1), A/B(C/D)=1. Thus, the phase deviation angle of the two channel input 
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signals is =arcsin1=90°. 

Note: 
⚫ The maximum sample rate in XY mode is 2.5 GSa/s. In this mode, CH1 and CH2 

are forced to be enabled; CH3 and CH4 are forced to be disabled. Generally, a 
longer sample waveform can ensure better display effect of Lissajous figure. But 
due to the limitation of the memory depth, you have to reduce the waveform 
sample rate to acquire a longer waveform (refer to the introduction in "Memory 
Depth"). Therefore, during the measurement, reducing the sample rate 
properly can achieve better display effect of Lissajous figure. 

⚫ The following functions are disabled in XY mode: 
"Delayed Sweep", "To Select the Display Type", "Scale", "Protocol 
Decoding", "Pass/Fail Test", "To Trigger the Oscilloscope", and 
"Waveform Recording & Playing". 

 
 

ROLL Mode 
 
In this mode, the waveform scrolls from right to left to update the display. The 
available range of the horizontal scale is from 200 ms to 1 ks. Click the function 
navigation icon to select the Acquisition icon, then click More → Auto ROLL to 
select "ON". The system automatically enters the ROLL mode, and slow sweep mode 
is disabled. 
 
Note:  
⚫ If the current delayed sweep is enabled, then when you enable the ROLL mode, 

the delayed sweep is disabled automatically. When you re-enable the "YT" mode, 
the delayed sweep will be re-enabled. 

⚫ The following functions cannot be set in ROLL mode: 
"To Adjust the Horizontal Position" (available when the oscilloscope is in 
"Stop" operating status), "Delayed Sweep", "To Trigger the Oscilloscope", 
"Protocol Decoding", "Pass/Fail Test", "Waveform Recording & 
Playing", and "To Set the Persistence Time". 

 

 
 
 
 

Slow Sweep 
It is similar to the ROLL mode. In YT mode, when the horizontal time base is set to 
200 ms/div or smaller, the instrument enters the "slow sweep" mode, in which the 
instrument first acquires the data at the left of the trigger point and then waits for 
a trigger event. After the trigger occurs, the instrument continues to finish the 
waveform at the right of the trigger point. When observing the low-frequency 
signal in the slow sweep mode, it is recommended that you set "Channel 
Coupling" to "DC". 
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Acquisition Mode 
 
The acquisition mode is used to control how to generate waveform points from the 
sample points. 
 
DS8000-R supports the following four acquisition modes: Normal, Average, Peak, 
and High Resolution. By default, the acquisition mode is Normal. 
 
Click on the function navigation icon to open the navigation function. Then, click 
Acquisition → Acquisition to select the desired acquisition mode. 
 

Normal 
 
In this mode, the oscilloscope samples the signal at a specified fixed time interval to 
rebuild the waveform. For most of the waveforms, using this mode can produce the 
optimal display effects. 
 

Average 
 
In this mode, the oscilloscope averages the waveforms from multiple samples to 
reduce the random noise of the input signal and improve the vertical resolution. 
Greater number of averages can lower the noise and increase the vertical resolution; 
while at the same time, it will slow the response of the displayed waveform to the 
waveform changes. 
 
When you select "Average" mode, click Averages and use the numeric keypad or 
scroll with the mouse to set the desired number of averages. When the average 
count value is not in Nth power-of-2, a prompt message "Truncation average error" is 
displayed. At this time, a value that is smaller than the one you input and the closest 
to the Nth power-of-2 will be input automatically. For example, if you input 9 with the 
numeric keypad, the average count will be input 8 automatically.  
 
The number of averages can be set to 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 
4096, 8192, 16384, 32768, or 65536. By default, it is 2. 
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Figure 4-2 Waveforms before Averaging 

 

 
Figure 4-3 Waveforms after 128 Times of Averaging 

 

Peak 
 
In this mode, the oscilloscope acquires the maximum and minimum values of the 
signal within the sample interval to get the envelope of the signal or the narrow pulse 
that might be lost. In this mode, signal aliasing can be prevented, but the noise 
displayed would be larger. 
 
In this mode, the oscilloscope can display all the pulses whose pulse widths are at 
least the same as the sample period. 
 

High Resolution 
 
This mode uses an over-sample technique to average the neighboring points of the 
sample waveform. This reduces the random noise on the input signal, generates a 
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much smoother waveform on the screen. This is generally used when the sample 
rate of the digital converter is greater than the storage rate of the acquisition 
memory. 
 
Note:  
⚫ The "Average" and "High Res" modes use different averaging methods. The 

former uses "Multi-sample Average" and the latter uses "Single-sample 
Average". 

⚫ In "High Res" mode, the oscilloscope improves the measurement accuracy at 
the cost of bandwidth. Each time the sampling rate changes, a window 
displaying the current bandwidth appears at the lower-left corner of the screen. 

⚫ In "High Res" mode, the highest waveform refresh rate mode is not supported. 
 
 

Sampling Mode 
 
This oscilloscope only supports the real-time sampling mode. In this mode, the 
oscilloscope produces the waveform display from samples collected during one 
trigger event. The highest real-time sample rate on the analog channel of DS8000-R 
series is 10 GSa/s (note that for DS8034-R, it is 5 GSa/s). The current sample rate is 
displayed under CH SampleRate. 
 

 
 

Sample Rate 
 
Sampling is the process of converting the analog signal into the digital signal at a 
specified time interval and then restoring them in sequence. The sample rate is the 
reciprocal of the time interval. 
 
The sample rate of the analog channel is related to the current channel mode. The 
maximum real-time sample rate in the single-channel mode of the oscilloscope is 10 
GSa/s. The maximum real-time sample rate in the dual-channel mode is 5 GSa/s, and 
the maximum real-time sample rate in the 4-channel mode is 2.5 GSa/s.  
Note: For DS8034-R, the maximum real-time sample rate in the single-channel 

mode of the oscilloscope is 5 GSa/s. The maximum real-time sample rate in 
the dual-channel mode is 5 GSa/s, and the maximum real-time sample rate in 
the 4-channel mode is 2.5 GSa/s 

Tip 

When you click the  label at the top of the screen to stop sampling, the 
oscilloscope will maintain its last captured graph. At this time, you can still expand 
or zoom the waveforms horizontally or vertically. 
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Note: The sample rate is displayed both in the label  at the 
upper part of the screen and in the CH SampleRate menu. To indirectly 

modify the sample rate, click the label  at the upper part 
of the screen. Then adjust the horizontal time base or modify the memory 
depth to modify the sample rate. In addition, if the triggering source selects 
the analog channel, it will cause the channel mode to change, affecting the 
sampling rate. 

 
The impact of low sample rate on the waveform: 
 
1. Waveform Distortion: when the sample rate is too low, some waveform 
details are lost, and the sample waveform displayed is rather different from the 
actual waveform of the signal. 

 
2. Waveform Aliasing: when the sample rate is twice lower than the actual 
signal frequency (Nyquist Frequency), the frequency of the waveform rebuilt from 
the sample data is smaller than the actual signal frequency. 

 

 
 

3. Waveform Leakage: when the sample rate is too low, the waveform rebuilt 
from the sample data does not reflect all the actual signal information. 

Tip 
Single-channel mode: only one of the four channels (CH1/CH2/CH3/CH4) is 
enabled. 
Dual-channel mode: either CH1 or CH2 is enabled; and either CH3 or CH4 is 
enabled. 
4-channel mode: CH1/CH2 are both enabled or CH3/CH4 are both enabled. 
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Memory Depth 
 
Memory depth refers to the number of points of the oscilloscope that can store in one 
trigger acquisition. It reflects the storage capability of the acquisition storage. This 
oscilloscope is equipped with a standard memory depth of up to 500 Mpts. 
 

T

Trigger Point

Pre-sample Delayed Sample

Memory Depth

 
Figure 4-4 Memory Depth 

 
The following equation shows the relations among memory depth, sample rate, and 
horizontal time base scale: 
 MDepth SRate TScale HDivs=     

MDepth ——indicates the memory depth. The unit is pts. 

SRate——indicates the sample rate. The unit is Sa/s. 

TScale ——indicates the horizontal time base scale. The unit is s/div. 

HDivs ——indicates the number of grids in the horizontal direction. The unit is div. 

 
Therefore, under the same horizontal time base scale, a higher memory depth can 
ensure a higher sample rate. 
 
In the Acquisition menu, click Mem Depth to select the desired memory depth. By 
default, the memory depth is 1M. 

Pulse 
disappeared 
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― In single-channel mode, the memory depths available include Auto, 1 Kpts, 10 
Kpts, 100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, 125 Mpts, 250 
Mpts, and 500 Mpts. 

― In dual-channel mode, the memory depths available include Auto, 1 Kpts, 10 
Kpts, 100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, 125 Mpts, and 250 
Mpts. 

― In 4-channel mode, the memory depths available include Auto, 1 Kpts, 10 Kpts, 
100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, and 125 Mpts. 

 
Note: In "Auto" mode, the oscilloscope selects the memory depth automatically 

according to the current sample rate. 
 
 

Anti-Aliasing 
 
At a slower sweep speed, the sample rate is reduced, and a dedicated display 
algorithm can be used to minimize the possibility of aliasing. 
 
In the Acquisition menu, click Anti-aliasing to enable or disable the anti-aliasing 
function. By default, anti-aliasing is disabled. In this case, it is more likely to generate 
waveform aliasing. 
 
Note: This function should be enabled when the horizontal time base has a large 

deviation from the period of the signal under test (e.g. when the horizontal 
time base is greater than five-fold the period of the signal under test). It is 
available when the timebase mode is "YT". 

 
 

Horizontal Expansion 
 
Horizontal expansion indicates the reference position that the screen waveform is 
referenced to when it is horizontally expanded or compressed. In YT mode, in the 
Acquisition menu, click More → Expand and then select the desired reference 
position. The horizontal expansion reference supported by the oscilloscope includes 
Center, Left, Right, Trigger, and User. The default is "Center". 
⚫ Center: when the horizontal time base is modified, the waveform will be 

expanded or compressed horizontally relative to the screen center. 
⚫ Left: when the horizontal time base is modified, the waveform will be expanded 

or compressed horizontally relative to the leftmost position of the screen. 
⚫ Right: when the horizontal time base is modified, the waveform will be 

expanded or compressed horizontally relative to the rightmost position of the 
screen. 

⚫ Trigger: when the horizontal time base is modified, the waveform will be 
expanded or compressed horizontally relative to the trigger point. 

⚫ User: when the horizontal time base is modified, the waveform displayed will be 
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expanded or compressed horizontally relative to the user-defined reference 
position. 
 

Note: This function is unavailable in YT mode with the delayed sweep being enabled, 
XY mode, and ROLL mode.
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Chapter 5 To Trigger the Oscilloscope 
 
As for trigger, you set certain trigger condition according to the requirement and 
when a waveform in the waveform stream meets this condition, the oscilloscope 
captures this waveform as well as the neighboring part, and displays them on the 
screen. For the digital oscilloscope, it samples waveform continuously no matter 
whether it is stably triggered, but only stable trigger can be stably displayed. The 
trigger module ensures that every time base sweep or acquisition starts from the 
user-defined trigger condition, namely every sweep is synchronous with the 
acquisition and the waveforms acquired is overlapped so as to display the stable 
waveforms. 
 
Trigger settings should be based on the features of the input signal. To quickly 
capture the desired waveform, you need to understand the signal under test. This 
oscilloscope provides abundant trigger types that help you focus on the desired 
waveform details. 
 
Contents in this chapter: 
◼ Trigger Source 
◼ Trigger Level 
◼ Trigger Mode 
◼ Trigger Coupling 
◼ Trigger Holdoff 
◼ Noise Rejection 
◼ Trigger Type 
◼ Zone Trigger 
◼ Trigger Output Connector 
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Trigger Source 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Click on the trigger icon  to open the trigger setting 
menu. Click Source to select the desired source. 
 
Analog channels (CH1-CH4), EXT (external trigger), or AC Line can all be selected as 
the trigger source. 
 
Analog channel input: 
Signals input from analog channels CH1-CH4 can all be used as trigger sources. No 
matter whether the channel selected is enabled, the channel can work normally. 
 
External trigger input: 
The external trigger source can be used to trigger on the fifth channel while all the 
other four channels are acquiring data. The trigger signal (e.g. external clock or 
signal of the circuit under test) will be connected to EXT trigger source via the 
external trigger input terminal [EXT TRIG] connector. You can set the trigger 
conditions within the range of the trigger level (from -5 V to +5 V). 
 
AC line input: 
The trigger signal is obtained from the AC power input of the oscilloscope. AC trigger 
is usually used to measure signals relevant to the AC power frequency. For example, 
stably triggering the waveform output from the transformer of a transformer 
substation. It is mainly used in related measurements of the power industry. 
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Trigger Level 
 
The adjustment of the trigger level is related to the type of the trigger source. 
 
⚫ When the trigger source is selected from CH1 to CH4, click on the trigger setting 

label  at the right-upper corner of the screen. Then, in the 
"Trigger Setting" window, input the trigger level with the pop-up numeric 
keypad into the "Level" field. You can also click the Up and Down arrow at the 
right of the "Level" field to increase or decrease the trigger level. During the 
adjustment, a trigger level line (the color of the trigger level line should be 
consistent with that of the channel color) and a trigger label " " are displayed 
on the screen, and they move up and down with the variation of the trigger level. 
When you stopping modifying the trigger level, the trigger level line disappears 
in about 2 s. The current trigger level value is displayed at the upper-right corner 
of the screen. 

Note: In Runt Trigger, Slope Trigger, and Window trigger, you need to set the 
upper and lower limits of the trigger level. In the trigger menu, you can set the 
specified trigger level. The difference between the current upper limit and lower 
limit of the trigger level is displayed at the upper-right side of the screen. Two 
trigger level labels (  and ) are displayed at the left side of the screen. 
Meanwhile, the real-time trigger level information is displayed at the lower-left 
side of the screen, as shown in the figure below. H indicates the upper limit of 

the trigger level, L indicates the lower limit of the trigger level, and △ indicates 

the deviation of the trigger level. 

 
 

⚫ When the trigger source is EXT, you can also set the trigger level in the "Trigger" 
menu. The current trigger level value is displayed at the upper-right corner of 
the screen. 
Note: For this trigger source, only the variation of the trigger level value is 
displayed on the screen during the adjustment of the trigger level, without 
displaying the trigger level lines on the screen. 
 

⚫ When the trigger source is AC Line, there is no trigger level. 
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Trigger Mode 
 
The following is the schematic diagram of the acquisition memory. To easily 
understand the trigger event, we classify the acquisition memory into the pre-trigger 
buffer and post-trigger buffer. 

 
Figure 5-1 Schematic Diagram of the Acquisition Memory 

 
After the system runs, the oscilloscope operates by first filling the pre-trigger buffer. 
It starts searching for a trigger after the pre-trigger buffer is filled. While searching 
for the trigger, the data sampled will still be transmitted to the pre-trigger buffer (the 
new data will continuously overwrite the previous data). When a trigger is found, the 
pre-trigger buffer contains the data acquired just before the trigger. Then, the 
oscilloscope will fill the post-trigger buffer and display the data in the acquisition 
memory.  
 
DS8000-R provides three trigger modes: Auto, Normal, and Single. The default is 
Auto. 
The trigger mode is displayed at the upper-right corner of the screen: A (Auto), N 
(Normal), and S (Single). 
⚫ Auto: In this trigger mode, if the specified trigger conditions are not found, 

triggers are forced and acquisitions are made so as to display the waveforms. 
This trigger mode should be used when the signal level is unknown or the DC 
should be displayed as well as when forcible trigger is not necessary as the 
trigger condition always occurs. 

⚫ Normal: In this trigger mode, triggers and acquisitions only occur when the 
specified trigger conditions are found. This trigger mode should be used when 
the signal is with low repetition rate or only the event specified by the trigger 
setting needs to be sampled as well as when auto trigger should be prevented to 
acquire stable display. 

⚫ Single: In this trigger mode, the oscilloscope performs a single trigger and 
acquisition when the specified trigger conditions are found, and then stops. This 
trigger mode should be used when you need to perform a single acquisition of 
the specified event and analyze the acquisition result (you can pan and zoom 
the currently displayed waveform, and the subsequent waveform data will not 
overwrite the current waveform). After a single trigger mode is initiated, the 
operating status of the oscilloscope is in "STOP" state.  

Pre-trigger Buffer Post-trigger Buffer 

Trigger Event 

Acquisition Memory 
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Click on the trigger setting label  at the upper-right corner of the 
screen. Then the following window is displayed. Click to select "Auto", "Normal", or 
"Single" as the trigger mode. 
 

 
 

Note: In "Normal" and "Single" trigger modes, press Force on the front panel to 

generate a trigger signal forcibly. 
 
 

Trigger Coupling 
 
Trigger coupling decides which kind of components will be transmitted to the trigger 
module. Please distinguish it from "Channel Coupling". 
 

Note: Trigger coupling is only valid when the trigger type is Edge and the trigger 
source is an analog channel. 
 

In the "Trigger" menu, click Coupling to select the desired coupling mode. 
DS8000-R provides four coupling mode: DC, AC, LFR, and HFR. By default, it is DC. 
⚫ DC: allows DC and AC components to pass the trigger path. 
⚫ AC: blocks the DC components and attenuates signals. 
⚫ LFR: blocks the DC components and rejects the low-frequency components. 
⚫ HFR: rejects the high frequency components. 
 

 
 

Trigger Holdoff 
 
Trigger holdoff can be used to stably trigger on complex repetitive waveforms that 
have multiple edges (or other events) between waveform repetitions (such as pulse 
series). Holdoff time indicates the time that the oscilloscope waits for re-arming the 
trigger module after generating a correct trigger. The oscilloscope will not trigger 
even if the trigger condition is met during the holdoff time and will only re-arm the 
trigger module after the holdoff time expires. 

Tip 
When "AC" or "LFR" is selected under Coupling, no trigger level lines and trigger 
icons are displayed. When you adjust the trigger level, you can only see the 
changes of the trigger level values at the upper-right corner of the screen. 
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For example, to stably trigger the repetitive pulse series as shown in the figure below, 
the holdoff time should be set to a value that is greater than t1 and smaller than t2. 
 
 

 
 
 

 
Figure 5-2 Schematic Diagram of Trigger Holdoff 

 

In the "Trigger" menu, click Holdoff (for some trigger, Holdoff is a sub menu under 
More, at this time, click More → Holdoff) and then set the holdoff time with the 
pop-up numeric keypad or scroll with the mouse to adjust the holdoff time. The 
adjustable range of holdoff time is from 8 ns to 10 s. By default, it is 8 ns. 
 
 

Noise Rejection 
 
Noise rejection can reject the high frequency noise in the signal and reduce the 
possibility of miss-trigger of the oscilloscope. 
 
In the "Trigger" menu, click Noise Reject continuously (for some trigger, Noise 
Reject is a sub menu under More, at this time, click More → Noise Reject) to 
enable or disable noise rejection. 
 
Note: This function is only available when the trigger source is an analog channel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Holdoff Time Trigger Position 

t1 
t2 
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Trigger Type 
 
DS8000-R series oscilloscope provides the following trigger functions.  
 
⚫ Edge Trigger 
⚫ Pulse Trigger 
⚫ Slope Trigger 
⚫ Video Trigger 
⚫ Pattern Trigger 
⚫ Duration Trigger 
⚫ Timeout Trigger 
⚫ Runt Trigger 
⚫ Window Trigger 
⚫ Delay Trigger 
⚫ Setup/Hold Trigger 
⚫ Nth Edge Trigger 
⚫ RS232 Trigger (Option) 
⚫ I2C Trigger (Option) 
⚫ SPI Trigger (Option) 
⚫ CAN Trigger (Option) 
⚫ FlexRay Trigger (Option)  
⚫ LIN Trigger (Option) 
⚫ I2S Trigger (Option) 
⚫ MIL-STD-1553 Trigger (Option) 
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Edge Trigger 
 
Triggers on the trigger level of the specified edge of the input signal. 
 
Trigger Type: 

Click on the function navigation icon  at the lower-left corner of the screen. Click 
the trigger icon and select Type in the trigger setting menu. Select "Edge", and then 
the current trigger setting information (including trigger type, trigger source, and 
trigger level) is displayed at the upper-right corner of the screen, as shown in the 
figure below. The information will change based on the trigger settings. 

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4, AC Line, or EXT. For 
details, refer to descriptions in "Trigger Source". The current trigger source is 
displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 

trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope to select the input signal the edge on which the oscilloscope triggers. 
Then, the current edge type is displayed at the upper-right corner of the screen.  

⚫ Rising: triggers on the rising edge of the input signal when the voltage level 
meets the specified trigger level. 

⚫ Falling: triggers on the falling edge of the input signal when the voltage level 
meets the specified trigger level. 

⚫ Either: triggers on the rising or falling edge of the input signal when the 
voltage level meets the preset trigger level. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger coupling, trigger holdoff, and noise rejection) 
under this trigger type. For details, refer to descriptions in "Trigger Coupling", 
"Trigger Holdoff", and "Noise Rejection". 
 
Trigger Level: 
Please refer to descriptions in "Trigger Level". The current trigger level value is 
displayed at the upper-right corner of the screen. 
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Pulse Trigger 
 
Triggers on the positive or negative pulse with a specified width. In this mode, the 
oscilloscope will trigger when the pulse width of the input signal satisfies the 
specified pulse width condition. 
 
In this oscilloscope, positive pulse width is defined as the time difference between 
the two crossing points of the trigger level and positive pulse; negative pulse width is 
defined as the time difference between the two crossing points of the trigger level 
and negative pulse, as shown in the figure below. 

 
Figure 5-3 Positive Pulse Width/Negative Pulse Width 

 
Trigger Type: 
Click Type, and select "Pulse". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Polarity: 
Click Polarity continuously to select the desired polarity. The polarities available are 

positive polarity ( ) and negative polarity ( ). 
 
Trigger Condition: 
Click When to select the trigger condition. 
⚫ When you select "Positive" for polarity, ">" for trigger condition, the oscilloscope 

Trigger 

Level 

Trigger 
Level 

+Width 

A B 

-Width 

A B 
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triggers when the positive pulse width of the input signal is greater than the 
specified pulse width. 

⚫ When you select "Positive" for polarity, "<" for trigger condition, the oscilloscope 
triggers when the positive pulse width of the input signal is smaller than the 
specified pulse width. 

⚫ When you select "Positive" for polarity, "<>" for trigger condition, the 
oscilloscope triggers when the positive pulse width of the input signal is greater 
than the specified lower limit of pulse width and smaller than the specified upper 
limit of pulse width. 

⚫ When you select "Negative" for polarity, ">" for trigger condition, the 
oscilloscope triggers when the negative pulse width of the input signal is greater 
than the specified pulse width. 

⚫ When you select "Negative" for polarity, "<" for trigger condition, the 
oscilloscope triggers when the negative pulse width of the input signal is smaller 
than the specified pulse width. 

⚫ When you select "Negative" for polarity, "<>" for trigger condition, the 
oscilloscope triggers when the negative pulse width of the input signal is greater 
than the specified lower limit of pulse width and smaller than the specified upper 
limit of pulse width. 

 
Pulse Width Setting: 
⚫ When ">" or "<" is set to the trigger condition, click Lower or Upper to set the 

lower/upper limit value with the pop-up numeric keypad or by scrolling with the 
mouse. The pulse range available is from 800 ps to 10 s. 

⚫ When "<>" is set to the trigger condition, click Upper and Lower to set the 
lower/upper limit value with the pop-up numeric keypad or by scrolling with the 
mouse.  
Note: The lower limit of the pulse width must be smaller than the upper limit. 

 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection". 
 
Trigger Level: 
Please refer to descriptions in "Trigger Level". The current trigger level value is 
displayed at the upper-right corner of the screen. 
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Slope Trigger 
 
In Slope trigger, the oscilloscope triggers on the positive or negative slope of the 
specified time. This trigger mode is applicable to ramp and triangle waveforms. 
 
In this oscilloscope, positive slope time is defined as the time difference between the 
two crossing points of trigger level line A and B with the rising edge; negative slope 
time is defined as the time difference between the two crossing points of trigger level 
line A and B with the falling edge, as shown in the figure below. 
  
 
 
 
 
 
 
 
 

Figure 5-4 Positive Slope Time/Negative Slope Time 
 

Trigger Type: 
Click Type to select "Slope". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to switch the trigger source and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope continuously to select the input signal edge on which the oscilloscope 
triggers. 

⚫ Rising: triggers on the rising edge of the input signal. 

⚫ Falling: triggers on the falling edge of the input signal. 
 
Slope Condition: 
Click When to select the trigger condition. 
⚫ When you select "Rising" for the edge type, ">" for trigger condition, the 

oscilloscope triggers when the positive slope time of the input signal is greater 
than the specified time. 

⚫ When you select "Rising" for the edge type, "<" for trigger condition, the 

Upper Limit of Trigger Level 
(Up Level) 

Lower Limit of Trigger Level 
(Low Level) 
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oscilloscope triggers when the positive slope time of the input signal is smaller 
than the specified time. 

⚫ When you select "Rising" for the edge type, "<>" for trigger condition, the 
oscilloscope triggers when the positive slope time of the input signal is greater 
than the specified lower limit time and smaller than the specified upper limit 
time. 

⚫ When you select "Falling" for the edge type, ">" for trigger condition, the 
oscilloscope triggers when the negative slope time of the input signal is greater 
than the specified time. 

⚫ When you select "Falling" for the edge type, "<" for trigger condition, the 
oscilloscope triggers when the negative slope time of the input signal is smaller 
than the specified time. 

⚫ When you select "Falling" for the edge type, "<>" for trigger condition, the 
oscilloscope triggers when the negative slope time of the input signal is greater 
than the specified lower limit time and smaller than the specified upper limit 
time. 

 
Slope Time Setting: 
⚫ When ">" or "<" is set to trigger condition, click Lower or Upper to set the 

lower/upper limit value with the pop-up numeric keypad or by scrolling with the 
mouse. The available range of the slope time is from 800 ps to 10 s. 

⚫ When "<>" is set to trigger condition, click Upper and Lower to set the upper/ 
lower limit value with the pop-up numeric keypad or by scrolling with the mouse.  
Note: The lower slope time limit must be smaller than the upper slope time 
limit. 
 

Level Selection and Adjustment of Trigger Level: 
After the trigger condition setting is completed, you need to adjust the trigger level 
to correctly trigger the signal and obtain a stable waveform. Click Level Select 
(when "<>" is selected as the trigger condition, Level Select is a sub-menu under 
More) to select the desired level type for adjustment.  
⚫ Level A: only adjusts the upper limit of the trigger level, and the lower limit of 

the trigger level remains unchanged. 
⚫ Level B: only adjusts the lower limit of the trigger level, and the upper limit of 

the trigger level remains unchanged. 
⚫ Level AB: adjusts the upper and lower limits of the trigger level at the same time, 

and the trigger level deviation (the difference between the upper limit and lower 
limit of the trigger level) remains unchanged. 

 

Click on the trigger label  at the upper-right corner of the screen. The 
"Trigger Setting" window is displayed. Input the trigger level into the "Level A" and 
"Level B" field with the pop-up numeric keypad. You can use the Up and Down arrow 
at the right side of the "Level A" or "Level B" field to adjust the trigger level. During 
the adjustment of trigger level, two trigger level lines appear on the screen, and they 
move up and down with the change of the trigger level. At the same time, the 
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real-time trigger level information is displayed at the lower-left corner of the screen 
(as shown in the figure below, H indicates the upper limit of the trigger level, L 
indicates the lower limit of the trigger level, and △ indicates the trigger level 

deviation). When you stopping modifying the trigger level, the trigger level line and 
the trigger level information at the lower-left corner of the screen disappear in about 
2 s. The current trigger level deviation is displayed at the upper-right corner of the 
screen. 

 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger holdoff and noise rejection) under this trigger 
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise 
Rejection". 



RIGOL Chapter 5 To Trigger the Oscilloscope 

5-14 DS8000-R User Guide 

Video Trigger 
 
The video signal can include image information and timing information, which adopts 
different standards and formats. DS8000-R series can trigger on the standard video 
signal field or line of NTSC (National Television Standards Committee), PAL (Phase 
Alternating Line), or SECAM (Sequential Couleur A Memoire). 
 
Trigger Type: 
Click Type to select "Video". The current trigger setting information is displayed at 
the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to switch the trigger source and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Video Polarity: 
Click Polarity continuously to select the desired video polarity. The polarities 

available are positive polarity ( ) and negative polarity ( ).  
 
Video Standard: 
Click Standard to select the desired video standard.  

Video 
Standard 

Frame Frequency 
(Frame) 

Scan Type TV Scan Line 

NTSC 30 Interlaced Scan 525 

PAL/SECAM 25 Interlaced Scan 625 

480p/60Hz 60 Progressive Scan 525 

576p/50Hz 50 Progressive Scan 625 

720p/60Hz 60 Progressive Scan 750 

720p/50Hz 50 Progressive Scan 750 

720p/30Hz 30 Progressive Scan 750 

720p/25Hz 25 Progressive Scan 750 

720p/24Hz 24 Progressive Scan 750 

1080p/60Hz 60 Progressive Scan 1125 

1080p/50Hz 50 Progressive Scan 1125 

1080p/30Hz 30 Progressive Scan 1125 

1080p/25Hz 25 Progressive Scan 1125 

1080p/24Hz 24 Progressive Scan 1125 

1080i/60Hz 60 Interlaced Scan 1125 

1080i/50Hz 50 Interlaced Scan 1125 
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Sync: 
Click Sync to select the sync type. 
⚫ All Lines: triggers on the first line found. 
⚫ Line: triggers on the specified line. 

When this sync type is selected, you can specify a line number. Click Line, then 
use the pop-up numeric keypad or scroll with the mouse to modify the line 
number. The range of the line number is related to the currently selected video 
standards. The range is from 1 to 525 (NTSC), 1 to 625 (PAL/SECAM), 1 to 525 
(480p), 1 to 625 (576p), 1 to 750 (720p), and 1 to 1125 (1080p/1080i). 

⚫ Odd: triggers on the rising edge of the first ramp pulse in the odd field. It is only   
available when the video standard is set to "NTSC", "PAL/SECAM", or "1080i". 

⚫ Even: triggers on the rising edge of the first ramp pulse in the even field. It is 
only available when the video standard is set to "NTSC", "PAL/SECAM", or 
"1080i". 

 
Noise Rejection: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Setting: 
For details, refer to descriptions in "Noise Rejection". 
 
Trigger Level: 
For details, refer to descriptions in "Trigger Level". 
 

 

Tip 
⚫ For a better observation of the waveform details in the video signal, you can 

set a larger memory depth first. 
⚫ In the trigger debugging process of video signals, the frequency in different 

part of the signal can be reflected by a different brightness, as RIGOL digital 

oscilloscope provides the intensity graded color display function. Experienced 
users can quickly judge the signal quality and discover abnormalities during 
the debugging process. 
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Pattern Trigger 
 
Identifies a trigger condition by searching for a specified pattern. This pattern is a 
logical "AND" combination of channels. Each channel can be set to H (high), L (low), 
or X (don't care). A rising or falling edge (you can only specify a single edge) can be 
specified for one channel included in the pattern. When an edge is specified, the 
oscilloscope will trigger at the edge specified if the pattern set for the other channels 
is true (namely the actual pattern of the channel is the same as the preset pattern). 
If no edge is specified, the oscilloscope will trigger on the last edge that makes the 
pattern true. If all the channels in the pattern are set to "X", the oscilloscope will not 
trigger. 

 
Figure 5-5 Pattern Trigger 

 
Trigger Type: 
Click Type to select "Pattern" as the trigger type. Then, the current trigger setting 
information is displayed at the upper-right corner of the screen, as shown in the 
figure below.  

  
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Pattern Setting: 
Click Code to select the pattern of the currently selected channel. The available 
patterns include the following five types: 
⚫ H: sets the pattern of the channel selected to "1", i.g. the voltage level is higher 

than the trigger level of the channel. 
⚫ L: sets the pattern of the channel selected to "0", i.g. the voltage level is lower 

than the trigger level of the channel. 
⚫ X: sets the pattern of the channel selected to "X", i.g. this channel is not used as 

a part of the pattern. When all channels in the pattern are set to "X", the 
oscilloscope will not trigger. 

⚫ Rising: sets the pattern to the rising edge ( ) of the channel selected. 
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⚫ Falling: sets the pattern to the falling edge ( ) of the channel selected. 
 
The corresponding pattern is displayed at the bottom of the screen. The patterns of 
channels CH1-CH4 are presented from left to right, as shown in the figure below. 

 
 
Click the above channel pattern. Then, a virtual keypad is displayed. For example, 
click CH2 pattern, then the virtual keypad for setting the channel pattern is displayed, 

as shown in Figure 5-6. Click the left arrow key  or the right arrow key  to 
move the pattern bit. Then select a pattern bit. After the pattern of the current 
channel is set completely, the cursor goes to the next pattern bit automatically. Set 
them respectively. After all the pattern bits are set completely, click OK to confirm 
the setting, and close the virtual keypad. You can also click ALL to apply the current 
pattern to all the channels. This key functions the same as the All Bits menu key. 
 

 
Figure 5-6 Virtual Keypad for Pattern Setting 

 
Note: Only one edge (rising or falling edge) can be specified in the pattern. If one 
edge item is currently defined and then another edge item is defined in another 
channel in the pattern, then a prompt message "Invalid input" is displayed. Then the 
latter defined edge item will be replaced by X. 

 
All Bits: 
Click All Bits to set the patterns of all channels to the currently selected pattern. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger holdoff and noise rejection) under this trigger 
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise 
Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen.  

Confirmation Key 
 

All Bits 
 

Move the cursor to 
the left  
Move the cursor to 
the right 

Pattern 
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Duration Trigger 
 
In duration trigger, the instrument identifies a trigger condition by searching for the 
duration of a specified pattern. This pattern is a logical "AND" combination of the 
channels. Each channel can be set to H (high), L (low), or X (don't care). When the 
duration (△T) of this pattern meets the preset time, the oscilloscope initiates a 

trigger, as shown in the figure below. 

 
 

Figure 5-7 Duration Trigger 
 
Trigger Type: 
Click Type to select "Duration". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Pattern Setting: 
Click Code to select the pattern of the currently selected channel. The corresponding 
pattern is displayed at the bottom of the screen. The patterns of channels CH1-CH4 
are presented from left to right, as shown in the figure below.  
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⚫ H: sets the pattern of the channel selected to "H", i.g. the voltage level is higher 
than the trigger level of the channel. 

⚫ L: sets the pattern of the channel selected to "L", i.g. the voltage level is lower 
than the trigger level of the channel. 

⚫ X: sets the pattern of the channel selected to "X", i.g. this channel is not used as 
a part of the pattern. When all channels in the pattern are set to "X", the 
oscilloscope will not trigger. 
 

Trigger Condition: 
Click When to select the trigger condition. 
⚫ >: triggers when the duration of the pattern is greater than the preset time. 

Click Lower to set the lower limit of the duration of the pattern. Its range is 
from 800 ps to 10 s. 

⚫ <: triggers when the duration of the pattern is smaller than the preset time. 
Click Upper to set the upper limit of the duration of the pattern. Its range is 
from 800 ps to 10 s. 

⚫ <>: triggers when the duration of the pattern is smaller than the upper limit of 

the preset time and greater than the lower limit of the preset time. Click Upper 

to set the upper limit of the duration of the pattern, and the range is from 801 ps 

to 10 s. Click Lower to set the lower limit of the duration of the pattern, and the 

range is from 800 ps to 9.9 s. 

⚫ ><: triggers when the duration of the pattern is greater than the upper limit of 

the preset time or smaller than the lower limit of the preset time. Click Upper to 

set the upper limit of the duration of the pattern, and the range is from 801 ps to 

10 s. Click Lower to set the lower limit of the duration of the pattern, and the 

range is from 800 ps to 9.9 s. 

Note: The lower time limit must be smaller than the upper time limit. 

 
All Bits: 
Click All Bits to set the pattern of all trigger sources to the pattern setting selected 
currently. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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Timeout Trigger 
 
In Timeout trigger, the oscilloscope triggers when the time interval (△T) (the time 

from when the rising edge (or falling edge) of the input signal passes through the 
trigger level to the time from when the neighboring falling edge (or rising edge) 
passes through the trigger level) is greater than the preset timeout value, as shown 
in the figure below. 

Time Out

T Time Out<   T

 
Figure 5-8 Timeout Trigger 

 
Trigger Type: 
Click Type to select "Timeout". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope to select the edge type of the input signal that starts to pass through the 
trigger level.  

⚫ Rising: starts timing when the rising edge of the input signal passes through 
the trigger level. 

⚫ Falling: starts timing when the falling edge of the input signal passes 
through the trigger level. 

⚫ Either: starts timing when either edge of the input signal passes through the 
trigger level. 
 

Timeout Value: 
Timeout value represents the maximum time that the signal remains idle before the 
signal passes through the trigger level. Click Timeout and use the pop-up numeric 
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keypad or scroll with the mouse to set the timeout value of Timeout trigger. The 
available range is from 16 ns to 10 s. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
For details, refer to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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Runt Trigger 
 
This trigger mode is used to trigger pulses that pass through one trigger level but fail 
to pass through another trigger level, as shown in the figure below. 
 
 

 
 
 

Figure 5-9 Runt Trigger 
 
Trigger Type: 
Click Type to select "Runt". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to switch the trigger source and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Polarity: 
Click Polarity continuously to select the pulse polarity of Runt trigger. 

⚫ Positive: triggers on the positive runt pulse. 

⚫ Negative: triggers on the negative runt pulse. 
 
Trigger Condition: 
Click When to set the trigger conditions of Runt trigger.  
⚫ None: indicates not setting the trigger condition of Runt trigger. 
⚫ >: triggers when the runt pulse width is greater than the lower limit of pulse 

width. Click Lower to set the minimum pulse width of Runt trigger.  
⚫ <: triggers when the runt pulse width is smaller than the upper limit of pulse 

width. Click Upper to set the maximum pulse width of Runt trigger.  
⚫ <>: triggers when the runt pulse width is greater than the lower limit and 

smaller than the upper limit of pulse width. Click Upper to set the maximum 

pulse width of Runt trigger. Click Lower to set the minimum pulse width of Runt 

trigger.  

Lower Limit of 
the Trigger Level 

Upper Limit of the 
Trigger Level 

Negative Runt Pulse 

Positive Runt Pulse 
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Note: The lower limit of the pulse width must be smaller than the upper limit. 

 
Level Selection and Adjustment of Trigger Level: 
After the trigger condition setting is completed, you need to adjust the trigger level 
to correctly trigger the signal and obtain a stable waveform. Click Level Select 
(when "<>" is selected as the trigger condition, Level Select is a sub-menu under 
More) to select the desired level type for adjustment.  
Level A: only adjusts the upper limit of the trigger level, and the lower limit of the 
trigger level remains unchanged. 
Level B: only adjusts the lower limit of the trigger level, and the upper limit of the 
trigger level remains unchanged. 
Level AB: adjusts the upper and lower limits of the trigger level at the same time, and 
the trigger level deviation (the difference between the upper limit and lower limit of 
the trigger level) remains unchanged. 
 

Click on the trigger level setting label  at the upper-right corner of the 
screen. Then a "Trigger Setting" window is displayed. In the Level field, input a 
value with the pop-up numeric keypad. You can also use the Up and Down arrow at 
the right of the Level field to increase or decrease the trigger level. During the 
adjustment of trigger level, two trigger level lines appear on the screen, and they 
move up and down with the change of the trigger level. At the same time, the 
real-time trigger level information is displayed at the lower-left corner of the screen 
(as shown in the figure below, H indicates the upper limit of the trigger level, L 
indicates the lower limit of the trigger level, and △ indicates the trigger level 

deviation). When you stopping modifying the trigger level, the trigger level line and 
the trigger level information at the lower-left corner of the screen disappear in about 
2 s. The current trigger level deviation is displayed at the upper-right corner of the 
screen. 

 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger holdoff and noise rejection) under this trigger 
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise 
Rejection". 
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Window Trigger 
 
Window trigger provides a high trigger level and a low trigger level. The instrument 
triggers when the input signal passes through the high trigger level or the low trigger 
level. 
 
Trigger Type: 
Click Type to select "Window". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to switch the trigger source and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope to select the input signal the edge on which the oscilloscope triggers.  

⚫ Rising: triggers on the rising edge of the input signal when the voltage level 
is higher than the preset high trigger level. 

⚫ Falling: triggers on the falling edge of the input signal when the voltage level 
is lower than the preset low trigger level. 

⚫ Either: triggers on the rising or falling edge of the input signal when the 
voltage level meets the preset trigger level. 
 
Trigger Position: 
After selecting the window type, click Position to select the trigger position so as to 
further specify the time point of trigger.  
⚫ Enter: triggers when the input signal enters the specified trigger level range. 
⚫ Exit: triggers when the input signal exits the specified trigger level range. 
⚫ Time: triggers when the accumulated hold time since the input signal entered 

the specified trigger level range is equal to the window time. When this type is 
selected, click Time to set the window time. You can also use the numeric 
keypad or scroll with the mouse to set it. Its available range is from 8 ns to 10 s. 
 

Level Selection and Adjustment of Trigger Level: 
After the trigger condition setting is completed, you need to adjust the trigger level 
to correctly trigger the signal and obtain a stable waveform. Click Level Select to 
select the desired level type for adjustment.  
⚫ Level A: only adjusts the upper limit of the trigger level, and the lower limit of 

the trigger level remains unchanged. 
⚫ Level B: only adjusts the lower limit of the trigger level, and the upper limit of 
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the trigger level remains unchanged. 
⚫ Level AB: adjusts the upper and lower limits of the trigger level at the same time, 

and the trigger level deviation (the difference between the upper limit and lower 
limit of the trigger level) remains unchanged. 

 

Click on the trigger level setting label  at the upper-right corner of the 
screen. Then a "Trigger Setting" window is displayed. In the Level field, input a 
value with the pop-up numeric keypad. You can also use the Up and Down arrow at 
the right of the Level field to increase or decrease the trigger level. During the 
adjustment of trigger level, two trigger level lines appear on the screen, and they 
move up and down with the change of the trigger level. At the same time, the 
real-time trigger level and slope information is displayed at the lower-left corner of 
the screen (as shown in the figure below, H indicates the upper limit of the trigger 
level, L indicates the lower limit of the trigger level, and △ indicates the trigger level 

deviation). When you stopping modifying the trigger level, the trigger level line and 
the trigger level information at the lower-left corner of the screen disappear in about 
2 s. The current trigger level deviation is displayed at the upper-right corner of the 
screen. 

 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger holdoff and noise rejection) under this trigger 
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise 
Rejection". 
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Delay Trigger 
 
In Delay trigger, you need to set Source A and Source B. The oscilloscope triggers 
when the time difference (△T) between the specified edges of Source A (Edge A) and 
Source B (Edge B) meets the preset time limit, as shown in the figure below. 
Note: Edge A and Edge B must be two neighboring edges. 

T

Source A

Source B

Edge A=
Edge B=

 
Figure 5-10 Delay Trigger 

 
Trigger Type: 
Click Type to select "Delay". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source A: 
Click SourceA to select CH1-CH4 as the trigger source of Source A. For details, 
please refer to descriptions in "Trigger Source". The current trigger source is 
displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge A: 
Click EdgeA continuously to select the trigger edge type of Source A in Delay trigger. 

It can be set to "Rising"  or "Falling" . 
 
Source B: 
Click SourceB to select CH1-CH4 as the trigger source of Source B. For details, refer 
to descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge B: 
Click EdgeB continuously to select the trigger edge type of Source B in Delay trigger. 
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It can be set to "Rising"  or "Falling" . 
 
Trigger Condition: 
Click When to set the time limit condition of Delay trigger. 
⚫ >: triggers when the time difference (△T) between the specified edges of 

Source A and Source B is greater than the preset time lower limit. Click Lower 

to set the delay time lower limit in Delay trigger.  

⚫ <: triggers when the time difference (△T) between the specified edges of 

Source A and Source B is smaller than the preset time upper limit. Click Upper 

to set the delay time upper limit in Delay trigger.  

⚫ <>: triggers when the time difference (△T) between the specified edges of 

Source A and Source B is greater than the lower limit of the preset time and 

smaller than the upper limit of the preset time. Click Upper to set the delay time 

upper limit in Delay trigger. Click Lower to set the delay time lower limit in Delay 

trigger.  

Note: The lower time limit must be smaller than the upper time limit. 

⚫ ><: triggers when the time difference (△T) between the specified edges of 

Source A and Source B is smaller than the lower limit of the preset time or 

greater than the upper limit of the preset time. Click Upper to set the delay time 

upper limit in Delay trigger. Click Lower to set the delay time lower limit in Delay 

trigger.  

Note: The lower time limit must be smaller than the upper time limit. 

 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameters (trigger holdoff and noise rejection) under this trigger 
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise 
Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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Setup/Hold Trigger 
 
In Setup/Hold trigger, you need to set the clock source and data source. The setup 
time starts when the data signal passes the trigger level and ends at the coming of 
the specified clock edge; the hold time starts at the coming of the specified clock 
edge and ends when the data signal crosses the trigger level again, as shown in the 
figure below. The oscilloscope triggers when the setup time or hold time is smaller 
than the preset time. 

T1
T2

Data Source

Clock Source

T2

T1 is the setup time

is the hold time

The edge type is The data type is H
 

 
Figure 5-11 Setup/Hold Trigger 

 
Trigger Type: 
Click Type to select "Setup/Hold". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Clock Source: 
Click SCL to set the signal source of the clock line. It can be set to CH1-CH4. For 
details, refer to descriptions in "Trigger Source". The current clock source (trigger 
source) is displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
clock source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope continuously to select the desired clock edge type, and it can be set to 

"Rising"  or "Falling" . 
 
Data Source: 
Click SDA to set the signal source of the data line. It can be set to CH1-CH4. For 
details, refer to descriptions in "Trigger Source". The current data source (trigger 
source) is displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
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Data Type: 
Click Data Type continuously to set the effective pattern of the data signal. It can 
be set to H (high level) or L (low level). 
 
Trigger Condition: 
Click When to select the trigger condition of Setup/Hold trigger.  
⚫ Setup: the oscilloscope triggers when the setup time is smaller than the 

specified setup time. After selecting this type, click More → Setup to set the 
setup time. You can use the pop-up numeric keypad or scroll with the mouse to 
set it. 

⚫ Hold: the oscilloscope triggers when the hold time is smaller than the specified 
hold time. After selecting this type, click More → Hold to set the hold time. You 
can use the pop-up numeric keypad or scroll with the mouse to set it.  

⚫ Setup/Hold: the oscilloscope triggers when the setup time or the hold time is 
smaller than the specified time value. After selecting this type, click More → 
Setup and More → Hold to set the setup time and hold time respectively. You 
can use the pop-up numeric keypad or scroll with the mouse to set them. 

 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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Nth Edge Trigger 
 
Triggers on the Nth edge that appears after the specified idle time. For example, in 
the waveform shown in the figure below, the instrument should trigger on the 
second rising edge after the specified idle time (the time between two neighboring 
rising edges), and the idle time should be within the range between P and M (P<Idle 
Time<M). Wherein, M is the time between the first rising edge and its previous rising 
edge; P is the maximum time between the rising edges that participate in counting. 

M

P<Idle Time<M

Edge Type=

Edge Num=2

P

 
Figure 5-12 Nth Edge Trigger 

 
Trigger Type: 
Click Type to select "Nth Edge". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope continuously to select the input signal edge on which the oscilloscope 
triggers. 

⚫ Rising: triggers on the rising edge of the input signal when the voltage level 
meets the specified trigger level. 

⚫ Falling: triggers on the falling edge of the input signal when the voltage level 
meets the specified trigger level. 
 
Idle Time: 
Click Idle Time to set the idle time before the edge counting in Nth edge trigger. Use 
the pop-up numeric keypad or scroll with the mouse to set the idle time. 
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Edge Count: 
Click Edges to set the value of "N" in Nth edge trigger. Use the pop-up numeric 
keypad or scroll with the mouse to set the edge count. Its available range is from 1 to 
65535. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 



RIGOL Chapter 5 To Trigger the Oscilloscope 

5-32 DS8000-R User Guide 

RS232 Trigger (Option) 
 
RS232 bus is a serial communication mode used in data transmission between PCs or 
between a PC and a terminal. In RS232 serial protocol, a character is transmitted as 
a frame of data. The frame consists of 1 start bit, 5-8 data bits, 1 check bit, and 1-2 
stop bits. Its format is as shown in the figure below. DS8000-R series oscilloscope 
triggers when the start frame, error frame, check error, or the specified data of the 
RS232 signal is detected. 
 

 

 
 

Figure 5-13 Schematic Diagram of RS232 Protocol 
 
Trigger Type: 
Click Type to select "RS232". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Trigger Condition: 
Click When to select the desired trigger condition.  
⚫ Start: triggers on the start frame position. 
⚫ Error: triggers when an error frame is detected. 
⚫ Check Error: triggers when a check error is detected.  
⚫ Data: triggers on the last bit of the preset data bits. Click Data, then use the 

numeric keypad or scroll with the mouse to set the data of RS232 trigger.  
 
Data Bits: 
Indicate the number of bits per frame. Click More → Data Bits to select the desired 
data bits. The available data bits include "5 Bits", "6 Bits", "7 Bits", and "8 Bits".  
 
Stop Bit: 
Indicate when to stop outputting. Click More → Stop Bit to select the desired stop 
bit. The available stop bit include "1 Bit", "1.5 Bits", and "2 Bits". 
 

Start Bit Data Bits Check Bit Stop Bit 
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Parity: 
Used to verify whether data are properly transmitted. Click More → Parity to select 
the desired parity. The available parity include "None", "Even", and "Odd".  
 
Polarity: 
Click Polarity continuously to select the polarity of data transmission. It can be set 
to "Pos"  or "Neg" .  
 
Baud Rate: 
Set the baud rate of data transmission (i.g. specifies a clock frequency). The 
following setting methods are available for baud rate:  
⚫ Click Baud Rate, then set the user-defined baud rate with the displayed 

numeric keypad or by scrolling with the mouse.  
⚫ Click Baud Rate, then select the preset baud rate from the available options. 

The available baud rates include 50 bps, 75 bps, 110 bps, 134 bps, 150 bps, 300 
bps, and etc.  
 

Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
For details, refer to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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I2C Trigger (Option) 
 
I2C is a 2-wire serial bus used to connect the microcontroller and its peripheral 
device. It is a bus standard widely used in the microelectronic communication control 
field. 
 
The I2C serial bus consists of SCL and SDA. Its transmission rate is determined by 
SCL, and its transmission data is determined by SDA, as shown in the figure below. 
DS8000-R triggers on the start condition, restart, stop, missing acknowledgment, 
specific device address, or data value. Besides, it can also trigger on the specific 
device address and data values at the same time. 
 

 
Figure 5-14 Schematic Diagram of I2C Protocol 

 
Trigger Type: 
Click Type to select "I2C". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click SCL and SDA to specify the signal sources of SCL and SDA respectively. They 
can be set to CH1-CH4. For details, refer to descriptions in "Trigger Source". The 
current trigger source is displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Trigger Condition: 
Click When to select the desired trigger condition.  
⚫ Start: triggers when SDA data transitions from high level to low level while SCL is 

high level. 
⚫ Stop: triggers when SDA data transitions from low level to high level while SCL is 

high level.  
⚫ Restart: triggers when another start condition occurs before a stop condition. 
⚫ MissedAck: triggers when the SDA data is high level during any acknowledgment 
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of SCL clock position. 
⚫ Address: the trigger searches for the specified address value. When this event 

occurs, the oscilloscope will trigger on the read/write bit. After this trigger 
condition is selected: 

➢ Click AddrBits to select the desired address bits. The available address bits 
are "7 Bits", "8 Bits", and "10 Bits". 

➢ Click Address, then use the numeric keypad or scroll with the mouse to set 
the address of I2C trigger. 

➢ Click More → Direction to select "Write", "Read", or "R/W".  

Note: This setting is not available when AddrBits is set to "8 Bits". 
⚫ Data: the trigger searches for the specified data value on the data line (SDA). 

When this event occurs, the oscilloscope will trigger on the clock line (SCL) 
transition edge of the last bit of data. After this trigger condition is selected: 

➢ Click Bit X, then scroll with the mouse to select data bit that needs to be 
operated on. Then set the current bit. As shown in the figure below, the left 
is its binary format, and the right is its corresponding Hex format. 

 

 

Then set it with the pop-up virtual keypad. For setting methods, refer to 
descriptions in "Pattern Trigger". If you modify the binary data bit, a 
virtual keypad as shown in Figure 5-15 (a) is displayed. If you modify the 
hex data bit, a virtual keypad as shown in Figure 5-15 (b) is displayed. 

 

        

(a) Virtual Keypad for Binary Data Bit  (b) Virtual Keypad for Hex Data Bit 

Figure 5-15 Virtual Keypad for Data Bit Settings 

 

➢ Click Bytes, then use the pop-up numeric keypad or scroll with the mouse 
to set the length of the data. Its range is from 1 to 5. 

➢ Click More → Addr Bits to select the desired address bits. The available 
address bits are "7 Bits", "8 Bits", and "10 Bits". 

⚫ A & D: the oscilloscope searches for the specified address and data at the same 
time, then triggers when both the address and data meet the conditions. After 
this trigger condition is selected, you need to set Bit X, Bytes, Addr Bits, 
Address, and Direction menu items. For setting methods, refer to descriptions 
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in "Address" and "Data" trigger conditions. 
 

Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 

upper-right corner of the screen. 
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SPI Trigger (Option) 
 
In SPI trigger, after the CS or timeout condition is satisfied, the oscilloscope triggers 
when the specified data is found. When using SPI trigger, you need to specify the 
SCL clock sources and SDA data sources. Below is the sequential chart of SPI bus. 
 

SDA

SCL

CS

D7 D6 D5 D4 D3 D2 D1 D0
 

 
Figure 5-16 Sequential Chart of SPI Bus 

 
Trigger Type: 
Click Type to select "SPI". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

  
 
Source Selection: 
Click CLK and MISO to specify the sources of SCL and SDA respectively. They can be 
set to CH1-CH4. For details, refer to descriptions in "Trigger Source". The current 
trigger source is displayed at the upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click Slope continuously to select the desired clock edge type. 

⚫ Rising: samples the SDA data on the rising edge of the clock. 

⚫ Falling: samples the SDA data on the falling edge of the clock. 

 
Trigger Condition: 
Click When continuously to select the desired trigger condition. 
⚫ Timeout: the oscilloscope starts to search for the data (SCL) on which to trigger 

after the clock signal (SDA) stays in the idle state for a specified period of time. 
After selecting this condition, you can click Timeout, then use the pop-up 
numeric keypad or scroll with the mouse to set the idle time. The range is from 
8 ns to 10 s.  

⚫ With CS: if the CS signal is valid, the oscilloscope will trigger when the data (SDA) 
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satisfying the trigger conditions is found. 
➢ Click CS to select the chip selection signal line. The available channels are 

CH1-CH4. For details, refer to descriptions in "Trigger Source". The 
current trigger source is displayed at the upper-right corner of the screen. 

➢ Click More → CS Mode to set the current CS mode to "Pos " (high 

level is valid) or "Neg " (low level is valid). 
 
Current Bit: 
Click More → Bit X to set the data bit that needs to be operated on. For setting 
methods, refer to descriptions in "I2C Trigger (Option)".  
 
Data Bits: 
Click More → DataBits, then use the pop-up numeric keypad or scroll with the 
mouse to set the number of bits in the serial data string. The number of bits in the 
string can be set to any integer ranging from 4 and 32. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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CAN Trigger (Option) 
 
DS8000-R can trigger on the start of a frame, end of a frame, frame of the specified 
type (e.g. Remote, Overload, Data, etc.), or error frame of the specified type (e.g. 
Answer Error, Check Error, Format Error, etc.) of the CAN signal. 
 
The data frame format of the CAN bus is as shown in the figure below. 
 

 
Figure 5-17 Data Frame Format of the CAN Bus 

 
Trigger Type: 
Click Type to select "CAN". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Trigger Condition: 
Click When to select the desired trigger condition. 
⚫ SOF: triggers at the start of a frame. 
⚫ EOF: triggers at the end of a frame. 
⚫ Remote ID: triggers on the remote frame with the specified ID. Set the following 

parameters: 
➢ Click Extended ID to enable or disable the extended ID. 
➢ Click Bit X to set the data bit that needs to be operated on. For setting 

methods, refer to descriptions in "I2C Trigger (Option)". 
⚫ Overload: triggers on the CAN overload frames. 
⚫ Frame ID: triggers on the data frames with the specified ID. Set the following 

parameters: 
➢ Click Extended ID to enable or disable the extended ID. 
➢ Click Bit X to set the data bit that needs to be operated on. For setting 

methods, refer to descriptions in "I2C Trigger (Option)". 
⚫ Frame Data: triggers on the data frames with specified data. Set the following 
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parameters: 
➢ Click Bit X to set the data bit that needs to be operated on. For setting 

methods, refer to descriptions in "I2C Trigger (Option)". 
➢ Click Bytes, then use the numeric keypad or scroll with the mouse to set 

the length of the data. Its range is from 1 to 8. 
⚫ Data&ID: triggers on the data frames with the specified ID and data. Set the 

following parameters: 
➢ Click Define to select "Data" or "ID".  
➢ When you select "Data", set Bit X and Bytes. For detailed settings, refer to 

parameter settings for "Frame Data". 
➢ When you select "ID", set Extended ID and Bit X. For detailed settings, 

refer to parameter settings for "Frame ID". 
⚫ Frame Error: triggers on the error frame. 
⚫ Bit Fill: triggers on the error frame with the bit fill. 
⚫ Answer Error: triggers on the answer error frame. 
⚫ Check Error: triggers on the check error frame. 
⚫ Format Error: triggers on the format error frame. 
⚫ Random Error: triggers on random error frame, such as the format error frame, 

answer error frame, etc. 
 
Signal Type: 
Click More → Signal Type to select the desired signal type.  

⚫ CAN_H: indicates the actual CAN_H bus signal. 
⚫ CAN_L: indicates the actual CAN_L bus signal. 
⚫ TX/RX: indicates the Transmit signal and Receive signal from the CAN bus    

transceiver. 
⚫ DIFF: The CAN differential bus signals connected to an analog source channel by 

using a differential probe. Connect the probe's positive lead to the CAN_H bus 
signal and connect the negative lead to the CAN_L bus signal. 
 

Baud Rate: 
Click More → Baud to set the baud rate. The following setting methods are 
available for baud rate: 
⚫ Click Baud, then set the user-defined baud rate with the displayed numeric 

keypad or by scrolling with the mouse.  
⚫ Click Baud, then select the preset baud rate from the available options. The 

available baud rates include 10 kbps, 20 kbps, 33.3 kbps, 50 kbps, 62.5 kbps, 
83.3 kbps, and etc. 

 
Sample Position: 
Sample position is a point within a bit’s time. The oscilloscope samples the bit level at 
this point. The sample position is represented by the proportion of "the time from the 
start of the bit to the sample position" to the "bit time", as shown in the figure below. 
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Figure 5-18 Sample Position 

 
Click More → Sample Position, then use the pop-up numeric keypad or scroll with 
the mouse to set the sample position. The settable range is from 10% to 90%. 

 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 

One Bit 

60% 

70% 

80% 
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FlexRay Trigger (Option) 
 
DS8000-R can trigger on the specified frame, symbol, error, or position of the 
FlexRay bus. 
 
FlexRay is a type of differential serial bus configured with three consecutive 
segments (i.g. header, payload, and trailer). Its data transmission rate is up to 10 
Mb/s. Each frame contains a static segment and a dynamic segment, and ends with 
the bus idle time.  
 

Its format is as shown in the figure below. 
 

 
Figure 5-19 Frame Format of FlexRay Bus 

Trigger Type: 
Click Type to select "FlexRay". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Baud Rate: 
Click Baud to select a FlexRay baud rate that matches the FlexRay bus signal. The 
available baud rates are 2.5 Mbps, 5 Mbps, and 10 Mbps. 
 
Trigger Condition: 
Click When to select the desired trigger condition.  
⚫ Post: triggers on the specified position of the FlexRay bus. Click Post to select 

"TSS End", "FSS_BSS End", "FES End", or "DTS End". 



Chapter 5 To Trigger the Oscilloscope  RIGOL 

DS8000-R User Guide 5-43 

⚫ Frame: triggers on the frame of FlexRay bus. 
➢ Click Frame to select the frame type. The types of frames include null, Sync, 

Start, and All. 
➢ Click More → Define to select "ID" or "Cyc Count".  

When you select "ID", set the following parameters: ID Comp, ID Min, and 
ID Max. Click More → ID Comp to select the comparison conditions. The 
available choices include =, ≠, >, <, ><, <>. Click More → ID Max or 

click More → ID Min, then use the pop-up numeric keypad or scroll with 
the mouse to set the frame ID. 
When you select "Cyc Count", set the following parameters: Cyc Comp, 
Count Min, and Count Max. Click More → Cyc Comp to select the 
comparison conditions. The available choices include =, ≠, >, <, ><, <>. 

Click More → Count Max or click More → Count Min, then use the 
pop-up numeric keypad or scroll with the mouse to set the cycle count. 

⚫ Symbol: triggers on the CAS/MTS (Collision Avoidance Symbol/Media Access 
Test Symbol) and WUS (Wake Up Symbol) of FlexRay bus. 
➢ Click Symbol to select the symbol type. The symbol type includes CAS/MTS 

and WUS. 
➢ Click More → ID Comp to select the comparison conditions. The available 

choices include =, ≠, >, <, ><, <>. Click More → ID Max or click More 

→ ID Min, then use the pop-up numeric keypad or scroll with the mouse to 
set the frame ID. 

⚫ Error: triggers when an error occurs to the FlexRay bus. 
Click Error to select the error type. It includes Head CRC Err, Tail CRC Err, 
Decode Err, and Random Err. 
 

Note: As the occurrence possibility of specified FlaxRay frame is very low, it is 
recommended that you set the oscilloscope to "Normal" trigger mode when the 
trigger condition is set to "Frame", so as to prevent the instrument from triggering 
automatically while waiting for the specified frame. The same goes for "Error" trigger 
condition. In addition, when multiple FlexRay errors occur at the same time, you 
need to adjust the trigger holdoff so as to view the specific error. 

 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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LIN Trigger (Option) 
 
DS8000-R can trigger on the sync field of LIN signal, and can also trigger on the 
specified identifier, data, or frame. 
 
The data frame format of the LIN bus is as shown in the figure below. 

 
Figure 5-20 Data Frame Format of the LIN Bus 

 
Trigger Type: 
Click Type to select "LIN". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Trigger Condition: 
Click When to select the desired trigger condition.  
⚫ Sync: triggers on the last bit of the sync field. 
⚫ ID: triggers when the frame with an ID equal to the selected value is detected. 

Click ID, then use the pop-up numeric keypad or scroll with the mouse to set ID. 
⚫ Data: triggers when the data that meet the preset conditions are found. 

➢ Click Bit X to set the data bit that needs to be operated on. For setting 
methods, refer to descriptions in "I2C Trigger (Option)". 

➢ Click Bytes, then use the pop-up numeric keypad or scroll with the mouse 
to set the length of the data. Its range is from 1 to 8. 

⚫ Data&ID: triggers when a frame with a specified ID and data that meet the 
preset conditions are both found. 
➢ Click Bit X to set the data bit that needs to be operated on. For setting 

methods, refer to descriptions in "I2C Trigger (Option)". 
➢ Click Bytes, then use the pop-up numeric keypad or scroll with the mouse 

to set the length of the data. Its range is from 1 to 8. 
➢ Click ID, then use the pop-up numeric keypad or scroll with the mouse to 

set ID. 
⚫ Sleep: triggers when the sleep frame is found.  
⚫ Wakeup: triggers when the wakeup frame is found. 
⚫ Error: triggers on the specified type of error frame. Click Error Type and select 
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the desired error type: Sync, Even Odd, or Check Sum. 
 
Protocol Version: 
Click More → Version to select the protocol version that matches the signal under 
test. The available versions include 1.X, 2.X, and Both. 
 
Baud Rate: 
Click More → Baud to set the baud rate. The setting methods are available for baud 
rate: 
⚫ Click Baud, then set the user-defined baud rate with the displayed numeric 

keypad or by scrolling with the mouse.  
⚫ Click Baud to select the preset baud rate from the available options. The 

available baud rates include 1.2 kbps, 2.4 kbps, 4.8 kbps, 9.6 kbps, 19.2 kbps, 
and etc. 

 
Sample Position: 
Sample position is a point within a bit’s time. The oscilloscope samples the bit level at 
this point. The sample position is represented by the proportion of "the time from the 
start of the bit to the sample position" to the "bit time", as shown in the figure below. 

 
 

 
Figure 5-21 Sample Position 

 
Click More → Sample Position, then use the pop-up numeric keypad or scroll with 
the mouse to set the sample position. The settable range is from 10% to 90%. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 
to descriptions in "Noise Rejection". 
 
Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
 
 

One Bit 

60% 

70% 

80% 
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I2S Trigger (Option) 
 
In I2S trigger, the oscilloscope searches for the specified data value and take it as the 
condition for identifying the trigger. You need to specify the serial clock line (SCLK, 1 
pulse is found on the clock line once 1 bit of digital audio data is sent), frame clock 
line (WS, used for switch the audio channel data), and serial data line (SDA, used for 
transmit audio data represented in binary (2's complement)). 
 
Below is the sequential chart of I2S bus. 
 

 
Figure 5-22 Sequential Chart of I2S Bus 

 
Trigger Type: 
Click Type to select "I2S". Then, the current trigger setting information is displayed 
at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click SCLK, WS, and SDA to specify the sources for SCLK, WS, and SDA respectively. 
The available choices are CH1-CH4. For details, refer to descriptions in "Trigger 
Source". The current trigger source is displayed at the upper-right corner of the 
screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
 
Edge Type: 
Click SCLK Edge to select the desired clock edge. 

⚫ Rising: samples the SDA data on the rising edge of the clock. 

⚫ Falling: samples the SDA data on the falling edge of the clock. 

 
Audio: 
Click Audio continuously to select "Left", "Right", or "Either". 
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Trigger Condition: 
Click When to select the desired trigger condition. 
⚫ =: triggers when the channel's data equal the set data value. Click Data to set 

the data bit. For setting methods, refer to descriptions in "I2C Trigger 
(Option)". 

⚫ ≠: triggers when the channel's data do not equal the set data value. Click Data 
to set the data bit. For setting methods, refer to descriptions in "I2C Trigger 
(Option)". 

⚫ <: triggers when the channel's data are smaller than the set data value. Click 
Data Max to set the upper limit of the data bit. For setting methods, refer to 
descriptions in "I2C Trigger (Option)". 

⚫ >: triggers when the channel's data are greater than the set data value. Click 
Data Min to set the lower limit of the data bit. For setting methods, refer to 
descriptions in "I2C Trigger (Option)". 

⚫ ><: triggers when the channel's data are smaller than the upper limit of the 
data value and greater than the lower limit of the data value. Click Data Max 
and Data Min to set the upper limit and lower limit of the data bit respectively. 
For setting methods, refer to descriptions in "I2C Trigger (Option)". 

⚫ <>: triggers when the channel's data are greater than the upper limit of the 
data value or smaller than the lower limit of the data value. Click Data Max and 
Data Min to set the upper limit and lower limit of the data bit respectively. For 
setting methods, refer to descriptions in "I2C Trigger (Option)". 

 
Width: 
Click More → Width, then use the pop-up numeric keypad or scroll with the mouse 
to set the width. Its range is from 4 to 32. 
 
User Width: 
Click More → User Width, then use the pop-up numeric keypad or scroll with the 
mouse to set the user width. Its range is from 4 to 32. 
Note: The user width is smaller than or equal to the width. 
 
Alignment: 
Click More → Alignment to select the alignment way for data signal.  
I2S: MSB (Most Significant Bit) of data for each sample is sent first, and LSB (Least 
Significant Bit) is sent last. The MSB appears on the SDA line one bit clock after the 
edge of the WS transition. 
LJ: data transmission (MSB first) begins at the edge of the WS transition. 
RJ: data transmission (MSB first) is right-justified to the WS transition. 
 
Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 

to descriptions in "Noise Rejection". 
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Trigger Level: 
Refer to "Trigger Level". The current trigger level value is displayed at the 
upper-right corner of the screen. 
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MIL-STD-1553 Trigger (Option) 
 
1553B is the abbreviation for the MIL-STD-1553 bus. DS8000-R can trigger on the 
sync field of 1553B bus, and can also trigger on the specified data word, command 
word, status word, or error type. 
 
The formats of the command word, data word, and status word of the 1553B bus is 
shown in the following figure. 
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Figure 5-23 Formats of the Command Word, Data Word, and Status Word of the 
1553B Bus 
 
Trigger Type: 
Click Type to select "MIL-STD-1553". Then, the current trigger setting information is 
displayed at the upper-right corner of the screen, as shown in the figure below.  

 
 
Source Selection: 
Click Source to open the signal source list and select CH1-CH4. For details, refer to 
descriptions in "Trigger Source". The current trigger source is displayed at the 
upper-right corner of the screen. 
Note: Only when we select the channel (that has been input with signals) as the 
trigger source, can we obtain a stable trigger. 
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Trigger Condition: 
Click When to select the desired trigger condition. 
⚫ Sync: triggers on the specified sync type. After the trigger condition is selected, 

click Sync to select the desired sync type: Data Sync, Cmd/Status Sync, or All 
Sync. 

⚫ Data: triggers on the specified data word. After the trigger condition is selected, 
click Comp to select the comparison conditions. The available choices include =, 
≠, >, <, ><, <>. 
➢ =: triggers when the channel's data word equals the set data word. Click 

Min to set the lower limit of the data word. For setting methods, refer to 
descriptions in "I2C Trigger (Option)". 

➢ ≠: triggers when the channel's data word does not equal the set data word. 
Click Min to set the lower limit of the data word. For setting methods, refer 
to descriptions in "I2C Trigger (Option)". 

➢ <: triggers when the channel's data word is smaller than the set data word. 
Click Max to set the upper limit of the data word. For setting methods, refer 
to descriptions in "I2C Trigger (Option)". 

➢ >: triggers when the channel's data word is greater than the set data word. 
Click Min to set the lower limit of the data word. For setting methods, refer 
to descriptions in "I2C Trigger (Option)". 

➢ ><: triggers when the channel's data word is smaller than the upper limit of 
the data word and greater than the lower limit of the data word. Click Max 
and Min to set the upper limit and lower limit of the data word respectively. 
For setting methods, refer to descriptions in "I2C Trigger (Option)". 

➢ <>: triggers when the channel's data word is greater than the upper limit of 
the data word or smaller than the lower limit of the data word. Click Max 
and Min to set the upper limit and lower limit of the data word respectively. 
For setting methods, refer to descriptions in "I2C Trigger (Option)". 

⚫ RTA: triggers on the specified remote terminal address. After this trigger 
condition is selected, click RTA to set the remote terminal address. For setting 
methods, refer to descriptions in "I2C Trigger (Option)". 

⚫ RTA+11Bit: triggers on the RTA and the remaining 11 bits. After this trigger 
condition is selected: 
➢ Click RTA to set the remote terminal address. For setting methods, refer to 

descriptions in "I2C Trigger (Option)". 
➢ Click Bit time to set the bit time position value to 0 (low), 1 (high), or X 

(don't care). For setting methods, refer to descriptions in "I2C Trigger 
(Option)". 

⚫ Error: triggers on the specified error type. After this trigger condition is selected, 
click Err Type to select the error type. 
➢ Sync Error: triggers when an invalid sync pulse is found. 
➢ Check Error: triggers when the parity bit is incorrect for the data in the 

word. 
 

Level Selection and Adjustment of Trigger Level: 
After the trigger condition setting is completed, you need to adjust the trigger level 
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to correctly trigger the signal and obtain a stable waveform. Click Level Select 
(when "Data" is selected for the trigger condition, click More → Level Select), then 
select the desired level type for adjustment.  
➢ Level A: only adjusts the upper limit of the trigger level, and the lower limit of 

the trigger level remains unchanged. 
➢ Level B: only adjusts the lower limit of the trigger level, and the upper limit of 

the trigger level remains unchanged. 
➢ Level AB: adjusts the upper and lower limits of the trigger level at the same time, 

and the trigger level deviation (the difference between the upper limit and lower 
limit of the trigger level) remains unchanged. 

 

You can click on the trigger setting label  at the upper-right corner of 
the screen to adjust the trigger level. During the adjustment of trigger level, two 
trigger level lines appear on the screen, and they move up and down with the change 
of the trigger level. At the same time, the real-time trigger level and slope 
information is displayed at the lower-left corner of the screen (as shown in the figure 
below, H indicates the upper limit of the trigger level, L indicates the lower limit of 
the trigger level, and △ indicates the trigger level deviation). When you stopping 

modifying the trigger level, the trigger level line and the trigger level information at 
the lower-left corner of the screen disappear in about 2 s. The current trigger level 
deviation is displayed at the upper-right corner of the screen. 

 
 

Polarity: 
Click More → Polarity to select the desired polarity. The polarities available are 

positive polarity ( ) and negative polarity ( ). 
 

Trigger Mode: 
For details, refer to descriptions in "Trigger Mode". 
 
Trigger Parameter Setting: 
Set the trigger parameter (noise rejection) under this trigger type. For details, refer 

to descriptions in "Noise Rejection". 
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Zone Trigger 
 
DS8000-R series oscilloscope supports the zone trigger and provides two rectangle 
areas: Trigger zone A and Trigger zone B. You can set the trigger conditions to 
"Intersect" or "Not intersect". Refer to "Rectangle Drawing" to select "Trigger 
zone A" or "Trigger zone B" to open the zone trigger setting menu. You can also click 
on the function navigation icon to open the navigation menu. Then click Measure → 
Analyze → Zone trigger to enter the zone trigger setting menu. 
 
Enable or disable Trigger zone A or Trigger zone B: 
Click Zone A enable or Zone B enable continuously to enable or disable Trigger 
zone A or Trigger zone B. You can also refer to "Rectangle Drawing" to select 
"Trigger zone A" or "Trigger zone B" to enable Trigger zone A or Trigger zone B. If 
both Trigger zone A and Trigger zone B are disabled, then the zone trigger function is 
disabled. At this time, you must enable either of them to re-enable the zone trigger. 
Note: The zone trigger function is disabled when you enable "XY Mode" or "ROLL 
Mode". 
 
Select Source A or Source B: 
Click Source A or Source B to select the desired source. The available sources 
include CH1-CH4. The zone name color and the zone color are the same as the color 
of the selected source channel. 
 
Set the conditions for Trigger zone A and Trigger zone B: 
Click Zone A or Zone B to select "Intersect" or "Not intersect". 
 
If you enable Zone A, select CH1 as Source A, and select "Intersect" as the condition, 
as shown in the figure below. 

 
 
If you enable Zone A, select CH1 as Source A, and select "Not intersect" as the 
condition, the following figure is displayed. 
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Tip 
If you enable both Trigger zone A and Trigger zone B, then perform the "A&&B" 
operation, and it will become the final trigger condition. 
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Trigger Output Connector 
 
The trigger output connector ([TRIG OUT]) on the rear panel of DS8000-R series 
can output trigger signals (hardware trigger) determined by the current setting. 
 

 
 

 
Figure 5-24 Trigger Output Connector 

 
Click on the function navigation icon to open the navigation menu. Then click Utility 
→ System → AUX Out to select "TrigOut". A signal which reflects the current 
capture rate of the oscilloscope can be output from the [TRIG OUT] connector each 
time a trigger is generated by the oscilloscope. If this signal is connected to a 
waveform display device to measure the frequency, the measurement result is the 
same as the current capture rate. 
 
Note: If you click Utility → System → AUX Out to select "PassFail", then in the 
pass/fail test, when a pass/fail event is detected, the oscilloscope outputs a pulse 
from the rear-panel [TRIG OUT] connector. 
 

Trigger Output Connector 
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Chapter 6 Operations and Measurements 
 
DS8000-R can perform math operations, auto measurements, and cursor 
measurements on sampled and displayed data. 
 
Contents in this chapter: 
◼ Math Operation 
◼ Auto Measurement 
◼ Cursor Measurement 
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Math Operation 
 

Click on the function navigation icon  to open the function navigation. Then click 

on the "Math" icon  to open the math operation menu. This oscilloscope supports 
four math operations: Math1, Math2, Math3, and Math4. The following section takes 
Math1 as an example to introduce the math operation in detail. 
 
Click Math → Math1 → Operator to select the desired math function. Click 
Operation continuously to enable or disable the operation. When enabled, the 
results of math operation are displayed with purple waveforms on the screen, and 
the math operation formula, vertical scale, and other parameters (the displayed data 
parameters are different for different math operations) are displayed at the bottom 
of the screen. The results of the math operation can be further measured. This 
oscilloscope supports enabling the four math operations at the same time, as shown 
in the figure below. 

 
 
DS8000-R series can realize multiple math operations between waveforms of 
different channels, including  
⚫ arithmetic operations (A+B, A-B, A× B, and A/B) 
⚫ FFT operation 
⚫ logic operation: A&&B, A||B, A^B, and !A 
⚫ function operation: Intg, Diff, Sqrt, Lg, Ln, Exp, Abs, and AX+B (linear function) 
⚫ math filter: low-pass filter, high-pass filter, band-pass filter, and band-stop filter 
 
Note: When you select the source, only the enabled channel is available. 
 
 

Addition 
 
Adds the waveform voltage values of signal source A and B point by point and 
displays the results. 
 
Click Math → Math1 → Operator to select "A+B": 

⚫ Click Operation continuously to enable or disable the addition operation 
function. 

⚫ Click SourceA and SourceB respectively to select the channel for Source A and 
Source B. The available channels for Source A and Source B are CH1-CH4 and 
Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 



Chapter 6 Operations and Measurements  RIGOL 

DS8000-R User Guide 6-3 

of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click More → AutoSetting to adjust the vertical scale and the offset of the 
operation results to the optimal value according to the current configuration, so 
as to better to observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Expand to expand or compress the math operation waveform 
around the "Center" or "GND". 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Subtraction 
 
Subtracts the waveform voltage values of signal source B from that of source A point 
by point and displays the results. 
 
Click Math → Math1 → Operator to select "A-B": 

⚫ Click Operation continuously to enable or disable the subtraction operation 
function. 

⚫ Click SourceA and SourceB respectively to select the channel for Source A and 
Source B. The available channels for Source A and Source B are CH1-CH4 and 
Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  



RIGOL Chapter 6 Operations and Measurements 

6-4 DS8000-R User Guide 

⚫ Click More → AutoSetting to adjust the vertical scale and offset of the 
operation results to the optimal value according to the current configuration, so 
as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Expand to expand or compress the math operation waveform 
around the "Center" or "GND". 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Multiplication 
 
Multiplies the waveform voltage values of signal source A and B point by point and 
displays the results. 
 
Click Math → Math1 → Operator to select "A× B": 

⚫ Click Operation continuously to enable or disable the multiplication operation 
function. 

⚫ Click SourceA and SourceB respectively to select the channel for Source A and 
Source B. The available channels for Source A and Source B are CH1-CH4 and 
Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click More → AutoSetting to adjust the vertical scale and offset of the 
operation results to the optimal value according to the current configuration, so 
as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Expand to expand or compress the measurement waveform 
around the "Center" or "GND". 
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⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 
 
 

Division 
 
Divides the waveform voltage values of signal source A by that of source B point by 
point and displays the results. It can be used to analyze the multiple relationships of 
waveforms of two channels.  
Note: When the voltage of signal source B is 0 V, the division result is treated as 0. 
 
Click Math → Math1 → Operator to select "A÷ B": 

⚫ Click Operation continuously to enable or disable the division operation 
function. 

⚫ Click SourceA and SourceB respectively to select the channel for Source A and 
Source B. The available channels for Source A and Source B are CH1-CH4 and 
Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click More → AutoSetting to adjust the vertical scale and offset of the 
operation results to the optimal value according to the current configuration, so 
as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Expand to expand or compress the measurement waveform 
around the "Center" or "GND". 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
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the color grade again. 

 

 

FFT 
 
FFT (Fast Fourier Transform) is used to transform time-domain signals to 
frequency-domain components (frequency spectrum). DS8000-R oscilloscope 
provides FFT operation function which enables you to observe the time-domain 
waveform and spectrum of the signal at the same time. FFT operation can facilitate 
the following works: 
⚫ Measure harmonic components and distortion in the system; 
⚫ Display the characteristics of the noise in DC power; 
⚫ Analyze vibration. 

 
Click Math → Math1 → Operator to select "FFT": 
⚫ Click Operation continuously to enable or disable the FFT operation function. 

When enabled, the operation results are displayed as purple waveforms on the 
screen. At the same time, the parameters such as vertical scale, center 
frequency, and resolution are displayed at the bottom of the screen, as shown in 
the following figure. Of which, FFT resolution is the quotient of the sample rate 
and the number of FFT points. If the number of FFT points is a fixed value 
(65535 at most), then the higher the sample rate, the higher the resolution.  
 

 

 

 
 
⚫ Click Source to select the channel. The available channels are CH1, CH2, CH3, 

and CH4. 
⚫ Click Offset to set the vertical offset of the operation results. For setting 

methods, refer to the descriptions in "Parameter Setting Method".  
⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 

refer to the descriptions in "Parameter Setting Method". If the source 
channel unit is set to "V", then the unit of the vertical scale is displayed as dBV. 
If you select other source channel units, then the unit of the vertical scale is 
displayed as dB. 

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to the optimal value according to the current configuration, so as to better 
observe. 

⚫ Click More → Unit to select the vertical unit. The vertical unit can be set to 
dBm/dBV or Vrms. The vertical amplitude can be expressed both in log form and 
linear form, with dBm/dBV and Vrms as the unit respectively. If you need to 
display the FFT spectrum within a larger dynamic range, dBm/dBV is 
recommended. 

Vertical Scale    Sample Rate   Center Frequency  Span       Resolution 
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⚫ Click More → X continuously to select "Span-Center" (frequency range to 
center frequency) or "Start-End" (start frequency to stop frequency). 
➢ "Span-Center" (frequency range to center frequency): the frequency range 

refers to the screen width, and you can divide the frequency range by 10 to 
obtain the frequency per division. Click Span to set the frequency range of 
the frequency-domain waveform. For setting methods, refer to descriptions 
in "Parameter Setting Method". Click Center to set the frequency of 
the frequency-domain waveform relative to the horizontal center of the 
screen. For setting methods, refer to descriptions in "Parameter Setting 
Method". 

➢ "Start-End" (start frequency to stop frequency): start frequency refers to 
the frequency at the left side of the screen. Click Start to set the start 
frequency of the frequency-domain waveform. For setting methods, refer to 
descriptions in "Parameter Setting Method". Stop frequency refers to 
the frequency at the right side of the screen. Click End to set the stop 
frequency of the frequency-domain waveform. For setting methods, refer to 
descriptions in "Parameter Setting Method". 

⚫ Click More → Peak Search to enter the peak search menu. 
Click Peak Search continuously to enable or disable the peak search function. 
When enabled, the peak search results are displayed on the screen, as shown in 
the figure below. Click the "Math" tab at the top of the peak search results to 
switch among Math1-Math4. 

 
 
➢ Click Peak Number, then use the pop-up numeric keypad or scroll with the 

mouse to set the number of peaks. The available range is from 1 to 15. By 
default, it is 5. 

➢ Click Threshold, then use the pop-up numeric keypad or scroll with the 
mouse to set the threshold of the peak. 

➢ Click Excursion, then use the pop-up numeric keypad or scroll with the 
mouse to set the excursion of the peak. 

➢ Click Table Order, then select the sorting mode of the peak. The available 
sorting mode is "Amp Order" and "Freq Order". By default, it is "Amp 
Order". 

➢ Click Export, and the save setting menu is displayed. You can export the 
peak search results to the internal memory or the external USB storage 
device in CSV format. For detailed saving operation, refer to descriptions in 
"Store and Load".  

⚫ Click More → Window to select the desired window function. 



RIGOL Chapter 6 Operations and Measurements 

6-8 DS8000-R User Guide 

Spectral leakage can be considerably decreased when a window function is used. 
DS8000-R provides 6 FFT window functions (as shown in Table 6-1) which have 
different characteristics and are applicable to measuring different waveforms. 
You need to select the window function according to the characteristics of the 
waveform to be measured. 
Table 6-1 Window Function 

Window 
Function 

Characteristics 
Waveforms Applicable to the 
Window Function 

Rectangular Best frequency 
resolution 
Poorest 
amplitude 
resolution 
Similar to the 
situation when 
no window is 
applied. 

Transient or short pulse, the signal 
levels before and after the 
multiplication are basically the same. 
Sine waveforms with the same 
amplitudes and rather similar 
frequencies. 
Wide band random noise with 
relatively slow change of waveform 
spectrum. 

Blackman-Harris Best amplitude 
resolution 
Poorest 
frequency 
resolution 

Single frequency signal, searching for 
higher order harmonics. 

Hanning 
 

Better frequency 
resolution and 
poorer amplitude 
resolution 
compared with 
Rectangular 

Sine, periodic, and narrow band 
random noise. 

Hamming A little bit better 
frequency 
resolution than 
Hanning 

Transient or short pulse, the signal 
levels before and after the 
multiplication are rather different. 

Flattop Measure the 
signals 
accurately 

Measure the signal that has no 
accurate reference and requires an 
accurate measurement 

Triangle Better frequency 
resolution 

Measure the narrow band signal and 
that has strong noise interference 

 
⚫ For FFT math operation setting label, refer to descriptions in "Math Operation 

Label". 

⚫ Click More → More → Color Grade to enable or disable the color grade 
display of the FFT operation results. When enabled, different colors are 
displayed on the screen to indicate the times of data acquisition or acquisition 
probability. 

⚫ Click More → More → Reset ColorGrade to clear the color grade display and 
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display the color grade again.  
 

 
 

"AND" Operation 
 
Performs logic "AND" operation on the waveform voltage values of the specified 
sources point by point and displays the results. In operation, when the voltage value 
of the source channel is greater than the threshold of the corresponding channel, it is 
regarded as logic "1"; otherwise it is logic "0". The results of logic AND operation of 
two binary bits are shown in Table 6-2. 
 
Table 6-2 Logic "AND" Operation 

A B A&&B 

0 0 0 

0 1 0 

1 0 0 

1 1 1 

 
Click Math → Math1 → Operator to select "A&&B": 

⚫ Click Operation continuously to enable or disable the "AND" operation function. 

⚫ Click SourceA and SourceB respectively to select the channel for SourceA and 
Source B. The available channels for Source A and Source B are CH1-CH4. 

Note: Only the channels that have been enabled currently can be selected. 

 

➢ If Source A (or Source B) selects CH1, click More → Thre.CH1 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH2, click More → Thre.CH2 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH3, click More → Thre.CH3 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH4, click More → Thre.CH4 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method".  

 

Tip 

FFT shortcut operation: click the function navigation icon  at the lower-left 
corner of the screen to open the function navigation. Then, click the "FFT" icon 
to open the FFT menu. This oscilloscope supports 4 FFTs: FFT1, FFT2, FFT3, and 
FFT4. For details, refer to the descriptions in this section. 
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⚫ Click Offset to adjust the vertical offset of the operation results with the 
displayed numeric keypad or by scrolling with the mouse.  

⚫ Click Size to select the waveform size. The available sizes include "Small", 
"Medium", and "Large".  

⚫ The AutoSetting menu under More is grayed out and disabled. 

⚫ Click More → Sensitivity to set the sensitivity of the digital signal converted 
from the analog signal on the source. For setting methods, refer to descriptions 
in "Parameter Setting Method".  

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

 
 
"OR" Operation 
 
Performs logic "OR" operation on the waveform voltage values of the specified 
sources point by point and displays the results. In operation, when the voltage value 
of the source channel is greater than the threshold of the corresponding channel, it is 
regarded as logic "1"; otherwise it is logic "0". The results of logic OR operation of 
two binary bits are as shown in Table 6-3. 
 
Table 6-3 Logic "OR" Operation 

A B A||B 

0 0 0 

0 1 1 

1 0 1 

1 1 1 

 
Click Math → Math1 → Operator to select "A||B": 

⚫ Click Operation continuously to enable or disable the "OR" operation function. 

⚫ Click SourceA and SourceB to select the channel for Source A and Source B. 
The available channels for Source A and Source B are CH1-CH4. 

Note: Only the channels that have been enabled currently can be selected. 

 

➢ If Source A (or Source B) selects CH1, click More → Thre.CH1 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH2, click More → Thre.CH2 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH3, click More → Thre.CH3 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH4, click More → Thre.CH4 to set the 
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threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

⚫ Click Offset to adjust the vertical offset of the operation results.  

⚫ Click Size to select the waveform size. The available sizes include "Small", 
"Medium", and "Large".  

⚫ The AutoSetting menu under More is grayed out and disabled. 

⚫ Click More → Sensitivity to set the sensitivity of the digital signal converted 
from the analog signal on the source. For setting methods, refer to descriptions 
in "Parameter Setting Method". 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

 

 

"XOR" Operation 
 
Performs logic "XOR" operation on the waveform voltage values of the specified 
sources point by point and displays the results. In operation, when the voltage value 
of the source channel is greater than the threshold of the corresponding channel, it is 
regarded as logic "1"; otherwise it is logic "0". The results of logic XOR operation of 
two binary bits are as shown in Table 6-4. 
 
Table 6-4 Logic "XOR" Operation 

A B A^B 

0 0 0 

0 1 1 

1 0 1 

1 1 0 

 
Click Math → Math1 → Operator to select "A^B": 

⚫ Click Operation continuously to enable or disable the "XOR" operation function. 

⚫ Click SourceA and SourceB to select the channel for SourceA and Source B. 
The available channels for Source A and Source B are CH1-CH4. 

Note: Only the channels that have been enabled currently can be selected. 

 

➢ If Source A (or Source B) selects CH1, click More → Thre.CH1 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH2, click More → Thre.CH2 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH3, click More → Thre.CH3 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 
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➢ If Source A (or Source B) selects CH4, click More → Thre.CH4 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

⚫ Click Offset to adjust the vertical offset of the operation results.  

⚫ Click Size to select the waveform size. The available sizes include "Small", 
"Medium", and "Large".  

⚫ The AutoSetting menu under More is grayed out and disabled. 

⚫ Click More → Sensitivity to set the sensitivity of the digital signal converted 
from the analog signal on the source. For setting methods, refer to descriptions 
in "Parameter Setting Method".  

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

 

 

"NOT" Operation 
 
Performs logic "NOT" operation on the waveform voltage values of the specified 
sources point by point and displays the results. In operation, when the voltage value 
of the source channel is greater than the threshold of the corresponding channel, it is 
regarded as logic "1"; otherwise it is logic "0". The results of logic "NOT" operation of 
two binary bits are as shown in Table 6-5. 
 
Table 6-5 Logic "NOT" Operation 

A !A 

0 1 

1 0 

 
Click Math → Math1 → Operator to select "!A": 

⚫ Click Operation continuously to enable or disable the "NOT" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4. 

Note: Only the channels that have been enabled currently can be selected. 

 

➢ If Source A (or Source B) selects CH1, click More → Thre.CH1 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH2, click More → Thre.CH2 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH3, click More → Thre.CH3 to set the 
threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

➢ If Source A (or Source B) selects CH4, click More → Thre.CH4 to set the 
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threshold of Source A (or Source B) in logic operation. For setting methods, 
refer to descriptions in "Parameter Setting Method". 

⚫ Click Offset to adjust the vertical offset of the operation results.  

⚫ Click Size to select the waveform size. The available sizes include "Small", 
"Medium", and "Large".  

⚫ The AutoSetting menu is grayed out and disabled. 

⚫ Click More → Sensitivity to set the sensitivity of the digital signal converted 
from the analog signal on the source. For setting methods, refer to descriptions 
in "Parameter Setting Method".  

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

 

Intg 
 
Calculates the integral of the selected source. For example, you can use integral to 
measure the area under a waveform or the pulse energy. 
 
Click Math → Math1 → Operator to select "Intg": 

⚫ Click Operation continuously to enable or disable the "Intg" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Bias to set the DC offset correction factor for the input signal. 
Note that this parameter can only be set by using the numeric keypad. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 



RIGOL Chapter 6 Operations and Measurements 

6-14 DS8000-R User Guide 

Diff 
 
Calculates the discrete time derivative of the selected source. For example, you can 
use differentiate to measure the instantaneous slope of a waveform. 
 
Click Math → Math1 → Operator to select "Diff": 

⚫ Click Operation continuously to enable or disable the "Diff" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Smooth to set the number of smoothing times in differential 
operation. For setting methods, refer to descriptions in "Parameter Setting 
Method". 

Note: As the high-frequency component of waveform data has a great impact 
on the differential operation, you need to adjust the parameter "Smooth" to a 
larger value, so as to restore the low-frequency component. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 
 

Sqrt 
 

Tip 
Because differentiation is very sensitive to noise, it is helpful to set acquisition 
mode to "Average". 
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Calculates the square root of the selected source point by point and displays the 
results.  
 
Click Math → Math1 → Operator to select "Sqrt": 

⚫ Click Operation continuously to enable or disable the "Sqrt" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Lg (Base 10 Exponential) 
 
Calculates the base 10 exponential of the selected source point by point and displays 
the results. 
Click Math → Math1 → Operator to select "Lg": 

⚫ Click Operation continuously to enable or disable the "Lg" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  
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⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Ln 
 
Calculates the natural logarithm (Ln) of the selected source point by point and 
displays the results.  
 
Click Math → Math1 → Operator to select "Ln": 

⚫ Click Operation continuously to enable or disable the "Ln" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
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the color grade again. 

 
 

Exp 
 
Calculates the exponential of the selected source point by point and displays the 
results. 
 
Click Math → Math1 → Operator to select "Exp": 

⚫ Click Operation continuously to enable or disable the "Exp" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Abs 
 
Calculates the absolute value of the selected source and displays the results. 
 
Click Math → Math1 → Operator to select "Abs": 

⚫ Click Operation continuously to enable or disable the "Abs" operation function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
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of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Low Pass 
 

Only allows the signals whose frequencies are lower than the current upper limit 
frequency to pass. 

 
Click Math → Math1 → Operator to select "LowPass": 

⚫ Click Operation continuously to enable or disable the "LowPass" operation 
function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click ωc to set the upper limit frequency. For setting methods, refer to 
descriptions in "Parameter Setting Method". 

Note: The settable range of the upper limit frequency is related to the Math 
sample rate (displayed at the bottom of the screen when the Math function is 
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enabled). The sample rate of the analog channel or the changes of the memory 
depth can affect the Math sample rate. 

⚫ Click More → AutoSetting to adjust the vertical scale and offset of the 
operation results to an optimal value based on the current configuration, so as 
to better observe. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

High Pass 
Only allows the signals whose frequencies are higher than the current lower limit 
frequency to pass. 

 
Click Math → Math1 → Operator to select "HighPass": 

⚫ Click Operation continuously to enable or disable the "HighPass" operation 
function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click ωc to set the lower limit frequency. For setting methods, refer to 
descriptions in "Parameter Setting Method". 

Note: The settable range of the lower limit frequency is related to the Math 
sample rate (displayed at the bottom of the screen when the Math function is 
enabled). The sample rate of the analog channel or the changes of the memory 
depth can affect the Math sample rate. 

⚫ Click More → AutoSetting to adjust the vertical scale and offset of the 
operation results to an optimal value based on the current configuration, so as 
to better observe. 
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⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Band Pass 
Only allows the signals whose frequencies are higher than the current lower limit 
frequency and lower than the current upper limit frequency to pass. 

 
Click Math → Math1 → Operator to select "BandPass": 

⚫ Click Operation continuously to enable or disable the "BandPass" operation 
function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → ωc1 to set the lower limit frequency. For setting methods, refer to 
descriptions in "Parameter Setting Method". 

⚫ Click More → ωc2 to set the upper limit frequency. For setting methods, refer 
to descriptions in "Parameter Setting Method". 

Note: The settable ranges of the upper and lower limit frequencies are related 
to the Math sample rate (displayed at the bottom of the screen when the Math 
function is enabled). The sample rate of the analog channel or the changes of 
the memory depth can affect the Math sample rate. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 
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⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 

 

Band Stop 
Only allows the signals whose frequencies are lower than the current lower limit 
frequency and higher than the current upper limit frequency to pass. 

 
Click Math → Math1 → Operator to select "BandStop": 

⚫ Click Operation continuously to enable or disable the "BandStop" operation 
function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → ωc1 to set the lower limit frequency. For setting methods, refer to 
descriptions in "Parameter Setting Method". 

⚫ Click More → ωc2 to set the upper limit frequency. For setting methods, refer 
to descriptions in "Parameter Setting Method". 

Note: The settable ranges of the upper and lower limit frequencies are related 
to the Math sample rate (displayed at the bottom of the screen when the Math 
function is enabled). The sample rate of the analog channel or the changes of 
the memory depth can affect the Math sample rate. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
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the color grade again. 

 

 

AX+B 
 
Applies a linear function to the selected source, and displays the results. 
 
Click Math → Math1 → Operator to select "AX+B": 

⚫ Click Operation continuously to enable or disable the "AX+B" operation 
function. 

⚫ Click SourceA to select the channel for Source A. The available channels for 
Source A are CH1-CH4 and Ref1-Ref10. 

Note: The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source 
of Math3 can be CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 
can be CH1-CH4, Ref1-Ref10, Math1, Math2, or Math3; only the channels that 
have been enabled currently can be selected. 

⚫ Click Offset to set the vertical offset of the operation results. For setting 
methods, refer to the descriptions in "Parameter Setting Method".  

⚫ Click Scale to set the vertical scale of the operation results. For setting methods, 
refer to the descriptions in "Parameter Setting Method".  

⚫ Click AutoSetting to adjust the vertical scale and offset of the operation results 
to an optimal value based on the current configuration, so as to better observe. 

⚫ Click More → A to set the value of A. Note that this parameter can only be set 
by using the numeric keypad. 

⚫ Click More → B to set the value of B. Note that this parameter can only be set 
by using the numeric keypad. 

⚫ Click More → Invert to enable or disable the inverted display function of the 
waveform. 

⚫ Click More → Label to set the label for math operation results. For details, refer 
to descriptions in "Math Operation Label". 

⚫ Click More → Color Grade to enable or disable the color grade display of the 
operation results. When enabled, different colors are displayed on the screen to 
indicate the times of data acquisition or acquisition probability. 

⚫ Click More → Reset ColorGrade to clear the color grade display and display 
the color grade again. 

 
 

Math Operation Label 
 
Click Label to enter the label setting menu. 
⚫ Click Display continuously to enable or disable the label display of the 

waveform. If it is enabled, the label will be displayed at the left side of the 
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waveform. 
⚫ Click Library to select the preset waveform label, including ADD, SUB, MUL, DIV, 

FFT, AND, OR, XOR, NOT, Intg, Diff, Sqrt, Lg, Ln, Exp, Abs, LPas, HPas, BPas, 
BStop, and AX+B. 

⚫ Click Label, and the label editing interface is automatically displayed. You can 
input the label manually. For details, refer to descriptions in "Channel Label". 

 
 



RIGOL Chapter 6 Operations and Measurements 

6-24 DS8000-R User Guide 

Auto Measurement 
 
DS8000-R provides auto measurements for 41 waveform parameters, as well as the 
statistics and analysis of the measurement results.  
 
 

Quick Measurement after AUTO 
 
When the oscilloscope is correctly connected and has detected a valid input signal, 
click Auto in the Web Control mode to enable the waveform auto setting function 
and open the auto setting function menu. 
 

⚫ : Click this key, and then the complete single period of the signal is 
displayed automatically on the screen. Meanwhile, the system will make 
measurements for the "period" and the "frequency" of the currently displayed 
waveforms in a complete single period. The measurement results are displayed 
at the bottom of the screen. 

⚫ : Click this key, and then multiple periods of the signal are displayed 
automatically on the screen. Meanwhile, the system will make measurements 
for the "period" and the "frequency" of the currently displayed waveforms in 
multiple periods. The measurement results are displayed at the bottom of the 
screen. 

⚫ : Click this key, and then one rising edge of the signal is displayed 
automatically on the screen. Meanwhile, the system will make measurements 
for the "rise time" of the currently displayed rising edge. The measurement 
results are displayed at the bottom of the screen. By default, it is intended for 
the fast edge signal. 

⚫ : Click this key, and then one falling edge of the signal is displayed 
automatically on the screen. Meanwhile, the system will make measurements 
for the "fall time" of the currently displayed falling edge. The measurement 
results are displayed at the bottom of the screen. By default, it is intended for 
the fast edge signal. 

⚫ : Click this key, and the system returns to the last set menu. 
⚫ Click Option to enter the auto setting function menu. 

➢ Click Lock to lock the AUTO function. To unlock the AUTO function, use the 
following two methods: 
Method 1: Send the remote command :SYSTem:AUToscale ON to unlock the 
AUTO function. 
Method 2: Click Lock again, then a password input dialog box is displayed. 
Input the password. By default, there is no password, and clicking OK 
directly can unlock the function. 
 
 
 



Chapter 6 Operations and Measurements  RIGOL 

DS8000-R User Guide 6-25 

 
 
 
 
 
 
 

➢ Click Peak to Peak to enable or disable the peak-peak priority setting. This 
function is intended for the shifted signal. If there is a large deviation, you 
can view the signal waveform in priority when you enable the function. 

➢ Click CH to select "All" or "Open". 
If you select "All", click Auto and the system will test the 4 analog channels 
(CH1-CH4) in sequence. If no signal is found on the channel, then the 
channel is disabled; if a signal is found on the channel, adjust the channel 
to an optimal scale to display the signal. 
If you select "Open", click Auto and the system will only test the enabled 
channels. 

➢ Click Overlay to enable or disable the waveform overlay display function. If 
enabled, waveforms of different channels will be displayed in the same 
position of the screen; if disabled, waveforms of different channels will be 
displayed on the screen from top to bottom in sequence. 

➢ Click Coupling to enable or disable the coupling hold function. If enabled, 
after you click Auto, the settings for the channel coupling remain 
unchanged; if disabled, then the channel coupling is, by default, set to 
"DC". 

➢ Click Password, and then the password reset dialog box is displayed, as 
shown in the figure below. You can reset the password. 
 

   
 

⚫ : Click this key to cancel the auto setting and recovers to the parameter 
settings prior to clicking the Auto key. 

 

Note: The waveform auto setting function requires that the frequency of the signal 
should be greater than or equal to 35 Hz, the amplitude greater than or equal to 5 
mV. If not meeting the conditions, the waveform auto setting function may be invalid. 

Tip 
If you lock the Auto function and then exit the auto setting function 
menu, you can click on the function navigation icon to open the function 
navigation, and click Utility → More → Auto Config to enter the auto 
setting function menu again to unlock the Auto function.  
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Measurement Parameter 
 

Click on the function navigation icon  to open the function navigation. Then click 
on the Measure icon to enter the measurement setting menu. You can set the 
measurement source, enable or disable the all measurement function, the statistical 
analysis function, and etc. You can also quickly make measurements for 41 waveform 
parameters. The measurement results will be displayed on the screen. The 
measurement results on the screen are always marked in the same color as the 
current measurement channel. You can also click the auto measurement label 
"Measure" at the top of the screen to enter the measurement setting menu. 
 
Note: If there is no signal input for the current source or the measurement result is 
not within the valid range (too large or too small), then the measurement results are 
invalid, and "*****" is displayed on the screen. Please re-input the signal or set the 
signal. 
 

Time Parameters 
 

 

 

 

 

 

 

 

 

 

 
 

Figure 6-1 Time Parameters 
 

1． Period: defined as the time between the middle threshold points of two 
consecutive, like-polarity edges. 

2． Frequency: defined as the reciprocal of period. 
3． Rise Time: indicates the time for the signal amplitude to rise from the threshold 

lower limit to the threshold upper limit. 
4． Fall Time: indicates the time for the signal amplitude to rise from the threshold 

upper limit to the threshold lower limit. 
5． +Width: indicates the time between the threshold middle value of a rising edge 

Fall Time 

Threshold 
Upper Limit 

Threshold 
Middle Value 

Threshold 
Lower Limit 

+Width -Width 

Period 

Rise Time 
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to the threshold middle value of the next falling edge. 
6． -Width: indicates the time between the threshold middle value of a falling edge 

to the threshold middle value of the next rising edge. 
7． +Duty: indicates the ratio of the positive pulse width to the period. 

8． -Duty:indicates the ratio of the negative pulse width to the period. 
9． Tvmax: indicates the time that corresponds to the maximum value of the 

waveform (Vmax). 
10. Tvmin: indicates the time that corresponds to the minimum value of the 

waveform (Vmin).  
 
Note: The default values for threshold upper limit, threshold middle value, and 
threshold low limit are 90%, 50%, and 10%, respectively. You can click Measure in 
the function navigation menu, then click Setting to enter the sub-menu to set the 
parameters. 

 

 

Count Values 

 
1． Positive Pulse Count: The number of positive pulses that rise from under the 

threshold lower limit to above the threshold upper limit. 
 
 

 
2． Negative Pulse Count: The number of negative pulses that fall from above 

the threshold upper limit to below the threshold lower limit. 
 

 

3． Rising Edge Count: The number of rising edges that rise from under the 
threshold lower limit to above the threshold upper limit. 
 
 
 
 
 

Positive Pulse Count = n 
1           2           n 

Negative Pulse Count = n 

1           2           n 

Threshold Upper Limit 

Threshold Lower Limit 

Threshold Upper Limit 

Threshold Lower Limit 
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4． Falling Edge Count: The number of falling edges that fall from above the 

threshold upper limit to below the threshold lower limit. 
 

 

 
Note: 

⚫ The above measurement items are only available for the analog channels. 
⚫ The default values for threshold upper limit and threshold low limit are 90% and 

10%, respectively. You can click Measure in the function navigation menu, then 
click Setting to enter the sub-menu to set the parameters. 
 

 

Delay and Phase 
 

Source A

Source B

Period

Delay

 
 

 
1． Delay A →B : indicates the time difference between the threshold middle 

values of the rising edge of Source A and that of Source B. Negative delay 
indicates that the rising edge of Source A occurred after that of Source B. 

2． Delay A →B : indicates the time difference between the threshold middle 

values of the falling edge of Source A and that of Source B. Negative delay 
indicates that the falling edge of Source A occurred after that of Source B. 

Rising Edge Count = n 
1           2           n 

Falling Edge Count = n 

1           2           n 

Threshold Upper Limit 

Threshold Lower Limit 

Threshold Upper Limit 

Threshold Lower Limit 
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3． Delay A →B : indicates the time difference between the threshold middle 

values of the rising edge of Source A and the falling edge of Source B. Negative 
delay indicates that the rising edge of Source A occurred after the falling edge of 
Source B. 

4． Delay A →B : indicates the time difference between the threshold middle 

values of the falling edge of Source A and the rising edge of Source B. Negative 
delay indicates that the falling edge of Source A occurred after the rising edge of 
Source B. 

5． Phase A →B : indicates the phase deviation between the threshold middle 

values of the rising edge of Source A and that of Source B. It is expressed in 
degree. The formula is as follows: 

°360×=
sourceA

RR
RR Period

BDelayA
BPhaseA  

Wherein, RRBPhaseA  represents Phase A →B , RRBDelayA represents 

Delay A →B , and sourceAPeriod  represents period of Source A. 

6． Phase A →B : indicates the phase deviation between the threshold middle 

values of the falling edge of Source A and that of Source B. It is expressed in 
degree. The formula is as follows: 

°360×=
sourceA

FF
FF Period

BDelayA
BPhaseA  

  

Wherein, FF BPhaseA  represents Phase A →B , FF BDelayA  represents 

Delay A →B , and sourceAPeriod  represents period of Source A. 

 
7． Phase A →B : indicates the phase deviation between the threshold middle 

values of the rising edge of Source A and falling edge of Source B. It is 
expressed in degree. The formula is as follows: 

°360×=
sourceA

FR
FR Period

BDelayA
BPhaseA  

Wherein, FRBPhaseA  represents Phase A →B , FRBDelayA represents 

Delay A →B , and sourceAPeriod  represents period of Source A. 

8． Phase A →B : indicates the phase deviation between the threshold middle 

values of the falling edge of Source A and the rising edge of Source B. It is 
expressed in degree. The formula is as follows: 

°360×=
sourceA

RF
RF Period

BDelayA
BPhaseA  

Wherein, RF BPhaseA  represents Phase A →B , RF BDelayA  represents 

Delay A →B , and sourceAPeriod  represents period of Source A. 
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Note: 
⚫ Source A and Source B can be any channel selected from CH1-CH4 and 

Math1-Math4. You can click Measure → Add to enter the sub-menu to set the 
parameters. 

⚫ The default threshold middle value is 50%. You can click Measure in the 
function navigation menu, then click Setting to enter the sub-menu to set the 
parameters. 
 
 

Voltage Parameters 
 

 

 

 

 

 

            

 
 
 
 

 
Figure 6-2 Voltage Parameters 

 
1． Vmax: indicates the voltage value from the highest point of the waveform to 

the GND. 
2． Vmin: indicates the voltage value from the lowest point of the waveform to the 

GND. 
3． Vpp: the voltage value from the highest point to the lowest point of the 

waveform. 
4． Vtop: indicates the voltage value from the flat top of the waveform to the GND. 
5． Vbase: indicates the voltage value from the flat base of the waveform to the 

GND. 
6． Vamp: indicates the voltage value from the top of the waveform to the base of 

the waveform. 
7． Vupper: indicates the actual voltage value that corresponds to the threshold 

maximum value. 
8． Vmid: indicates the actual voltage value that corresponds to the threshold 

middle value. 
9． Vlower: indicates the actual voltage value that corresponds to the threshold 

minimum value. 

Preshoot 

Overshoot 

Vamp 

Vbase 

Vmax 

Vmin 

Vpp 

Vtop 

Vupper 

Vmid 

Vlower 
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10.  Vavg: indicates the arithmetic average value on the whole waveform or in the 
gating area. The formula is shown as follows: 

 
n

x
Average

n

i i∑
1=

=   

Wherein, 
ix  is the measurement result of the i th point, and n  is the number 

of points being measured. 
 
 

11. VRMS: indicates the root mean square value on the whole waveform or in the 
gating area. The formula is as follows: 

n

x
RMS

n

i i∑
1

2

==   

Wherein, 
ix  is the measurement result of the i th point, and n  is the number 

of points being measured. 
12. Per.VRMS: indicates the root mean square value within a period. The formula is 

as shown above. 
13. Overshoot: indicates the ratio of the difference between the maximum value 

and the top value of the waveform to the amplitude value. 
14. Preshoot: indicates the ratio of the difference between the minimum value and 

the base value of the waveform to the amplitude value. 
15. Std. Dev: indicates the root-mean-square value of the waveforms, with the DC 

component removed. The formula is shown as follows: 

 
n

Averagex
DevS

n

i i∑
1

2)(
.td =

−
=   

Wherein, ix is the amplitude of the i th point, Average is the waveform average 

value, and n is the number of the points being measured. 

 
 

Other Parameters 
 

1． Positive Slew Rate: On the rising edge, first calculate the difference between 
the high value and the low value, then use the difference to divide the 
corresponding time value to obtain the positive slew rate. 

2． Negative Slew Rate: On the falling edge, first calculate the difference 
between the low value and the high value, then use the difference to divide the 
corresponding time value to obtain the negative slew rate. 

3． Area: indicates the area of the whole waveform within the screen. The unit is 
V*s. The area of the waveform above the zero reference (namely the vertical 
offset) is positive, and the area of the waveform below the zero reference is 
negative. The area measured is the algebraic sum of the area of the whole 
waveform within the screen. 
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4． Period Area: indicates the area of the first period of waveform on the screen. 
The unit is V*s. The area of the waveform above the zero reference (namely the 
vertical offset) is positive, and the area of the waveform below the zero 
reference is negative. The area measured is the algebraic sum of the whole 
period area. 
 
 

Measurement Settings 
 

1． Measurement Category 
Click Measure → Add → Category to select "Horizontal", "Vertical", or "Other". 
Meanwhile, the specific measurement parameters are displayed on the screen, 
as shown in the figure below. In the measurement category area, you can click 
to select "Horizontal", "Vertical", or "Other".  
⚫ "Horizontal" measurement parameters: Period, Freq, RiseTime, FallTime, 

+Width, -Width, +Duty, -Duty, +Pulses, -Pulses, +Edges, -Edges, Tvmax, 
Tvmin, +SlewRate, and –SlewRate. 

⚫ "Vertical" measurement parameters: Vmax, Vmin, Vpp, Vtop, Vbase, Vamp, 
Vupper, Vmid, Vlower, Vavg, VRMS, Per.VRMS, Overshoot, Preshoot, Area, 
Per.Area, and Std.Dev. 

⚫ "Other" measurement parameters: Delay(A →B ), Delay(A →B ), 

Delay(A →B ), Delay(A →B ), Phase(A →B ), Phase(A →B ), 

Phase(A →B ), and Phase(A →B ). 

 
 
 
 

 
 
In the measurement parameter area, click to select a measurement item. Then 
the measurement results of the item are displayed at the bottom of the screen 
(measurement results of up to 10 items can be displayed at most). When you 
add a new measurement item, its measurement result will be displayed as the 
first, with the original items moving right in sequence. If the number of 
measurement items added exceeds 10, then when you add one item, the 
rightmost item at the bottom of the screen will be disabled.  
 

Measurement Category Area  Measurement Parameter Area 
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2． Source Selection 

For different measurement categories, the selection methods for measurement 
sources are different. 
⚫ Horizontal and vertical parameter measurement 

Click Measure → Add → Source A to select the desired channel for 
measurement. The available channels include CH1-CH4 and Math1-Math4. 
 

⚫ Other (Delay and Phase) parameter measurement 
Click Measure → Add → Source A (Source B) to set the two source 
channels for the current measurement category. The available channels 
include CH1-CH4 and Math1-Math4. 

 
3． Indicator 

Click Indicator continuously to enable or disable the indicator. You can also 
Click Measure → Add → Indicator to enable or disable the indicator. For 
details, refer to descriptions in "Measure Mode". 

 
4． Measurement Settings 

Click Measure → Setting to enter the sub-menu of measurement. 
⚫ Click Mode to select the measurement mode to "Normal" or 

"Precision". 
➢ Normal: executes measurement of up to 1 Mpts. 
➢ Precision: executes measurement of up to 200 Mpts, improving the 

resolution of measurement results. Note, in this mode, the refresh rate 
of the waveforms may be reduced. 
Note: When the memory depth is less than or equal to 1K points or the 
"High Res" mode is opened, the "Precision" measurement mode will 
automatically switch to the "Normal" measurement mode. 

 
⚫ Click Type to select "Threshold", "Range", or "Amp Method". 

➢ Select "Threshold", and then make the following settings: 
--Click Source to select the desired channel for measurement 
(CH1-CH4 or Math1-Math4). 

Tip 
In the measurement category area, click to select "Analyze". The following 
figure is displayed. Select "Counter", "DVM", "Histogram", "Power" (required 
to install the option DS8000-R-PWR), "Eye", or "Jitter" (required to install the 
option DS8000-R-JITTER) to enter the corresponding function setting menu. 
For descriptionsn about these functions, refer to relevant chapters. 
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--Click Upper to select "Upper(%)" or "Upper(Abs)" first, and then 
click the key to set the upper limit of the measurement. For details, 
refer to descriptions in "Parameter Setting Method". When the 
upper limit is set to be smaller than or equal to the current middle 
value, a prompt message "Set at lower limit" is displayed. Then, 
the oscilloscope will automatically adjust the upper limit and make 
it greater than the middle value. By default, it is 90%. 
--Click Mid to select "Mid(%)" or "Mid(Abs)" first, and then click 
the key to set the middle value of the measurement. For details, 
refer to descriptions in "Parameter Setting Method". The 
middle value is limited by the settings of the upper limit and lower 
limit. By default, it is 50%. 
--Click Lower to select "Lower(%)" or "Lower(Abs)" first, and 
then click the key to set the lower limit of the measurement. For 
details, refer to descriptions in "Parameter Setting Method". 
When the lower limit is set to be greater than or equal to the 
current middle value, a prompt message "Set at upper limit" is 
displayed. Then, the oscilloscope will automatically adjust the 
lower limit and make it smaller than the middle value. By default, it 
is 10%. 
--Click Default, and then the upper value, middle value, and lower         
value will be restored to the defaults. 

➢ Select "Range", and then click Region to select "Main", "Zoom", 
or "Cursor". 
--Main: indicates that the measurement range is within the main 
time base region. 
--Zoom: indicates that the measurement range is within the 
zoomed time base region. Note: Only when you enable the 
delayed sweep function first, can "Zoom" be enabled. 
--Cursor: when you select it, two cursors will be displayed on the 
screen. At this time, click CursorA and CursorB respectively to 
adjust the positions of the two cursors to determine the 
measurement range. Also, you can click CursorAB to adjust the 
positions of the two cursors simultaneously. 

➢ Select "Amp Method", and then click Amp Method to select 
"Auto" or "Manual". This method affects the measurement method 
for the top and base values. If you select "Manual", you need to 
set the following parameters: 
--Click Top to select "Histogram" or "Max-Min". 
--Click Base to select "Histogram" or "Max-Min". 
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Remove the Measurement Result  
This oscilloscope allows you to remove the measurement results of the parameters. 
Click Measure → Remove to enter the "Remove" sub-menu. 

⚫ Click Remove to remove the last added measurement item. Note that clicking 
this key one time can only remove one measurement item. When you remove a 
measurement item, the measurement result of the last added item at the 
bottom of the screen will be removed. 

⚫ Click Remove All to remove all the displayed measurement items. 

⚫ Click Indicator to enable or disable the indicator.  

 

Besides, you can also click Measure → Add → Remove to enter the "Remove" 
sub-menu. 

 

 

 

Statistical Function 
Performs statistics and displays the measurement results (Cur, Avg, Max, Min, Dev, 
and Cnt) of at most 10 items, as shown in the figure below. 

 

 

Tip 
⚫ Modifying the threshold will affect the measurement results of 

the time, delay and phase parameters. 
⚫ If you select "Manual" under Amp Method, the measurement 

results of other parameters may be affected.  
⚫ "Histogram" and "Max-Min" are the internal measurement 

algorithm for the oscilloscope. The "Histogram" method here is 
different from the Histogram function of the oscilloscope. 

Tip 
If the "Remove" sub-menu is not displayed in the current menu, when you select 
a certain measurement item, the system will automatically enter the "Remove" 
sub-menu. 
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Click Measure → Statistic to enter the sub-menu of "Statistic". 

⚫ Click Statistic to enable or disable the statistical function. 

⚫ Click Reset Stat. to clear the history statistics data and makes statistics again. 

⚫ Click Count, then use the pop-up numeric keypad or scroll with the mouse to 
set the count value. Its range is from 2 to 100000. By default, it is 1000. 

 

 

All Measurement 
All measurement could measure the time parameter, count value, voltage 
parameters, and other parameters of the current measurement source and display 
the results on the screen. Click Measure → All Measure to select "OFF" (disabling 
the all measurement function) or select the desired channel for measurement 
(CH1-CH4). If you select "CH1", data of all measurement parameters of CH1 are 
displayed on the screen. 

Note: The removal operation will not clear the measurement results of the 
all-measurement function. 

 

 

Cursor Measurement 
 
Cursor measurement can measure the X-axis values (e.g. Time) and Y-axis values 
(e.g. Voltage) of the selected waveform. Before making cursor measurement, 
connect the signal to the oscilloscope to acquire stable display. All the parameters 
supported by the "Auto Measurement" function can be measured with cursor 
measurement. The cursor measurement function provides the following two cursors. 
 
 
 
 

  
 
 
⚫ X Cursor 

X cursor is a vertical solid/dotted line that is used to make horizontal 
adjustments. It can be used to measure time (s), frequency (Hz), phase (°), and 

Y Cursor (Cursor B) 

Y Cursor (Cursor A) 

X Cursor (Cursor A) X Cursor (Cursor B) 
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ratio (%). 

➢ Cursor A is a vertical solid line (  is displayed at the bottom of the screen), 

and Cursor B is a vertical dotted line (  is displayed at the bottom of the 
screen). 

➢ In the X-Y cursor mode, X cursor is used to measure the waveform 
amplitude of CH1. 
 

⚫ Y Cursor 
Y cursor is a horizontal solid/dotted line that is used to make vertical adjustment. 
It can be used to measure amplitude (the unit is the same as that of the source 
channel amplitude) and ratio (%). 

➢ Cursor A is a horizontal solid line (  is displayed at the right section of the 

screen), and Cursor B is a horizontal dotted line (  is displayed at the 
right section of the screen). 

➢ In the X-Y cursor mode, Y cursor is used to measure the waveform 
amplitude of CH2. 

 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then click on the cursor icon  to open the cursor 
measurement menu. 
 
In the cursor measurement menu, click Mode to select the desired cursor mode. The 
available modes are "Manual", "Track", "XY", and "Measure". When you select "OFF", 
the cursor measurement function is disabled.  
Note: When the Time Base Mode is set to "XY", the XY cursor measurement mode is 
valid. 
 
 

Manual Mode 
 
In this mode, you can adjust the cursor manually to measure the value of the 
waveforms of the specified source at the current cursor. The measurement results 
are displayed at the upper-left corner of the screen. When you change the cursor 
position, the measurement results will be changed accordingly. 
 
Click Mode to select "Manual" to enable the manual cursor measurement function. If 
the settings for the parameter such as "Select", "Source", "Hori. Unit", and "Vert. 
Unit" are different, the measurement results will be different for cursor measurement. 
The measurement results are displayed at the upper-left corner of the screen, as 
shown in the figure below. 
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⚫ AX: indicates the X value at Cursor A.  
⚫ AY: indicates the Y value at Cursor A. 
⚫ BX: indicates the X value at Cursor B. 
⚫ BY: indicates the Y value at Cursor B. 
⚫ △X: indicates the horizontal spacing between Cursor A and Cursor B. 
⚫ △Y: indicates the vertical spacing between Cursor A and Cursor B. 

⚫ 1/△X: indicates the reciprocal of the horizontal spacing between Cursor A and 

Cursor B. 
 
1. Select Cursor Type 

Click Select continuously to select the cursor type. 
⚫ X: It is a pair of vertical solid (Cursor A)/dotted (Cursor B) lines, used for 

measuring time parameters. The measurement results include AX, BX, △X, 

and 1/△X (displayed only when "s" or "Hz" is selected under Hori. Unit). 
⚫ Y: It is a pair of horizontal solid (Cursor A)/dotted (Cursor B) lines, used for 

measuring voltage parameters. The measurement results include AY, BY, 
and △Y. 

 
2. Select Measurement Source 

Click Source to select the desired source (CH1-CH4). The available source 
channels are None, CH1-CH4, and Math1-Math4. 
Note: Only channels currently enabled can be selected. 
 

3. Adjust Cursor Position 
1) When "X" is selected under Select, you can adjust the position of X cursor. 

⚫ Click AX to adjust the horizontal position of Cursor A (X cursor). Its 
adjustable range is limited within the screen. 

⚫ Click BX to adjust the horizontal position of Cursor B (X cursor). Its 
adjustable range is limited within the screen. 

⚫ Click AX BX and then scroll with the mouse to adjust the horizontal 
position of Cursor A and Cursor B (X cursors) simultaneously. Its 
adjustable range is limited within the screen. The horizontal spacing 
between Cursor A and Cursor B (X cursors) remains unchanged. 

2) When "Y" is selected under Select, you can adjust the position of Y cursor. 
⚫ Click AY to adjust the vertical position of Cursor A (Y cursor). 
⚫ Click BY to adjust the vertical position of Cursor B (Y cursor). 
⚫ Click AY BY and then scroll with the mouse to adjust the vertical 

position of Cursor A and Cursor B (Y cursors) simultaneously. The 
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vertical spacing between Cursor A and Cursor B (Y cursors) remains 
unchanged. 

 
4. Select Screen Region 

⚫ When the delayed sweep function is disabled, click More, and "Main" is 
automatically selected under Region and cannot be modified. 

⚫ When the delayed sweep function is enabled, the screen is divided into two 
regions: main time base and zoomed time base. Click Region continuously 
to select "Main" or "Zoom". 
➢ When "Main" is selected, the cursor is displayed in the main time base 

region, and you can measure the parameters in the main time base 
region. 

➢ When "Zoom" is selected, the cursor is displayed in the zoomed time 
base region, and you can measure the parameters in the zoomed time 
base region. 
 

5. Set the Horizontal/Vertical Measurement Unit 

⚫ When "X" is selected under Select, you can set the horizontal measurement 
unit. When the source can be Math1-Math4, this menu is grayed out and 
disabled. 

Click More → Hori. Unit to select the horizontal measurement unit. The 
available units include "s", "Hz", "Degree(°)", and "Percent(%)". 
➢ s: measures the time value at X Cursor (taking the trigger position as 

reference). The measurement results include AX, BX, △X, and 1/△X. 

Wherein, AX, BX, and △X all indicate time, and 1/△X indicates 

frequency. 
➢ Hz: measures the frequency value at X Cursor (taking the trigger 

position as reference). The measurement results include AX, BX, △X, 

and 1/△X. Wherein, AX, BX, and △X all indicate frequency, and 1/△X 
indicates time. 

➢ Degree(°): measures the phase value at X Cursor. The measurement 
results include AX, BX, and △X, and they are all expressed in degree.  
This oscilloscope allows you to set the reference position for the phase 
according to your needs. After adjusting X Cursor to a desired position, 
click Set Reference to take the current cursor position as the 
reference. The current positions of Cursor A and Cursor B are 
respectively defined as "0°" and "360°". Meanwhile, two vertical 
cursors (in blue) that cannot be moved are displayed on the screen as 
the phase reference position (the phase position at "0°" and "360°" are 
respectively marked by a solid line and a dotted line). Before you set 
manually, the oscilloscope adopts the default phase reference position. 

➢ Percent(%): measures ratio at X Cursor. The measurement results 
include AX, BX, and △X, and they are all expressed in percentage. This 
oscilloscope allows you to set the reference position for the ratio 
according to your needs. After adjusting X Cursor to a desired position, 
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click Set Reference to take the current cursor position as the 
reference. The current positions of Cursor A and Cursor B are 
respectively defined as "0%" and "100%". Meanwhile, two cursors (in 
blue) that cannot be moved are displayed on the screen as the ratio 
reference position (the ratio position at "0%" and "100%" are 
respectively marked by a solid line and a dotted line). Before you set 
manually, the oscilloscope adopts the default ratio reference position. 
 

⚫ When "Y" is selected under Select, you can set the vertical measurement 
unit. When the source can be Math1-Math4, this menu is grayed out and 
disabled. 
Click More → Vert. Unit to select the vertical measurement unit. The 
available units include "Source" and "Percent(%)". 
➢ Source: measures the amplitude at Y Cursor (taking the channel 

ground point as the reference). The measurement results include AY, 
BY, and △Y (its unit is consistent with that of the current source). 

➢ Percent(%): measures ratio at Y Cursor. The measurement results 
include AY, BY, and △Y, and they are all expressed in percentage.  

This oscilloscope allows you to set the reference position for the ratio 
according to your needs. After adjusting Y Cursor to a desired position, 
click Set Reference to take the current cursor position as the 
reference. The current positions of Cursor A and Cursor B are 
respectively defined as "0%" and "100%". Meanwhile, two cursors (in 
blue) that cannot be moved are displayed on the screen as the ratio 
reference position (the ratio position at "0%" and "100%" are 
respectively marked by a solid line and a dotted line). Before you set 
manually, the oscilloscope adopts the default ratio reference position. 
 

6. Measurement Example 
Measure the period of a sine wave by using the manual cursor measurement 
and auto measurement respectively. The measurement results are both 1 ms, as 
shown in Figure 6-3. 
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Figure 6-3 Manual Cursor Measurement Example 

 
 

Track Mode 
 
In this mode, you can adjust the two pairs of cursors (Cursor A and Cursor B) to 
measure the X and Y values on two different sources respectively. The points being 
measured on Cursor A and Cursor B are marked by  and  respectively. When 
the cursors are moved horizontally/vertically, the markers will position on the 
waveform automatically. When the waveform is expanded or compressed 
horizontally/vertically, the markers will track the points being marked at the last 
adjustment of the cursors.  
Note: When the delayed sweep function is enabled, the track cursor is within the 
expanded area. 
 
Click Mode to select "Track" to enable the cursor track function, and the 
measurement results will be displayed at the upper-left corner of the screen, as 
shown in the following figure. When you change the measurement parameter for the 
track mode, the measurement results will be changed accordingly. 

 
 
⚫ AX: indicates the X value at Cursor A.  
⚫ AY: indicates the Y value at Cursor A. 
⚫ BX: indicates the X value at Cursor B. 

Auto 
Measurement 

Cursor 
Measurement 

 
 
 
 
 
 
 
 



RIGOL Chapter 6 Operations and Measurements 

6-42 DS8000-R User Guide 

⚫ BY: indicates the Y value at Cursor B. 
⚫ △X: indicates the horizontal spacing between Cursor A and Cursor B. 

⚫ △Y: indicates the vertical spacing between Cursor A and Cursor B. 

⚫ 1/△X: indicates the reciprocal of the horizontal spacing between Cursor A and    

Cursor B. 
 
1. Select Measurement Source 

⚫ Click AX Source to select the desired measurement source. The available 
source channels are None, CH1-CH4, and Math1-Math4. 

⚫ Click BX Source to select the desired source. The available source 
channels are None, CH1-CH4, and Math1-Math4. 
 

Note: Only channels currently enabled can be selected. 
 

2. Select the Track Axis 
Click Track to select "X" or "Y" as the current track axis. The default is "X". 
⚫ X: tracks X Cursor and measures the value at X Cursor.  
⚫ Y: tracks Y Cursor and measures the time of the first point at the left side of 

the screen. 
 

3. Adjust Cursor Position 
1) When "X" is selected under Track, you can adjust the position of X cursor. 

⚫ Click AX and drag/scroll the mouse to adjust the horizontal position of 
Cursor A (X cursor). Its adjustable range is limited within the screen. 

⚫ Click BX and drag/scroll the mouse to adjust the horizontal position of 
Cursor B (X cursor). Its adjustable range is limited within the screen. 

⚫ Click AX BX and drag/scroll the mouse to adjust the horizontal position 
of Cursor A and Cursor B (X cursors) simultaneously. Its adjustable 
range is limited within the screen. The horizontal spacing between 
Cursor A and Cursor B (X cursors) remains unchanged. 

2) When "Y" is selected under Track, you can adjust the position of Y cursor. 
⚫ Click AY and drag/scroll the mouse to adjust the vertical position of 

Cursor A (Y cursor). 
⚫ Click BY and drag/scroll the mouse to adjust the vertical position of 

Cursor B (Y cursor). 
⚫ Click AY BY and drag/scroll the mouse to adjust the vertical position of 

Cursor A and Cursor B (Y cursors) simultaneously. The vertical spacing 
between Cursor A and Cursor B (Y cursors) remains unchanged. 

 
Note: In track mode, the horizontal cursor (or vertical cursor) will track the 
marked point in a timely manner (i.g, the cursor will move up and down with the 
transient change of the waveform). Thus, the X value (or Y value) might change 
even though you do not adjust the cursor. 

 
4. Measurement Example 

Measure the waveforms of CH1 and CH2 with Cursor A and Cursor B, 
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respectively. Then, expand the waveforms horizontally, and you will find that the 
cursor will track the point that has been marked, as shown in the following 
figure. 
 
Track Measurement (before Horizontal Expansion): 

  
 
Track Measurement (after Horizontal Expansion): 

  
 
 

XY Mode 
 
XY mode is only available when the horizontal time base mode is "XY" (refer to 
"Timebase Mode"). In this mode, two pairs of cursors will appear. You can adjust 
the cursor positions to measure the X and Y values at the crossing points of the two 
pairs of cursors. 
 
Click Mode to select "XY" to enable the XY cursor measurement function. The 
measurement results are displayed at the upper-left corner of the screen, as shown 
in the following figure. 
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⚫ AX: indicates the X value at Cursor A.  
⚫ AY: indicates the Y value at Cursor A. 
⚫ BX: indicates the X value at Cursor B. 
⚫ BY: indicates the Y value at Cursor B. 
⚫ △X: indicates the horizontal spacing between Cursor A and Cursor B. 

⚫ △Y: indicates the vertical spacing between Cursor A and Cursor B. 

 

1. Adjust Cursor Position 

⚫ Click AX to adjust the X value at Cursor A. 

⚫ Click BX to adjust the X value at Cursor B. 

⚫ Click AY to adjust the Y value at Cursor A. 

⚫ Click BY to adjust the Y value at Cursor B. 

⚫ Click More → ABX, then drag or scroll with the mouse to adjust the X value 
at Cursor A and the X value at Cursor B simultaneously. 

⚫ Click More → ABY, then drag or scroll with the mouse to adjust the Y value 
at Cursor A and the Y value at Cursor B simultaneously. 

 

During the adjustment, the measurement results will change accordingly. The 
adjustable range is limited within the screen. 

 
2. Display Lissajous Legend 

This oscilloscope provides the Lissajous schematic diagram under different 
frequencies and phase deviation, as shown in Figure 6-4. Click More → 
Lissajous, then the Lissajous schematic diagram is displayed. 

 
Figure 6-4 Lissajous Schematic Diagram 

 
 

Measure Mode 
 
Click Mode to select "Measure". In this mode, the cursor position for measurement is 
displayed. 

Phase deviation 
between two signals 

Frequency ratio 
between two signals 
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Click Indicator continuously to enable or disable the indicator. If it is enabled, one 
or multiple cursors are displayed on the screen. Before enabling the indicator, you 
need to enable at least one parameter for auto measurement. The number of cursors 
will change along with the enabled measurement parameters. 

 
Note: If no measurement parameter is selected or no measurement source is input, 
no cursor is displayed. When you expand or compress the waveforms horizontally, 
the cursor will change accordingly. 
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Chapter 7 Digital Voltmeter (DVM) and 
Frequency Counter 
 
DS8000-R series oscilloscope provides a built-in digital voltmeter (DVM) and 
frequency counter, which enable you to perform an accurate measurement, 
improving user experience in counter and frequency measurement.  
 
Contents in this chapter: 
◼ Digital Voltmeter (DVM) 
◼ Frequency Counter 
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Digital Voltmeter (DVM) 
 
The built-in DVM of this oscilloscope provides 3-digit voltage measurements on any 
analog channel. DVM measurements are asynchronous from the oscilloscope’s 
acquisition system and are always acquiring. 
 

The following methods are available for you to enter the DVM setting menu: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click on the "DVM" icon  to enter the DVM 
setting menu.  

⚫ Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click on the "Measure" icon  to enter the 
"Measure" menu. Click Analyze → DVM to enter the DVM setting menu. 

⚫ Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click on the "Measure" icon  to enter the 
"Measure" menu. Then click Add. In the displayed measurement category area, 
click to select "Analyze", and then select "DVM" to open the DVM setting menu. 

⚫ Click on the "MEASURE" label at the top of the screen, then click the "Analyze" 
tab to select "DVM" to open the DVM setting menu.  

 

 

To Enable or Disable DVM Measurement 
 
In the "DVM" setting menu, click DVM continuously to enable or disable DVM 
measurement. When enabled, the following figure is displayed. The DVM display also 
has a scale that is determined by the channel's vertical scale and vertical offset. The 
scale range is the range of the screen. The scale's yellow triangle pointer shows the 
most recent measurement result. The specific value above the pointer shows the 
real-time voltage value. 
 
 

 
 

 
 
 
 

Note: DVM measurement and the oscilloscope share the same probe, so the unit for 
the DVM measurement is consistent with that of the channel. 

Pointer   Scale   

Source  Mode   Voltage Value           
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To Select the Measurement Source 
 
Click Source in the "DVM" setting menu to select the desired source. The analog 
channel (CH1-CH4) can be selected to be the measurement source. 
Note: Even if the analog channel (CH1-CH4) is not enabled, you can still perform the 
DVM measurement. 
 

 

To Select Measurement Mode 
 
Click Mode in the "DVM" setting menu to select the desired mode. The DVM 
measurement modes include AC RMS, DC, and AC+DC RMS. 
⚫ AC RMS: displays the root-mean-square value of the acquired data, with the DC 

component removed. 
⚫ DC: displays the average value of the acquired data. 
⚫ AC+DC RMS: displays the root-mean-square value of the acquired data. 
 

 

To Set the Limits 
 
Click Limits to enter the sub-menu of Limits. Then set the following parameters. 
⚫ Beeper 

Click Beeper continuously to enable or disable the beeper. 
 

⚫ Limits Condition Setting 
Click When to select the desired limit setting condition. The limits conditions 
include "In Limits" and "Out Limits". 
➢ In Limits: when the voltage value is within the limits, you can enable or 
disable the beeper to sound an alarm. 
➢ Out Limits: when the voltage value is outside of the limits, you can enable 
or disable the beeper to sound an alarm. 
 

⚫ Upper/Lower Limit Setting 
Click Upper, then use the pop-up numeric keypad or scroll with the mouse to 
set the upper limit of the voltage. 
Click Lower, then use the pop-up numeric keypad or scroll with the mouse to 
set the lower limit of the voltage. 
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Frequency Counter 
 
The frequency counter analysis function provides frequency, period, or edge event 
counter measurements on any analog channel.  
 

The following methods are available for you to enter the frequency counter setting 
menu: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click on the "Counter" icon  to enter the 
frequency counter setting menu.  

⚫ Click on the "MEASURE" label at the top of the screen, then click the "Analyze" 
tab to select "Counter" to open the frequency counter setting menu.  

⚫ Click on the function navigation icon , then select Measure, then click Add. 
In the displayed measurement category area, click to select "Analyze", and then 
select "Counter" to open the frequency counter setting menu. 

 

 

To Enable or Disable the Frequency Counter 
 
In the "Counter" setting menu, click Counter continuously to enable or disable the 
frequency counter measurement. When enabled, the following figure is displayed. 
 
 
 
 

 
 
 

To Select the Measurement Source 
 
Click Source to select the desired source. The analog channels (CH1-CH4) and EXT 
can all be selected as the source of the frequency counter. 
 
 

To Select the Measurement Item 
 
The measurement items supported by the frequency counter of this oscilloscope 
include Frequency, Period, and Totalize measurements. Wherein, Totalize indicates 
the count of edge events on the signal. 
 
Click Measure in the "Counter" menu to select the desired measurement item. 

Source  Measurement Item  Value  
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To Set Resolution 
 
For Period and Frequency measurements, you need to set the readout resolution. 
Click Resolution, then use the pop-up numeric keypad or scroll with the mouse to 
set the resolution. The range of resolution is from 3 bits to 6 bits. By default, it is 5 
bits. 
 
Note: The greater the resolution, the longer the gate time. In this way, the 
measurement time will be longer. 
 
 

To Clear Count 
 

When "Totalize" is selected under Measure, the oscilloscope measures the count of 
edge events on the signal. At this time, click Clear Count to clear the measurement 
results. 
 
 

To Enable or Disable the Statistical Function 
 
For Period and Frequency measurements, enable the frequency counter statistical 
function. Click Statistic continuously to enable or disable the statistical function. 
When enabled, the maximum value and minimum value will be displayed in the 
frequency counter data, as shown in the following figure. 
 

 
 

 
 
 

Statistics 
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Chapter 8 Power Analysis (Option)  
 
DS8000-R series oscilloscope provides an optional power analysis function, which 
can help you easily analyze the efficiency and reliability of the switch-mode power 
supplies. With the power analysis function, you can analyze the power quality and 
output ripple noise of the input power. 
 
Contents in this chapter: 
◼ Power Quality 
◼ Ripple 
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Power Quality  
 
By analyzing the power quality, you can test the quality of AC input lines. The specific 
measurement parameters for power quality analysis include V_RMS, I_RMS, real 
power, apparent power, reactive power, power factor, reference frequency, phase 
angle, impedance, voltage crest factor, and current crest factor. 
 
The following methods are available for you to enter the power quality setting menu: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen 

to open the function navigation. Click on the "Power" icon  to enter the 
power analysis setting menu.  

⚫ Click on the "MEASURE" label at the top of the screen, then click the "Analyze" 
tab to select "Power" to open the power analysis setting menu.  

⚫ Click on the function navigation icon , then select Measure, then click Add. 
In the displayed measurement category area, click to select "Analyze", and then 
select "Power" to open the power analysis setting menu. 

 

To Select the Analysis Type 
 
In the power analysis setting menu, click Analysis Type to select "Power Quality". 

 
 

To Set the Power Quality Analysis Source 
 
In the power analysis setting menu, click Source to enter the source setting menu. 
⚫ Click Voltage to select the channel (CH1-CH4) for acquiring voltage.  
⚫ Click Current to select the channel (CH1-CH4) for acquiring current.  
⚫ Click Freq. Ref continuously to select "Voltage" or "Current" as the frequency 

reference. 
 
 

To Set the Reference Level 
 
In the power analysis setting menu, click Ref Levels (level of the frequency 
reference channel) to enter the reference level setting menu. 
⚫ Click Type to set the reference level display type to "Percent(%)" or "Absolute". 
⚫ Click Upper, then use the pop-up numeric keypad or scroll with the mouse to 

set the upper limit value. 
⚫ Click Mid, then use the pop-up numeric keypad or scroll with the mouse to set 

the middle value. The middle value is limited by the settings of the upper limit 
and lower limit. 

⚫ Click Lower, then use the pop-up numeric keypad or scroll with the mouse to 
set the lower limit.  
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⚫ Click Default, and then the upper value, middle value, and lower value will be 
restored to the defaults. 
 
 

To Set Count 
 
Click Count, then use the pop-up numeric keypad to set the number of statistical 
times for power quality analysis. Its range is from 2 to 5000. By default, it is 1000. 

 
 

To Reset 
  
Click Reset Stat. to clear the current data and execute statistics on the 
measurement results again. 
 
 

To Open or Close the Results Display Window 
 
Click Display continuously to enable or disable the display of the results. 
When enabled, the statistical results will be displayed on the screen, as shown in the 

figure below. Click on the icon  at the right-upper corner of the statistical results 
window to close it. 
Note: If you select "ON" under Display, the multiplication operation will be enabled 
in the Math operation. 

 

 
 
 

To View the Connection Diagram 
 
Click Tips, and then the connection diagram of the power quality analysis is 
displayed on the screen. Please connect the cables according to the connection 

method as shown in Figure 8-1. Click Tips again or click on the icon  at the 
right-upper corner of the connection diagram window to close it. 
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Figure 8-1 Connection Diagram of Power Quality Analysis 

 
 

Ripple 
 
Power ripple is an important parameter for evaluating DC power supply, which 
indicates the ripple quantity of the output DC voltage. The ripple analysis can 
measure the current value, average value, minimum value, maximum value, 
standard deviation, and count value of the ripples on the power output terminal. 
Note: The 1X probe is recommended for the ripple measurement. For example, 
PVP2150 or PVP2350. 
 

To Select the Analysis Type 
 
In the power analysis setting menu, click Analysis Type to select "Ripple". 

 
 

To Set the Ripple Analysis Source 
 
In the power analysis setting menu, click Source to select the ripple analysis source 
(CH1-CH4). 

 
 

To Set Count 
 
Click Count, then use the pop-up numeric keypad to set the number of statistical 
times for ripple analysis. Its range is from 2 to 5000. By default, it is 1000. 

 
 

To Reset  
 
Click Reset Stat. to clear the current data and execute statistics on the 
measurement results again. 
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To Open or Close the Results Display Window 
 
Click Display continuously to enable or disable the display of the results. 
When enabled, the statistical results will be displayed on the screen, as shown in the 

figure below. You can also click on the icon  at the right-upper corner of the 
statistical results window to close it. 
 

 
 
 

To View the Connection Diagram 
 
Click Tips, and then the connection diagram of the ripple analysis is displayed on the 
screen. Please connect the cables according to the connection method as shown in 

Figure 8-2. Click Tips again or click on the icon  at the right-upper corner of the 
connection diagram window to close it. 
 

 
Figure 8-2 Connection Diagram of Ripple Analysis
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Chapter 9 Histogram Analysis 
 
DS8000-R series oscilloscope supports the histogram analysis function, enabling you 
to judge the trend of waveforms, and quickly locate the potential problems of the 
signal.  

 

Contents in this chapter: 
◼ To Enable or Disable the Histogram Function 
◼ To Select the Histogram Type 
◼ To Select the Histogram Source 
◼ To Select the Measurement Item 
◼ To Set the Histogram Height 
◼ To Set the Histogram Range 
◼ To Enable or Disable the Statistical Function 
◼ To Reset 
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To Enable or Disable the Histogram Function 
 
The histogram analysis function supported by the DS8000-R series is available to 
provide a statistical view of waveforms or measurement results. It can be classified 
into horizontal histogram, vertical histogram, measurement histogram, and jitter 
histogram (available only when the sub-menu Histogram under Measure in the 
Jitter menu is enabled). With the on-going acquisition and measurement of the 
waveforms, the height of the bar graph will change within the set range of the 
histogram window to indicate the number of times for data statistics. 
 
You can enter the "Histogram" setting menu through the following methods: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Histogram" icon , and then 
the histogram setting menu is displayed at the right section of the screen. 

⚫ Click on the function navigation icon , then select Measure. In the displayed 
menu, select Analyze → Histogram to enter the "Histogram" setting menu. 

⚫ Click on the function navigation icon , and select Measure. Then click Add. 
In the displayed measurement category area, click to select "Analyze", and then 
select "Histogram" to open the "Histogram" setting menu. 

⚫ Click the auto measurement label "MEASURE" at the top of the screen to enter 
the measurement setting menu. In the measurement category area, click to 
select the "Analyze" tab and select "Histogram" to enter the "Histogram" setting 
menu. 

⚫ Refer to descriptions in "Rectangle Drawing" to enter the "Histogram" setting 
menu. 

 
Click Enable continuously to enable or disable the histogram analysis function. 
 

 

 

To Select the Histogram Type 
 
The histogram includes the following types: 
⚫ Horizontal: displays the number of times for statistics making in the forms of 

columns in the histogram bar graph at the bottom of the graticule. 
⚫ Vertical: displays the number of times for statistics making in the forms of rows 

in the histogram bar graph at the left of the graticule. 
⚫ Measure: displays the number of times for statistics of the measurement results 

in the forms of columns in the histogram bar graph at the bottom of the 
graticule. 

Tip 
To record peaks or glitches in the histogram data, please always enable the 
histogram function. 
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⚫ Jitter: displays the number of times for statistics of the jitter measurement 
results in the forms of columns in the histogram bar graph at the bottom of the 
graticule. 
The parameters for the jitter histogram are required to be set in the Jitter menu. 
For detailed operations, refer to "To Set the Jitter Measurement". The jitter 
type is only available when the sub-menu Histogram under Measure in the 
Jitter menu is enabled. 
 

Click Type to select the desired histogram type. 
 
 

To Select the Histogram Source 
 
If "Horizontal" or "Vertical" is selected under Type, you need to set the source 
(CH1-CH4). Click Source to select the desired source. 
 
 

To Select the Measurement Item 
 
⚫ When you select "Measure" as the histogram type, click Measure → Add or 

click the auto measurement label "MEASURE" at the top of the screen to enter 
the measurement setting menu, and then add one or multiple measurement 
items. At this time, the added measurement item(s) can be served as the 
measurement histogram source(s) and displayed in the Item menu. 

⚫ When "Jitter" is selected as the histogram type, please first click on the 
navigation icon to open the function navigation. Then click Jitter → Measure 
→ Item to select the measurement item. At this time, the selected item is 
shown in the Item menu.  

 
 

To Set the Histogram Height 
 
The histogram height indicates the number of grids the histogram bar graph should 
occupy on the screen. Click Height, then use the pop-up numeric keypad to set the 
height. The available range of height is from 1 to 4. By default, it is 2. 
 
 

To Set the Histogram Range 
 
When "Horizontal" or "Vertical" is selected under Type, you need to set the window 
range. Set "Left Limit", "Right Limit", "Top Limit", and "Bottom Limit" respectively to 
adjust the size and position of the histogram window. Click Range to enter the 
sub-menu of histogram range. Then click the corresponding key to scroll with the 
mouse to set their values.  
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Note: The adjustment for the horizontal time base and vertical scale will not affect 
the time base of the histogram range, but only shows variation with the scale.  
 
 

To Enable or Disable the Statistical Function 
 
Click Statistic to enable or disable the statistical function. When the statistical 
function is enabled, the statistical results of the histogram data will be displayed, as 
shown in the following figure. Note that when you select "Measure" under Type, the 
statistical data results also include the parameter XScale. 
 

 
⚫ Sum: indicates the sum of all bins (buckets) in the histogram. 
⚫ Peaks: indicates the maximum number of hits in any single bin. 
⚫ Max: indicates the value that corresponds to the maximum bin that has any hits. 
⚫ Min: indicates the value that corresponds to the minimum bin that has any hits. 
⚫ Pk_Pk: indicates the Delta between the max. value and the min. value. 
⚫ Mean: indicates the average value of the histogram. 
⚫ Median: indicates the median value of the histogram. 
⚫ Mode: indicates the mode value of the histogram. 
⚫ Bin width: indicates the width of each bin (bucket) in the histogram. 
⚫ Sigma: indicates the standard deviation of the histogram. 
 
 

To Reset 
 
Click Reset to reset the statistical data and restart to make statistics. 
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Chapter 10  Real-time Eye Diagram and 
Jitter Analysis (Option) 
 
The DS8000-R series oscilloscope provides the real-time eye plot and measurement 
with the clock recovery function. The flexible and convenient jitter measurement and 
analysis enable the users to instinctively understand the strong and weak 
Inter-Symbol Interference in the system, so as to accurately and quickly make 
deterministic jitter measurement for high-speed serial signal. 
 
If you have purchased and activated the DS8000-R-JITTER option, the oscilloscope 
also supports real-time eye diagram and jitter analysis functions. 
Note: The DS8000-R-JITTER option is not available for DS8034-R. Therefore, the 
real-time eye diagram and jitter analysis functions mentioned in this chapter are not 
available for DS8034-R. 
 
Contents in this chapter: 
◼ Real-time Eye Analysis 
◼ Jitter Analysis 
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Real-time Eye Analysis 
 
An eye diagram is a view of a signal. A real- time eye accomplishes this by acquiring 
data, performing clock recovery, and then superimposing (folding) successive unit 
intervals within a single plot. This is a statistical view in the form of a color grade. The 
eye analysis function is usually used to observe the waveforms of the Receive signal 
to analyze the impact of inter-symbol interference (ISI) and noise on the system 
performance. 
 
Note: The eye diagram can only be obtained when the horizontal time base is less 
than or equal to 100 ns/div. 
 
You can go to the "Eye" setting menu through the following ways: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Eye" icon  to open the 
"Eye" setting menu. 

⚫ Click on function navigation icon  at the lower-left corner of the screen to 
open the function navigation. Then, click Measure → Analyze → Eye 
Analysis to enter the "Eye" setting menu. 

⚫ Click on the function navigation icon , and select Measure. Then click Add. 
In the displayed measurement category area, click to select "Analyze", and then 
select "Eye" to open the "Eye" setting menu. 

⚫ Click the auto measurement label "MEASURE" at the top of the screen to enter 
the measurement setting menu. In the measurement category area, click the 
"Analyze" tab to select the "Eye" option to enter the "Eye" setting menu. 

 
 

To Enable or Disable the Eye Analysis Function 
 
In the "Eye" setting menu, click the Enable key continuously to enable or disable the 
eye diagram analysis function. 
 
 

To Select the Eye Source 
 
Click Source in the "Eye" setting menu to select the desired eye source. The analog 
channel (CH1-CH4) can be selected as the eye source. 
 
 

To Set the Threshold 
 
In the "Eye" setting menu, click Threshold to enter the threshold setting menu.  
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⚫ Set the high threshold 
Click HighThres, then use the pop-up numeric keypad to set the high 
threshold.  
Note: If you reduce the high threshold to a value below the set middle 

threshold, the oscilloscope will automatically adjust the high threshold to 
make it greater than the middle threshold. 

 
⚫ Set the middle threshold 

Click MidThres, then use the pop-up numeric keypad to set the middle 
threshold. 
Note: The middle threshold is limited by the set low threshold and high 

threshold. 
 

⚫ Set the low threshold 
Click LowThres, then use the pop-up numeric keypad to set the low threshold. 
Note: If you increase the low threshold to a value above the set middle 

threshold, the oscilloscope will automatically adjust the low threshold to 
make it smaller than the middle threshold. 

 
 

To Set Clock Recovery 
 
The clock recovery provides an ideal clock for comparison to actual signal edges. 
 
In the "Eye" setting menu, click Clock Recovery to enter the clock recovery menu. 
This oscilloscope supports several clock recovery methods, including constant clock, 
phase-locked loop (PLL), and external clock. 
 
1. Setting method for constant clock recovery 

 
Click RecoveryType to select "Constant".  
 
⚫ Set the data rate type 

The data rate type for Constant includes Manual, Semi-auto, and Auto. 
➢ Manual: recovers the clock by the data rate input manually.  
➢ Semi-auto: recovers the clock by the manually preset data rate and the 

signal edge.  
➢ Auto: recovers the clock based on the narrowest pulse of the signal. 
Click Type to select the desired data rate type.  
 

⚫ Set the data rate 
Click Data Rate, then use the pop-up numeric keypad to set the data rate.  
Note: When the data rate type is set to Auto, the Data Rate menu is 
grayed out and disabled, and only the automatically recovered frequency of 
the ideal clock can be displayed. 
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2. Setting method for phase-locked loop (PLL) 
 
Click RecoveryType to select "PLL".  

 
⚫ Set the data rate 

Click Data Rate, then use the pop-up numeric keypad to set the data rate. 
 

⚫ Set the PLL order 
This oscilloscope supports first-order PLL and second-order PLL. Click PLL 
Order to select the order number. 
 

⚫ Set the loop BW 
Click Loop BW, then use the pop-up numeric keypad to set the loop 
bandwidth. 
 

⚫ Set the damping factor 
When PLL order is set to "2nd Order", you need to set the damping factor. It 
is the damping factor of the PLL's observed jitter transfer function (OJTF). 
Click DampFactor, then use the pop-up numeric keypad to set the 
damping factor. 
 
The typical damping factor is 1.0 and 0.707. The former is critically damped, 
and the latter is the ideal or optimal value.  
 

3. Setting method for external clock recovery 
 
Click RecoveryType to select "Explicit". 
 
Click Source to select the desired source. The analog channel (CH1-CH4) can 
be selected as the source of the external clock. 

 
 

To Enable or Disable the Eye Measurement Result 
 
In the "Eye" setting menu, click the Result key continuously to enable or disable the 
eye measurement result. When it is enabled, the statistical results of the eye 
measurement item data will be displayed at the upper-left corner of the screen, as 
shown in the following figure. You can drag the statistical results with the mouse to 
any place where you want to put it for view on the screen. 
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Wherein, 
One: indicates "1" level. 
Zero: indicates "0" level. 
Eye Width: indicates the width of an eye diagram. 
Eye Height: indicates the height of an eye diagram. 
Eye Amp: indicates the amplitude of an eye diagram. 
Cross: indicates the crossing percentage of an eye diagram. 
Q Factor: indicates the Q factor. 
 
The parameters of the eye measurement are shown in Figure 10-1. 

 
Figure 10-1 Diagram of Eye Measurement Parameters 

 
 

To Reset Color 
 
Click Reset Color to clear the color level counter. 
 
 

Persistence 
 
Click Persistence continuously to enable or disable the overlaying display function. 
When enabled, the overlaying plots of waveforms in the eye diagram are displayed. 
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When disabled, the overlaying plots of waveforms will not be displayed, but only 
display the updated plots of waveforms for the eye diagram.  

 
 

Jitter Analysis 
 
The jitter analysis function is mainly used to analyze the integrity of the high-speed 
serial signal and measure the variance of a measurement over time. The 
measurement item includes TIE, Cycle to Cycle, +Width to +Width, and –Width to 
-Width. Wherein, TIE indicates time interval error. The TIE measurement compares 
the edges in a data signal with the edges in an ideal data signal determined by the 
clock recovery feature to generate error statistics. 
 

You can go to the "Jitter" setting menu through the following ways: 

⚫ Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Jitter" icon  to open the 
"Jitter" setting menu. 

⚫ Click on function navigation icon  at the lower-left corner of the screen to 
open the function navigation. Then, click Measure → Analyze → Jitter to 
enter the "Jitter" setting menu. 

⚫ Click the auto measurement label "MEASURE" at the top of the screen to enter 
the measurement setting menu. In the measurement category area, click the 
"Analyze" tab to select the "Jitter" option to enter the "Jitter" setting menu. 

⚫ Click on the function navigation icon , and select Measure. Then click Add. 
In the displayed measurement category area, click to select "Analyze", and then 
select "Jitter" to open the "Jitter" setting menu. 

 
 

To Enable or Disable the Jitter Analysis Function 
 
In the "Jitter" setting menu, click the Enable key continuously to enable or disable 
the jitter analysis function. When the jitter analysis function and the jitter trend are 
enabled, Math3 trend operation function is enabled by default and the trend diagram 
is displayed on the screen. 
 
 

To Select the Jitter Source 
 
Click Source in the "Jitter" setting menu to select the desired jitter source. The 
analog channel (CH1-CH4) can be selected as the jitter source. 
 
 



Chapter 10 Real-time Eye Diagram and Jitter Analysis (Option)                        RIGOL 

DS8000-R User's Guide 10-7 

To Set the Threshold 
 
For the threshold setting methods of the jitter, please refer to descriptions in "To Set 
the Threshold" in the "Real-time Eye Analysis" section. 
 
 

To Set Clock Recovery 
 
For setting methods of the clock recovery in the jitter, refer to descriptions in "To Set 
Clock Recovery" in the "Real-time Eye Analysis" section. 
Note: When the measurement item is "TIE", you need to set the clock recovery. For 
other measurement items, you do not need to set the clock recovery. 
 
 

To Set the Jitter Measurement 
 
Click Measure to enter the jitter measurement menu. You can set the jitter 
measurement item and the graph display mode of the jitter measurement results. 
 
⚫ Set the jitter measurement item 

 
The jitter measurement items supported by this oscilloscope include TIE, Cycle 
to Cycle, +Width to +Width, and –Width to -Width. 
 
Click Item to select the desired measurement item. 
 
➢ TIE 

Compares edges in a signal under test with the edges in an ideal signal 
determined by the clock recovery feature. Then, all the signal intervals are 
measured based on the ideal data rate to generate the error statistics. 

 

 
 

➢ Cycle to Cycle 
Measures the first cycle and then subtracts the first cycle from the second 
cycle. The measurement is made according to this rule. 
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Cycle1 Cycle2

1st Measurement = Cycle2 - Cycle1

Cycle3 Cycle4

2nd Measurement = Cycle4 – Cycle3  
 

➢ +Width to +Width 
The +Width to +Width jitter measurement subtracts the first cycle's 
positive pulse width from the second cycle's positive pulse width for the first 
measurement result. Then, the second cycle's positive pulse width from the 
third cycle's positive pulse width for the second measurement result, and so 
on, until all of the cycles of the waveform have been measured. 

  
 

➢ -Width to -Width 
The -Width to -Width jitter measurement subtracts the first cycle's negative 
pulse width from the second cycle's negative pulse width for the first 
measurement result. Then, the second cycle's negative pulse width from 
the third cycle's negative pulse width for the second measurement result, 
and so on, until all of the cycles of the waveform have been measured. 

  
 

⚫ Jitter edge 
 

When the measurement item is "TIE" or "Cycle to Cycle", you need to set the 
edge for the measurement signal. The edges include Rising, Falling, and Either 
(available when TIE is selected as the measurement item). Click Slope to select 
the desired edge.  
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⚫ Jitter trend graph 
 

The trend graph can display the trend of the jitter measurement results. The 
data obtained from the waveforms of the same frame are generated to form a 
curve, which enables users to find out the cause for jitter. 
Click Trend continuously to enable or disable the display of the trend graph. 

 
Note: When the clock recovery method is set to "PLL", the PLL system cannot 
reach the expected ideal clock frequency until it reaches the specified lock time. 
During the lock time, the TIE jitter measurement results based on the ideal 
recovery clock are incorrect. The data produced during this time will be 
discarded in data processing. Therefore, in the TIE jitter trend graph based on 
the PLL recovery, part of trend graph at the left section of the screen will be lost. 
When a message "Invalid settings" is displayed below the trend graph, please 
modify the loop bandwidth, the horizontal timebase, or other related settings to 
make valid measurements. 

 
⚫ Jitter histogram 

 
The histogram shows the distribution of the jitter measurement results. 
Gaussian distributions indicate random jitter, and non-Gaussian distributions 
indicate the deterministic jitter. 
Click Histogram continuously to enable or disable the display of the histogram. 
 
Note: When you select the specified measurement item and enable the display 
of the histogram, the selected item will be displayed under the Item menu of 
the Histogram setting menu simultaneously. Meanwhile, the jitter analysis 
function in the histogram setting menu will also be enabled. The histogram type 
will be switched to Jitter. At this time, the statistical count and distribution of the 
jitter measurement results will be displayed in columns in the bar histogram at 
the screen bottom. 
 

⚫ Auto setting 
 
Used to configure the scale of the trend graph automatically. 
Click Auto Setting, and then the vertical scale and offset of the trend graph will 
be automatically adjusted to optimal values based on the current configurations, 
so that users can get a better observation of the results. 
 
 

To Enable or Disable the Jitter Measurement Result 
 
In the jitter setting menu, click Result continuously to enable or disable the jitter 
measurement result. When enabled, the jitter measurement data results will be 
displayed on the screen, as shown in the following figure. You can drag the jitter 
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measurement data results to any place for view.  
 

 
 
 

To Reset 
 
In the jitter setting menu, click Reset to reset the statistics of the jitter 
measurement result. 
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Chapter 11 Protocol Decoding 
 
You can use the protocol analysis to discover errors, debug hardware, and accelerate 
development easily, ensuring you to accomplish the projects with high speed and 
good quality. Protocol decoding is the basis of protocol analysis. Only protocol 
analyses with correct protocol decoding are acceptable, and only correct protocol 
decoding can identify more error information. DS8000-R provides four bus decoding 
modules (Decode 1, Decode 2, Decode 3, and Decode 4) to make common protocol 
decoding (including Parallel (standard), RS232 (option), I2C (option), SPI (option), 
LIN (option), CAN (option), FlexRay (option), I2S (option), and 1553B (option)) for 
the input signals of the analog channels (CH1-CH4). As the decoding functions and 
setting methods of Decode1, Decode2, Decode3, and Decode4 are the same, this 
chapter takes Decode1 as an example for illustration. 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Decode" icon  to open the 
decode setting menu. 
 
To get the decoding option information, refer to descriptions in "Appendix A: 
Accessories and Options". 
If you have purchased the decoding option, activate it according the descriptions in 
"To View the Option Information and the Option Installation". 
 
Contents in this chapter: 
◼ Parallel Decoding 
◼ RS232 Decoding (Option) 
◼ I2C Decoding (Option) 
◼ SPI Decoding (Option) 
◼ LIN Decoding (Option) 
◼ CAN Decoding (Option) 
◼ FlexRay Decoding (Option) 
◼ I2S Decoding (Option) 
◼ 1553B Decoding (Option) 
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Parallel Decoding 
 
Parallel bus consists of clock line and data line. As shown in the figure below, CLK is 
the clock line, whereas Bit0 and Bit1 are the 0 bit and 1st bit on the data line 
respectively. The oscilloscope will sample the channel data on the rising edge, falling 
edge, or the rising/falling edge of the clock and judge each data point (logic "1" or 
logic "0") according to the preset threshold level. 
 

 
Figure 11-1 Schematic Diagram of Parallel Decoding 

 
In the decode setting menu, click Decode1 → Bus Type to select "Parallel". 
 
1． Enable or disable the bus 

Click Bus Status to enable or disable the decoding function. 
 
2． Clock setting (CLK) 

Click Clock to enter the clock line setting menu. 
 
⚫ Set clock channel 

Click CLK to select any clock channel. The available choices include OFF 
and CH1-CH4. The analog channel (CH1-CH4) can be selected as the clock 
source. If "OFF" is selected, no clock channel is set, and sampling is 
performed when a hop occurs to the data of the data channel during 
decoding. 
 

⚫ Set the clock edge type 
Click CLK Edge to select the clock edge type. You can select to sample the 

channel data on the rising edge ( ), falling edge ( ), or both edges 

( ) of the clock signal. 

Rising : samples the channel data on the rising edge of the clock. 

Falling : samples the channel data on the falling edge of the clock. 

Both : samples the channel data on both the rising edge and the 
falling edge of the clock. 
 

⚫ Set the threshold 
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Click Threshold, then use the pop-up numeric keypad or scroll with the 
mouse to set the threshold. 
 

3． Bus setting 
Click Bus to enter the bus setting menu. 

⚫ Set the bus 

Click BUS to select the digital bus for Parallel decoding, as shown in the 

following table.  

Bus Width Bit X Channel Remarks 

CH1 1 0 CH1 Width, Bit X, and CH 
are set automatically, 
and you cannot modify 
them. 

CH2 1 0 CH2 Width, Bit X, and CH 
are set automatically, 
and you cannot modify 
them. 

CH3 1 0 CH3 Width, Bit X, and CH 
are set automatically, 
and you cannot modify 
them. 

CH4 1 0 CH4 Width, Bit X, and CH 
are set automatically, 
and you cannot modify 
them. 

User 1-4 0 (default) -- -- 

 
⚫ Set the width 

When BUS is set to "User", you can set the bus width. Click Width, and use 
the pop-up numeric keypad or scroll with the mouse to set the width. The 
available range is from 1 to 4. By default, it is 1. When BUS is set to CH1, 
CH2, CH3, or CH4, the Width menu is grayed out and disabled. 
 

⚫ Specify data channel for each bit 
When "BUS" is greater than 1, you can specify data channel for each bit. 
Click Bit X, then use the pop-up numeric keypad or scroll with the mouse to 
set the bit of the channel. By default, 0 is selected. Its available range is 
from 0 to (width - 1).  
Click CH to select a channel source. The analog channel (CH1-CH4) can be 
selected as the channel source. 

 
⚫ Set the threshold level 

To judge logic "1" and logic "0" of the buses, you need to set a threshold for 
each analog channel (CH1-CH4). When the channel signal amplitude is 
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greater than the preset threshold, it is judged as logic "1"; otherwise logic 
"0". Click Threshold, then use the pop-up numeric keypad or scroll with 
the mouse to set the threshold. 

 

 
 

⚫ Set the endian 
Click Endian continuously to select "Normal" or "Invert" as the endian of 
the bus. 
 

⚫ Polarity 

Click Polarity continuously to select Positive  or Negative  as the 
polarity for data decoding. 

 
4． Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.  

 
⚫ Set the label display 

Click Label to enable or disable the label display of the Parallel decoding 
bus. When enabled, the bus label "Parallel" will be displayed at the 
upper-left side of the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, the corresponding line number, and 
time information.  
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-2. You can also 

Channel Logic Level 

Channel Signal Amplitude 
Threshold Level 

1 

0 0 
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click on the icon  at the upper-right corner of the table to close the 
event table.  
 
 
 
 

  
Figure 11-2 Parallel Decoding Event Table 

 
Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload".  
If you select "Packets", the time and decoded data are displayed in the 
event table. If you select "Details", the detailed data in the specified 
row will be displayed in the event table. If "…" appears in the row of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view. If you select 
"Payload", all data in the specified column will be displayed in the event 
table. If "…" appears in the specified column of data, it indicates that 
the decoded data are not fully displayed. At this time, you can view the 
details in the "Packets" view.  

➢ Export: If you select "Packets", then set the operating status of the 

Line Number    Time   Decode Name  Decoded Data 

Event Table 
 
 
 

 
Parallel Bus 
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oscilloscope to "STOP". You can export time and the corresponding 
decoded data. Click Export, the save setting menu is displayed. You 
can export the data table of the packets to the internal or external USB 
storage device (when detected) in CSV format. For detailed saving 
operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
5． Noise rejection 

Click Settings → Noise Reject to enable or disable the noise rejection 
function. Noise rejection can remove the data that last not enough time on the 
bus and eliminate the burst glitch in the actual circuit. When the noise rejection 
is enabled, click Reject Time, then use the pop-up numeric keypad or scroll 
with the mouse to set the desired rejection time. The available range of the 
rejection time is from 0 s to 1 s. 
 
 

RS232 Decoding (Option) 
 
RS232 serial bus consists of the transmitting data line (TX) and the receiving data 
line (RX). 
 

DeviceA DeviceB

Tx Rx

Rx Tx

 
Figure 11-3 Schematic Diagram of RS232 Serial Bus 

 
The industry standard of RS232 uses "Negative Logic", i.g. high level is logic "0" and 
low level is logic "1". 

1

0 0 0 0

1 1 1 1 1
 

Figure 11-4 Schematic Diagram of Negative Logic 
 
In RS232, baud rate is used to represent the transmission rate (namely bits per 
second) of the data. You need to set the start bit, data bits, check bit (optional), and 
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stop bit for each frame of data. 
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Start Bit: indicates when to output data. 
Data Bit: indicates the number of data bits actually contained in each frame of data. 
Check Bit: used to check whether the data are properly transmitted. 
Stop Bit: indicates when to stop outputting data. 
 
In the decode setting menu, click Decode1 → Bus Type to select "RS232".  
 
1． Enable or disable the bus 

Click Bus Status to enable or disable the decoding function. 
 
2． Quickly apply RS232 trigger settings to RS232 decoding 

Click Copy Trig to copy the current RS232 trigger settings and apply them to 
RS232 decoding function (set the corresponding RS232 decoding parameters 
automatically). For source channels, copy the source channel of the trigger to 
the Tx source channel of the decoding. 
 

3． Set the baud rate 
The following methods are available for baud rate:  
⚫ Click Baud, then set the user-defined baud rate with the displayed numeric 

keypad.  
⚫ Click Baud, then select the preset baud rate from the available options. The 

available baud rates include 50 bps, 75 bps, 110 bps, 134 bps, 150 bps, 300 
bps, and etc.  
 

4． Source setting 
Click Sources to enter the source setting menu. 
 
⚫ Set the Tx source and the threshold 

➢ Click Tx to select the desired channel. The available channels include 
OFF and CH1-CH4. 

➢ When you select the analog channel (CH1-CH4), click Threshold, then 
use the pop-up numeric keypad or scroll with the mouse to adjust the 
threshold of Tx source. When you modify the threshold of the Tx 
source channel, a dotted line displaying the current threshold level is 
displayed on the screen. The dotted line disappears in about 2 s after 
you stop modifying the threshold. 

 
⚫ Set the Rx source and the threshold 
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Use the same method to select the Rx source and set the threshold (only 
when the Rx source channel is set to an analog channel (CH1-CH4)). 

Note: The Tx and Rx source channels cannot be set to "OFF" at the same time. 
 

⚫ Polarity 
Click Polarity continuously to select the polarity of data transmission. It 

can be set to " " or " ". 

➢ : positive logic. High level indicates logic "1"; low level 
indicates logic "0". 

➢ : negative logic. High level indicates logic "0"; low level 
indicates logic "1". 

 
5． Set data package 

Click Settings to enter the data package setting menu. 
 
⚫ Data  

Click Data to set the number of data bits actually contained in each frame 
of data. The available data bits are 5 bits, 6 bits, 7 bits, 8 bits, and 9 bits.  
 

⚫ Parity 
It is used to check whether the data transmission is correct. Click Parity to 
select the desired parity mode. 
➢ None: indicates that no check bit appears during the transmission. 
➢ Even: indicates that the total number of "1" in the data bit and check 

bit is an even number. For example, when 0x55 (01010101) is sent, "0" 
should be added to the check bit. 

➢ Odd: indicates that the total number of "1" in the data bit and check bit 
is an odd number. For example, when 0x55 (01010101) is sent, "1" 
should be added to the check bit. 

 
⚫ Stop Bit 

Click Stop Bit to set the stop bits after each frame of data. It can be set to 

1 bit, 1.5 bits, or 2 bits. 

 
⚫ Endian 

Click Endian to select "LSB" or "MSB". By default, it is "LSB". 
LSB: indicates Least Significant Bit transmission sequence, i.g. the lowest 
bit of the data is transmitted first. 
MSB: indicates Most Significant Bit transmission sequence, i.g. the highest 
bit of the data is transmitted first. 
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          LSB                             MSB 

⚫ Package 
Click Package to enable or disable the package display in data 
transmission. When enabled, several data blocks will be combined based on 
the separator.  
 

⚫ Separator 
Click Separator to select the desired package separator in data 
transmission. It can be set to 0A(LF), 0D(CR), 20(SP), or 0(NUL). 

 
6． Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.  

 
⚫ Set the label display 

Click Label to enable or disable the label display of the RS232 decoding bus. 
When enabled, the bus label "RS232-TX" and/or "RS232-RX" will be 
displayed at the upper-left side of the bus (when the bus display is 
enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data (Tx and/or Rx), the corresponding 
line number, time, and error information (Tx and/or Rx).  
Note: When the Tx and Rx source channels are set to "OFF", information of 
the data line is not displayed in the data table. 
 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. You can also click on the icon  at 
the upper-right corner of the table to close the event table. Besides, 
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when the operating status is "STOP", you can select a specified line and 
view the corresponding decoding information. 
 
Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" (Tx and/or Rx) in the event table. The available formats include 
"Hex", "Dec", "Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also click the "Packets", "Details", or "Payload" tab 
at the top of the event table to select it. 
If you select "Packets", the decoded data (Tx/Rx), time, and error 
information (Tx/Rx) are displayed in the event table; if you select 
"Details", the detailed data in the specified row will be displayed in the 
event table. If "…" appears in the row of data, it indicates that the 
decoded data are not fully displayed. At this time, you can view the 
details in the "Packets" view. If you select "Payload", all data in the 
specified column will be displayed in the event table. If "…" appears in 
the specified column of data, it indicates that the decoded data are not 
fully displayed. At this time, you can view the details in the "Packets" 
view.  

➢ Export: If you select "Packets", then set the operating status of the 
oscilloscope to "STOP". You can export time, the corresponding 
decoded data, and etc. Click Export, the save setting menu is 
displayed. You can export the data table of the packets to the internal 
or external USB storage device (when detected) in CSV format. For 
detailed saving operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
7． Error expressions in decoding 

In RS232 decoding, parity error and/or EOF (end of frame) error may occur. 
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⚫ Parity Error 
When a parity error is detected during the decoding, red error report 
information will be displayed. For example, when "none" is chosen for the 
parity on the transmitter and "odd" is chosen for the parity on the decoder, 

the following parity error information  (its display form is related to the 
value of the horizontal time base) occurs. Wherein, the number of 1s in the 
8-digit figure (01001111) is an odd number, and the parity bit should be 0. 
However, the parity bit detected on the Tx is 1; thus a parity error occurs.  

 
 

⚫ EOF Error 
This error is generated when the EOF condition is not met. For example, if 
the Stop Bit is set to 1.5, but the actual stop bits is less than 1.5 bits, then 

the red error report information  (its display form is related to the value 
of the horizontal time base) is displayed in the following figure.  

 
 

⚫ Parity Error and EOF Error 
When both the parity error and the EOF error are detected, the error report 
information (its display form is related to the value of the horizontal time 
base), as shown in the following figure, will be displayed. 
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I2C Decoding (Option) 
 
I2C serial bus consists of the clock line (SCL) and the data line (SDA). 
SCL: samples SDA on the rising or falling edge of the clock. 
SDA: indicates the data channel. 
 

SCL

SDA

 
Figure 11-5 I2C Serial Bus 

 
In the decode setting menu, click Decode1 → Bus Type to select "I2C".  
 
1． Enable or disable the bus 

Click Bus Status continuously to enable or disable the decoding function. 
 
2． Quickly apply I2C trigger settings to I2C decoding 

Click Copy Trig to copy the clock signal and data signal settings (SCL and SDA) 
of the current I2C trigger settings and apply them to I2C decoding function (SCL 
and SDA).  

 
3． Source setting 

Click Sources to enter the source setting menu. 
 
⚫ Set the clock channel source and the threshold 

➢ Click SCL to select the desired source of the clock channel. The 
available channels include CH1-CH4. 

➢ Click SCL Thre, then use the pop-up numeric keypad or scroll with the 
mouse to adjust the threshold of the clock channel. After modifying the 
threshold of the clock channel, a dotted line displaying the current 
threshold level is displayed on the screen. The dotted line disappears in 
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about 2 s after you stop modifying the threshold. 
 

⚫ Set the data channel source and the threshold 
➢ Click SDA to select the desired source of the clock channel. The 

available channels include CH1-CH4. 
➢ Click SDA Thre, then use the pop-up numeric keypad or scroll with the 

mouse to adjust the threshold of the clock channel. After modifying the 
threshold of the clock channel, a dotted line displaying the current 
threshold level is displayed on the screen. The dotted line disappears in 
about 2 s after you stop modifying the threshold. 

 
⚫ Exchange sources 

Click Exchange continuously to select "SCL/SDA" or "SDA/SCL" to 
exchange the sources of the current clock channel and data channel. 

 
4． Specify whether the address information includes the "R/W" bit 

For I2C bus, each frame of data starts with the address information. The address 
information includes the read address and the write address. Click R/W 
continuously to select whether the address information includes the "R/W" bit. 
When "With" is selected, the "R/W" bit will be included in the address 
information and located at the lowest bit; when "Without" is selected, the "R/W" 
bit will not be included in the address information. 

 
5． Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus. 
 

⚫ Set the label display 
Click Label to enable or disable the label display of the I2C decoding bus. 
When enabled, the bus label "I2C" will be displayed at the upper-left side of 
the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, the corresponding line number, time, 
R/W bit, address information, and acknowledgement information.  
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➢ Open or close the event table: Click Event Table continuously to 
enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-6. Click on the 

icon  at the upper-right corner of the table to close the event table. 
Besides, when the operating status is "STOP", you can select a 
specified line and view the corresponding decoding information. 
 
 
 
 

 
 

Figure 11-6 I2C Decoding Event Table 
 

Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also click the "Packets", "Details", or "Payload" tab 
at the top of the event table to select it. 
If you select "Packets", the decoded data, time, and error information 
are displayed in the event table. If you select "Details", the detailed 
data in the specified row will be displayed in the event table. If "…" 
appears in the row of data, it indicates that the decoded data are not 

Line Number Time   R/W Bit  Address  Decoded Data Acknowledgement 

Event Table 
 
 
 

 
I2C Bus 
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fully displayed. At this time, you can view the details in the "Packets" 
view. If you select "Payload", all data in the specified column will be 
displayed in the event table. If "…" appears in the specified column of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view.  

➢ Export: If you select "Packets", then set the operating status of the 
oscilloscope to "STOP". You can export time, the corresponding 
decoded data, and etc. Click Export, the save setting menu is 
displayed. You can export the data table of the packets to the internal 
or external USB storage device (when detected) in CSV format. For 
detailed saving operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
6． Address information in decoding 

In I2C bus, each frame of data starts with the address information (include the 
read address and write address). In the address information, "Read" denotes 

the read address (e.g. ) and "Write" denotes the write address (e.g. 

) You can also set the address information to include or exclude 
the "R/W" bit.  

  
 

 
7． Error expressions in decoding 

In I2C decoding, when ACK (acknowledgement) is 1, ACK error occurs. When 

when the detected ACK is 1, red error report information  (the display form is 

Address Information (Read Address) 
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related to the value of the horizontal time base) is dispalyed.  
 

  
 

 
 

SPI Decoding (Option) 
 
SPI bus is based on the master-slave configuration and usually consists of chip select 
line (CS), clock line (CLK), and data line (SDA). Wherein, the data lines include the 
master input/slave output (MISO) data line and master output/slave input (MOSI) 
data line. The oscilloscope samples the channel data on the rising or falling edge of 
the clock signal. The oscilloscope will also judge each data point (logic "1" or logic "0") 
according to the preset threshold level. 
 

Master Slave
MOSI

CLK

MISO

CS

  

CLK

SDA
(MISO/MOSI)  
 

Figure 11-7 SPI Serial Bus 
 
In the decode setting menu, click Decode1 → Bus Type to select "SPI". 
  
1． Enable or disable the bus 

Click Bus Status to enable or disable the decoding function. 
 

The detected ACK is 1 
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2． Quickly apply SPI trigger settings to SPI decoding 
Click Copy Trig to copy the SPI trigger settings and apply them to SPI decoding 
function (set the corresponding SPI decoding parameters automatically). The 
settings available for copy include CS/Timeout mode, CLK, MISO, Slope, and etc.  

 
3． Mode 

Click Mode to enter the mode setting menu. Click Mode to select "Timeout" or 
"CS". 
 
⚫ Timeout: you can perform frame synchronization according to the timeout, 

and the timeout value must be greater than half of the clock cycle. Click 
Timeout, and then use the pop-up numeric keypad or scroll with the 
mouse to set the timeout value. The available range of the timeout value is 
from 8 ns to 10 s. By default, it is 1 μs. 
 

⚫ CS: contains a chip select line (CS). You can perform frame synchronization 
according to CS. When "CS" is selected, 
➢ Click CS to select the desired channel. The analog channel (CH1-CH4) 

can be selected as the CS channel. 
➢ Click CS Polarity continuously to select (Positive) or 

(Negative) as the polarity for CS channel. 
➢ Click Threshold, then use the pop-up numeric keypad or scroll with 

the mouse to set the threshold.  
 

4． Source setting 
Click Sources to enter the source setting menu. 
 
⚫ CLK setting 

➢ Click CLK to select the desired source of the clock channel. The analog 
channel (CH1-CH4) can be selected. 

➢ Click Threshold below the CLK menu, then use the pop-up numeric 
keypad or scroll with the mouse to set the threshold level of the clock 
channel.  

➢ Click Slope continuously to set the instrument to sample MISO and 

MOSI on the rising edge ( ) or falling edge ( ) of the clock signal. 
 

⚫ MISO and MOSI setting 
➢ Click MISO to select the desired MISO data channel. The available 

channels include OFF and analog channels (CH1-CH4). When you 
select an analog channel (CH1-CH4), click Threshold below the MISO 
menu, then use the pop-up numeric keypad or scroll with the mouse to 
set the threshold of the MISO data channel. 

➢ Click MOSI to select the desired MOSI data channel. The available 
channels include OFF and analog channels (CH1-CH4). When you 
select an analog channel (CH1-CH4), click Threshold below the MOSI 
menu, then use the pop-up numeric keypad or scroll with the mouse to 
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set the threshold of the MOSI data channel. 
Note: MISO and MOSI source channels cannot be both set to "OFF" at 
the same time. 
 

5． Data setting 
Click Settings to enter the data setting menu. 
 
⚫ Endian setting 

Click Endian to select "LSB" or "MSB". By default, it is "MSB". 
LSB: indicates Least Significant Bit transmission sequence, i.g. the lowest 
bit of the data is transmitted first. 
MSB: indicates Most Significant Bit transmission sequence, i.g. the highest 
bit of the data is transmitted first. 

 
⚫ Polarity setting 

Click Polarity continuously to select Positive  or Negative  as the 
polarity for data decoding. 

 
⚫ Width setting 

Click Width, then use the pop-up numeric keypad or scroll with the mouse 
to set the bits of each frame of data. The available range is from 4 to 32. By 
default, it is 8. 

 
6． Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus. 
 

⚫ Set the label display 
Click Label to enable or disable the label display of the SPI decoding bus. 
When enabled, the bus label "SPI-MISO" and/or "SPI-MOSI" will be 
displayed at the upper-left side of the bus (when the bus display is 
enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data (MISO and/or MOSI), the 
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corresponding line number, time, and error information (MISO and/or 
MOSI).  
Note: When the source channel of MISO or MOSI is set to "OFF", 
information of the data line is not displayed in the data table. 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-8. You can click 

on the icon  at the upper-right corner of the table to close the event 
table. Besides, when the operating status is "STOP", you can select a 
specified line and view the corresponding decoding information. 
 
 

  
Figure 11-8 SPI Decoding Event Table 

Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" (MISO and/or MOSI) in the event table. The available formats 
include "Hex", "Dec", "Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also click the "Packets", "Details", or "Payload" tab 
at the top of the event table to select it. 
If you select "Packets", the decoded data (MISO and/or MOSI), time, 
and error information (MISO and/or MOSI) are displayed in the event 
table. If you select "Details", the detailed data in the specified row will 
be displayed in the event table. If "…" appears in the row of data, it 

Line Number  Time MISO Decoding Data  MISO Error MOSI Decoding Data MOSI Error 

 
 
Event Table 

 

 
SPI Bus 
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indicates that the decoded data are not fully displayed. At this time, 
you can view the details in the "Packets" view. If you select "Payload", 
all data in the specified column will be displayed in the event table. If 
"…" appears in the specified column of data, it indicates that the 
decoded data are not fully displayed. At this time, you can view the 
details in the "Packets" view.  

➢ Export: If you select "Packets", then set the operating status of the 
oscilloscope to "STOP". You can export time and the corresponding 
decoded data. Click Export, the save setting menu is displayed. You 
can export the data table of the packets to the internal or external USB 
storage device (when detected) in CSV format. For detailed saving 
operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
 

LIN Decoding (Option) 
 
The oscilloscope samples the LIN signal, and judges each data point to be logic "1" 
or logic "0" according to the preset threshold level. The LIN decoding is required to 
specify the LIN signal protocol version. 
 
In the decode setting menu, click Decode1 → Bus Type to select "LIN".  
 
1. Enable or disable the bus 

Click Bus Status continuously to enable or disable the decoding function. 
 

2. Quickly apply LIN trigger settings to LIN decoding 
Click Copy Trig to copy the LIN trigger settings and apply them to LIN decoding 
function (set the corresponding LIN decoding parameters automatically).  
 

3. Set the source and the threshold 
 
⚫ Click Source to select the desired source channel. The available channels 

include CH1-CH4. 
 

⚫ Click Threshold, then use the pop-up numeric keypad or scroll with the 
mouse to set the threshold of the source channel. When you modify the 
threshold of the clock channel, a dotted line displaying the current threshold 
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level is displayed on the screen. The dotted line disappears in about 2 s 
after you stop modifying the threshold. 

 
4. Signal setting 

Click Settings to enter the signal setting menu. 
 
⚫ Set baud rate 

The following setting methods are available for baud rate:  
➢ Click Baud Rate, then set the user-defined baud rate with the 

displayed numeric keypad. You can also adjust the baud rate by 
scrolling with the mouse. 

➢ Click Baud Rate, then select the preset baud rate from the available 
options. The available baud rates include 2.4 kbps, 4.8 kbps, 9.6 kbps, 
19.2 kbps, and etc. 

 
⚫ Set the parity bit 

Click Parity bit continuously to select whether the data contains the parity 
bit. 

 
⚫ Set the protocol version 

Click Version to select a protocol version that matches the LIN bus signal. 
The available versions include 1.X, 2.X, and Both. 

 
5. Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.  

 
⚫ Set the label display 

Click Label continuously to enable or disable the label display of the LIN 
decoding bus. When enabled, the bus label "LIN" will be displayed at the 
upper-left side of the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, the corresponding line number, time, 
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frame ID, CRC, and error information.  
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-9. You can click 

on the icon  at the upper-right corner of the table to close the event 
table. Besides, when the operating status is "STOP", you can select a 
specified line and view the corresponding decoding information. 
 
 
 

  
Figure 11-9 LIN Decoding Event Table 

 
Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". If you select "Packets", the decoded data, time, and error 
information are displayed in the event table. If you select "Details", the 
detailed data in the specified row will be displayed in the event table. If 
"…" appears in the row of data, it indicates that the decoded data are 
not fully displayed. At this time, you can view the details in the 
"Packets" view. If you select "Payload", all data in the specified column 
will be displayed in the event table. If "…" appears in the specified 

Line Number  Time   Frame ID  Decoded Data CRC  Error 

Event Table 
 
 
 

 
LIN Bus 
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column of data, it indicates that the decoded data are not fully 
displayed. At this time, you can view the details in the "Packets" view.  

➢ Export: If you select "Packets", then set the operating status of the 
oscilloscope to "STOP". You can export time and the corresponding 
decoded data. Click Export, the save setting menu is displayed. You 
can export the data table of the packets to the internal or external USB 
storage device (when detected) in CSV format. For detailed saving 
operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
6. Interpret the decoded LIN data 

⚫ Break (Sync Break): expressed in Hex, displayed as a pink patch. 
⚫ SYNC (Sync): expressed in Hex, displayed in dark yellow-green. 
⚫ ID (Frame ID): expressed in Hex, displayed in yellow-green. 
⚫ Data (Data): its display format is the same as that of the bus data (Hex, Dec, 

Bin, or ASCII), displayed as a black patch. 
⚫ CRC (Cyclic Redundancy Check): expressed in Hex, displayed in light 

yellow-green. When errors occur, it is displayed as a red patch. 
 

 
 
 

 
 

⚫ Wakeup (wake up symbol): displayed as a tangerine patch. 

 
 

7. Error expressions in decoding 
In LIN decoding, the parity error, checksum error, or sync error may occur. 
 
⚫ Parity Error 

If the parity error is detected, frame ID and parity bit (when the signal is set 
to include the parity bit) will be displayed in red, as shown in the figure 
below. 

Break    Sync      ID         Data        CRC 
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⚫ Checksum Error 
If the checksum error is detected, CRC is displayed in red, as shown in the 
figure below. 

  
 
 
 

⚫ Sync Error 
If the sync error is detected, SYNC is displayed in red, as shown in the 
figure below. 

Parity Error 

Checksum Error 
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CAN Decoding (Option) 
 
The oscilloscope samples the CAN signal at the specified sample position. The 
oscilloscope will also judge each data point (logic "1" or logic "0") according to the 
preset threshold level. You need to specify the CAN signal type and sample position 
for CAN decoding. 
 
In the decode setting menu, click Decode1 → Bus Type to select "CAN".  
 
1. Enable or disable the bus 

Click Bus Status continuously to enable or disable the decoding function. 
 

2. Quickly apply CAN trigger settings to CAN decoding 
Click Copy Trig to copy the CAN trigger settings and apply them to CAN 
decoding function (set the corresponding CAN decoding parameters 
automatically).  
 

3. Set the source and the threshold 
 
⚫ Click Source to select the desired source channel. The available channels 

include CH1-CH4. 
⚫ Click Threshold, then use the pop-up numeric keypad or scroll with the 

mouse to set the threshold of the source channel. When you modify the 
threshold of the clock channel, a dotted line displaying the current threshold 
level is displayed on the screen. The dotted line disappears in about 2 s 
after you stop modifying the threshold. 
 

4. Signal setting 

Sync Error 
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Click Settings to enter the signal setting menu. 
 
⚫ Set the signal type 

Click Signal to select a signal type that matches the CAN bus signal. The 
available signal types include CAN_H, CAN_L, Rx, Tx, and Diff. 
➢ CAN_H: indicates the actual CAN_H bus signal. 
➢ CAN_L: indicates the actual CAN_L bus signal.  
➢ Rx: indicates the Receive signal from the CAN bus transceiver. 
➢ Tx: indicates the Transmit signal from the CAN bus transceiver. 
➢ Diff: The CAN differential bus signals connected to an analog source 

channel by using a differential probe. Connect the probe's positive lead 
to the CAN_H bus signal and connect the negative lead to the CAN_L 
bus signal. 

 
⚫ Specify the standard signal rate 

The following setting methods are available for baud rate: 
➢ Click Baud, then set the user-defined baud rate with the displayed 

numeric keypad. You can also adjust the baud rate by scrolling with the 
mouse. 

➢ Click Baud, then select the preset baud rate from the available options. 
The available baud rates include 10 kbps, 20 kbps, 33.3 kbps, 50 kbps, 
and etc. 

 
⚫ Sample Position: 

Sample position is a point within a bit’s time. The oscilloscope samples the 
bit level at this point. The sample position is represented by the proportion 
of "the time from the start of the bit to the sample position" to the "bit time", 
as shown in the figure below. 

 
 

 
Figure 11-10 Sample Position 

 
Click Sample Position, then use the pop-up numeric keypad or scroll with 
the mouse to set the sample position. The settable range is from 10% to 
90%. 

 
5. Display-related Setting 

Click Display to enter the display setting menu. 
 

One Bit 

60% 

70% 

80% 
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⚫ Set the display format 
Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.  

 
⚫ Set the label display 

Click Label to enable or disable the label display of the CAN decoding bus. 
When enabled, the bus label "CAN" will be displayed at the upper-left side 
of the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, the corresponding line number, time, 
frame ID, data length code (DLC), cyclic redundancy check (CRC), and 
Acknowledgement (ACK) information.  
 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-11. You can 

also click on the icon  at the upper-right corner of the table to close 
the event table. Besides, when the operating status is "STOP", you can 
select a specified line and view the corresponding decoding 
information. 
 
 
 

  
Figure 11-11 CAN Decoding Event Table 

Line Number  Time  Frame ID  DLC  Decoded Data   CRC   ACK 

Event Table 
 
 
 

 
CAN Bus 
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Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also tap "Packets", "Details", or "Payload" at the top 
of the event table to select it. 
If you select "Packets", the decoded data, time, and other information 
are displayed in the event table. If you select "Details", the detailed 
data in the specified row will be displayed in the event table. If "…" 
appears in the row of data, it indicates that the decoded data are not 
fully displayed. At this time, you can view the details in the "Packets" 
view. If you select "Payload", all data in the specified column will be 
displayed in the event table. If "…" appears in the specified column of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view.  

➢ Export: If you select "Packets", then set the operating status of the 
oscilloscope to "STOP". You can export time and the corresponding 
decoded data. Click Export, the save setting menu is displayed. You 
can export the data table of the packets to the internal or external USB 
storage device (when detected) in CSV format. For detailed saving 
operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
6. Interpret the decoded CAN data 

⚫ Frame ID: expressed in Hex, displayed as a dark yellow-green patch. 
⚫ DLC (Data Length Code): expressed in Hex, displayed as a blue-green 

patch.  

⚫ Data: its display format is the same as that of the bus data (Hex, Dec, Bin, 
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or ASCII), displayed as a green patch. 
⚫ CRC (Cyclic Redundancy Check): expressed in Hex, displayed in 

yellow-green. When errors occur, it is displayed as a red patch. 
⚫ ACK (Acknowledgement): when effective, displayed as a light yellow-green 

patch; when errors (ACK is detected to be 1) occur, displayed as a red 

patch.  

 
 

 
 
 
 

⚫ R (Remote frame): displayed as a tangerine patch. 

 
 

⚫ Stuff (Bit filling error): displayed as a red patch. 

 
 
 

FlexRay Decoding (Option) 
 
FlexRay is a type of differential serial bus configured with three consecutive 
segments (i.g. header, payload, and trailer). The oscilloscope samples the FlexRay 
signal at the specified sample position and judges each data point as logic "1" or 
logic "0" according to the preset threshold level. The FlexRay decoding is required to 
specify the signal type and baud rate. 
 
In the decode setting menu, click Decode1 → Bus Type to select "FlexRay".  
 
1. Enable or disable the bus 

Click Bus Status continuously to enable or disable the decoding function. 
 

2. Quickly apply FlexRay trigger settings to FlexRay decoding 
Click Copy Trig to copy the FlexRay trigger settings and apply them to FlexRay 
decoding function (set the corresponding FlexRay decoding parameters 
automatically).  
 

3. Set the source and the threshold 
 
⚫ Click Source to select the desired source channel. The available channels 

include CH1-CH4. 
 

Frame ID    DLC           Data              CRC   ACK 
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⚫ Click Threshold, then use the pop-up numeric keypad or scroll with the 
mouse to set the threshold of the source channel. When you modify the 
threshold of the channel, a dotted line displaying the current threshold level 
is displayed on the screen. The dotted line disappears in about 2 s after you 
stop modifying the threshold. 
 

4. Signal setting 
Click Settings to enter the signal setting menu. 
 
⚫ Channel selection 

Click Channel continuously to select a channel ("A" or "B") that matches 
the actual FlexRay bus signal. 
 

⚫ Specify the signal rate 
Click Baud to open the baud rate list (2.5 Mbps, 5 Mbps, and 10 Mbps), and 
select a preset baud rate that matches the actual FlexRay bus signal.  
 

⚫ Set the signal type 
Click Signal to select a signal type that matches the actual FlexRay bus 
signal. The available signal types include BP, BM, and RX/TX. 
 

⚫ Sample Position: 
Sample position is a point within a bit’s time. The oscilloscope samples the 
bit level at this point. The sample position is represented by the proportion 
of "the time from the start of the bit to the sample position" to the "bit time", 
as shown in the figure below. 
 
 

 
Figure 11-12 Sample Position 

 
Click Sample Position, then use the pop-up numeric keypad or scroll with 
the mouse to set the sample position. The settable range is from 10% to 
90%. 

 
5. Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 

One Bit 

60% 

70% 

80% 
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display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.   

 
⚫ Set the label display 

Click Label continuously to enable or disable the label display of the 
FlexRay decoding bus. When enabled, the bus label "Flexray" will be 
displayed at the upper-left side of the bus (when the bus display is 
enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, the corresponding line number, time, 
frame ID, and Payload Length (PL).  
 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-13. You can 

also click on the icon  at the upper-right corner of the table to close 
the event table. Besides, when the operating status is "STOP", you can 
select a specified line and view the corresponding decoding 
information. 
 
 
 

 
Figure 11-13 FlexRay Decoding Event Table 

Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

Line Number   Time Frame ID PL  Header CRC CYC Decoded Data Frame CRC 

Event Table 
 
 
 

 
FlexRay Bus 
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on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

➢ Set the event table format: Click Format to select the display format of 
"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also click the "Packets", "Details", or "Payload" tab 
at the top of the event table to select it. 
If you select "Packets", the decoded data, time, and other information 
are displayed in the event table. If you select "Details", the detailed 
data in the specified row will be displayed in the event table. If "…" 
appears in the row of data, it indicates that the decoded data are not 
fully displayed. At this time, you can view the details in the "Packets" 
view. If you select "Payload", all data in the specified column will be 
displayed in the event table. If "…" appears in the specified column of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view.  

➢ Export: If you select "Packets", set the operating status of the 
oscilloscope to "STOP". Click Export, the save setting menu is 
displayed. You can export the data table of the packets to the internal 
or external USB storage device (when detected) in CSV format. For 
detailed saving operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
6. Interpret the decoded FlexRay frame data 

⚫ TSS: transmission start sequence, displayed as a pink patch. 
⚫ Sync Frame: displayed as a pink patch.   

⚫ ID (Frame ID): expressed in Hex, displayed as a blue-green patch. 
⚫ PL (Payload Length): expressed in Hex, displayed as a dark blue patch.  
⚫ HCRC (Header Cyclic Redundancy Check): expressed in Hex, displayed as a 

yellow-green patch. When CRC error occurs, it is displayed as a red patch. 
⚫ CYC (Cycle Number): expressed in Hex, displayed as a light blue patch. 
⚫ Data: Its display format is the same as that of the bus data (Hex, Dec, Bin, 

or ASCII), displayed as a green patch. 
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⚫ TCRC (Tail Cyclic Redundancy Check): expressed in Hex, displayed as a 
yellow-green patch. When CRC errors occur, it is displayed as a red patch. 
 
 

 
 

 
 
 
 

 

I2S Decoding (Option) 
The oscilloscope samples the I2S signal and judges each data point as logic "1" or 
logic "0" according to the preset threshold level. I2S decoding is required to specify 
the serial clock, channel signal, and the data's source channel. You need to set 
Alignment, WS Low, and other parameters. 
 
In the decode setting menu, click Decode1 → Bus Type to select "I2S".  

 
1. Enable or disable the bus 

Click Bus Status continuously to enable or disable the decoding function. 
 

2. Quickly apply I2S trigger settings to I2S decoding 
Click Copy Trig to copy the I2S trigger settings and apply them to I2S decoding 
function (set the corresponding I2S decoding parameters automatically).  
 

3. Source Setting 
Click Sources to enter the source setting menu. 
 
⚫ Set the serial clock channel source, threshold, and clock edge 

➢ Click SCLK to select the desired channel. The available channels 
include CH1-CH4. 

 
➢ Click SCLK Thre below SCLK, then use the pop-up numeric keypad or 

scroll with the mouse to set the threshold of the SCLK. When you 
modify the threshold of the clock channel, a dotted line displaying the 
current threshold level is displayed on the screen. The dotted line 
disappears in about 2 s after you stop modifying the threshold. 

 

➢ Click SCLK Edge continuously to select "Rising( )" or "Falling( )" 
as the desired clock edge. 

 
⚫ Set the WS source and the threshold 

➢ Click WS to select the desired channel. The available channels include 

    TSS  Sync Frame Frame  PL  HCRC   CYC  Data             TCRC  
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CH1-CH4. 
 

➢ Click WS Thre below WS, then use the pop-up numeric keypad or 
scroll with the mouse to set the threshold of the WS signal. When you 
modify the WS threshold, a dotted line displaying the current threshold 
level is displayed on the screen. The dotted line disappears in about 2 s 
after you stop modifying the threshold. 
 

⚫ Set the data channel source and the threshold 
➢ Click Data to select the desired data channel source. The available 

channels include CH1-CH4. 
 

➢ Click Data Thre below Data, then use the pop-up numeric keypad or 
scroll with the mouse to set the threshold of the data signal. When you 
modify the threshold of the data signal, a dotted line displaying the 
current threshold level is displayed on the screen. The dotted line 
disappears in about 2 s after you stop modifying the threshold. 

 
4. Bus Setting 

Click Settings to enter the bus setting menu. 
 
⚫ Set the word size 

Click Word Size, then use the pop-up numeric keypad or scroll with the 
mouse to set the word size. Its range is from 4 to 32. 

 
⚫ Set the receiver word size 

Click Receive, then use the pop-up numeric keypad or scroll with the 
mouse to set the receiver word size. Its range is from 4 to 32. 

 
⚫ Alignment 

Click Alignment to select the alignment way for data signal. The available 
alignment ways include I2S, LJ, and RJ. 
 

⚫ Set the WS Low 
Click WS Low continuously to select "Left" or "Right". 
 

⚫ Endian 
Click Endian to select "LSB" or "MSB". By default, it is "MSB". 
 

⚫ Polarity setting 

Click Data Polarity continuously to select Positive  or Negative  as 
the polarity for data decoding. 
 

5. Display-related setting 
Click Display to enter the display setting menu. 
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⚫ Set the display format 
Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus. 

 
⚫ Set the label display 

Click Label to enable or disable the label display of the I2S decoding bus. 
When enabled, the bus label "I2S" will be displayed at the upper-left side of 
the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded left channel data, right channel data, the 
corresponding line number, and time.  
 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-14. You can 

click on the icon  at the upper-right corner of the table to close the 
event table. Besides, when the operating status is "STOP", select a 
specified line and view the corresponding decoding information. 
 
 

  
Figure 11-14 I2S Decoding Event Table 

Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

Line Number   Time  Left Channel Data  Right Channel Data 

Event Table 
 
 
 

 
I2S Bus 
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on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

➢ Set the event table format: Click Format to select the display format of 
"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also tap "Packets", "Details", or "Payload" at the top 
of the event table to select it. 
If you select "Packets", the decoded data, time, and other information 
are displayed in the event table. If you select "Details", the detailed 
data in the specified row will be displayed in the event table. If "…" 
appears in the row of data, it indicates that the decoded data are not 
fully displayed. At this time, you can view the details in the "Packets" 
view. If you select "Payload", all data in the specified column will be 
displayed in the event table. If "…" appears in the specified column of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view.  

➢ Export: If you select "Packets", you can export time and the 
corresponding decoded data. Set the operating status of the 
oscilloscope to "STOP". Click Export, the save setting menu is 
displayed. You can export the data table of the packets to the internal 
or external USB storage device (when detected) in CSV format. For 
detailed saving operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 

 
 

1553B Decoding (Option) 
The oscilloscope samples the 1553B signal, and judges each data point to be logic 
"1" or logic "0" according to the preset threshold level. 1553B decoding is required to 
specify the data channel source and the threshold. 
 
In the decode setting menu, press Decode1 → Bus Type to select "1553B".  
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1. Enable or disable the bus 
Click Bus Status continuously to enable or disable the decoding function. 
 

2. Quickly apply 1553B trigger settings to 1553B decoding 
Click Copy Trig to copy the 1553B trigger settings and apply them to 1553B 
decoding function (set the corresponding 1553B decoding parameters 
automatically).  
 

3. Set the data channel source and the threshold 
 
⚫ Click Data to select the desired data channel source. The available 

channels include CH1-CH4. 
 

⚫ Click Threshold, then use the pop-up numeric keypad or scroll with the 
mouse to set the threshold of the source channel. When you modify the 
threshold of the channel, a dotted line displaying the current threshold level 
is displayed on the screen. The dotted line disappears in about 2 s after you 
stop modifying the threshold. 

 
4. Display-related setting 

Click Display to enter the display setting menu. 
 
⚫ Set the display format 

Click Format to select the display format of the bus data. The available 
display formats of the bus data are "Hex", "Dec", "Bin", and "ASCII". 
 

⚫ Adjust the vertical position of the bus 
Click Position, and then place the mouse cursor over the menu to scroll 
with the mouse or drag the decode label at the left side of the screen to 
adjust the vertical display position of the bus.  

 
⚫ Set the label display 

Click Label to enable or disable the label display of the 1553B decoding bus. 
When enabled, the bus label "1553B" will be displayed at the upper-left side 
of the bus (when the bus display is enabled). 
 

⚫ Event table 
Click Event Table to enter the event table setting menu. The event table 
displays the detailed decoding information in time order in the form of a 
table, so as to better observe the long decoded data. The decoding 
information includes the decoded data, word type, the corresponding line 
number, time, and error information.  
 
➢ Open or close the event table: Click Event Table continuously to 

enable or disable the event table. When you enable the event table, 
the following figure is displayed, as shown in Figure 11-15. You can 
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click on the icon  at the upper-right corner of the table to close the 
event table. Besides, when the operating status is "STOP", select a 
specified line and view the corresponding decoding information. 
 
 
 

  
Figure 11-15 1553B Decoding Event Table 

 
Note: 
⚫ When you adjust the horizontal time base, the waveform displayed 

on the screen will also change, and the total number of lines 
containing the decoding information in the event table will also be 
changed.  

⚫ The displayed decoded data information in the bus is related to the 
value of the horizontal time base. Reducing the horizontal time 
base can help you view the detailed information.  

 
➢ Set the event table format: Click Format to select the display format of 

"Data" in the event table. The available formats include "Hex", "Dec", 
"Bin", and "ASC". 

➢ Set the view type: Click View to select the form of the event table to 
be viewed. The available choices include "Packets", "Details", and 
"Payload". You can also click the "Packets", "Details", or "Payload" tab 
at the top of the event table to select it. 
If you select "Packets", the decoded data, time, and other information 
are displayed in the event table. If you select "Details", the detailed 
data in the specified row will be displayed in the event table. If "…" 
appears in the row of data, it indicates that the decoded data are not 
fully displayed. At this time, you can view the details in the "Packets" 
view. If you select "Payload", all data in the specified column will be 
displayed in the event table. If "…" appears in the specified column of 
data, it indicates that the decoded data are not fully displayed. At this 
time, you can view the details in the "Packets" view.  

Line Number  Time  Word Type  Data       Error 

Event Table 
 
 
 

 
 

1553B Bus 
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➢ Export: If you select "Packets", you can export time and the 
corresponding decoded data. Set the operating status of the 
oscilloscope to "STOP". Click Export, the save setting menu is 
displayed. You can export the data table of the packets to the internal 
or external USB storage device (when detected) in CSV format. For 
detailed saving operation, refer to descriptions in "Store and Load". 

➢ Jump to: Set the operating status of the oscilloscope to "STOP". Then, 
select the data of the specified time from the event table. Click Jump 
to and the specified data waveforms are displayed in the center of the 
screen. 

➢ Decode: The setting of this menu enables you to quickly view the 
corresponding event tables of four decode modules (Decode1, 
Decode2, Decode3, and Decode4). Click Decode to select a decode 
module. 
 

5. Interpret the decoded 1553B data 
⚫ C/S: command/status word. It is displayed as a blue-green patch.  
⚫ RTA: remote terminal address of the command/status word. It is displayed 

as a tangerine patch.  

⚫ C/S data: the rest data value of the command/status word. Its display 

format is the same as that of the bus data (Hex, Dec, Bin, or ASCII), 

displayed as a green patch. 

⚫ Parity bit: displayed as a yellow-green patch; when errors occur, displayed 

as a red patch.  

⚫ Data word data: data of the data word. Its display format is the same as 

that of the bus data (Hex, Dec, Bin, or ASCII), displayed as a green patch. 

 

 
 

 
 
 C/S Word    RTA         C/S Data  Parity Bit Data Word    Data Word Data  Parity Bit 
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Chapter 12 Reference Waveform 
 
DS8000-R series oscilloscope provides 10 reference waveform positions (Ref1-Ref10). 
In the actual test process, you can compare the signal waveform with the reference 
waveform to locate the failure. 
 
Contents in this chapter: 
◼ To Enable Ref Function 
◼ To Select the Reference Channel 
◼ To Select the Ref Source 
◼ To Adjust the Ref Waveform Display 
◼ To Save to Internal Memory 
◼ To Clear the Display of the Reference Waveform 
◼ To View Details of the Reference Waveform 
◼ To Reset the Reference Waveform 
◼ Color Setting 
◼ Label Setting 
◼ To Export to Internal or External Memory 
◼ To Import from Internal or External Memory 
◼ Binary Data Format (.bin) 
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To Enable Ref Function 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then click on the "Ref" icon  to enable the 
reference waveform function. 
 
When the Ref function is enabled, you can select a different color for each reference 
waveform, set the source of each reference channel, adjust the vertical scale and 
offset of the reference waveform, save the reference waveform to the internal or 
external memory, and recall it when needed.  
 
Note: When the horizontal time base is set to XY, the reference waveform function is 
disabled. 
 
 

To Select the Reference Channel 
 
Click Current to select the desired reference waveform channel (Ref1-Ref10). Ref1 
is enabled by default. 
 
 

To Select the Ref Source 
 
Click Source to select the desired reference waveform source (CH1-CH4 or 
Math1-Math4).  
 
Note: Only the currently enabled channel can be selected as the source channel of 
the reference waveform. 

 
 

To Adjust the Ref Waveform Display 
 
After clicking SaveToRef, you can adjust the vertical scale and offset of the 
reference waveform specified under Current. 
 
⚫ Click VScale, then use the pop-up numeric keypad or scroll with the mouse to 

set the vertical scale of the reference waveform.  
⚫ Click VOffset, then use the pop-up numeric keypad or scroll with the mouse to 

set the vertical offset of the reference waveform. 
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To Save to Internal Memory 
 
Click SaveToRef to save the displayed waveform for the specified source to the 
internal memory as the reference waveform. 
 
Note: This operation only saves the reference waveform to the volatile memory, and 
the waveform will be cleared at power-off. 
 
 

To Clear the Display of the Reference Waveform 
 
Click Clear to clear the display of the current reference waveform on the screen. 
Meanwhile, the VScale and VOffset menus for the reference waveform are grayed 
out and disabled.  
 
Note: This operation only clears the display of the reference waveform on the screen, 
and the reference waveform is still saved in the memory.  
 
 

To View Details of the Reference Waveform 
 
Click More → Details, and the detailed information about all the reference 
waveforms will be displayed on the screen in the form of a list. Click Details again to 

close the details list. You can also click on the icon  at the right-upper corner of 
the table to close it. 
 

 
 
 

To Reset the Reference Waveform 
 
Click More → Reset, and the reference waveform is restored to the position where 
the source channel waveform is located when the SaveToRef operation was 
executed. 
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Color Setting 
 
DS8000-R series oscilloscope provides five colors (gray, green, blue, red, and orange) 
to mark the reference waveforms of different channels in order to distinguish the 
reference waveforms of different reference waveform channels. 
 
Click Color to select the color of the reference waveform of the channel. The GND 
icon and the label at the left side of the waveform of the currently selected channel 

will be filled with the specified color. For example,  and . 
 
 

Label Setting 
 
Click More → Label to enter the label setting menu. You can use the built-in label in 
the library or manually input a label. Three input methods are available for you to 
input a label name, including Chinese, English, and Traditional Chinese. 
⚫ Click Display continuously to enable or disable the display of the reference 

waveform label. If it is enabled, the label will be displayed at the left side of the 
waveform. If the current channel is REFn (n=1,2, …10), then the default label of 
the reference waveform is REFn (n=1, 2, …10). 

 
⚫ Click Library to select the preset label. The available preset labels include 

Default, ACK, ADDR, BIT, CLK, and etc. 
 
⚫ Click Label, and the label editing interface is automatically displayed. You can 

input the label manually. For the label editing methods, refer to descriptions in 
"Channel Label". 

 
 

To Export to Internal or External Memory 
 
You can also save the current reference waveform to the internal memory or external 
USB storage device. The file format of the reference waveform is ".ref", ".bin", or 
".csv". 
 
Click More → Export to enter the reference waveform file saving interface. Please 
refer to descriptions in "Store and Load" to save the reference waveform to the 
internal or external memory. Only when the reference waveform is saved, can this 
export function be valid. 
 
Note: DS8000-R series oscilloscope only supports the flash memory USB storage 
device of FAT32 format. 
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To Import from Internal or External Memory 
 
You can also import the stored reference waveform file from the internal memory or 
external USB storage device to the instrument and display the file on the screen. 
 
Click More → Import to enter the reference waveform file loading interface. Please 
refer to descriptions in "Store and Load" to import the reference waveform to the 
instrument and display it on the screen. 
 
Note: DS8000-R series oscilloscope only supports the flash memory USB storage 
device of FAT32 format. 
 
 

Binary Data Format (.bin) 
 

Binary data format stores waveform data in binary format and provides data headers 
that describe these data. As data is displayed in binary format, its file size is much 
smaller than the ASCII format. If several channels are enabled, then all the displayed 
channels will be saved (save the first channel then save the second, and then it goes 
on like this until all the displayed channels are saved). 
 

In BIN file format, the data are displayed as follows: 
― CH1 data 
― CH2 data 
― CH3 data 
― CH4 data 

― Digital Channel Data 
― Math Waveform Data 
 
 

Binary Header Format 
 

1. File Header 
There is only one file header in a binary file. The file header contains the 
following information. 
 

Cookie Two-byte characters, RG, indicating that the file is the RIGOL 
binary data file format. 

Version Two bytes, indicating the file version. 

File Size A 4-byte integer, indicating the number of bytes in the file. It 
includes the header. 

Number of 
Waveforms 

A 4-byte integer, indicating the number of waveforms that are 
stored in the file. 
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2. Waveform Header 
It is possible to store several waveforms in the file. Each stored waveform has a 
waveform header. When several channels are stored, each channel can be 
considered as a separate waveform. The waveform header contains the 
information about the type of waveform data that are stored following the 
waveform data header. 
 

Header Size A 4-byte integer, indicating the number of bytes in the 
header. 

Waveform 
Type 

A 4-byte integer, indicating the type of the waveform stored 
in the file. 
0 = Unknown 
1 = Normal 
2 = Peak Detection 
3 = Average 
4 = Not Used 
5 = Not Used 
6 = Logic 

Number of 
Waveform 
Buffers 

A 4-byte integer, indicating the number of waveform buffers 
required to read the data. 

Number of 
Points 

A 4-byte integer, indicating the number of waveform points in 
the data. 

Count A 4-byte integer, indicating the number of hits at each time 
interval during waveform recording when using a certain 
sample mode (e.g. Average) to create the waveforms. For 
example, when averaging, a count of 4 indicates that each 
waveform data point in the waveform recording has been 
averaged at least 4 times. The default value is 0. 

X Display 
Range 

A 4-byte float, indicating the X-axis duration of the waveform 
that is displayed. For time-domain waveforms, 
it indicates the duration of time across the display. If the 
value is zero, then no data has been acquired. 

X Display 
Origin 

A 8-byte double, indicating the X-axis value at the left edge of 
the screen. For time-domain waveforms, it indicates the time 
at the start of the display. The value is treated as a double 
precision 64-bit float point number. If the value is zero, then 
no data has been acquired. 

X Increment A 8-byte double, indicating the duration between data points 
on the X axis. For time-domain waveforms, 
it indicates the time between points. If the value is zero, then 
no data has been acquired. 

X Origin A 8-byte double, indicating the X-axis value of the first data 
point in the data recording. For time-domain waveforms, it 
indicates the time of the first point. The value is treated as a 
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double precision 64-bit float point number. If the value is 
zero, then no data has been acquired. 

X Units A 4-byte integer, indicating the unit of measurement for X 
values in the acquired data. 
0 = Unknown 
1 = Volts (V) 
2 = Seconds (s) 
3 = Constant 
4 = Amps (A) 
5 = dB 
6 = Hz 

Y Units 
 

A 4-byte integer, indicating the unit of measurement for Y 
values in the acquired data. The possible values are listed 
above under X Units. 

Date A 16-byte character array, not used 

Time A 16-byte character array, not used 

Frame A 24-byte character array, indicating the model number and 
serial number of the oscilloscope in the format: 
MODEL#:SERIAL#. 

Waveform 
Label 

A 16-byte character array that contains the label assigned to 
the waveform. 

 
3. Waveform Data Header 

A waveform may have multiple data sets. Each waveform data set has a 
waveform data header. The waveform data header consists of information about 
the waveform data set. The header is stored before the data set. 
 

Header Size A 4-byte integer, indicating the number of bytes in 
the waveform data header. 

Buffer Type 
 

A 2-byte integer, indicating the type of the 
waveform data stored in the file. 
0 = Unknown 
1 = Normal 32-bit float data 
2 = Maximum float data 
3 = Minimum float data 
4 = Not Used 
5 = Not Used 
6 = Digital unsigned 8-bit character data (for 
digital channels) 

Bytes Per Point A 2-byte short integer, indicating the number of 
bytes per data point. 

Buffer Size A 4-byte integer, indicating the size of the buffer 
required to hold the data points. 

 
Note: DS8000-R series does not support the digital channel. 
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Chapter 13 Pass/Fail Test 
 
During the product design and manufacturing process, you usually need to monitor 
the variations of the signal or judge whether the product is up to standard. The 
pass/fail test function of DS8000-R series oscilloscope can accomplish this task 
perfectly. 
 
Contents in this chapter: 
◼ To Enable or Disable the Pass/Fail Test 
◼ To Start or Stop the Pass/Fail Test Operation 
◼ To Select the Source 
◼ To Create a Mask 
◼ To Save a Mask 
◼ To Load a Mask 
◼ To Set the Output Form of the Test Results 
◼ To Enable or Disable the Display of the Statistics of the Test Results 
◼ Statistics Reset 
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To Enable or Disable the Pass/Fail Test Function 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Pass/Fail" icon  to open the 
pass/fail test setting menu. 
 
In the menu, click Enable continuously to enable or disable the pass/fail test 
function. 
 

Note: The pass/fail test function cannot be enabled in the following conditions: 
when the time base mode is "XY" or "ROLL"; when the delay sweep is enabled. 
 
 

To Start or Stop the Pass/Fail Test Operation 
 
After the Pass/Fail test function is enabled, click Operate continuously to start or 
stop the test operation. 
 
During the test process, the oscilloscope will test the waveforms, display the test 
information, and output the test failure information based on the current settings. 
You can set the test mask, the display status of the test information, and the output 
form of a failed test based on the selected source channel for the test. Then save the 
test mask range to the internal or external memory, and then recall it when needed. 
For the details, please refer to the following section. 
 
Note: 
⚫ Only when the pass/fail test function is enabled, can you start or stop the 

pass/fail test operation, enable or disable the display of the test information, 
save and recall the test mask range. 

⚫ After starting the test operation, you can neither modify the source channel nor 
adjust the test mask. 

 
 

To Select the Source 
 
Before selecting the source, connect the signal under test to the analog channel 
input terminal of the oscilloscope. Click Source to select the desired source channel. 
The available source channels include the analog channel (CH1-CH4). 
Note: Only the channels that have been enabled currently can be selected. 
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To Create a Mask 
 
Click Mask → Create to self-define the mask of the pass/fail test. Click Range to 
select the mask range. You can select "Screen" or "Cursor" as the mask region. The 
default is "Screen". 
⚫ If "Screen" is selected under Range, then the whole waveform display area is 

considered to be the mask region. Click X Mask and Y Mask respectively. Use 
the pop-up numeric keypad or scroll with the mouse to adjust the horizontal 
tolerance range and vertical tolerance range of the test mask. During the 
adjustment, two white curves would be displayed in the interface to show the 
outline of the current mask. Click Create to apply the currently created mask 
(the region not covered by blue within the screen). 

 
⚫ When "Cursor" is selected, two cursors (used to specify the current test mask 

range) will be displayed on the screen. Cursor A is at the left and Cursor B is at 

the right. Click CursorA and CursorB respectively, and scroll with the mouse to 

adjust the positions of both Cursor A and Cursor B. Also you can click CursorAB 

and scroll with the mouse to adjust the two cursors synchronously (the spacing 

between Cursor A and Cursor B remains unchanged). Then, refer to the above 

methods to adjust the horizontal and vertical tolerance ranges, as well as create 

a mask (the region not covered by blue within the cursor region). 

 
 

To Save a Mask 
 
When the pass/fail test function is enabled, you can save the current test mask range 
to the internal memory or external USB storage device (when detected) in "*.pf" 
format.  
 
Click Mask → Save to enter the file saving interface. Please refer to descriptions in 
"Store and Load" to save the test mask file to the internal or external memory. 
 
 

To Load a Mask 
 
When the pass/fail test function is enabled, you can load the test mask files from the 
internal memory or external USB storage device (when detected) and apply them to 
the current pass/fail test function. 
 
Click Mask → Load to enter the file loading interface. Please refer to descriptions in 
"Store and Load" to load the specified test mask files (in *.pf format) and apply 
them to the current pass/fail test function. 
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To Set the Output Form of the Test Results 
 
Click Option to enter the "Option" menu. You can set what the oscilloscope will 
execute when test results are detected according to your needs. 
 
⚫ Set the output event and Aux output 

➢ Click Output Event to select "Fail" or "Pass". 
➢ Click Aux Output continuously to enable or disable the Aux output. If 

enabled, open the function navigation menu, and then click Utility → 
System, and then the AUX Out is automatically set to "PassFail". When a 
successful or failed event is detected, a pulse will be output from the 
rear-panel [TRIG OUT] connector. If the Aux output is disabled, click 
Utility → System, and then the AUX Out is automatically set to "TrigOut". 
The output of the rear-panel [TRIG OUT] connector is irrelevant with the 
pass/fail test. 
 

⚫ Set the output polarity and output pulse width 
Click Polarity continuously to select "Positive" or "Negative". Then click Pulse, 
use the pop-up numeric keypad or scroll with the mouse to set the pulse width. 
Its range is from 100 ns to 10 ms. By default, it is 1 μs. 
 

⚫ Set the error action 
Click Err Action to set the operation that the oscilloscope will execute once a 
failed test is detected.  
➢ Stop: indicates stopping test when a failed test event is found. 
➢ Beeper: indicates that the beeper sounds an alarm when a failed test 

event is found (irrelevant with the on/off status of the beeper). 
➢ Screenshot: performs the screenshot operation when a failed test event is 

found. If an external storage device is detected, the screenshot will be 
saved to the external storage device directly. Otherwise, it will be saved to 
the local disk. 
Note: If "Screenshot" is selected under Err Action, the test will be 
stopped forcibly. After capturing the screenshot, the test will continue. 

 
 

To Enable or Disable the Display of the Statistics 
of the Test Results 
 
Click Information continuously to enable or disable the display of the statistics of 

the test results. You can also click on the icon  at the right-upper corner of the 
statistics window to close it. 
 
The test results statistics include the number of failed frames, the number of 
successful frames, and total number of frames, as shown in the figure below. 
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Statistics Reset 
 
Click Reset to clear the current test results and execute statistics on the test results 
again. 
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Chapter 14 Waveform Recording & Playing 
 
Waveform recording & playing function can play the recorded waveforms of the 
analog input channels (CH1-CH4), enabling you to analyze the waveforms better.  
 
Note: The horizontal time base must be set to "YT" mode during waveform 
recording. 
 
Contents in this chapter: 
◼ Common Settings 
◼ Record Options 
◼ Play Options 
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Common Settings 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Record" icon  to open the 
waveform recording function setting menu. 
 
1. Waveform Recording 

Click Record continuously to enable the waveform recording function. Before 
recording the waveform, you can refer to descriptions in "Record Options" to 
set the waveform recording parameters. Click Record to start recording the 

waveform. The record icon turns " " from " " automatically. During the 
recording, the current real-time recording information is displayed on the screen, 
as shown in Figure 14-1. In the figure, the data at the left side of the slash is the 
current frame. Its value changes constantly (the value under the Current menu 
is changing constantly too), and the data at the right of the slash indicate the 
number of frames for recording. The time difference △T at the upper-right 

corner indicates the time different between the current frame and the first frame. 

After the recording is completed, " " automatically turns out to be " ". The 
recording is stopped automatically. During the recording, you can double-click 
any place on the screen to stop recording manually.  
 

 

 
 
 
 

Figure 14-1 Recording Process Information 
2. Play 

Click Playing to start playing the recorded waveforms. " " automatically turns 

out to be " ". For details about playing, refer to descriptions in "Play Options". 
During the waveform recording, the current frame changes accordingly (the 
value of the parameter Current changes accordingly). After playing is 

completed, " " automatically turns out to be " " automatically. During the 
playing process, you can also double-click any place on the screen to stop 
playing manually. 

 
3. Current Frame 

Click Current, then use the pop-up numeric keypad or scroll with the mouse to 
set the current frame. At this time, the waveform of the current frame is 
displayed on the screen. 
 

Time Difference 

 Current Frame   Recording Frames 
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4. Set Transition 

Click Jump To continuously to select to jump to the recorded end frame ( Last) 

or the recorded start frame ( First). For settings of the start and end frames, 
refer to descriptions in "Play Options". 

 
 

Record Options 
 
During the waveform recording, the oscilloscope records the waveforms of the 
currently enabled channel at a specified interval until you manually stop the 
recording operation or the number of recorded frames has reached the set value. 
 
Note: Before starting the recording operation, turn on the desired channel and 
adjust the waveform display to the desired state. When starting the recording 
operation, you can neither enable/disable the channel output nor adjust the 
waveform display. 
 
Before recording the waveforms, you can click More → Setting to select "Record" 
to set the following parameters. 
 
1. Recording Interval 

The recording interval indicates the time interval between the frames during the 
recording process. 
Click Interval, then use the pop-up numeric keypad or scroll with the mouse to 
set the time interval between frames. The available range is from 10 ns to 10 s. 

 
2. Recording Frames 

The recording frames refer to the number of frames that can be recorded 
actually. After starting the recording operation, the oscilloscope stops the 
recording operation automatically when the number of recorded frames reaches 
the set value. 
Click Frames, then use the pop-up numeric keypad or scroll with the mouse to 
set the number of recorded frames. The available range is from 1 to the 
maximum number of frames that can be recorded currently (available in the 
Max Frames menu). Click Set to Max to set the number of recorded 
waveform frames to the maximum number of frames automatically. 
 

3. Max Frames 
The menu shows the maximum number of frames that can be recorded currently. 
As the capacity of the waveform memory is fixed, the more the number of points 
each frame of waveform has, the less the number of waveform frames that can 
be recorded. Therefore, the maximum number of recorded frames is related to 
the currently selected "memory depth" (refer to "Memory Depth"). The 
current memory depth refers to the number of waveform points per frame. 
Memory Depth = Sample Rate x Horizontal Time Base x Number of Grids in the 
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Horizontal Direction. Therefore, the maximum number of frames of waveform 
recording is also related to the "Sample Rate" and "Horizontal Time Base". This 
oscilloscope provides ceaseless recording for a maximum of 450,000 frames of 
real-time waveforms. 

 
4. Beeper 

Click Beeper continuously to set whether the beeper sounds when the 
recording is completed. 

⚫ : the beeper sounds at the end of recording. 

⚫ : the beeper does not sound at the end of recording. 
 
 

Play Options 
 
Waveform playing function can play back the waveforms currently recorded. Before 
playing back the waveforms, you can click More → Setting to select "Play" to set 
the following parameters. 
 
1. Play Mode 

Click Mode continuously to set the playback mode to  (cycle) or  
(single). 

⚫ : plays back repeatedly until you stop it manually. 

⚫ : plays for a single time, and then stops automatically. 
 

2. Playback Sequence 

Click Sequence continuously to select the playback sequence to  (playback 

clockwise) or  (playback counterclockwise). 

⚫ : plays from the start frame to the end frame. 

⚫ : plays from the end frame to the start frame. 
 

3. Playback Interval 
The playback interval indicates the time interval between the frames during the 
playing process. 
Click Interval, then use pop-up numeric keypad or scroll with the mouse to set 
the time interval between frames. The available range is from 5 ms to 10 s. 

 
4. Start Frame 

Click Start Frame, then use pop-up numeric keypad or scroll with the mouse to 
set the start frame for playing back the waveforms. 
 

5. End Frame 
Click End Frame, then use pop-up numeric keypad or scroll with the mouse to 
set the end frame for playing back the waveforms. 
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Chapter 15 Search and Navigation 
Function 
 
The search function allows you to search for relevant events based on the search 
condition that you set. The navigation function includes the recording & playing 
navigation, time navigation, and event navigation. 
 
Contents in this chapter: 
◼ Search Function 
◼ Navigation Function 
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Search Function 
 
The search function enables you to search the channel edge, Pulse trigger, Runt 
trigger, Slope trigger, RS232 trigger, I2C trigger, or SPI trigger. Click on the function 

navigation icon  at the lower-left corner of the screen to open the function 

navigation. Then, click on the "Search" icon  to open the search setting menu. 
 

To Enable or Disable the Search Function 
 
Click Search continuously to enable or disable the search function. 
 
 

To Select the Search Type and Set the Parameters 
 
Click Type to select the desired type (Edge, Pulse, Runt, Slope, RS232, I2C, or SPI).  
⚫ Edge: Click Type to select "Edge" as the search type. For Edge Set menu 

settings, refer to descriptions in "Edge Trigger". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set the threshold. 

 
⚫ Pulse: Click Type to select "Pulse" as the search type. For Pulse Set menu 

settings, refer to descriptions in "Pulse Trigger". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set the threshold. 

 
⚫ Runt: Click Type to select "Runt" as the search type. For Runt Set menu 

settings, refer to descriptions in "Runt Trigger". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set Threshold A and Threshold B. 

 
⚫ Slope: Click Type to select "Slope" as the search type. For Slope Set menu 

settings, refer to descriptions in "Slope Trigger". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set Threshold A and Threshold B. 

 
⚫ RS232: Click Type to select "RS232" as the search type. For RS232 Set menu 

settings, refer to descriptions in "RS232 Trigger (Option)". Click Threshold 
to enter the threshold setting menu. Use the pop-up numeric keypad or scroll 
with the mouse to set the threshold. 

 
⚫ I2C: Click Type to select "I2C" as the search type. For I2C Set menu settings, 

refer to descriptions in "I2C Trigger (Option)". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set the thresholds of SCL and SDA. 
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⚫ SPI: Click Type to select "SPI" as the search type. For SPI Set menu settings, 
refer to descriptions in "SPI Trigger (Option)". Click Threshold to enter the 
threshold setting menu. Use the pop-up numeric keypad or scroll with the 
mouse to set the thresholds of CLK, MISO, and CS. 

 
 

To Copy Trigger  
 
⚫ Copy to Trigger 

Click More → To Trigger to copy the selected search type to the same trigger 
type. For example, if the current search type is "Edge", click To Trigger to copy 
the edge search settings to the "Edge Trigger" settings. 

  
⚫ From Trigger 

Click More → From Trigger to copy from the trigger settings of the selected 
search type to the search settings. For example, if the current trigger type is 
"Edge Trigger", click From Trigger to copy from the Edge trigger settings to 
the "Edge" search settings.  
Note: If you select "From Trigger", you need to set the search type first, and 
then copy the trigger type settings from the trigger menu. 

 
 

To Open or Close the Mark Table 
 
Click MarkTable continuously to enable or disable the display of the mark table. The 

mark table is shown as below. You can also click on the icon  at the right-upper 
corner of the table to close it. 
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To Navigate 
 
Click Navigation, then use the pop-up numeric keypad or scroll with the mouse to 
set the event No. to navigate the event. You can also use the Web Control method to 
make navigations at a step of 1. For details, refer to descriptions in "Navigation 
Function". 
 
 

To Save 
 
You can save the event mark data to the internal memory or external USB storage 
device in "*.csv" format. 

 
Click More → Save events to enter the file saving interface. Please refer to 
descriptions in "Store and Load" to save the event mark data to the internal or 
external memory. 
 
Note: DS8000-R only supports the flash memory USB storage device of FAT32 
format. 
 
 

Navigation Function 
 
When you control the oscilloscope in the Web Control mode, you can click the Pre, 
NSTop, or Next keys at the right side of the operation interface to realize the 
navigation function. The navigation function includes the recording & playing 
navigation, time navigation, and event navigation. 
 
⚫ Recoding & Playing Navigation 

When you enable the waveform recording function and complete the waveform 
recording operation, you can play the recorded waveforms by clicking the 
navigation keys. Click the Pre key to play the recorded waveforms in reverse 
order; click the Next key to play the recorded waveforms in normal order; click 
the NStop key to stop playing. 
 

⚫ Time Navigation 
After the data acquisition stops, you can play the captured data waveforms in a 
fast and continuous way. Click the Pre key to play the previous recorded 
waveforms; click the Next key to play the next recorded waveforms; click the 
NStop key to stop playing. Besides, click the Pre key or the Next key 
repeatedly can accelerate the playing of the waveforms, so that you can quickly 
locate the acquired data waveforms. 
 
Note: The time navigation function is only available when the time base mode is 

"YT" and the instrument stays in "STOP" status. 
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⚫ Event Navigation 
When you enable the navigation function and complete the event search, you 
can use the navigation combination keys to quickly navigate the specific event in 
the event mark table. Click the Pre key to navigate to the previous event (the 
serial number in the mark table decreases); click the Next key to navigate to 
the next event (the serial number in the mark table increases); the NStop key 
does not work for the event navigation. 
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Chapter 16 Display Control 
 
In the display control setting menu, you can set the parameters such as the 
waveform display type, persistence time, intensity, grid type, grid brightness, and 
etc. 
 
Contents in this chapter: 
◼ To Select the Display Type 
◼ To Set the Persistence Time 
◼ To Set the Waveform Intensity 
◼ To Set the Screen Grid 
◼ To Set the Grid Brightness 
◼ Scale 
◼ Color Grade 
◼ Waveform Freeze 
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To Select the Display Type 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then, click on the "Display" icon  to open the 
display setting menu. Click Type continuously to set the waveform display mode to 
"Vector" or "Dots". 
 
⚫ Vector display: indicates that the sample points are connected by lines and 

displayed. In most cases, this mode can provide the most vivid waveform for you 
to view the steep edge of the waveform (such as square waveform). 

⚫ Dots display: displays the sample points directly. You can directly view each 
sample point and use the cursor to measure the X and Y values of the sample 
point. 

 
 

To Set the Persistence Time 
 
Click Persis.Time to set the persistence time for the oscilloscope. The available 
values are Min, 100 ms, 200 ms, 500 ms, 1 s, 2 s, 5 s, 10 s, and Infinite. 
 
The following part introduces the waveform effects of a Sine wave frequency sweep 
signal in a different persistence time. 
 
1. Min 

Enables to view waveform changing in high refresh rate. 
 

2. Specific Values 
Enables to view glitches that change relatively slowly or glitches with lower 
occurrence probability. The persistence time can be set to 100 ms, 200 ms, 500 
ms, 1 s, 2 s, 5 s, or 10 s. 
 

3. Infinite 
In this mode, the oscilloscope displays the waveform newly acquired without 
clearing the waveforms acquired formerly. The waveforms acquired formerly will 
be displayed in relatively low-brightness color and the newly acquired 
waveforms will be displayed in normal brightness and color. Infinite persistence 
can be used to measure noise and jitter and to capture incidental events. 
 

 

To Set the Waveform Intensity 
 
Click Intensity, then use the pop-up numeric keypad or scroll with the mouse to set 
the waveform intensity. The default is 50%, and the range available is from 1% to 
100%. 
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To Set the Screen Grid 
 
Click Grid to set the grid type. You can select "FULL", "HALF", "NONE", or "IRE". 
 
⚫ FULL: turns the background grid and coordinate on. 
⚫ HALF: turns the background grid off. 
⚫ NONE: turns the background grid and coordinate off. 
⚫ IRE: only available for testing the video signal (i.g. the trigger type is set to 

"Video" trigger, and the vertical scale is set to 140 mV). 
When "IRE" is selected, the screen displays the vertical graticule in IRE and 
marks it at the left side of the screen. Its range is from -40 IRE to +100 IRE. 
Meanwhile, 0.35 V and 0.7 V levels are displayed at the right side of the screen, 
as shown in the following figure. 
 

 
 
 

To Set the Grid Brightness 
 
Click Brightness, then use the pop-up numeric keypad or scroll with the mouse to 
set the grid intensity. The default is 20%, and the range available is from 1% to 
100%. 
 
 

Scale 
 
Click Show Scale continuously to enable or disable the scale display on the screen. 
By default, it is set to "OFF". 
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Color Grade 
 
Click More → Color Grade to enable or disable the color grade display of the analog 
channel waveforms on the screen. By default, it is set to "OFF". When enabled, 
different colors are displayed on the screen to indicate the times of data acquisition 
or acquisition probability. 
 
 

Waveform Freeze 
 
Click More → Waveform Freeze to enable or disable waveform freeze function. If 
enabled, the waveform display is frozen. The oscilloscope displays the waveform 
after multiple sampling and superposition when sampling is stopped by pressing 

RUN/STOP on the front panel. If disabled, the last triggered waveform is displayed. 
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Chapter 17 Function/Arbitrary Waveform 
Generator (Option) 
 
DS8000-R series has an optional built-in single-channel, 25 MHz signal source, which 
integrates the signal source and the oscilloscope into one, providing great 
convenience for engineers who need to use the signal source and oscilloscope at the 
same time. This chapter introduces how to use the built-in signal source. 
 
Contents in this chapter: 
◼ To Output Basic Waveforms 
◼ To Output the Arbitrary Waveform 
◼ Modulation 
◼ Sweep 
◼ Burst 
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To Output Basic Waveforms 
 

Click the AWG label  at the bottom of the screen to enable/disable the output of 
the [GEN] connector on the rear panel, and enter the Function/Arbitrary Waveform 
Generator setting interface. DS8000-R series' built-in Function/Arbitrary Waveform 
Generator can output a variety of basic waveforms, including Sine, Square, Ramp, 
Pulse, DC, Noise, Sinc, Exp.Rise, Exp.Fall, ECG, Gauss, Lorentz, Haversine, and Arb. 
 
 

To Output Sine 
 
Click Wave to select "Sine". At this time, you can set the parameters for the sine 
waveform. 
 
1. Set the frequency or period 

Click the Frequency/Period menu to select "Frequency" or "Period". Select the 
desired item, and use the pop-up numeric keypad or scroll with the mouse to set 
the frequency or period value of the current signal. Different waveforms have 
different frequency or period (reciprocal of the frequency) ranges. 
Sine: 100 mHz to 25 MHz 
Square: 100 mHz to 15 MHz 
Ramp: 100 mHz to 100 kHz 
Pulse: 100 mHz to 1 MHz 
DC and Noise: no frequency parameter. 

 
2. Set the amplitude or high level 

Click the Amplitude/High Level menu to select "Amplitude" or "High Level". 
Select the desired item, and use the pop-up numeric keypad or scroll with the 
mouse to set the amplitude or high level value of the current signal. Note that if 
you select "Amplitude" for this menu, then the menu below the Amplitude is 
automatically turns out to be "Offset"; if you select "High Level" for this menu, 
then the menu below the High Level is automatically turns out to be "Low 
Level". When Impedance is set to "HighZ", the available range of the amplitude is 
from 20 mVpp to 5 Vpp; when Impedance is set to "50Ω", the available range of 
the amplitude is from 10 mVpp to 2.5 Vpp. 
 

3. Set the offset or low level 
Click the Offset/Low Level menu to select "Offset" or "Low Level". Select the 
desired item, and use the pop-up numeric keypad or scroll with the mouse to set 
the offset or low level value of the current signal. When Impedance is set to 
"HighZ", the available range of the offset is from (-2.5 V+currently set amplitude 
value/2) to (2.5 V- currently set amplitude value/2); when Impedance is set to 
"50Ω", the available range of the offset is from (-1.25 V+currently set amplitude 
value/2) to (1.25 V- currently set amplitude value/2). 
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4. Set the start phase 
Click Start Phase, then use the pop-up numeric keypad or scroll with the mouse 
to set the start phase of the current signal. Its available range is from 0° to 360°. 

 
5. Setting options 

Click Settings to enter the setting options menu. You can set the parameters 
such as modulation, sweep, burst, and impedance. 
⚫ Modulation, sweep, and burst 

Click Type to select "None", "Modulation", "Sweep", or "Burst". For details 
about modulation, sweep, and burst, refer to descriptions in "Modulation", 
"Sweep", and "Burst".  
Note: When "Pulse", "DC", or "Noise" is selected under Wave, this menu is 
not available. 
 

⚫ Set the impedance 
Click Impedance continuously to set the output impedance of the 
Function/Arbitrary Waveform Generator. It can be set to "HighZ" or "50Ω". 

 
 

To Output Square 
 
Click Wave to select "Square". At this time, you can set the parameters for the 
square waveform. For setting methods, refer to descriptions in "To Output Sine". 
The duty cycle of the square waveform is a fixed value 50%. 
 
 

To Output Ramp 
 
Click Wave to select "Ramp". At this time, you can set the parameters for the ramp 
waveform. For setting methods, refer to descriptions in "To Output Sine". This 
section only introduces "Symmetry". 
 
Symmetry is defined as the percentage that the rising period of the ramp takes up in 
the whole period, as shown in the figure below. 

T

t Symmetry=t/T*100%

 
Figure 17-1 Symmetry Definition 
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Click Settings → Symmetry, then use the pop-up numeric keypad or scroll with 
the mouse to set the symmetry of the ramp waveform. The settable range is from 
1% to 100%. 
 
 

To Output Pulse 
 
Click Wave to select "Pulse". At this time, you can set the parameters for the pulse 
waveform. For setting methods, refer to descriptions in "To Output Sine". This 
section only introduces "Duty Cycle". 
 
Duty cycle is defined as the percentage that the high level takes up in the whole 
pulse period, as shown in the figure below. 

T

t
Duty Cycle=t/T*100%

 
Figure 17-2 Duty Cycle Definition 

 
Click Settings → Duty Cycle, then use the pop-up numeric keypad or scroll with 
the mouse to set the duty cycle of the current pulse signal. Its settable range is from 
2% to 98%. 
 
 

To Output DC 
 
Click Wave to select "DC". At this time, you can set the offset and impedance of the 
DC signal. 
 
1. Set the offset 

Click Offset, then use the pop-up numeric keypad or scroll with the mouse to 
set the offset value of the current DC signal. When the current impedance is set 
to HighZ, the settable range of offset is from -2.5 V to +2.5 V; when the 
impedance is set to 50 Ω, the settable range of offset is from -1.25 V to +1.25 V. 

 
2. Set the impedance 

Click Impedance continuously to set the output impedance of the 
Function/Arbitrary Waveform Generator. It can be set to "HighZ" or "50Ω". 
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To Output Noise 
 
Click Wave to select "Noise". At this time, you can set the amplitude/high level, 
offset/low level, and impedance of the noise signal. For detailed setting methods, 
refer to relevant contents in "To Output Sine". 
 
 

Sinc 
 
Click Wave to select "Sinc". You can set the parameters for the Sinc waveform (as 
shown in the figure below). For setting methods, refer to descriptions in "To Output 
Sine".  

 
Figure 17-3 Sinc 

 
 

Exp.Rise 
 
Click Wave to select "Exp.Rise ". At this time, you can set the parameters for the 
Exp.Rise waveform (as shown in the figure below). For setting methods, refer to 
descriptions in "To Output Sine".  

 
Figure 17-4 Exp.Rise 
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Exp.Fall 
 
Click Wave to select "Exp.Fall". At this time, you can set the parameters for the 
Exp.Fall waveform (as shown in the figure below). For setting methods, refer to 
descriptions in "To Output Sine". 
 

 
Figure 17-5 Exp.Fall 

 
 

ECG 
 
Click Wave to select "ECG". At this time, you can set the parameters for the ECG 
waveform (as shown in the figure below). For setting methods, refer to descriptions 
in "To Output Sine".  

 
Figure 17-6 ECG 

 

Gauss 
 
Click Wave to select "Gauss". At this time, you can set the parameters for the Gauss 
waveform (as shown in the figure below). For setting methods, refer to descriptions 
in "To Output Sine".  
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Figure 17-7 Gauss 

 
 

Lorentz 
 
Click Wave to select "Lorentz". At this time, you can set the parameters for the 
Lorentz waveform (as shown in the figure below). For setting methods, refer to 
descriptions in "To Output Sine".  
 

 
Figure 17-8 Lorentz 

 

Haversine 
 
Click Wave to select "Haversine". At this time, you can set the parameters for the 
Haversine waveform (as shown in the figure below). For setting methods, refer to 
descriptions in "To Output Sine".  
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Figure 17-9 Haversine 

 
 

To Output the Arbitrary Waveform 
 
DS8000-R series oscilloscope allows you to define the arbitrary waveform and save it 
to the internal or external memory. The user-defined waveform can contain 2 to 
16,384 data points (i.g. 2 pts to 16 kpts). 
 
Click Wave to select "Arb". At this time, you can set the parameters for the arbitrary 
waveform. 
 
 

To Load the Channel and Waveform 
 
1. Load the Channel 

Click Load from CH to enter the channel loading menu. You can set the 
channel signal required to be loaded. 
⚫ Channel selection 

Click Channel to select the desired channel (CH1-CH4). 
 
⚫ Set the waveform range 

Click Region continuously to set the waveform in the "Cursor" or "Screen" 
region for load. When "Cursor" is selected, click to select Cursor A or 
Cursor B, and scroll with the mouse to adjust the positions of the two 
cursors respectively. Click to select Cursor AB, and scroll with the mouse 
to adjust the positions of cursors A and B at the same time to determine the 
waveform range. 
 

⚫ Load 
Click Load to load the set channel signal. 
 

2. Load the Waveform 
Click Load Stored to enter the waveform loading interface. In the disk 
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management interface, select the waveform from the internal memory or the 
external memory. The waveform file is suffixed with "*.arb". Then, click Load to 
load the selected waveform. For details, refer to descriptions in "Store and 
Load". 

 
 

To Create the Waveform 
 
You can create arbitrary waveforms according to your needs. Click Create to enter 
the waveform creation menu. Meanwhile, the waveform editor is displayed on the 
screen. 
 
⚫ Set the frequency or period 

Click to select Frequency or Period. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Set the amplitude or high level 
Click to select Amplitude or High Level. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Set the offset and low level 
Click to select Offset or Low Level. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Set the initial number of points 
The initial number of points indicates the number of editable points. By default, 
the number of editable points of arbitrary waveforms created can be preset to 2. 
Point 1 is fixed at 0 s and Point 2 is fixed at the middle of the period. Click Init 
Points, then use the pop-up numeric keypad or scroll with the mouse to set the 
number of editable points for the arbitrary waveform. The maximum number of 
editable points supported by the system is 16,384 (16 kpts). 
 

⚫ Linear interpolation 
Click Linear Interp to enable or disable the linear interpolation between the 
defined points of the waveform. 
➢ ON: the waveform editor connects two points using a straight line. 
➢ OFF: the waveform editor will keep a constant voltage level between two 

points and create a ladder-like waveform. 
 

⚫ Edit points 
Click Edit Points to enter the point editing menu. You can specify the voltage 
value for each waveform point to define the waveforms. 
➢ Current Point 

Click PointX, then use the pop-up numeric keypad or scroll with the mouse 
to select the points to be edited. The available range is from 1 to the 
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number of initial points. 
➢ Voltage 

Click Voltage, then use the pop-up numeric keypad or scroll with the 
mouse to set the voltage value of the current point. Its available range is 
from -2.5 V to +2.5 V. 

➢ Insert 
Click Insert to insert a new editable point between the current editing 
point and the next editing point. The number of initial points adds 1 
automatically. You can click Insert continuously to increase the editable 
points gradually.  

➢ Delete 
Click Delete to delete the current point from the waveform, and connect 
the remaining points with the current interpolation method. 

➢ Zoom 
Click Zoom continuously to enable or disable the zoom function of 
horizontal time base. 

➢ Apply 
Click Apply to apply the current settings for the currently edited arbitrary 
waveforms and output the edited waveforms. 

 
⚫ Save the arbitrary waveform 

Click Save to enter the file saving interface. Please refer to descriptions in 
"Store and Load" to save the currently edited waveform file to the internal or 
external memory in "*.arb" format (you can overwrite the original file or save 
the currently edited waveform again). 

 
 

To Edit Waveforms 
 
You can edit the waveforms in the current volatile memory. Click Edit to enter the 
waveform editing menu. 
⚫ Set the frequency or period 

Click to select Frequency or Period. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Set the amplitude or high level 
Click to select Amplitude or High Level. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Set the offset and low level 
Click to select Offset or Low Level. For detailed setting methods, refer to 
descriptions in "To Output Sine". 
 

⚫ Linear Interpolation 
Click Linear Interp to enable or disable the linear interpolation between the 
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defined points of the waveform. 
➢ ON: enables the linear interpolation. The waveform editor connects two 

defined points by using a straight line. 
➢ OFF: disables the linear interpolation. The waveform editor will keep a 

constant voltage level between two points and create a ladder-like 
waveform. 
 

⚫ Edit Points 
Click Edit Points to enter the point editing menu. You can specify the voltage 
value for each waveform point to define the waveforms. 
➢ Current Point 

Click PointX, then use the pop-up numeric keypad or scroll with the mouse 
to select the points to be edited. The available range is from 1 to the 
number of initial points. 

➢ Voltage 
Click Voltage, then use the pop-up numeric keypad or scroll with the 
mouse to set the voltage value of the current point. Its available range is 
from -2.5 V to +2.5 V. 

➢ Insert 
Click Insert to insert a new editable point between the current editing 
point and the next editing point. The number of initial points adds 1 
automatically. You can click Insert continuously to increase the editable 
points gradually.  

➢ Delete 
Click Delete to delete the current point from the waveform, and connect 
the remaining points with the current interpolation method. 

➢ Zoom 
Click Zoom continuously to enable or disable the zoom function of 
horizontal time base. 

➢ Apply 
Click Apply to apply the current settings for the currently edited arbitrary 
waveforms and output the edited waveforms. 

 
⚫ Save the arbitrary waveform 

Click Save to enter the file saving interface. Please refer to descriptions in 
"Store and Load" to save the currently edited waveform file to the internal or 
external memory in "*.arb" format (you can overwrite the original file or save 
the currently edited waveform again). 
 
 

Modulation 
 
The built-in Function/Arbitrary Waveform Generator of DS8000-R series oscilloscope 
supports amplitude modulation (AM), frequency modulation (FM), and 
frequency-shift keying modulation (FSK). A modulated waveform consists of a carrier 
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waveform and a modulating waveform. The carrier waveform is the waveform output 
from the Function/Arbitrary Waveform Generator, and the modulating signal can be 
the built-in sine, square, triangle waveform, or noise signal. 
 
Click Settings → Type to select "Modulation". 
 
Click Type to select the desired modulation type. The available modulation types 
include AM, FM, and FSK. 
 
 

AM 
 
AM (Amplitude Modulation), namely the amplitude of the carrier waveform changes 
with the amplitude of the modulating waveform, as shown in the figure below. 
 

 
Figure 17-10 Amplitude Modulation 

 
 
1. Select the Modulating Waveform 

Click Waveform to select the desired modulating waveform. The available 
modulating waveforms include Sine, Square, Triangle, and Noise. 
 

2. Set the Modulation Frequency 
Click Frequency, then use the pop-up numeric keypad or scroll with the mouse 
to set the frequency of the modulation signal. The available range is from 1 Hz 
to 50 kHz. 
 

3. Set the Modulation Depth 
The modulation depth refers to the strength of the AM and is expressed in 

Modulating 
Signal 

Carrier Signal 

Modulated 
Waveform 
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percentage. Click AM Depth, then use the pop-up numeric keypad or scroll with 
the mouse to set the AM depth of the modulating waveform. The available range 
is from 0% to 120%. When it is set to 0%, the output amplitude is half of the 
carrier amplitude. When it is set to 100%, the output amplitude equals the 
carrier amplitude. When it is set to a value greater than 100%, envelop 
distortion will occur, which must be avoided in actual circuit; at this point, the 
output of the instrument will not exceed 2.5 Vpp (the load is 50 Ω). 
 
 

FM 
 
FM (Frequency Modulation), namely the frequency of the carrier waveform changes 
with that of the modulating waveform, as shown in the figure below. 

 
Figure 17-11 Frequency Modulation 

 
1. Select the Modulating Waveform 

Click Waveform to select the desired modulating waveform. The available 
modulating waveforms include Sine, Square, Triangle, and Noise. 
 

2. Set the Modulation Frequency 
Click Frequency, then use the pop-up numeric keypad or scroll with the mouse 
to set the frequency of the modulation signal. The available range is from 1 Hz 
to 50 kHz. 
 

3. Set the Frequency Offset 
Click Deviation, then use the pop-up numeric keypad or scroll with the mouse 
to set the frequency deviation of modulating waveform from the carrier 
frequency. The available range of the frequency deviation is from 100 mHz to 
the frequency of the current carrier waveform. 
 

Modulating 
Signal 

Carrier Signal 

Modulating 
Waveform 



RIGOL Chapter 17 Function/Arbitrary Waveform Generator (Option) 

17-14 DS8000-R User Guide 

FSK 
 
FSK (Frequency-shift Keying) is a modulation method that uses the digital signal to 
control the carrier frequency changes. It is one of the modulation methods that have 
been early used in information transmission. Its advantages lie in good performance 
in anti-noise and anti-attenuation, and it has been widely used in low and medium 
rate of data transmission. 

 
1. Set the Modulation Polarity 

Click Polarity continuously to select "Positive" or "Negative" of the modulating 
waveform to control the frequency output. 
 

2. Set the Modulation Frequency 
Click FSK Rate, then use the pop-up numeric keypad or scroll with the mouse 
to set the frequency of the modulation signal. The available range is from 1 Hz 
to 50 kHz. 
 

3. Set the Hopping Frequency 
Hopping frequency indicates the frequency of the modulating waveform. The 
range of the hopping frequency is from 100 mHz to the maximum frequency of 
the carrier waveform. By default, it is 10 kHz. Click Hop Freq, then use the 
pop-up numeric keypad or scroll with the mouse to set the hopping frequency.  
 

 

Sweep 
 
The built-in Function/Arbitrary Waveform Generator of DS8000-R series oscilloscope 
supports the sweep function. In the sweep mode, the Function/Arbitrary Waveform 
Generator outputs from the start frequency to the end frequency at a specified 
sweep time. DS8000-R series supports 3 sweep modes: Linear, Log, and Step. You 
are allowed to set the parameters such as Start Keep, End Keep, and Return Time. 
Internal and Manual trigger sources are supported. The sweep output is available for 
Sine, Square, Ramp, and Arb (DC excluded) waveforms. 
 
Click Settings → Type to select "Sweep". 
 
1. Set the Sweep Type 

Click Sweep Type to select the desired sweep type. The available sweep types 
include Linear, Log, and Step. 
⚫ Linear: the frequency of the signal changes linearly. 
⚫ Log: the frequency of the signal changes in log form. 
⚫ Step: the frequency of the signal changes with ladder-like step. 
 

2. Sweep Settings 
Click Settings to enter the sweep setting menu. 
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⚫ Set start frequency and end frequency 
Start frequency and end frequency indicate the upper and lower limits of 
the sweep frequency. The Function/Arbitrary Waveform Generator always 
sweeps from the start frequency to the end frequency, and then returns 
back to the start frequency. 
➢ When start frequency is smaller than the end frequency, the 

Function/Arbitrary Waveform Generator sweeps from low frequency to 
high frequency. 

➢ When start frequency is greater than the end frequency, the 
Function/Arbitrary Waveform Generator sweeps from high frequency 
to low frequency. 

➢ When start frequency is equal to the end frequency, the 
Function/Arbitrary Waveform Generator outputs at a fixed frequency. 

 
Click Start Freq, then use the pop-up numeric keypad or scroll with the 
mouse to set the start frequency. Click End Freq, then use the pop-up 
numeric keypad or scroll with the mouse to set the end frequency. By 
default, the start frequency is 100 Hz, and the end frequency is 1 kHz. The 
ranges of start frequency and end frequency for different sweep waveforms 
are different. After modifying the "Start Freq" and "End Freq", the 
Function/Arbitrary Waveform Generator will restart to output from the 
specified "Start Freq". 

 
⚫ Start Keep 

Start keep indicates the time that the output signal keeps outputting at the 
"Start Freq" after the sweep starts. After the start keep time expires, the 
Function/Arbitrary Waveform Generator will continue outputting at a 
different frequency based on the current sweep type. 
 
Click Start Keep, then use the pop-up numeric keypad or scroll with the 
mouse to set the start keep time. The default is 0 s, and the range is from 0 
s to 500 s. 
 

⚫ End Keep 
End keep indicates the time that the output signal continues outputting at 
the "End Freq" after the Function/Arbitrary Waveform Generator sweeps 
from "Start Freq" to "End Freq". 
 
Click End Keep, then use the pop-up numeric keypad or scroll with the 
mouse to set the end keep time. The default is 0 s, and the range is from 0 
s to 500 s. 
 

⚫ Set the step 
When the sweep type is set to "Step", this menu is enabled and can be 
settable. Click Step number, then use the pop-up numeric keypad or scroll 
with the mouse to set the step value. By default, it is 2. Its available range 
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is from 2 to 1,000.  
 

⚫ Set the trigger source 
The trigger sources of the sweep can be Internal or Manual. When the 
Function/Arbitrary Waveform Generator receives a trigger signal, a sweep 
output is generated, and then it waits for another trigger signal. 
Click Trig Source to select the desired trigger source. The available trigger 
sources include Internal and Manual. 
➢ Internal: The Function/Arbitrary Waveform Generator outputs 

continuous sweep waveforms. 
➢ Manual: When you click Manual Trig for one time, one sweep is 

immediately launched for the corresponding channel. 
 
3. Set the Sweep Time 

Click Sweep Time, then use the pop-up numeric keypad or scroll with the 
mouse to set the sweep time. By default, it is 1 s. Its available range is from 1 
ms to 500 s. After modifying the sweep time, the Function/Arbitrary Waveform 
Generator will restart to output from the specified "Start Freq". 
 

4. Set the Return Time 
Return time indicates the time that the output signal restores from "End Freq" to 
"Start Freq" after the Function/Arbitrary Waveform Generator sweeps from 
"Start Freq" to "End Freq" and the "End Keep" time expires. 
 
Click Return Time, then use the pop-up numeric keypad or scroll with the 
mouse to set the return time. By default, it is 0 s. Its available range is from 0 s 
to 500 s. 
 
 

Burst 
 
The built-in Function/Arbitrary Waveform Generator of DS8000-R series oscilloscope 
supports outputting the burst waveforms with a specified number of cycles. It 
supports using internal and manual trigger sources to control the output of the burst 
waveforms. Two burst types are supported: N Cycle and Infinite. 
 
Click Settings → Type to select "Burst". 
 
1. Set the Burst Type 

Click Burst Type to select the desired burst type. The available burst types 
include N Cycle and Infinite. 
⚫ N Cycle: outputs the burst waveforms with a specified number of cycles 

once receiving the trigger signal. 
⚫ Infinite: sets the number of cycles to Infinite. It outputs continuous 

waveforms once receiving the trigger signal. 
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2. Set the Number of Cycles 
When the burst type is set to "N Cycle", you need to set the number of cycles. 

 
Click Cycles, then use the pop-up numeric keypad or scroll with the mouse to 
set the number of cycles. For the Infinite burst type, the Cycles menu is 
disabled and grayed out. 

 
3. Set the Burst Delay 

Burst delay indicates the time from when receiving the trigger signal to starting 
to output N Cycle of bursts or Infinite burst. 
 
Click Delay, then use the pop-up numeric keypad or scroll with the mouse to set 
the desired delay time. The range of the delay time is related to the burst cycles, 
waveform frequency, and burst period. 
 

4. Burst Setting 
Click Settings to enter the burst setting menu. 
⚫ Set the trigger source 

The trigger sources of the burst can be Internal or Manual. When the 
Function/Arbitrary Waveform Generator receives a trigger signal, a burst 
output is generated, and then it waits for another trigger signal. 
 
Click Trig Source to select the desired trigger source. The available trigger 
sources include Internal and Manual. For the Infinite burst type, the Trig 
Source menu is disabled and grayed out. You can only initiate an trigger 
manually. 
➢ Internal: The Function/Arbitrary Waveform Generator outputs 

continuous N cycle bursts. 
➢ Manual: When you click Manual Trig for one time, one burst output is 

immediately launched for the channel. For the Infinite burst type, the 
Cycles menu is disabled and grayed out. 

 
⚫ Set the burst period 

It is defined as the time from the beginning of one burst to that of another 
burst. 
 
Click Burst Period, then use the pop-up numeric keypad or scroll with the 
mouse to set the desired burst period. Its available range is from 1 us to 
500 s. By default, it is 10 ms.
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Chapter 18 Store and Load 
 
You can save the current settings, waveforms, screen image, and parameters of the 
oscilloscope in internal memory or external storage device (such as USB storage 
device) in various formats and load the stored settings or waveforms when needed. 
You can also copy a new file of the specified type as well as delete and rename the 
specified type of file in the internal memory or external USB storage device via the 
disk management menu. 
 
Note: DS8000-R only supports the flash memory USB storage device of FAT32 
format. 
 
Contents in this chapter: 
◼ Storage System 
◼ Storage Type 
◼ Load Type 
◼ Internal Storage and Load 
◼ External Storage and Load 
◼ Disk Management 
◼ Factory Settings 
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Storage System 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then click on the "Storage" icon  to enter the store 
and load setting interface. It provides two USB interfaces on the front panel and two 
USB HOST interfaces on the rear panel, which can all be connected to the USB 
storage device for external storage. The USB storage devices connected are marked 
as "Removable USB Disk(D)", "Removable USB Disk(E)", "Removable USB Disk(F)", 
and "Removable USB Disk(G)", respectively. 
 
 

Storage Type 
 
The file types for storage include image, waveform, and setups. The storage 
descriptions of each type are as follows. 
 
1. Image 

Click Save Image → Format to select the image type. Save the screen image 
to the internal or external memory in "*.png", "*.bmp", "*.jpg", or "*.tif" 
format.  
After selecting this type: 

➢ Click File Name to input the file name to be saved. For filename input, 
refer to descriptions in "To Create a Folder". Click Storage → More → 
Auto Name to select "ON", then the filename is generated automatically. If 
the filename that you input is the same as the existing filename, a prompt 
message will be displayed, reminding you that the existing file will be 
overwritten and asking you whether to continue or not. 

➢ Click Invert to enable or disable the invert function. 

➢ Click Color to select the desired storage color. It can be set to "Gray" or 
"Color". 

➢ Click NewFolder to create a new storage folder. For details, refer to 
descriptions in "To Create a Folder". 

➢ Click Window to display or hide the disk management interface. 

➢ Click Save to save the set image file. 

➢ Click Storage → More → Header to select "ON" or "OFF". If you select 
"ON", the instrument model, firmware version number, serial number, and 
the image creation date will be displayed in the header of the image when 
you save the image file. 
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2. Wave 

Click Save Wave to enter the waveform storage setting interface. Save the 
main setting information (e.g. "On/Off" state of the channel, vertical scale, and 
horizontal time base) and waveform data of all enabled channels to the internal 
or external memory. 
After selecting this type: 

➢ Click Data Source to select "Screen" or "Memory". 
➢ Click Format to select the format of the waveform storage, such as "*.bin", 

"*.csv", and "*.wfm" (when "Memory" is selected under Data Source). 

➢ Click File Name to input the file name to be saved. For filename input, 
refer to descriptions in "To Create a Folder". Click Storage → More → 
Auto Name to select "ON", then the filename is generated automatically. If 
the filename that you input is the same as the existing filename, a prompt 
message will be displayed, reminding you that the existing file will be 
overwritten and asking you whether to continue or not. 

➢ Click Channel, and then the available storage channels include CH1-CH4. 
Only when you select "Memory" under Data Source and the format is 
"*.bin" or "*.csv", can you set the storage channel. 

➢ Click NewFolder to create a new storage folder. For details, refer to 
descriptions in "To Create a Folder". 

➢ Click Save to save the set waveform file. 

➢ Click Window to display or hide the disk management interface. When 
"Memory" is selected under Data Source and the format is "*.csv", you 
need to click More → Window. 

➢ Click More → Time information to enable or disable the display of the 
time information in the waveform data. If enabled, the time information for 
the waveform data will be displayed. If disabled, the time information for 
the waveform data will not be displayed. Only when you select "Memory" 
under Data Source and the format is "*.csv", can you set the time 
information. 

 
3. Setup 

Click Save Setup to enter the setup setting interface. Save the setups of the 
oscilloscope to the internal or external memory in "*.stp" format. The stored 
setups can be recalled. 
After selecting this type: 
➢ Click File Name to input the file name to be saved. For filename input, 

Tip 
After a USB storage device (FAT32 format, flash memory) is connected, you can 
control the instrument through the Web Control page. Click Quick at the right 
section of the operation interface to save the file. You can select to save to the 
internal memory or the external USB storage device. By default, it is saved to the 
external memory. 
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refer to descriptions in "To Create a Folder". Click Storage → More → 
Auto Name to select "ON", then the filename is generated automatically. If 
the filename that you input is the same as the existing filename, a prompt 
message will be displayed, reminding you that the existing file will be 
overwritten and asking you whether to continue or not. 

➢ Click NewFolder to create a new storage folder. For details, refer to 
descriptions in "To Create a Folder". 

➢ Click Window to display or hide the disk management interface. 

➢ Click Save to save the set setup file. 

 
 

Load Type 
 
This oscilloscope provides two load types: waveform load and setup load. The 
descriptions of each load type are as follows. 
 
1. Waveform Load 

 
Click Load Wave to load the waveforms from the internal memory or the external 
USB disk. The default file type is "*.wfm", and no other options are available. Load 
the file from the memory, then click Load to load the selected file. 

 
2. Setup Load 

 
Click Load Setup to load the setups from the internal memory or the external USB 
disk. The default file type is "*.stp", and no other options are available. Load the file 
from the memory, then click Load to load the selected file. 
 
 

Internal Storage and Load 
 
The internal memory supports the storage and load of the image file, waveform file, 
setup file, reference waveform file, and pass/fail test mask file. 
 
1. Save the Specified Oscilloscope Setups to the Internal Memory (Take 

Save Setup as an Example) 
1) Connect a signal to the oscilloscope and obtain the stable display of 

waveforms. 
2) Click Storage → Save Setup to enter the setup storage interface. The disk 

management interface is displayed automatically. By default, "Local Disk(C)" 
is selected. 

3) Click to enter the internal memory storage interface. 

4) Select the desired storage location. Clicking  can go to the previous 
location. Besides, you can also click NewFolder to create a new storage 
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folder. For details, refer to descriptions in "To Create a Folder". 
5) Click File Name to name the setup file for storage. For details, refer to 

descriptions in "To Create a Folder". Click Storage → More → Auto 
Name to select "ON", then the filename is generated automatically. If the 
filename that you input is the same as the existing filename, a prompt 
message will be displayed, reminding you that the existing file will be 
overwritten and asking you whether to continue or not. 

6) Click Save to save the set setup file to the selected folder in "*stp" format. 
 

Tip 
⚫ After saving the reference waveform, click Ref → More → Export to enter 

the disk management interface of reference waveform file storage. 
⚫ Click Utility → PassFail to enable the pass/fail test function. Then click 

Mask → Save to enter the disk management interface of pass/fail test mask 
file storage. 

 
2. Load the Setup File from the Internal Memory (Take Load Setup as an 

Example) 
1) Click Storage → Load Setup to enter the setup load interface. The disk 

management interface is displayed automatically. By default, "Local Disk(C)" 
is selected. 

2) Click to enter the internal memory storage interface. 

3) Select the desired storage location. Clicking  can go to the previous 
location.  

4) Select the file to be loaded (the default file type is in "*stp" format). Then, 
the Load menu is enabled. Click Load to load the selected file.  

 

Tip 
⚫ Click Ref → More → Import to enter the disk management interface of 

reference waveform file load. 
⚫ Click Utility → PassFail to enable the pass/fail test function. Then click 

Mask → Load to enter the disk management interface of pass/fail test mask 
file load. 
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External Storage and Load 
 
Before external storage and recall, ensure that the USB disk is properly connected. 
The external memory supports image saving, waveform saving, setup saving, 
waveform loading, and setup loading.  
 
1. Save the Specified Type of File to the External USB Storage Device 

(Take Waveform Saving as an Example) 
1) Connect a signal to the oscilloscope and obtain the stable display of 

waveforms. 
2) Click Storage → Save Wave to enter the waveform storage interface. The 

disk management interface is displayed automatically. 
3) Click to select one disk from "Removable USB Disk(D/E/F/G…)" to open the 

external disk storage interface. Clicking  can go to the previous 
location. Besides, you can also click NewFolder to create a new storage 
folder. For details, refer to descriptions in "To Create a Folder".   

4) To set the waveform saving, refer to descriptions of "Wave" in "Storage 
Type". 

5) Click Save to save the waveform file to the selected folder in the specified 
save format.  
 

2. Load the Specified Type of File from the External USB Storage Device 
(Take Waveform Loading as an Example) 
1) Click Storage → Load Wave to enter the waveform loading interface. The 

disk management interface is displayed automatically. 
2) Click to select one disk from "Removable USB Disk(D/E/F/G…)" to open the 

external disk storage interface. Clicking  can go to the previous 
location. 

3) After selecting a file to be loaded, then the Load menu is enabled. Click 
Load to load the selected file.  
 

 

Disk Management 
 
Click Storage → Disk to turn on the disk management interface as shown in Figure 
18-1. The disk currently selected is displayed in red shading. Click to open the 
selected disk.  
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Figure 18-1 Disk Management Interface 

 
Execute the following operations through the disk management menu: 
⚫ To Select a File Type 
⚫ To Create a Folder 
⚫ To Delete a File or Folder 
⚫ To Copy and Paste a File or Folder 
⚫ To Rename a File or Folder 
⚫ To Clear the Internal Memory Safely  
 
 

To Select a File Type 
 
Except the image storage, waveform storage, and setup storage, the oscilloscope 
can also save the files of advanced applications. 
 
Click Storage → Disk → File Type to select the desired file type. The default is 
"*.*". In the current path, only the file whose suffix of its file name matches that of 
the file type selected will be displayed in the current path. 
 
 

To Create a Folder 
 
Before using the external disk, make sure that a USB storage device (FAT32 format, 
flash memory) is connected correctly. 
 
In the disk management interface, click to select the storage location. By default, the 
internal memory "Local Disk(C)" is selected. Click NewFolder to enter the interface, 
as shown in Figure 18-2.  
 

 



RIGOL Chapter 18 Store and Load 

18-8 DS8000-R User Guide 

 
Figure 18-2 To Create a Folder 

 
This oscilloscope supports Chinese/English input method. The length of the folder 
name is limited to 22 bytes (one Chinese character occupies two bytes). The 
following part introduces how to input a folder name using Chinese/English input 
method. 
 
 

English Input Method 
 
For example, create a folder with the name "Filename". 

 
  

 
 

 
 

1. Select English Input Method 
If the current input method is "En/中/繁", please go to Step 2. If the current 

input method is "中/繁/En" or "繁/En/中", click to select the input switch key 

"En/中/繁". "En" is located first and highlighted. 

Name Input Area                                       Virtual Keypad 

Upper/Lower  

Case Switch 

 Input Method  
Switch 
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2. Clear the Name Input Area 
If there is no character in the "Name Input Area", please go to Step 3. If there 
are characters in the "Name Input Area", click the Delete key  to delete all 
the characters in the name input area in order. 
 

3. Input the First Character "F" 
1) If the current setting is uppercase input, please go to Step 2). If the current 

setting is lowercase input, click "Caps" to switch to the uppercase input. 
2) Click to select "F". The character is displayed in the name input area. 
 

4. Input the Other Characters 
Use the same method to input the remaining letters "ilename" by referring to 
Step 3. Pay attention to the upper-lower case of the letters when inputting them. 
 

5. Modify or Delete the Unwanted Characters that Have Been Entered. 
While entering a filename, you can modify or delete the unwanted character if 
necessary. To delete the input characters, select and click the delete key  in 
the virtual keypad. To modify the input characters, delete the unwanted 
characters and input the desired characters again. If the character to be 
modified is in the middle, click the delete key  to delete the characters 
starting from the last one to the character to be modified, then input the new 
character again. 
  
You can also directly move the cursor to the character required to be modified or 
deleted, and then input the desired character again or delete the unwanted 
character. 
 

6. After finishing the input, click OK. The oscilloscope will create a folder or a 
specified type of file with this name under the current directory. 

 
 

Simplified Chinese (or Traditional Chinese) Input Method 
 
For example, create a folder with the name "文件名". Note that the input method of 

traditional Chinese is the same as that of the simplified Chinese. 
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1. Chinese Input Method 

If the current input method is "中/繁/En", please go to Step 2. If the current 

input method is "En/中/繁" or "繁/En/中", click the input switch key to switch to 

"中/繁/En". "中" is located first and highlighted. 

 
2. Clear the Pinyin Input Area and Name Input Area 

If there is no character in the "Pinyin Input Area" and "Name Input Area", please 
go to Step 3. If there are characters in the "Name Input Area" and "Pinyin Input 
Area", click to select the delete key  to delete all the characters in the name 
input area in order. 
 

3. Input the First Chinese Character "文" 

1) Input the pinyin "wen" in the "Pinyin Input Area" 
Click to select the first letter "w" in the pinyin "wen" to input "w" in the 
"Pinyin Input Area". Use the same method to input the remaining letters 
"en" in the pinyin "wen". After finishing the input, the Chinese characters 
available are displayed in the "Chinese Character Selecting Area". 
 

2) Select the desired Chinese character from the "Chinese Character Selecting 
Area" 
Click to select "文", and then "文" is input in the "Name Input Area". If the 

Chinese character is not found in the current page, click  to go to the 
next page until you find the desired character. 

 
4. Input the Other Characters 

Refer to Step 3 and use the same method to input the remaining Chinese 
characters "件名" in sequence. 

 
5. Modify or Delete the Unwanted Characters that Have Been Entered 

When inputting the filename, you can modify or delete the filename characters 
input in the "Name Input Area" as well as delete the pinyin characters input in 

Name Input Area Chinese Character Selection Area Pinyin Input Area  Virtual Keypad        

 
Go to Previous 
Page  

 

 

Upper/Lower  

Case Switch 

Input Method 
Switch 

 

 
Go to 

Next Page 
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the "Pinyin Input Area". To delete the input characters, select and click the 
delete key  in the virtual keypad. To modify the input characters, delete the 
unwanted characters and input the desired characters again. If the character to 
be modified is in the middle, click the delete key  to delete the characters 
starting from the last one to the character to be modified, then input the new 
character again. 
 
You can also directly move the cursor to the character required to be modified or 
deleted, and then input the desired character again or delete the character. 
 

 
6. After finishing the input, click OK. The oscilloscope will create a folder or a 

specified type of file with this name under the current directory. 
 
 

To Delete a File or Folder 
 
1. Delete a File or Folder from the Internal Memory 

1) Click Storage → Disk to open the internal memory "Local Disk(C)".  
2) Scroll with the mouse to select the file or the folder to be deleted. 
3) Click Delete, and then a confirmation dialog box is displayed. Click "Yes" to 

delete the file or the folder. 
 

2. Delete a File or Folder from the External Memory 
1) Click Storage → Disk to open the external memory.  
2) Scroll with the mouse to select the file or the folder to be deleted. 
3) Click Delete, and then a confirmation dialog box is displayed. Click "Yes" to 

delete the file or the folder. 
 

 
 

To Copy and Paste a File or Folder 
 
1) Click Storage → Disk to select a path.  
2) Scroll with the mouse to select the file or folder to be copied and pasted. 
3) Click Copy to copy the selected file or folder. 
4) Select the destination disk, then click Paste to paste the selected file or folder. 

Tip 
If characters already exist in the Pinyin input area, when deleting the 
characters in the name input area, the characters in the Pinyin input area will 
be deleted first. 

Tip 
When you delete a directory where a file or a folder exists, the directory cannot be 
deleted. 
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To Rename a File or Folder 
 
1) Click Storage → Disk to select the internal or external memory.  
2) Scroll with the mouse to select the file or folder to be renamed. 
3) Click Rename, and then the filename input interface is displayed. For the 

filename input method, refer to descriptions in "To Create a Folder". 
 

 

To Clear the Internal Memory Safely 
 
1) Click Storage → Disk → More. 
2) Click SecurityClear, and then a prompt message "Execute secure memory 

wipe?" for confirming security clear is displayed. 
3) Click OK to clear all the files stored in the internal memory. 
 
 

Export 
 
Click Export to export the selected file to the external memory. 
 
 

Factory Settings 
 
Click Storage → More → Default, then a prompt message "Restore default 
settings?" is displayed. Click OK to restore the oscilloscope to the factory default 
settings, as shown in the table below. 

Tip 
If the destination directory has the same file or folder that you want to paste, 

then a prompt message "File or directory exists" is displayed. You are not 
allowed to execute the copy and paste operation. 
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Table 18-1 Factory Settings 

Parameter Factory Settings 

Horizontal 
Vertical 
Acquire 
Trigger 
Display 
AWG (Gen)  
Cursor 
Storage 
Utility 
Math 
Protocol Decoding (Decode) 
Ref 

Horizontal 

Horizontal Time 
Base 

1 μs 

Horizontal Position 0 s 

Delayed Sweep Off 

Timebase Mode YT 

Fine Off 

Horizontal 
Expansion 

Center 

 

Vertical 

Vertical Scale 100 mV 

Vertical Offset 0 V 

CH1 On 

CH2 Off 

CH3 Off 

CH4 Off 

Channel Coupling DC 

BW Limit Off 

Attenuation 1X 

Input Impedance 1 MΩ 

Invert Off 

Fine Off 

Channel Unit [V] 

Display Label Off 

Ch-Ch Skew 0 s 

Offset Cal 0 V 

 

Acquire 

Acquisition Mode Normal 

Memory Depth 1 M 
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Anti-Aliasing Off 

 

Trigger 

Trigger Type Edge Trigger 

Source Selection CH1 

Edge Type Rising 

Trigger Mode Auto 

Trigger Coupling DC 

Trigger Holdoff 8 ns 

Noise Rejection Off 

 

Display 

Display Type Vector 

Persistence Time Min 

Intensity 50% 

Grid FULL 

Brightness 20% 

Show Scale Off 

Color Grade Off 

Waveform Freeze On 

 

AWG (Gen) [1] 

Gen Off 

Status Display Off 

Gen 

Wave Sine 

Output Off 

Frequency 1 kHz 

Amplitude 500 mV 

Offset 0 V 

Start Phase 0° 

Type None 

Impedance HighZ 

 

Cursor 

Mode Off 

Manual 

Select Y 

Source CH1 

AY 100 mV 

BY -100 mV 

Vertical Unit Source 

Hori. Unit s 

Region Main 
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Track 

AX Source CH1 

BX Source CH1 

AX -1 μs 

BX 1 μs 

Track X 

XY 

AX -233.3 mV 

BX 100 mV 

AY -233.3 mV 

BY -100 mV 

Measure 

Indicator Off 

 

Storage 

Auto Name ON 

Header ON 

Save Image 

Format *.png 

Invert OFF 

Color Color 

Window Show 

Save Wave 

Data Source Screen 

Format *.csv 

Window Show 

Save Setup 

File Type *.stp 

Window Show 

Load Wave 

File Type *.wfm 

Load Setup 

File Type *.stp 

Disk 

File Type *.* 

 

Utility 

Beeper OFF 

PassFail 

Enable OFF 

Source CH1 

Operate Stop 

Range Screen 

X Mask 0.24 div 



RIGOL Chapter 18 Store and Load 

18-16 DS8000-R User Guide 

Y Mask 0.48 div 

Load File Type *.pf 

Save File Type *.pf 

File Name RigolDS0 

Window Show 

Information OFF 

Aux Output OFF 

Output Event Fail 

Polarity Positive 

Pulse 1 μs 

Err Action None 

Record 

Record OFF 

Record  
Play  
Record 

Interval 10 ns 

Beeper  
Current 0 

Play 

Mode  
Sequence  
Interval 100 ms 

Current 0 

Jump To First  

System 

Power On Default 

Power status Switch Off 

AUX Out TrigOut 

Ref Clock OFF 

Key Locker Unlocked 

HDMI Output ON 

HDMI Resolution 1280x720 

Screen Saver Off 

SelfCal 

Window Open 

Auto Config 

Peak to Peak OFF 

CH All 

Overlay OFF 

Coupling OFF 

Printer 

Copies 3 

Paper Size A4 
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Ink Saver ON 

Printer HP/Laserjet 

Email 

Attachment Screen 

Quick Settings 

Operation Save Image 

Format *.png 

Invert OFF 

Color Color 

 

Math 

Invert OFF 

Expand GND 

Display Label OFF 

Library ADD 

Label Editing ADD 

A+B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Offset 0 V 

Scale 500 mV 

A-B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Offset 0 V 

Scale 500 mV 

A× B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Offset 0 U 

Scale 500 mU 

A÷B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Offset 0 U 

Scale 500 mU 

FFT 

Operation OFF 

Source CH1 

Offset 0 dBV 
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Scale 2 dBV 

Unit dBm/dBV 

X Start-End 

Start Freq 0 Hz 

Stop Freq 10 MHz 

Window Function Hanning 

Peak Search OFF 

Peak Number 5 

Threshold 5.5 dBV 

Excursion 1.8 dBV  

Table Order Amp Order 

A&&B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Wave Size Medium 

Thre.CH1 0 V 

Thre.CH2 0 V 

Thre.CH3 0 V 

Thre.CH4 0 V 

Sensitivity 0.3 Div 

A||B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Wave Size Medium 

Thre.CH1 0 V 

Thre.CH2 0 V 

Thre.CH3 0 V 

Thre.CH4 0 V 

Sensitivity 0.3 Div 

A^B 

Operation OFF 

SourceA CH1 

SourceB CH1 

Wave Size Medium 

Thre.CH1 0 V 

Thre.CH2 0 V 

Thre.CH3 0 V 

Thre.CH4 0 V 

Sensitivity 0.3 Div 

!A 

Operation OFF 

SourceA CH1 
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Wave Size Medium 

Thre.CH1 0 V 

Thre.CH2 0 V 

Thre.CH3 0 V 

Thre.CH4 0 V 

Sensitivity 0.3 Div 

Intg 

Operation OFF 

Source CH1 

Offset 0 v*s 

Scale 500 mv*s 

Bias 0 

Invert OFF 

Diff 

Operation OFF 

Source CH1 

Offset 0 v/s 

Scale 500 mv/s 

Smooth 5 

Invert OFF 

Sqrt 

Operation OFF 

Source CH1 

Offset 0 U 

Scale 500 mU 

Invert OFF 

Lg 

Operation OFF 

Source CH1 

Offset 0 U 

Scale 500 mU 

Invert OFF 

Ln 

Operation OFF 

Source CH1 

Offset 0 U 

Scale 500 mU 

Invert OFF 

Exp 

Operation OFF 

Source CH1 

Offset 0 U 

Scale 500 mU 

Invert OFF 
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Abs 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mU 

Invert OFF 

Low Pass 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mV 

ωc 50 MHz 

Invert OFF 

High Pass 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mV 

ωc 50 MHz 

Invert OFF 

Band Pass 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mV 

ωc1 50 MHz 

ωc2 100 MHz 

Invert OFF 

Band Stop 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mV 

ωc1 50 MHz 

ωc2 100 MHz 

Invert OFF 

AX+B 

Operation OFF 

Source CH1 

Offset 0 V 

Scale 500 mV 

A 1 

B 0 

Invert OFF 
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Protocol Decoding (Decode) 

Bus Type Parallel 

Bus Status OFF 

Format Hex 

Label ON 

Event Table OFF 

Noise Reject OFF 

CLK OFF 

RS232 

Bus Status OFF 

Baud 9.6 kbps 

Tx CH1 

Threshold 0 V 

Rx OFF 

Polarity  
Endian LSB 

Data 8 bits 

Stop Bit 1 bit 

Parity None 

Package OFF 

Separator 0(NUL) 

I2C 

Bus Status OFF 

SCL CH1 

SCL Thre 0 V 

SDA CH2 

SDA Thre 0 V 

Exchange SCL/SDA 

R/W Without 

SPI 

Bus Status OFF 

Mode Timeout 

Timeout 1 μs 

CLK CH1 

Threshold 0 V 

Slope Rising 

MISO CH2 

Threshold 0 V 

MOSI OFF 

Polarity  
Width 8 

Endian MSB 

LIN 

Bus Status OFF 
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Source CH1 

Threshold 0 V 

Baud 19.2 kbps 

Parity Without 

Version Both 

CAN 

Bus Status OFF 

Source CH1 

Threshold 0 V 

Signal CAN_L 

Baud 1 Mbps 

Sample Position 50% 

FlexRay 

Bus Status OFF 

Source CH1 

Threshold 0 V 

Channel  A 

Baud 10 Mbps 

Signal BP 

Sample Position 50% 

I2S 

Bus Status OFF 

SCLK CH1 

SCLK Thre 0 V 

SCLK Edge Rising 

WS CH2 

WS Thre 0 V 

Data CH3 

Data Thre 0 V 

Word Size 4 

Receive 4 

Alignment I2S 

WS Low Left 

Endian MSB 

Data Polarity  
1553B 

Bus Status OFF 

Data CH1 

Threshold 0 V 

 

Ref 

Current Ref1 

Source CH1 

VScale 1 V 
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VOffset 0 V 

Color Orange 

Label Display OFF 

Library Default 

Label REF1 
Note[1]: This function is only available for the model installed with the DS8000-R-AWG option. 
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Chapter 19 System Utility Function Setting 
 
In the system function setting menu, you can set the parameters for the remote 
interface and the system-related parameters. 
 
Contents in this chapter: 
◼ Remote Interface Configuration 
◼ System-related 
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Remote Interface Configuration 
 
DS8000-R series can communicate with the PC via the USB, LAN, or GPIB (requiring 
to work with RIGOL's USB-GPIB interface converter) interface. Before using the 

remote interfaces, configure the corresponding interface according to the 
introductions in the following section. 
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the function navigation. Then click on the "Utility" icon  to enter the "Utility" 
setting menu. Click LAN to set the interface. 
 
 

LAN Configuration 
 
Before using the LAN bus, use a network cable to connect the oscilloscope to your 
local area network. The network interface of the oscilloscope is on the rear panel. 
 
Click IO → LAN to open the LAN Settings interface, as shown in the following figure. 
You can view the current network settings and configure the network parameters. 

 

  

 
                   Figure 19-1 LAN Network Connection Setting Interface 

 
 

Network Status 
 
Different prompts will be displayed according to the current network connection 
status. 
⚫ Network Config Succeeded! 
⚫ Acquiring IP... 
⚫ IP Conflict! 

Network Status 

Current IP Config. 

Type 

MAC Address 

VISA Descriptor 
 
IP Config. Type 

 

Network Parameters 

Web Control Info. 
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⚫ Disconnected! 
⚫ DHCP Config Failed! 
⚫ Read Status Fail! 
⚫ Connected! 
⚫ Invalid IP! 
⚫ IP lost! 
⚫ Please wait... 

 
 

IP Configuration Type 
 
The configuration type of the IP address can be DHCP, Auto IP, or Static IP. For 
different IP configuration types, the configurations for IP address and other network 
parameters are different. 
 
DHCP 
 
Click IP Config Type to select "DHCP". When DHPC is valid, the DHCP server in the 
current network will assign the network parameters (e.g. IP address, Subnet, 
Gateway, and DNS) for the oscilloscope. 
 
Auto IP 
 
Click IP Config Type to select "Auto IP". In auto IP mode, the oscilloscope will get 
the IP address (ranging from 169.254.0.1 to 169.254.255.254) and the subnet mask 
(255.255.0.0) automatically according to the current network configuration. Only 
when "DHCP" is not selected or failed to be connected, can "Auto IP" be valid. 

 
Static IP 
 
Click IP Config Type to select "Static IP". Note: when this type is valid, you need to 
disable DHCP and Auto IP manually. At this time, the "IP", "SubMask", "Gateway", 
and "DNS" menu items are added. Thus, you can self-define the network parameters 
(e.g. IP address) of the oscilloscope. 
 
1. Set IP Address 

The format of the IP address is nnn.nnn.nnn.nnn. The range of the first segment 
(nnn) of the address is from 0 to 255 (except 127); wherein, the valid range is 
from 0 to 223. The range for the other three segments is from 0 to 255. You are 
recommended to ask your network administrator for an IP address available. 
 
Click IP, and then the numeric keypad is displayed. Use the numeric keys to 
input the desired IP address. This setting will be saved to the non-volatile 
memory; if "Power On" is set to "Last", then DHCP and Auto IP are disabled at 
the next power-on. The oscilloscope will load the preset IP address 
automatically. 
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2. Set the Subnet Mask 
The format of the subnet mask is nnn.nnn.nnn.nnn; wherein, the range of "nnn" 
is from 0 to 255. You are recommended to ask your network administrator for a 
subnet mask available. 
 
Click SubMask, and then the numeric keypad is displayed. Use the numeric 
keys to input the desired subnet mask. This setting will be saved in the 
non-volatile memory; if "Power On" is set to "Last", then DHCP and Auto IP are 
disabled at the next power-on. The oscilloscope will load the preset subnet mask 
automatically. 
 

3. Set the Gateway 
You can set this parameter in Static IP mode. 
The format of the gateway is nnn.nnn.nnn.nnn. The range of the first segment 
(nnn) is from 0 to 223 (except 127), and the range for the other three segments 
is from 0 to 255. You are recommended to ask your network administrator for a 
gate address available. 

 
Click Gateway, and then the numeric keypad is displayed. Use the numeric 
keys to input the desired subnet mask. This setting will be saved in the 
non-volatile memory; if "Power On" is set to "Last", then DHCP and Auto IP are 
disabled at the next power-on. The oscilloscope will load the preset gateway 
automatically. 

 
4. Set the DNS 

You can set this parameter in Static IP mode. 
The format of the DNS address is "nnn.nnn.nnn.nnn". The range for the first 
segment (nnn) of the address is from 0 to 223 (except 127); and the range for 
the other three segments is from 0 to 255. You are recommended to ask your 
network administrator for an address available. 

 
Click DNS, and then the numeric keypad is displayed. Use the numeric keys to 
input the desired DNS address. Generally, you do not need to set the DNS, 
therefore this parameter setting can be ignored. 
 

 
 

Apply the Network Parameter Setting 
 
Click Apply to apply the current network parameter setting. 

Tip 
⚫ When the three IP configuration types are all turned on, the priority of the 

parameter configuration from high to low is "DHCP", "Auto IP", and "Static 
IP". 

⚫ The three IP configuration types cannot be all turned off at the same time. 
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MAC Address 
 
For each oscilloscope, the MAC address is unique. When assigning the IP address for 
the oscilloscope, the system uses the MAC address to identify the instrument. 
 
 

VISA Address 
 
Displays the VISA address currently used by the oscilloscope. 
 
 

Web Control Information 
 
Displays the user name and password for network configuration of the oscilloscope 
through the LXI webpage. 
Tip: Connect the oscilloscope to the local area network. Start up Ultra Sigma, and 
then right-click the resource name and select "LXI-Web" to load the LXI webpage. 
You can also directly input the IP address of the oscilloscope into the address bar of 
the browser to load the LXI webpage. 
 
 

To Set mDNS 
 
Click mDNS continuously to enable or disable the multicast Domain Name System 
(mDNS). This system is used to provide the function of DNS server for service 
discovery in a small network without a DNS server. 
 
 

To Set Host Name 
 
Click Host Name to input the host name. For the host name input method, refer to 
relevant descriptions in "To Create a Folder". 
 

To Set the GPIB Address 
 
Before using the GPIB bus to control the oscilloscope, use the USB-GPIB interface 
converter (an option that requires to be ordered separately) to extend the GPIB 
interface, and then use the GPIB cable to connect the instrument to the PC.  
 

Click on the function navigation icon  at the lower-left corner of the screen to 

open the funciton navigaiton. Click on the Utility icon  to enter the "Utility" 
setting menu. Click IO → GPIB to set the GPIB address. Use the pop-up numeric 
keypad to input the GPIB address. Its settable range is from 1 to 30. By default, it is 
1. 
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To Set HDMI 
 
Sets the status and parameters of the HDMI video output interface on the rear panel. 
Note that only when the HDMI interface is connected, can this menu be enabled. 
 
Click HDMI to enter the HDMI setting menu. 
⚫ Click Output continuously to enable or disable the video output. 

➢ ON: You can connect the instrument to an external display via this interface 

to better observe the waveform display from the external display.  

➢ OFF: disables the interface. 

 

⚫ Click Resolution to set the screen resolution. The available resolution includes 
640x480, 720x480, and 1280x720. 

 
 

SFP+ Configuration 
 
First use the optical fiber cable to connect the oscilloscope to your LAN via the 
rear-panel SFP+ interface.  
 
Click IO → SFP+ to open the "SFP+" setting menu. The SFP+ setting window is 
displayed, as shown in the figure below. You can view the current network settings 
and configure the network parameters. 

 

 
   Figure 19-2 SFP+ Network Connection Setting Interface 

 
1. To Enable or Disable the SFP+ Network Configuration Window 

Click Display to enable or disable the display of the SFP+ network configuration 
window. 

 
2. To Set the Local IP 

Click Local IP, and then the numeric keypad is displayed. Use the numeric keys 
to input the desired IP address. This setting will be saved to the non-volatile 
memory. The oscilloscope will load the preset IP address automatically at the 
next power-on. 
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3. To Set the Local Port 
Click Local Port, and then the numeric keypad is displayed. Use the numeric 
keys to input the local port. The range of the port number is from 1 to 65535. 
This setting will be saved to the non-volatile memory. The oscilloscope will load 
the preset local port automatically at the next power-on. 
 

4. To Set the Remote IP 
Click Remote IP, and then the numeric keypad is displayed. Use the numeric 
keys to input the desired remote IP address. This setting will be saved to the 
non-volatile memory. The oscilloscope will load the preset remote IP address 
automatically at the next power-on. 

 
5. To Set the Remote Port 

Click Remote Port, and then the numeric keypad is displayed. Use the numeric 
keys to input the remote port. The range of the port number is from 1 to 65535. 
This setting will be saved to the non-volatile memory. The oscilloscope will load 
the preset remote port automatically at the next power-on. 

 
6. To Enable or Disable the SFP+ Interface 

Click SFP+. If the SFP+ interface is currently disabled, a prompt message 
"Open the optical port?" is displayed when you click this menu. If the SFP+ 
interface is currently enabled, a prompt message "Close the optical port?" is 
displayed when you click this menu. Click OK or Cancel to confirm or cancel 
your setting. 
 
Note: When the SFP+ interface is enabled, the search function, the precision 
measurement mode, rectangular drawing, zone trigger, and the statistics 
function under the pass/fail test are disabled.  

 
7. To Apply the SFP+ Parameter Setting 

Click Apply to validate the current network parameter setting. 
 
 

USB Connection 
 
The oscilloscope can communicate with a PC via the USB DEVICE interface on the 
rear panel. No parameters are required to be configured. 
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System-related 
 

Beeper 
 
When the beeper is enabled, you can hear the sound of the beeper when the 
following conditions occur: 
⚫ Press a key on the front panel 
⚫ Use the mouse to operate on the screen 
⚫ When a prompt message is displayed 
 

Click Utility, and then click Beeper continuously to select "ON" ( ) or "OFF" ( ). 
By default, it is OFF. 
 
 

Language 
 
This oscilloscope supports menus in multiple languages. Both Chinese and English 
are available for the display of the help information, prompt messages, and interface. 
 
Click Utility → Language to select the desired language. 
 
 

System Information 
 
Click Utility → System → About to view the system information of the oscilloscope, 
including the manufacturer, product model, serial number, etc.  
 
You can also view the system information of the oscilloscope in the "Help" system 
menu. 
 
 

Power On 
 
You can set the system configuration to be recalled when the oscilloscope is powered 
on again after power-off. 
 
Click Utility → System, and then click Power On continuously to select "Last" or 
"Default". By default, it is "Default". 
⚫ Last: returns to the setting of the system at last power-off. 
⚫ Default: returns to the factory setting of the system. 
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Power Status 
 
Use the power line to connect the oscilloscope to the AC power and then turn on the 
power switch to power on the instrument. You can set the power status after it is 
powered on. 
 
Click Utility → System, and then click Power status to select "Switch On" or 
"Switch Off". 
⚫ Switch Off: after the oscilloscope is connected to power, you need to press the 

Power key on the front panel to power on the instrument. 
⚫ Switch On: After the oscilloscope is connected to power, it will be powered on 

immediately. 
 

Note: Whatever the option you select, you still can press the Power key on the front 
panel to turn on or off the instrument. 
 
 

Aux Output 
 
You can set the type of the signal output from the [TRIG OUT] connector on the 
rear panel. 
 
Click Utility → System, and then click the AUX Out key continuously to select 
"TrigOut" or "PassFail". 
 
⚫ Trigger Output 

After this type is selected, at each trigger (hardware trigger), the oscilloscope 
outputs a signal from the [TRIG OUT] connector on the rear panel that can 
reflect the current capture rate of the oscilloscope. Connect this signal to a 
waveform display device, measure the signal frequency. It is found that the 
measurement result is the same as the current capture rate. 
 

⚫ Pass/Fail 
When this type is selected, the instrument can output a positive or negative 
pulse via the [TRIG OUT] connector when a successful or failed event is 
detected. Refer to descriptions in "To Set the Output Form of the Test 
Results". When you enable the Aux output, the AUX Out menu is 
automatically set to "PassFail". When the AUX Out menu is automatically set to 
"TrigOut", then in the pass/fail test menu, the Aux Out function is automatically 
disabled. 

 
 

Ref Clock 
 
This oscilloscope can output the internal 10 MHz sample clock signal from the 
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rear-panel [10M In/Out] connector, and it can also receive the external 10 MHz 
clock signal from the connector. This function can be used for the synchronization of 
multiple oscilloscopes. 
 
Click Utility → System → Ref Clock to select the desired clock type.  
⚫ OFF: disables the reference clock function. 
⚫ Clock Input: receives the external 10 MHz clock signal from the rear-panel [10M 

In/Out] connector. 
 
 

Help 
 
Click Utility → System → Help to enter the "Help" function menu.  
⚫ Click About to view the system information of the oscilloscope. 
⚫ Click Content to enter the built-in help system. 
⚫ Click Option list to view the name of the installed option and other detailed 

information about the option from the option list. 
⚫ Click Option install to install the desired option. For detailed installation 

procedures, refer to descriptions in "To View the Option Information and 
the Option Installation". 

⚫ Click Online upgrade to perform online upgrading for the system software. For 
the method of online upgrade, refer to "Tip" in "Rear Panel Overview" 
section.  
Note: If you connect the oscilloscope to the network via the LAN interface, 
every Monday you power on the instrument, the oscilloscope will check whether 
the latest version of the upgrade software is available on the RIGOL official 

website. If yes, a red spot appears at the upper-left corner of the Online 
upgrade menu, prompting you that the latest upgrade version is available and 
you can perform online upgrade. 

⚫ Click Local upgrade, then a dialog box "Upgrade system firmware?" is 
displayed. Click OK to perform local upgrading for the system software (required 
to insert the USB disk that contains the software installation package); click 
Cancel to cancel local upgrading operation. 

 

 

Self-calibration 
 
The self-calibration program can quickly make the oscilloscope to work in an optimal 
state to get the precise measurement results. You can perform self-calibration at any 

time, especially when the changes of the ambient temperature reach or above 5℃. 

Make sure that the oscilloscope has been warmed up or operating for more than 30 
minutes before the self-calibration. 
 
Disconnect all the input channels, then click Utility → System → SelfCal, and the 
self-calibration interface is displayed, as shown in the following figure. 
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Figure 19-3 Self-calibration Interface 

 
⚫ Click Start, and then the oscilloscope will start to execute the self-calibration 

program. 
⚫ After the self-calibration program is launched, the Exit menu does not function. 

You can double-click any place on the screen to stop the self-calibration. 
⚫ Click Window continuously to open or close the self-calibration information 

window. You can also click on the icon  at the upper-right corner of the 
self-calibration information window to close the window. 

 
Note: After the self-calibration starts, the "Calibration" window is displayed. The 
status shows "Waiting", indicating that the instrument is calibrating. At this time, to 
cancel the calibration, double-click any place on the screen. Then, the calibration 
status is changed to "Abort". Click Start again, and the oscilloscope starts to 
calibrate again. After the calibration has been completed, the status shows "Stop" 
again. During the self-calibration, most of the menus are disabled. 
 
 

Auto Config 
 
Click Utility → More → Auto Config, and set the parameters for the Auto key at 
the right section of the Web Control page. For detailed settings, refer to descriptions 
in "Quick Measurement after AUTO". 
 

 

Print Setting 
 
Connect the oscilloscope to the local area network via the network cable. The 
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DS8000-R series supports printing the whole screen to the network printer. You can 
connect the oscilloscope to the printer directly via the USB DEVICE interface on the 
rear panel. Then, you can set the print parameters on the oscilloscope to control the 
printer to output the corresponding picture. 
 
Click Utility → More → Printer to enter the printer setting menu. After the printer 
is properly connected, you need to set the network configurations for printing, and 
then set the printer parameters. 
 
1. Network Configuration 

Click Setting to enter the network configuration menu. 
⚫ Select the Printer 

Click Printer to select the printer model.  
 

⚫ Set the IP Address 
Click Printer IP to set each segment of the IP address for the printer. Click 
the mouse to switch among the segments. Scroll up and down with the 
mouse to adjust the value of each segment of the IP address. 

 
⚫ Set the Port 

Click Printer Port to adjust the port number. Use the pop-up numeric 
keypad to input the port number. 
 

⚫ Network Test 
Click Test to test whether the network is connected. If connected, a prompt 
message "Network connected" is displayed. 

 
⚫ Print Test Page 

Click Print test page to carry out the print test. The print progress is also 
displayed on the screen. 

 
2. Set the Printer Parameters 

⚫ Print  
After the printer parameters are set, click Print to execute the print 
operation. 

 
⚫ Copies 

Click Copies to set the number of copies to be printed. Use the pop-up 
numeric keypad or scroll with the mouse to set it. The settable range is from 
1 to 99. By default, it is 3. 

 
⚫ Paper Size 

The Paper Size menu is grayed out and disabled. The paper size 
supported by the oscilloscope is only A4. 
 

⚫ Ink Saver 
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Click Ink Saver continuously to enable or disable the ink saver setting. If 
disabled, you need to set Color. Click Color continuously to select "Gray" 
or "Color". 

 
 

Email 
 
This oscilloscope supports sending files via emails. Click Utility → More → Email to 
enter the email setting menu.  
 
1. Set the Email Server 

Click Settings to enter the email server login setting menu. The following 
window is displayed. After the setting, click OK to complete the server login. To 

cancel login, click Cancel to exit or click on the icon  at the upper-right 
corner of the window to exit. If you exit the server setting window, you can click 
SMTP, Port, UserName, or PassWord to reopen the window. 
 

 
 
⚫ Set SMTP 

Click SMTP to set the mail transmission protocol. For detailed settings of 
mail transmission protocol, refer to descriptions in "To Create a Folder". 

 
⚫ Set the port 

Click Port to set the protocol port in the pop-up numeric keypad. Its range 
is from 1 to 65535. 

 
⚫ Set the user name 

Click UserName to set the user name of the server. For detailed setting 
methods for the user name, refer to descriptions in "To Create a Folder". 

 
⚫ Set the password 

Click PassWord to set the password of the server. For detailed setting 
methods for the password, refer to descriptions in "To Create a Folder". 

 
⚫ Email test 

Click Test to test whether the e-mail server is properly set. 
 

⚫ Restore default settings  
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Click Default to restore the settings of receiver and mail settings to 
defaults. 
 

2. Set the Receiver 
Click Receiver to display the receiver input interface, and you can edit the email 
address of the receiver. For detailed input methods of the receiver email address, 
refer to descriptions in "To Create a Folder". 
 

3. Upload Attachment 
Click Attachment to select the attachment type to be uploaded. The available 
attachments include "Screen", "Setup", and "Other". If you select "Other", you 
also need to click File Select to select the file to be uploaded. 
 

4. Send the Mail 
Click Send Mail to send the edited email to the receiver. 
 
 

Key Locker 
 
You can set whether to lock all the function keys (except the Power key). Click 
Utility → More → Key Locker to select "Locked" or "Unlocked". By default, it is 
unlocked. 
⚫ Locked: indicates that all operation keys of the oscilloscope (except the Power 

key on the front panel) are locked. You cannot do any operation on the screen 

with the mouse. 

⚫ Unlocked: unlocks the function keys. You are allowed to operate on the screen. 

To unlock the keyboard, perform any one of the following operations. 

1. Restart the oscilloscope by pressing the Power key.  

2. Send the command (:SYSTem:LOCKed 0) with the Ultra Sigma software. For 

details, refer to DS8000-R Programming Guide. 

3. Click the Touch key in the Web Control operation page.  

 
 

Quick Operation 
 
 
Click Utility → More → Quick settings to enter the quick key operation menu.  
 
1. Image Saving 

When the Quick shortcut key is set to "Save Image", click Quick at the right 
section of the operation interface in the Web Control page to capture the screen. 
 
⚫ Operation Type 
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Click Operation to select "Save Image". 
 

⚫ Image Format 
Click Format to select the image format. The image formats include "*.png", 
"*.bmp", "*.jpg", and "*.tif". 

 
⚫ Invert 

Click Invert continuously to enable or disable the invert function. 
 

⚫ Color 
Click Color continuously to set the color of the saved image to "Color" or 
"Gray". 

 
2. Waveform Saving 

When the Quick shortcut key is set to "Save Wave", click Quick at the right 
section of the operation interface in the Web Control page to save the waveform. 
 
⚫ Operation Type 

Click Operation to select "Save Wave".  
 
⚫ Data Source 

Click Data Source continuously to select "Memory" or "Screen" as the 
source of the saved waveform. 
 

⚫ Format 
Click Format to select the waveform format. When Data Source is "Screen", 
the available formats are "*.bin" and "*.csv". When Data Source is "Memory", 
the available formats are "*.bin", "*.csv", and "*wfm". 

 
⚫ Storage Channel 

If "Memory" is selected under Data Source, you need to set the storage 
channel. Click Channel to select the storage channel. The available storage 
channels include CH1-CH4. 

 
3. Setup Saving 

When the Quick shortcut key is set to "Save Setup", click Quick at the right 
section of the operation interface in the Web Control page to save the setup of 
the oscilloscope. 
 
Click Operation to select "Save Setup". 
 

4. All Measurement 
When the Quick shortcut key is set to "All Measure", click Quick at the right 
section of the operation interface in the Web Control page to measure all the 
parameters of the current measurement source. 
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⚫ Operation Type 
Click Operation to select "All Measure". 
 

⚫ All Measurement 
Click All Measure to select the desired measurement channel. The available 
measurement channels include OFF and CH1-CH4. 

 
5. Statistics Reset 

When the Quick shortcut key is set to "Stat Reset", click Quick at the right 
section of the operation interface in the Web Control page to make statistics 
reset of measurement or pass/fail test reset. 
 
⚫ Operation Type 

Click Operation to select "Stat Reset".  
 

⚫ Statistics Reset 
Click Stat Reset to select the function that requires statistics reset. You can 
select "Measure" or "PassFail". 
 

6. Print 
When the Quick shortcut key is set to "Print", click Quick at the right section of 
the operation interface in the Web Control page to print the screen image of the 
oscilloscope. 
 
Click Operation to select "Print".  
 

7. Email 
When the Quick shortcut key is set to "Email", click Quick at the right section of 
the operation interface in the Web Control page to send the file through email. 
 
Click Operation to select "Email". 

 
8. Record 

When the Quick shortcut key is set to "Record", click Quick at the right section 
of the operation interface in the Web Control page to record the waveform. 
 
Click Operation to select "Record".  

 
9. Save Group 

When the Quick shortcut key is set to "Save Group", click Quick at the right 
section of the operation interface in the Web Control page to save group. 
 
⚫ Operation Type 

Click Operation to select "Save Group". 
 
⚫ Storage Option 
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Click Group to select the desired storage option. The storage options include 
"Save Image", "Save Wave", and "Save Setup". 

 

Screen Saver 
 
When the oscilloscope enters the idle state and holds for a certain period of time, the 
screen saver program will be enabled. 
Click More → Screen Saver to enter the screen saver setting menu. The available 
screen saver types include "Off", "Picture", and "Text". The screen saver program is 
disabled by default. 
 
1. Select the Screen Saver 

⚫ If you select "Off" under Screen Saver, it indicates that the screen saver is 
disabled. 

⚫ If you select "Picture" under Screen Saver, click Select Picture to select 
the file. The file types include "*.png", "*.bmp", "*.jpg", and "*.tif". 

⚫ If you select "Text" under Screen Saver, click Text, and then the filename 
input interface is displayed, e.g. inputting "RIGOL Scope". For details, refer 
to descriptions in "To Create a Folder". 

 
2. Set the Wait Time 

Click Time to Start to set the screen saver time. Also, you can use the pop-up 
numeric keypad or scroll with the mouse to input the screen saver time. The 
available range is from 1 min to 999 min. By default, it is 30 min. 
 

3. Preview 
Click Preview to view the set screen saver. 

 
4. Default 

Click Default to restore the screen saver to the default settings. 
 
 

Self-check 
 
The oscilloscope supports key test. 
 
Click Utility → More → More → Self Check to enter the self-check menu. 
 
Click Key Test to enter the keyboard test interface (virtual keypad of the front 
panel). At this time, you can press the keys on the front panel to check whether the 
virtual keys are highlighted. If yes, it indicates that the keys work normally; if no, it 

indicates that there's something wrong with the keys. Press RUN/STOP on the front 

panel for three consecutive times to exit the keyboard test interface. You can also 
click the screen for three times to exit the keyboard test interface. 
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System Time 
 
The system time is displayed at the lower-right side of the screen in "hh:mm 
(hour:minute)" format. When you save the waveform, the output file will contain the 
time information. 
 
Click Utility → More → More → Time to open the time setting menu. 
 
1. Set the System Time 

(1) Click Show Time to open or close the system time interface. 
(2) Set "year": Click Year to set it. Use the pop-up numeric keypad to input the 

numeric value or scroll with the mouse to set it.  
(3) Set "month": Click Month to set it. Use the pop-up numeric keypad to input 

the numeric value or scroll with the mouse to set it. 
(4) Set "day": Click Day to set it. Use the pop-up numeric keypad to input the 

numeric value or scroll with the mouse to set it. 
(5) Set "Hour": Click Hour to set it. Use the pop-up numeric keypad to input 

the numeric value or scroll with the mouse to set it. 
(6) Set "Minute": Click Minute to set it. Use the pop-up numeric keypad to 

input the numeric value or scroll with the mouse to set it. 
 

The setting range of each item of the system time conforms to the convention. 
⚫ Year: 2017 to 2099 
⚫ Month: 01 to 12 
⚫ Date: 01 to 31 (28, 29, or 30) 
⚫ Hour: 00 to 23 
⚫ Minute: 00 to 59 
⚫ Second: 00 to 59 
 

2. Apply the Currently Set System Time 
Click Apply to validate the current settings. The time at the lower-right side of 
the screen will be updated. 

 
 

Default Option 
 
Used to determine whether the impedance is modified while configuring the 
oscilloscope to restore its default settings. To restore its default settings, two 
methods are available. 
⚫ Click the function navigation icon to open the function navigation. Click Storage 

→ More → Default. 
⚫ Click the Default key at the right section of the operation interface in Web 

Control page. 
 
Click Utility → More → More → Default Option, then enter the default option 
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menu. Click Keep Impedance continuously to enable or disable the impedance 
keep function. If you select ON, after you click Default, the impedance value that 
you set remains unchanged and other settings will be restored to the default settings. 
If you select OFF, after you click Default, the impedance value will be restored to its 
default value 1 MΩ. 
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Chapter 20 Remote Control 
 
The oscilloscope can be remotely controlled in the following three methods: 
 
User-defined Programming 
You can program and control the oscilloscope by using the SCPI (Standard 
Commands for Programmable Instruments) commands. For details about the 
relevant commands and programming, refer to DS8000-R Programming Guide. 
 
PC Software 
You can use the PC software to send commands to control the oscilloscope remotely. 
RIGOL Ultra Sigma is recommended. You can download the software from RIGOL 

official website (www.rigol.com). 
 
Operation Procedures: 
(1) Set up communication between the instrument and PC. 
(2) Run Ultra Sigma and search for the instrument resource. 
(3) Open the remote command control panel to send commands. 
 
Web Control 
DS8000-R series digital oscilloscope supports Web Control. When the instrument is 
connected to the internet, Web Control can display the waveform interface of the 
oscilloscope in a real-time manner. You can migrate the instrument control and 
waveform analysis to the control terminals (e.g. PC, mobile, and iPad) through Web 
Control to realize remote control of the instrument. When you log in to the Web 
Control for the first time, use the user name "admin" (without quotation marks) and 
the password "rigol" (without quotation marks). 
 
The oscilloscope can communicate with the PC via the following interfaces: 
◼ Remote Control via USB 
◼ Remote Control via LAN 
◼ Remote Control via GPIB 
 
This chapter will illustrate how to use RIGOL's Ultra Sigma software to remotely 

control the oscilloscope via various interfaces. Note: When communicating with the 
PC via GPIB, the oscilloscope does not support large data transmission operation 
such as screen shot and waveform reading. 
 

 

CAUTION 
Before setting up communication, please turn off the instrument to avoid 
causing damage to the communication interfaces. 

 
 
 

http://www.rigol.com/
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Remote Control via USB 
 
1. Connect the device 

Use a USB cable to connect the oscilloscope (USB DEVICE interface) with the PC 
(USB HOST interface). 
 

2. Install the USB driver 
This oscilloscope is a USB-TMC device. After you connect the oscilloscope to the 
PC properly and power it on for the first time (the oscilloscope will be 
automatically configured with the USB interface). In this case, "Found New 
Hardware Wizard" dialog box appears on the PC. Please install "USB Test and 
Measurement Device (IVI)" according to the instructions. The steps are as 
follows: 
 

 
 

1 

2 
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5 

6 

3 

4 
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3. Search for the device resource 
Start up Ultra Sigma and the software will automatically search for the resource 
currently connected to the PC via the USB interface. You can also click 

 to search for the resource. 
 

4. View the device resource 
The searched instrument resource will be under the directory of "RIGOL Online 
Resource", with the model of the instrument and the USB interface information 
being displayed as follows. 

7 
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5. Control the instrument remotely 
Right-click the resource name "DS8204-R 
(USB0::0x1AB1::0x0516::DS8R820400003::INSTR)" and select "SCPI Panel 
Control" to turn on the remote command control panel, through which you can 
send commands and read data. 
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Remote Control via LAN 
 
1. Connect the device 

Use the network cable to connect the oscilloscope to your local area network 
(LAN). 
 

2. Configure network parameters 
Configure the network parameters of the oscilloscope according to "LAN 
Configuration". 
 

3. Search for the device resource 

Start up Ultra Sigma and click  to open the panel as shown in the 

figure below. Click  and the software searches for the instrument 
resource currently connected to LAN. The resource found is displayed at the 

right of the panel. Click  to add it. Besides, you can input the IP 
address of the instrument manually into the text field under "Manual Input LAN 

Instrument IP", then click . If the instrument passes the test, click 

 to add the instrument to the LAN instrument resource list in the right 
section; if the instrument fails the test, please check whether the IP address that 
you input is correct, or use the auto search method to add the instrument 
resource. 

 
 

4. View the device resource 
The resources found will appear under the "RIGOL Online Resource" directory. 
For example, DS8204-R (TCPIP::172.16.3.14::INSTR). 
 

5. Control the instrument remotely 
Right-click the resource name "DS8204-R (TCPIP::172.16.3.14::INSTR)" and 
select "SCPI Panel Control" to turn on the remote command control panel, 
through which you can send commands and read data. 
 

6. Load LXI webpage 
As this oscilloscope conforms to LXI CORE 2011 DEVICE standards, you can load 
LXI webpage through Ultra Sigma (right-click the instrument resource name and 
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select "LXI-Web"). Various important information about the instrument 
(including the model, manufacturer, serial number, description, MAC address, 
and IP address) will be displayed on the webpage. You can also directly input 
the IP address of the oscilloscope in the address bar of the PC browser to load 
the LXI webpage. 
 
 

Remote Control via GPIB 
 

1. Connect the device 
Use the USB-GPIB interface converter to extend the GPIB interface for the 
oscilloscope, and then use the GPIB cable to connect the oscilloscope to the PC 
to realize remote control. 
 

2. Install the driver of GPIB card 
Correctly install the driver of the GPIB card which has been connected to the PC. 
 

3. To Set the GPIB Address 
Set the GPIB address of the oscilloscope according to the description in "To Set 
the GPIB Address". 
 

4. Search for the device resource 

Start Ultra Sigma, and then click . A window is displayed as shown in 
Figure (a). Click  and the software searches for the instrument 
resource currently connected to the PC via the GPIB interface. The resource 
found is displayed at the right of the window as shown in Figure (b). Click 

 to add it. 

 
(a) 
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(b) 

Note: If you want to remove the resource, select the resource and then click 
 to remove it. 

If the resource cannot be searched automatically: 
⚫ Select the GPIB card address of the PC from the drop-down box of 

"GPIB0::" and select the GPIB address set in the oscilloscope from the 
drop-down box of "0::INSTR". 

⚫ Click  to check whether the GPIB communication works 
normally; if not, please follow the corresponding prompt messages to 
handle it. 

 
5. View the device resource 

The searched instrument resource will be under the directory of "RIGOL Online 
Resource", as shown in the following figure. 

 
 

6. Control the instrument remotely 
Right-click the resource name "DS8204-R (GPIB0::18::INSTR)", and select 
"SCPI Panel Control" to open the remote command control panel. Then you can 
send commands and read data through the panel. 
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Chapter 21 Troubleshooting 
 
The commonly encountered failures of the oscilloscope and their solutions are listed 
below. If the following problems occur, locate and resolve the problems according to 
the following steps. If the problems still persist, contact RIGOL and provide your 

instrument information to us. 
 
1. The screen is still dark after pressing the power key. 

(1) Check whether the power switch is really on. 
(2) Check whether the power is correctly connected. 
(3) Check whether the fuse is burned out. If the fuse needs to be changed, 

please use the specified fuse. 
(4) Restart the instrument after finishing the above inspections. 
(5) If it still does not work correctly, please contact RIGOL. 

 
2. No waveform of the signal is displayed on the screen. 

(1) Check whether the probe is properly connected to the item under test. 
(2) Check whether there are signals generated from the item to be tested (you 

can connect the probe compensation output signal to the faulty channel to 
locate the problem, and then determine whether the channel or the item to 
be tested has a problem). 

(3) Resample the signal. 
 
3. The display of waveform is ladder-like. 

(1) The horizontal time base might be too low. Increase the horizontal time 
base to improve the display effects. 

(2) If the display type is "Vector", the lines between the sample points may 

cause ladder-like display results. Click on the function navigation icon  
at the lower-left corner of the screen to open the function navigation. Then 

click the "Display" icon  to enter the display setting menu. Click Type 
continuously to select "Dots". 

 
4. The USB storage device cannot be recognized. 

(1) Check whether the USB storage device can work normally. 
(2) Make sure the USB storage device used is FAT32-format Flash storage type, 

as this instrument does not support USB3.0 storage device and hardware 
storage type. 

(3) Check whether the capacity of the USB storage device is too large. It is 
recommended that the capacity of the USB storage device should not 
exceed 8 GB for this oscilloscope. 

(4) Restart the instrument and insert the USB storage device to check it. 
(5) If the USB storage device still cannot work normally, please contact 

RIGOL. 
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Chapter 22 Appendix 
 

Appendix A: Accessories and Options 
 

Order Information Order No. 

Model 

DS8204-R (2 GHz, 10 GSa/s, 500 Mpts, 4CH compact 
digital oscilloscope) 

DS8204-R  

DS8104-R (1 GHz, 10 GSa/s, 500 Mpts, 4CH compact 
digital oscilloscope)  

DS8104-R  

DS8034-R (350 MHz, 5 GSa/s, 500 Mpts, 4CH compact 
digital oscilloscope) 

DS8034-R 

Standard Accessories 

USB cable 
CB-USBA-USBB-FF
-150 

Power cord conforming to the standard of the destination 
country 

—— 

Rack mount kit RM1011 & RM1012 

Recommended Accessories 

Passive high-impedance probe (500 MHz BW) RP3500A 

Passive high-impedance probe (350 MHz BW) PVP2350 

Passive low-impedance probe (1.5 GHz BW) RP6150A 

Active single-ended/differential probe (2.5 GHz BW) PVA7250 

Active differential probe (1.5 GHz BW) RP7150 

Active differential probe (800 MHz BW) RP7080 

Active single-ended probe (1.5 GHz BW) RP7150S 

Active single-ended probe (800 MHz BW) RP7080S 

50 Ω impedance matching device (2W, 1 GHz) ADP0150BNC 

Power analysis phase difference correction jig RPA246 

64CH synchronization module DS SYNC64 

2-way power splitter (DC to 4 GHz) PRSC42 

10 GE Communication Option 

High-speed data communication option DS8000-R HSDC 

Software Tool 

Software development kit (open source, available to 
download from RIGOL official website) 

—— 

Bundle Option 

Function and application bundle option, including 
DS8000-R-COMP, DS8000-R-EMBD, DS8000-R-AUTO, 
DS8000-R-FLEX, DS8000-R-AUDIO, DS8000-R-AERO, 
DS8000-R-AWG, DS8000-R-JITTER and DS8000-R-PWR 

DS8000-R-BND 

Serial Protocol Analysis Option 

PC serial bus trigger and analysis (RS232/UART) DS8000-R-COMP 
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Embedded serial bus trigger and analysis (I2C, SPI) DS8000-R-EMBD 

Auto serial bus trigger and analysis (CAN, LIN) DS8000-R-AUTO 

FlexRay serial bus trigger and analysis (FlexRay) DS8000-R-FLEX 

Audio serial bus trigger and analysis (I2S) DS8000-R-AUDIO 

MIL-STD-1553 serial bus trigger and analysis 
(MIL-STD-1553) 

DS8000-R-AERO 

Measurement Application Option 

25 MHz arbitrary waveform generator DS8000-R-AWG 

Built-in power analysis (required to purchase the RPA246 
phase deviation correction jig) 

DS8000-R-PWR 

Real-time eye diagram and jitter analysis (option, only 
available for DS8104-R and DS8204-R) 

DS8000-R-JITTER 

 
Note: For all the accessories and options, please contact the local office of RIGOL. 
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Appendix B: Warranty 
 
RIGOL TECHNOLOGIES CO., LTD. (hereinafter referred to as RIGOL) warrants that 

the product will be free from defects in materials and workmanship within the 
warranty period. If a product proves defective within the warranty period, RIGOL 

guarantees free replacement or repair for the defective product. 
 
To get repair service, please contact with your nearest RIGOL sales or service office. 

 
There is no other warranty, expressed or implied, except such as is expressly set 
forth herein or other applicable warranty card. There is no implied warranty of 
merchantability or fitness for a particular purpose. Under no circumstances shall 
RIGOL be liable for any consequential, indirect, ensuing, or special damages for any 

breach of warranty in any case. 
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