VIAVI (Spirent) TestCenter Segment Routing Emulation — решение для
VIAVI TestCenter Segment Routing Emulation
Обзор
Segment Routing основан на маршрутизации от источника. Основная мотивация Segment Routing — снижение сложности, существующей в современных сетевых узлах из-за плоскости управления MPLS.
Segment Routing устраняет необходимость в плоскости управления MPLS, используя протоколы IGP, такие как OSPF, ISIS и BGP, для распространения меток пересылки или идентификаторов сегментов. В результате только входному узлу требуется хранить состояние потоков трафика, при этом плоскость пересылки MPLS может повторно использоваться для пересылки трафика с применением меток Segment Routing.
Поскольку состояние пересылки потока трафика находится в заголовке Segment Routing пакета, это открывает возможность программируемости сети или функциональности SDN с менее значительными изменениями существующей сети. Политики могут задаваться административно на входном узле или динамически с использованием централизованного контроллера SDN.
Segment Routing представляет собой эволюционный подход к SDN и снижению сложности существующих сетевых узлов. Помимо тестирования масштабируемости, функциональности и производительности реализации протокола, важно проверять взаимодействие между сетевыми узлами с поддержкой и без поддержки SR.
VIAVI Segment Routing Emulation обеспечивает функциональное тестирование, тестирование масштабируемости, производительности и совместимости протокола Segment Routing. Решение поддерживает расширения OSPF, ISIS и BGP для Segment Routing.
Возможности
Этот пакет является интегрированным компонентом VIAVI TestCenter и работает совместно с другими компонентами TestCenter. Протоколы Segment Routing могут комбинироваться с протоколами SDN, Routing and Switching, Access или Data Center.
Преимущества
Рисунок 1. Segment Routing Test Topology
Поддерживаемые функции
Технические спецификации
| Segment Routing | |
| RFC 8665 | OSPF Extensions for Segment Routing |
| RFC 8666 | OSPFv3 Extensions for Segment Routing |
| RFC 8667 | IS-IS Extensions for Segment Routing |
| draft-ietf-isis-segment-routing-msd-15 | Signaling MSD (Maximum SID Depth) using IS-IS |
| RFC 8669 | Segment Routing Prefix Segment Identifier Extensions for BGP |
| draft-ietf-lsr-flex-algo-16 | IGP Flexible Algorithm |
| draft-ietf-idr-segment-routing-te-policy-14 | Advertising Segment Routing Policies in BGP |
| RFC 8919 | IS-IS Application-Specific Link Attributes |
| RFC 8920 | OSPF Application-Specific Link Attributes |
| draft-cheng-spring-mpls-path-segment-00 | Path Segment in MPLS Based Segment Routing Network |
| draft-ietf-mpls-spring-lsp-ping-02 | Label Switched Path (LSP) Ping/Trace for Segment Routing Networks Using MPLS Dataplane |
| SRv6 | |
| RFC 8986 | Segment Routing over IPv6 (SRv6) Network Programming |
| draft-previdi-isis-ipv6-prefix-sid-01 | Segment Routing IPv6 Prefix-SID |
| draft-li-ospf-ospfv3-srv6-extensions-07 | OSPFv3 Extensions for SRv6 |
| draft-ietf-6man-segment-routing-header-14 | IPv6 Segment Routing Header (SRH) |
| draft-ietf-lsr-isis-srv6-extensions-17 | IS-IS Extensions to Support Routing over IPv6 Dataplane |
| draft-bonica-6man-comp-rtg-hdr-08 | The IPv6 Compact Routing Header (CRH) |
| draft-ietf-bess-srv6-services-15 | SRv6 BGP based Overlay Services |
| draft-filsfils-spring-net-pgm-extension-srv6-usid-10 | Network Programming extension: SRv6 uSID instruction |
| CMCC xxx | General Technical Requirements for Generalized SRv6 |
| RFC9259 | Operations, Administration, and Maintenance (OAM) in Segment Routing over IPv6 (SRv6) |
Информация для заказа
| Номер позиции | Описание |
|---|---|
| BPK-1317A | Segment Routing for OSPFV2 Base Package A |
| BPK-1318A | Segment Routing for ISIS Base Package A |
| BPK-1329A | Segment Routing for BGP Base Package A |
| BPK-1341 | Segment Routing LSP PING Base Package |
| BPK-1345 | Segment Routing V6 for IS-ISV6 Package |
| BPK-1346 | Segment Routing V6 for OSPFV3 Package |
| BPK-1347 | Segment Routing IS-ISV4 L2-Bundle Package |
| BPK-1348 | Segment Routing V6 Based VPN Package |
| BPK-1365 | Flex-Algo for ISIS-SR Package |
| BPK-1366 | FLEX-ALGO OSPF-SR Package |
| BPK-1377 | OSPFV3 Extensions for Segment Routing Base Package (MPLS) |
| BPK-1397 | BFD AND SBFD FOR SRv6 Policy |
| BPK-1398 | Segment Routing V6 Ping Base Package |
| BPK-1399 | Segment Routing V6 Traceroute Base Package |
| BPK-1400 | BFD and SBFD for SR MPLS |
| BPK-1401 | Multicast Segment Routing V6 for IS-IS Base Package |
| BPK-1402 | Multicast Segment Routing V6 for BGP Base Package |
| BPK-1403 | Ping for Multicast Segment Routing V6 Base Package |
| BPK-1404 | Traceroute for Multicast Segment Routing V6 Base Package |
| SPK-1131 | Segment Routing for OSPFV2 and ISIS Test Solution |
| SPK-1131A | Segment Routing for OSPFV2, ISIS and Bgp Test Solution |
| SPK-1211 | FLEX-ALGO for ISIS & OSPF Package |
| SPK-1216 | Multicast Segment Routing V6 for IS-IS and BGP Test Solution |
| SPK-1217 | Segment Routing V6 and SDN Basic Test Solution |
| SPK-1218 | Segment Routing V6 and SDN Advanced Test Solution |
| TPK-1084 | SR-TE Convergence Methodology Test Package |
Характеристики VIAVI (Spirent) TestCenter Segment Routing Emulation — решение для эмуляции и тестирования Segment
Документация VIAVI (Spirent) TestCenter Segment Routing Emulation — решение для эмуляции и тестирования Segment Routing
Возможность автоматизации с помощью собственного ПО: интеграция, автоматизация измерений, собственные база данных и VISA-мост.
СПОАИ — специальное программное обеспечение для автоматизации измерений, разработанное на мощностях "Акметрон" — отечественного разработчика программного обеспечения, производителя и крупнейшего поставщика оборудования с 2012 года.
Это клиент-серверное приложение с многопользовательской распределённой архитектурой, которое решает задачи повышения производительности труда на производстве, сокращения длительности измерений и снижения требований к квалификации персонала. ПО внесено в реестр Минцифры: №28145
Ключевые преимущества:
- Полный цикл «под ключ»: от разработки до сопровождения
- Клиент-серверная архитектура с самостоятельной переналадкой
- Централизованный сбор и хранение результатов в БД с возможностью миграции в вашу БД
- Генератор отчетов на основе ваших шаблонов (docx. и xlsx.)
- Управление приборами с любым типом интерфейса
- ПО работает на системах Windows, Linux, MacOS, доступна веб-версия
Результаты внедрений:
- Непрерывная работа в автоматическом режиме до 48 часов
- До 4 500 измерений за этап
- Одновременное управление 15+ приборами
- Автоматизация техтренировки и полной программы испытаний выпускаемых изделий — более 10 контролируемых приборов на одном рабочем месте, до 4 500 автоматизированных измерений в каждом этапе, непрерывная работа в автоматическом режиме 24–48 часов
- Измерение радиотехнических характеристик приемопередающих модулей
- Автоматизация тестирования фотонных интегральных схем
- Контроль и испытания СВЧ-усилителей для космических аппаратов
Для каждого продукта мы предоставляем полный комплект документации: инструкция по установке с пошаговой настройкой, руководство по эксплуатации с описанием требований и рабочих процессов, презентация с обзором возможностей и кейсов внедрения.
Предоставим систему с учётом требований промышленных стандартов и рассчитанную на многолетнюю эксплуатацию. Также мы обеспечиваем соответствие отраслевым требованиям, надёжность архитектуры для критических систем и масштабируемость без потери стабильности.
Наши специалисты помогут вам решить самые сложные задачи по автоматизации, измерениям и интеграции